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Warranty
The material contained in this document is 
provided "as is," and is subject to being 
changed, without notice, in future editions. 
Further, to the maximum extent permitted 
by applicable law, Keysight disclaims all 
warranties, either express or implied, with 
regard to this manual and any information 
contained herein, including but not limited 
to the implied warranties of 
merchantability and fitness for a particular 
purpose. Keysight shall not be liable for 

errors or for incidental or consequential 
damages in connection with the furnishing, 
use, or performance of this document or of 
any information contained herein. Should 
Keysight and the user have a separate 
written agreement with warranty terms 
covering the material in this document that 
conflict with these terms, the warranty 
terms in the separate agreement shall 
control.

Technology License
The hardware and/or software described in 
this document are furnished under a license 
and may be used or copied only in 
accordance with the terms of such license.

U.S. Government Rights
The Software is "commercial computer 
software," as defined by Federal Acquisition 
Regulation ("FAR") 2.101. Pursuant to FAR 
12.212 and 27.405-3 and Department of 
Defense FAR Supplement ("DFARS") 
227.7202, the U.S. government acquires 
commercial computer software under the 
same terms by which the software is 
customarily provided to the public. 
Accordingly, Keysight provides the Software 
to U.S. government customers under its 
standard commercial license, which is 
embodied in its End User License Agreement 
(EULA), a copy of which can be found at 
www.keysight.com/find/sweula. The 
license set forth in the EULA represents the 
exclusive authority by which the U.S. 
government may use, modify, distribute, or 
disclose the Software. The EULA and the 
license set forth therein, does not require or 
permit, among other things, that Keysight: 
(1) Furnish technical information related to 
commercial computer software or 
commercial computer software 
documentation that is not customarily 
provided to the public; or (2) Relinquish to, 
or otherwise provide, the government rights 
in excess of these rights customarily 
provided to the public to use, modify, 
reproduce, release, perform, display, or 
disclose commercial computer software or 
commercial computer software 
documentation. No additional government 
requirements beyond those set forth in the 
EULA shall apply, except to the extent that 
those terms, rights, or licenses are explicitly 
required from all providers of commercial 

computer software pursuant to the FAR and 
the DFARS and are set forth specifically in 
writing elsewhere in the EULA. Keysight 
shall be under no obligation to update, 
revise or otherwise modify the Software. 
With respect to any technical data as 
defined by FAR 2.101, pursuant to FAR 
12.211 and 27.404.2 and DFARS 227.7102, 
the U.S. government acquires no greater 
than Limited Rights as defined in FAR 27.401 
or DFAR 227.7103-5 (c), as applicable in any 
technical data.

Safety Notices
This product has been designed and tested 
in accordance with accepted industry 
standards, and has been supplied in a safe 
condition. The documentation contains 
information and warnings that must be 
followed by the user to ensure safe 
operation and to maintain the product in a 
safe condition.

CAUTION

A CAUTION notice denotes a hazard. 
It calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or 
adhered to, could result in damage 
to the product or loss of important 
data. Do not proceed beyond a 
CAUTION notice until the indicated 
conditions are fully understood and 
met.

WARNING

A WARNING notice denotes a 
hazard. It calls attention to an 
operating procedure, practice, or 
the like that, if not correctly 
performed or adhered to, could 
result in personal injury or death. 
Do not proceed beyond a WARNING 
notice until the indicated 
conditions are fully understood and 
met.

http://www.keysight.com/find/sweula
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InfiniiVision HD3-Series Oscilloscopes—At a Glance

The Keysight InfiniiVision HD3-Series oscilloscopes deliver these features:

• An MSO lets you debug your mixed-signal designs using analog signals and 
tightly correlated digital signals simultaneously. The sample rate for 8 digital 
channels (in D0-D7 or in D8-D15 only) is 1.6 GSa/s and the sample rate for all 
16 digital channels is 800 MSa/s. The digital channels have a 100 MHz toggle 
rate.

• 10.1 inch WXGA touchscreen display (1280 x 800 pixels).
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Table 1 HD3-Series Oscilloscope Model Numbers, Bandwidths, Sample Rates

HD302MSO HD304MSO

Bandwidth 200 MHz standard, options for 350 MHz, 500 MHz, and 1 GHz

Sample Rate 3.2 GSa/s 3.2 GSa/s

Memory Depth 20 Mpts standard, options for 50 Mpts and 100 Mpts

Analog Channels 2 4

Logic Channels MSO 16 16
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• Interleaved (full) or non-interleaved (half) MegaZoom IV memory for the fastest 
waveform update rates, uncompromised.

• Trigger types: edge, edge then edge, pulse width, pattern, OR, rise/fall time, 
runt, and setup & hold.

• Zone trigger.

• Protocol decode/trigger options for: ARINC 429, CAN, I2C, LIN, MIL-STD-1553, 
SENT, SPI, UART/RS232, USB 2.0, and USB PD. Listing window for protocol 
decode.

• Math waveforms:

• Arithmetic — add, subtract, multiply, and divide.

• Transforms — absolute value, Ax+B, base 10 exponential, common 
logarithm, differentiate, exponential, integrate, natural logarithm, square 
root, and squared.

• FFT — magnitude and phase.

• Filters — band pass filter, low pass filter, high pass filter, averaged value, 
envelope, and smoothing.

• Visualizations — magnify, max hold, maximum, measurement trend, min 
hold, minimum, and peak-peak.

• Reference waveforms (4) for comparing with other channel or math waveforms.

• Many built-in measurements and a measurement statistics display.

• Built-in license-enabled 100 MHz waveform generator with: arbitrary, sine, 
square, ramp, pulse, DC, noise, sine cardinal, exponential rise, exponential fall, 
cardiac, and gaussian pulse.

• USB and LAN ports make saving and sharing data easy.

• Online Help information is built into the oscilloscope.

For more information about InfiniiVision oscilloscopes, see: 
www.keysight.com/find/scope

http://www.keysight.com/find/scope
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In This Guide
This guide shows how to use the InfiniiVision HD3-Series oscilloscopes.

When unpacking and using the 
oscilloscope for the first time, see:

• Chapter 1, “Getting Started,” starting on page 23

When displaying waveforms and 
acquired data, see:

• Chapter 2, “Horizontal Controls,” starting on page 49

• Chapter 3, “Vertical Controls,” starting on page 63

• Chapter 4, “FFT Spectral Analysis,” starting on page 73

• Chapter 5, “Math Waveforms,” starting on page 83

• Chapter 6, “Reference Waveforms,” starting on page 
109

• Chapter 7, “Digital Channels,” starting on page 113

• Chapter 8, “Protocol Decode,” starting on page 129

• Chapter 9, “Display Settings,” starting on page 135

When setting up triggers or changing 
how data is acquired, see:

• Chapter 10, “Triggers,” starting on page 149

• Chapter 11, “Trigger Mode and Conditioning,” starting 
on page 169

• Chapter 12, “Acquisition Control,” starting on page 
177

Making measurements and analyzing 
data:

• Chapter 13, “Markers,” starting on page 191

• Chapter 14, “Measurements,” starting on page 199

• Chapter 15, “Histogram,” starting on page 229

• Chapter 16, “Color Grade Waveform,” starting on page 
237

• Chapter 17, “Jitter Analysis,” starting on page 241

• Chapter 18, “Mask Testing,” starting on page 249

• Chapter 19, “Digital Voltmeter and Counters,” starting 
on page 263

• Chapter 20, “Fault Hunter,” starting on page 269

• Chapter 21, “Frequency Response Analysis,” starting 
on page 275

When using the built-in waveform 
generator, see:

• Chapter 22, “Waveform Generator,” starting on page 
279

When saving or recalling files, see: • Chapter 23, “Save/Email/Recall (Setups, Screens, 
Data),” starting on page 291

When using the oscilloscope's utility 
functions or web interface, see:

• Chapter 24, “Utility Settings,” starting on page 303

• Chapter 25, “Web Interface,” starting on page 325
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See Also

The Power Measurement Application User's Guide at: 
www.keysight.com/find/HD3-Series-manual

For reference information, see: • Chapter 26, “Reference,” starting on page 337

When using licensed serial bus 
triggering and decode features, see:

• Chapter 27, “ARINC 429 Triggering and Serial 
Decode,” starting on page 351

• Chapter 28, “CAN Triggering and Protocol Decode,” 
starting on page 359

• Chapter 29, “I2C Triggering and Protocol Decode,” 
starting on page 371

• Chapter 30, “LIN Triggering and Protocol Decode,” 
starting on page 379

• Chapter 31, “MIL-STD-1553 Triggering and Serial 
Decode,” starting on page 387

• Chapter 32, “SENT Triggering and Serial Decode,” 
starting on page 395

• Chapter 33, “SPI Triggering and Protocol Decode,” 
starting on page 407

• Chapter 34, “UART/RS232/422/485 Triggering and 
Protocol Decode,” starting on page 415

• Chapter 35, “USB 2.0 Triggering and Serial Decode,” 
starting on page 423

• Chapter 36, “USB PD Triggering and Serial Decode,” 
starting on page 431

TIP Pressing keys, selecting user interface items, and choosing a series of menu items

Instructions for pressing front panel keys include square brackets around the key name and 
bold typeface, for example: Press [Key].

Instructions for selecting user interface items include bold typeface, for example: Select 
Option Name or Button....

Instructions for choosing a series of menu items are abbreviated. For example, instead of 
saying choose Menu Item, then choose Sub Item, then choose Sub Sub Item, those stages are 
abbreviated into: Choose Menu Item > Sub Item > Sub Sub Item.

http://www.keysight.com/find/HD3-Series-manual
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This chapter describes the steps you take when using the oscilloscope for the first 
time.

Inspect the Package Contents

• Inspect the shipping container for damage.

If your shipping container appears to be damaged, keep the shipping container 
or cushioning material until you have inspected the contents of the shipment 
for completeness and have checked the oscilloscope mechanically and 
electrically.

• Verify that you received the following items and any optional accessories you 
may have ordered:

• InfiniiVision HD3-Series oscilloscope.

• Power cord (country of origin determines specific type).

• Oscilloscope probes:



24 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

1 Getting Started
 

• Two probes for 2-channel models.

• Four probes for 4-channel models.

See Also • "Probes and Accessories" on page 339
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Learn the Front Panel Inputs and Outputs
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3. Probe Comp
and Ground

terminals

2. Analog
channel
inputs

4. USB
Host
ports

1. Power switch

1. Power switch Press once to switch power on; press again to switch power off.

The front panel switch is a standby switch only and is not a LINE switch. The detachable 
power cord is the instrument disconnecting device. It disconnects the mains circuits from the 
mains supply before other parts of the instrument. Therefore, install the instrument so that 
the detachable power cord is readily identifiable and is easily reached by the operator.

See "Power-On the Oscilloscope" on page 29.

2. Analog channel 
inputs

Attach oscilloscope probes or BNC cables to these BNC connectors.

With the InfiniiVision HD3-Series oscilloscopes, you can set the input impedance of the 
analog channels to either 50 Ω or 1 MΩ. See "To specify channel input impedance" on 
page 66.

The InfiniiVision HD3-Series oscilloscopes also provide the AutoProbe interface. The 
AutoProbe interface uses a series of contacts directly below the channel's BNC connector to 
transfer information between the oscilloscope and the probe. When you connect a 
compatible probe to the oscilloscope, the AutoProbe interface determines the type of probe 
and sets the oscilloscope's parameters (units, offset, attenuation, coupling, and impedance) 
accordingly.
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Learn the Back Panel Inputs and Outputs

For the following figure, refer to the numbered descriptions in the table that 
follows.

3. Probe Comp and 
Ground terminals

• Probe Comp terminal — After a [Default Setup], this terminal outputs the Probe Comp 
signal which helps you match a probe's input capacitance to the oscilloscope channel to 
which it is connected. See "Compensate Passive Probes" on page 33.

The oscilloscope can also output demo or training signals on this terminal.

• Ground terminal — Use the ground terminal for oscilloscope probes connected to the 
Probe Comp terminal.

4. USB Host ports These ports are for connecting a USB mass storage device, mouse, or keyboard to the 
oscilloscope.

Connect a USB compliant mass storage device (flash drive, disk drive, etc.) to save or recall 
oscilloscope setup files and reference waveforms or to save data and screen images. See 
Chapter 23, “Save/Email/Recall (Setups, Screens, Data),” starting on page 291.

You can also use the USB port to update the oscilloscope's system software when updates 
are available.

You do not need to take special precautions before removing the USB mass storage device 
from the oscilloscope (you do not need to "eject" it). Simply unplug the USB mass storage 
device from the oscilloscope when the file operation is complete.

There is a third USB host port on the back panel.
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8. Digital channel inputs
2. LAN port

5. GEN OUT connector

1.Power cord
connector

1. Power cord 
connector

Attach the power cord here.

2. LAN port Lets you place the oscilloscope on the network for access the built-in web 
server and remote programming. See Chapter 25, “Web Interface,” 
starting on page 325 and "Remote Programming with Keysight IO 
Libraries" on page 328.

3. USB Host port This port functions identically to the USB host ports on the front panel. 
USB Host Port is used for saving data from the oscilloscope and loading 
software updates.

4. USB Device port This port is for connecting the oscilloscope to a host PC. You can issue 
remote commands from a host PC to the oscilloscope via the USB device 
port. See "Remote Programming with Keysight IO Libraries" on 
page 328.

5. GEN OUT 
connector

Built-in, license-enabled waveform generator can output arbitrary, sine, 
square, ramp, pulse, DC, noise, sine cardinal, exponential rise, exponential 
fall, cardiac, or Gaussian pulse waveforms on the GEN OUT BNC 
connector. Modulated waveforms are available except for arbitrary, pulse, 
DC, and noise waveforms. Press the [Wave Gen] key to set up the 
waveform generator. See Chapter 22, “Waveform Generator,” starting on 
page 279.
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Tilt the Oscilloscope for Easy Viewing

There are tabs under the oscilloscope's front feet that can be flipped out to tilt the 
oscilloscope.

6. AUX OUT 
connector

Auxiliary output BNC connector. See "Setting the Rear Panel AUX 
OUT Source" on page 312.

7. AUX TRIG IN 
connector

Auxiliary trigger input BNC connector. See "External Trigger Input" on 
page 175 for an explanation of this feature.

8. Digital channel 
inputs

Connect the digital probe cable to this connector. See Chapter 7, “Digital 
Channels,” starting on page 113.

9. Kensington lock 
hole

This is where you can attach a Kensington lock for securing the instrument.

Flip-Out Feet
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Power-On the Oscilloscope

Power
Requirements

Line voltage, frequency, and power:

• ~ 100-120 Vac, 50/60/400 Hz

• ~ 100-240 Vac, 50/60 Hz

• 275 Watts MAX

Mains supply voltage fluctuations are not to exceed ±10% of the nominal supply 
voltage.

Ventilation
Requirements

The air intake and exhaust areas must be free from obstructions. Unrestricted air 
flow is required for proper cooling. Always ensure that the air intake and exhaust 
areas are free from obstructions.

The fan draws air in from the left side and bottom of the oscilloscope and pushes it 
out behind the oscilloscope.

When using the oscilloscope in a bench-top setting, provide at least 2" clearance 
at the sides and 4" (100 mm) clearance above and behind the oscilloscope for 
proper cooling.

To power-on the
oscilloscope

1 Connect the power cord to the rear of the oscilloscope, then to a suitable AC 
voltage source. Route the power cord so the oscilloscope's feet and legs do not 
pinch the cord.

Install the instrument so that the detachable power cord is readily identifiable 
and is easily reached by the operator. The detachable power cord is the 
instrument disconnecting device. It disconnects the mains circuits from the 
mains supply before other parts of the instrument. The front panel switch is only 
a standby switch and is not a LINE switch. Alternatively, an externally installed 
switch or circuit breaker (which is readily identifiable and is easily reached by 
the operator) may be used as a disconnecting device.

2 The oscilloscope automatically adjusts for input line voltages in the range 100 
to 240 VAC. The line cord provided is matched to the country of origin.

3 Press the power switch.

The power switch is located on the lower left corner of the front panel. The 
oscilloscope will perform a self-test and will be operational in a minute or so.

To power cycle the
oscilloscope

From the menu, choose File > Power Cycle. This is the same as pressing the front 
panel power button to power down the oscilloscope and then pressing the power 
button again to start the oscilloscope.

WARNING Always use a grounded power cord. Do not defeat the power cord ground.
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To shut down the
oscilloscope

From the menu, choose File > Shut Down. This is the same as pressing the front 
panel power button to power down the oscilloscope. This allows the oscilloscope 
to shut down gracefully.

Select the User Interface Language

To select the user interface language:

1 From the menu, choose Help > Language....

2 In the Language dialog box, select your preferred user interface Language.

The following languages are available: English, French, German, Italian, Japanese, 
Korean, Portuguese, Simplified Chinese, Spanish, Thai, and Traditional Chinese.

Connect Probes to the Oscilloscope

1 Connect the oscilloscope probe to an oscilloscope channel BNC connector.

2 Connect the probe's retractable hook tip to the point of interest on the circuit or 
device under test. Be sure to connect the probe ground lead to a ground point 
on the circuit.

CAUTION  Maximum input voltage at analog inputs

1 MΩ input: 135 Vrms, 190 Vpk

50 Ω input: ≤104 mV/div: ±1.5 Vpk, >104 mV/div: 5 Vrms, 15 Vpk

With the 50 Ω input protection, the 50 Ω load will disconnect when 
greater-than-specified voltages are detected. However, the inputs could still be 
damaged, depending on the time constant of the signal. The 50 Ω input protection 
functions only when the oscilloscope is powered on.

When using Keysight PP0001A, PP0002A, or PP0003A probes, input voltages at the 
oscilloscope are ≤30 Vrms.

CAUTION When measuring voltages over 80 V, use a 10:1 probe.
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Input a Waveform

The first signal to input to the oscilloscope is the Probe Comp signal. This signal is 
used for compensating probes.

1 Connect an oscilloscope probe from channel 1 to the Probe Comp terminal on 
the front panel.

2 Connect the probe's ground lead to the ground terminal (below the Probe Comp 
terminal).

Recall the Default Oscilloscope Setup

To recall the default oscilloscope setup:

1 Press [Default Setup].

The default setup restores the oscilloscope's default settings. This places the 
oscilloscope in a known operating condition. The major default settings are:

CAUTION  Do not float the oscilloscope chassis

Defeating the ground connection and "floating" the oscilloscope chassis will probably 
result in inaccurate measurements and may also cause equipment damage. The probe 
ground lead is connected to the oscilloscope chassis and the ground wire in the power 
cord. If you need to measure between two live points, use a differential probe with 
sufficient dynamic range.

WARNING Do not negate the protective action of the ground connection to the oscilloscope. 
The oscilloscope must remain grounded through its power cord. Defeating the 
ground creates an electric shock hazard.

Horizontal Normal mode, 100 μs/div scale, 0 s delay, center time reference.

Vertical (Analog) Channel 1 on, 5 V/div scale, DC coupling, 0 V position, 1 MΩ impedance.

Trigger Edge trigger, Auto trigger mode, 0 V level, channel 1 source, DC coupling, rising 
edge slope, 40 ns holdoff time.

Display Persistence off, 20% grid intensity, 50% waveform intensity.

Other Acquire mode normal, [Run/Stop] to Run, markers and measurements off.

Labels All custom labels that you have created in the Label Library are preserved (not 
erased), but all channel labels will be set to their original names.
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In the Default dialog box (from the menu, choose Control > Default...), there are also 
options for restoring the complete factory settings (see "Recalling Default 
Setups" on page 301) or performing a secure erase (see "Performing a Secure 
Erase" on page 302).

Use Autoscale

Use [Auto Scale] to automatically configure the oscilloscope to best display the 
input signals.

1 Press [Auto Scale].

You should see a waveform on the oscilloscope's display similar to this:

2 If you want to return to the oscilloscope settings that existed before, select the 

 Undo button.

3 If you want to enable "fast debug" autoscaling, change the channels 
autoscaled, or preserve the acquisition mode during autoscale, use the 
Autoscale dialog box (from the menu, choose Utilities > User Options..., then 
select Autoscale...). See "To set Autoscale preferences" on page 310.

If you see the waveform, but the square wave is not shaped correctly as shown 
above, perform the procedure "Compensate Passive Probes" on page 33.

If you do not see the waveform, make sure the probe is connected securely to the 
front panel channel input BNC and to the Probe Comp terminal.
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How Autoscale Works

Autoscale analyzes any waveforms present at each channel and at the external 
trigger input. This includes the digital channels, if connected.

Autoscale finds, turns on, and scales any channel with a repetitive waveform that 
has a frequency of at least 25 Hz, a duty cycle greater than 0.5%, and an 
amplitude of at least 10 mV peak-to-peak. Any channels where no signal is found 
are turned off.

The trigger source is selected by looking for the first valid waveform starting with 
external trigger, then continuing with the lowest number analog channel up to the 
highest number analog channel, and finally (if digital probes are connected) the 
highest number digital channel.

During Autoscale, the delay is set to 0.0 seconds, the horizontal time/div (sweep 
speed) setting is a function of the input signal (about 2 periods of the triggered 
signal on the screen), and the triggering mode is set to Edge.

Compensate Passive Probes

Each oscilloscope passive probe must be compensated to match the input 
characteristics of the oscilloscope channel to which it is connected. A poorly 
compensated probe can introduce significant measurement errors.

1 Input the Probe Comp signal (see "Input a Waveform" on page 31).

2 Press [Default Setup] to recall the default oscilloscope setup (see "Recall the 
Default Oscilloscope Setup" on page 31).

3 Press [Auto Scale] to automatically configure the oscilloscope for the Probe 
Comp signal (see "Use Autoscale" on page 32).

4 Open the Channel dialog box (from the menu, choose Sources > Channel N...) 
where N is the channel to which the probe is connected (1, 2, etc.).

5 Select Probe....

6 In the Probe dialog box, select Probe Check; then, follow the instructions 
on-screen.

If necessary, use a nonmetallic tool (supplied with the probe) to adjust the 
trimmer capacitor on the probe for the flattest pulse possible.

On N2894A probes, the trimmer capacitor is located on the probe BNC 
connector.
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7 Connect probes to all other oscilloscope channels (channel 2 of a 2-channel 
oscilloscope, or channels 2, 3, and 4 of a 4-channel oscilloscope).

8 Repeat the procedure for each channel.

Learn the Front Panel Keys and Knobs

On the front panel, key refers to any key (button) you can press.

For the following figure, refer to the numbered descriptions in the table that 
follows.

Perfectly compensated 

Over compensated 

Under compensated
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15. [Touch] screen on/off

13. Entry knob
11. Trigger level knob

14. [Wave Gen] on/off
16. [Save Screen] capture

2. [Single] acquisition

19. [Markers] on/off

4. Horizontal position knob

7. [Auto Scale] 8. [Default Setup]

23. Vertical scale knob

21. [Protocol Decode] on/off20. [Measure] add/
edit/delete

22. [Digital] channels
on/off

6. [Clear Display]

3. Horizontal scale knob

1. [Run/Stop] acquisitions

5. Horizontal [Zoom] on/off

12. [Force] trigger

10. Trigger [Mode]
9. Trigger [Slope]

(rising/falling edge)

18. X marker position knob
17. Y marker level knob

25. Vertical offset knob

24. Analog channel
select, off/on

LEDs show channel
selected for knobs

LEDs show selected mode

1. [Run/Stop] key When the [Run/Stop] key is green, the oscilloscope is running, that is, acquiring data when 
trigger conditions are met. To stop acquiring data, press [Run/Stop].

When the [Run/Stop] key is red, data acquisition is stopped. To start acquiring data, press 
[Run/Stop].

See "Running, Stopping, and Making Single Acquisitions (Run Control)" on 
page 177.

2. [Single] key To capture and display a single acquisition (whether the oscilloscope is running or stopped), 
press [Single]. The [Single] key is yellow until the oscilloscope triggers.

See "Running, Stopping, and Making Single Acquisitions (Run Control)" on 
page 177.
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3. Horizontal scale 
knob Turn the knob in the Horizontal section that is marked  to adjust the time/div 

(sweep speed) setting. The symbols under the knob indicate that this control has the effect of 
spreading out or zooming in on the waveform using the horizontal scale. See Chapter 2, 
“Horizontal Controls,” starting on page 49.

4. Horizontal position 
knob

Turn the knob marked  to pan through the waveform data horizontally. You can see the 
captured waveform before the trigger (turn the knob clockwise) or after the trigger (turn the 
knob counterclockwise). If you pan through the waveform when the oscilloscope is stopped 
(not in Run mode) then you are looking at the waveform data from the last acquisition taken. 
See Chapter 2, “Horizontal Controls,” starting on page 49.

5. [Zoom] key Press the [Zoom] key to split the oscilloscope display into Normal and Zoom sections without 
opening the Horizontal Menu. See Chapter 2, “Horizontal Controls,” starting on page 49.

6. [Clear Display] key When you press the [Clear Display] key, acquisition data is cleared from the oscilloscope 
display. See "To clear the display" on page 139.

7. [Auto Scale] key When you press the [Auto Scale] key, the oscilloscope will quickly determine which channels 
have activity, and it will turn these channels on and scale them to display the input signals. 
See "Use Autoscale" on page 32.

8. [Default Setup] key Press this key to restore the oscilloscope's default settings (details on "Recall the Default 
Oscilloscope Setup" on page 31).

9. [Slope] key Press until the desired slope LED is lit. You can have an edge trigger on a rising or falling 
edge. See Chapter 10, “Triggers,” starting on page 149.

10. [Mode] key Press until the desired LED is lit (Trig'd or Auto).

When Trig'd is selected, the oscilloscope must find the trigger before saving and displaying 
captured data.

When Auto is selected, if a trigger does not occur within a certain amount of time, an 
acquisition is automatically saved and displayed. In Auto trigger mode, you are able to see 
your signals while setting up the desired trigger.

See Chapter 10, “Triggers,” starting on page 149.

11. Trigger Level knob Turn the knob adjust the vertical level used for analog channel edge detection. See 
Chapter 10, “Triggers,” starting on page 149.

12. [Force] key Press to trigger on anything and make a single acquisition.

This is sometimes useful in the Trig'd mode to view a signal when triggers are not occurring.

See Chapter 10, “Triggers,” starting on page 149.

13. Entry knob The Entry knob is used to select items from menus and to change values. The function of the 
Entry knob changes based upon the current menu and entry field selections.

Note that the curved arrow symbol next to the entry knob illuminates whenever the 

entry knob can be used to select a value. Also, note that when the Entry knob symbol 
appears in an entry field, you can use the Entry knob, to select values.

Often, rotating the Entry knob is enough to make a selection. Sometimes, you can push the 
Entry knob to enable or disable a selection. Pushing the Entry knob also makes popup menus 
disappear.
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14. [Wave Gen] key Press this key to access waveform generator functions. See Chapter 22, “Waveform 
Generator,” starting on page 279.

15. [Touch] key Press this key to disable/enable the touchscreen.

16. [Save Screen] key Press to capture and save a screen image to a file.

A message about the saved file is displayed and logged. See "Using the Touchscreen 
User Interface" on page 39.

The location and file name are derived from the last values   specified in the Save dialog box. 
See "To save BMP or PNG image files" on page 293.

17. Y marker level knob When markers are turned on, push this knob to cycle through Y marker selection. Selected 
marker(s) are highlighted. Then, rotate the knob to adjust the selected marker(s) level. See 
Chapter 13, “Markers,” starting on page 191.

18. X marker position 
knob

When markers are turned on, push this knob to cycle through X marker selection. Selected 
marker(s) are highlighted. Then, rotate the knob to adjust the selected marker(s) position. See 
Chapter 13, “Markers,” starting on page 191.

19. [Markers] key Press this key to turn markers on or off.

In the Markers results window, you can select the edit (pencil) icon to open the Markers 
dialog box where you can select the markers mode source. See Chapter 13, “Markers,” 
starting on page 191.

20. [Digital] key Press this key to turn the digital channels on or off.

If a trace is repositioned over an existing trace the indicator at the left edge of the trace will 
change from Dnn designation (where nn is a one or two digit channel number from 0 to 15) to 
D*. The "*" indicates that two or more channels are overlaid.

You can rotate the upper knob to select an overlaid channel, then rotate the lower knob to 
position it just as you would any other channel.

For more information on digital channels see Chapter 7, “Digital Channels,” starting on page 
113.

21. [Protocol Decode] 
key

This key is used to enable protocol decode. See Chapter 8, “Protocol Decode,” starting on 
page 129.

22. Analog channel 
on/off keys

Use these keys to switch a channel on or off. There is one channel on/off key for each analog 
channel.

LEDs next to the channels keys show the channel selected for the vertical scale and position 
knob adjustment.

See Chapter 3, “Vertical Controls,” starting on page 63.

23. Vertical scale knob

This knob is marked . Use this knob to change the vertical sensitivity (gain) of the 
selected analog channel. See Chapter 3, “Vertical Controls,” starting on page 63.

24. Vertical position 
knob

Use this knob to change the selected channel's vertical position on the display. See 
Chapter 3, “Vertical Controls,” starting on page 63.
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Front Panel Overlays for Different Languages

Front panel overlays, which have translations for the English front panel keys and 
label text, are available in several languages. The appropriate overlay is included 
when the localization option is chosen at time of purchase.

To install a front panel overlay:

1 Gently pull on the front panel knobs to remove them.

2 Insert the overlay's side tabs into the slots on the front panel.

3 Reinstall the front panel knobs.

Front panel overlays may be ordered from www.keysight.com/find/parts using the 
following part numbers:

Language 2 Channel Overlay 4 Channel Overlay

French 54763-94348 54762-94348

German 54763-94346 54762-94346

Italian 54763-94350 54762-94350

Japanese 54763-94349 54762-94349

http://www.keysight.com/find/parts
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Using the Touchscreen User Interface

When the [Touch] key is lit, you can control the oscilloscope by touching different 
areas of the screen. You can:

• "Access Features From the Main Menu" on page 40

• "View and Change Settings With Badges" on page 40

• "Quick-Select Waveforms to Display" on page 41

Korean 54763-94341 54762-94341

Portuguese 54763-94345 54762-94345

Simplified Chinese 54763-94342 54762-94342

Spanish 54763-94347 54762-94347

Thai 54763-94343 54762-94343

Traditional Chinese 54763-94340 54762-94340

Language 2 Channel Overlay 4 Channel Overlay

Waveform
grids

Menu

Quick
waveform
selection

Draw box
or drag

waveforms
mode

Waveform
settings
badges

Results
area

Favorites
Message

log
Horizontal
settings
badge

Trigger
settings
badge

Sample rate and
memory depth badge
(Acquisition settings)
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• "Lay Out Waveform Grids" on page 41

• "View Waveforms in a Grid" on page 43

• "Drag Markers" on page 44

• "Customize the Favorites Menu" on page 44

• "View Logged Messages" on page 44

• "Select Draw Box or Drag Waveforms Mode" on page 44

• "View Results" on page 46

• "Enter Names Using Alpha-Numeric Keypad Dialogs" on page 46

• "Use a USB Mouse and/or Keyboard for Touchscreen Controls" on page 46

• "Access the Built-In Online Help" on page 47

Access Features From the Main Menu

Touch or select the upper-left main menu to access oscilloscope features and 
settings.

View and Change Settings With Badges

These badges appear at the top of the screen:
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• Waveform settings badges

• Horizontal settings badge

• Sample rate and memory depth badge (Acquisition settings)

• Trigger settings badge

Select the badge to open the settings dialog box.

Quick-Select Waveforms to Display

Select the  Quick Selection button to open the Quick Selection dialog box.

Check the waveforms you want to display.

Lay Out Waveform Grids

You can specify the waveform layout in the Quick Selection dialog box or in the 
Display dialog box (from the menu, choose Setup > Display...).

Up to four waveform grids can be stacked (the default), tiled, overlaid, or managed 
in a custom layout dialog box.

Waveform
settings
badges

Horizontal
settings
badge

Trigger
settings
badge

Sample rate and
memory depth badge
(Acquisition settings)
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Figure 1 Tiled waveform layout

Figure 2 Overlaid waveform layout
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View Waveforms in a Grid

Waveforms displayed within a grid have these features:

• Draggable waveform reference and trigger levels are shown on the left side of a 
grid.

• Vertical scale(s) are shown on the right side of a grid. Dual vertical scales can 
be shown if there are multiple waveforms in a grid.

• The horizontal scale is shown at the bottom of a grid.

Figure 3 Custom waveform layout (drag waveforms to grids using dialog box)

Waveform
reference

level

Trigger (t = 0)
location

Trigger
level

Horizontal scale

Horizontal
position

Vertical
scale



44 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

1 Getting Started
 

Drag Markers

When markers are turned on in the Markers dialog box (press [Markers] or choose 
Measure > Markers... from the main menu (see page 40)), you can drag the name 
handles to position them.

Customize the Favorites Menu

You can add your favorite menu items to the Favorites menu for quicker access.

Select Edit Favorite to customize the Favorites menu.

View Logged Messages

Select the  Message Log button to view information, caution, and failure 
messages.

Select Draw Box or Drag Waveforms Mode

Draw box or Drag waveforms mode:



Getting Started 1

Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide 45

 

•  Draw box mode — Drag a box and release to access a menu of possible 
actions for the selected waveform area.

• Cancel — Closes the popup menu.

• Horizontal Waveform Zoom — Changes the horizontal scaling and position to 
zoom the waveform within the drawn box. See Chapter 2, “Horizontal 
Controls,” starting on page 49.

• Waveform Zoom — Changes the horizontal scaling and position, as well as the 
vertical scaling and offset, to zoom the waveform within the drawn box. See 
Chapter 2, “Horizontal Controls,” starting on page 49 and Chapter 3, 
“Vertical Controls,” starting on page 63.

• Add Zone Trigger - Must Intersect, Add Zone Trigger - Must Not Intersect, Replace 
Zone Trigger - Must Intersect, Replace Zone Trigger - Must Not Intersect — Adds or 
replaces triggering zones based on the drawn box. See "Zone Qualified 
Trigger" on page 165.

• Histogram — Turns on a histogram using the drawn box to define the 
histogram window limits. See "Waveform Histogram Set Up" on page 230.

• Place X Markers here — Turns on manual markers using the left and right sides 
of the drawn box as the X marker positions. See "To make marker 
measurements" on page 192.

• Add Annotation — Adds an annotation at the upper-left corner of the drawn 
box. See "To add an annotation" on page 143.

•  Drag waveforms mode — Drag a waveform left or right in the grid to 
change the horizontal position. Drag a waveform up or down in the grid to 
change the vertical offset.



46 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

1 Getting Started
 

View Results

The Results area displays the results for markers, measurements, histograms, 
counters, digital voltmeter (DVM), and more.

You can size the Results area by dragging the  sizing handle up or down

Windows for the different types of results can be tabbed within the area or listed.

Use  to undock a window from the Results area or  to re-dock a window. 

Select the  Edit button to open the associated settings dialog box.

The results area or the waveform grids can be displayed full-screen.

Enter Names Using Alpha-Numeric Keypad Dialogs

Some fields open alpha-numeric dialogs that let you touch to enter names.

Use a USB Mouse and/or Keyboard for Touchscreen Controls

Connecting a USB mouse gives you a mouse pointer on the display. Mouse clicks 
and drags behave the same as screen touches and finger drags.

Figure 4 Listed windows in Results area
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If you connect a USB keyboard, you can use it to enter values in alpha-numeric 
keypad dialogs.

Access the Built-In Online Help

To access the built-in online help, you can:

• From the menu, choose Help > Help....

• Most user interface dialog boxes have a ? help button next to the X close 
button.

Select the ? to open the online help for the dialog box.

The Help viewer dialog box has these features:

•  Home button — goes to the home topic.

•  Previous button — goes to the previous topic in the navigation 
sequence.

•  Next button — (after using the Previous button) goes to the next 
topic in the navigation sequence.

• Contents tab — lists the hierarchy of help topics.

Select a topic in the list to navigate to that topic.

• Index tab — contains a list of indexed keywords.

Select a keyword in the list to navigate to the topic where the keyword is 
mentioned.

Use the field above the list to list only those keywords that contain the string.

• Search tab — lets you search the online help for topics in which the entered 
words are found.

Enter the words to search for. Then, select List Topics.
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• The Help viewer dialog box cannot be resized, but it can be minimized, 
maximized, or dragged off the right side and/or bottom of the screen.

• You can resize the left-side navigation pane by dragging the vertical bar 
between it and the topic viewer pane left or right.
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2 Horizontal Controls

To adjust the horizontal scale (time/div) / 50
To adjust the horizontal delay (position) / 51
Panning and Zooming Single or Stopped Acquisitions / 52
To change the horizontal time mode (Normal, XY, or Roll) / 52
To display the zoomed time base / 56
To change the horizontal scale coarse/fine adjustment setting / 57
To position the time reference (left, center, right, custom) / 57
Searching for Events / 58
Navigating the Time Base / 59

The horizontal controls include:

• The horizontal scale and position knobs.

• The horizontal settings badge and Setup > Horizontal... menu item for accessing 
the Horizontal dialog box.

• The [Zoom] zoom key for quickly enabling/disabling the split-screen zoom 
display.

• The Analyze > Search... menu item and Search dialog box for finding events on 
analog channels or in protocol decode.

• The Analyze > Navigate... menu item and Navigate dialog box for navigating time, 
search events, or segmented memory acquisitions.

The following figure shows controls in the Horizontal dialog box.
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The Horizontal dialog box lets you select the time mode (Normal, XY, or Roll), 
enable Zoom, set the time base Fine control (vernier), and specify the time 
reference.

The current sample rate is displayed in the acquisition settings badge.

To adjust the horizontal scale (time/div)

You can adjust the horizontal scale in these ways:

• Turn the large horizontal scale (sweep speed) knob marked  to change 
the horizontal time/div setting.

Note that the horizontal scale knob has a different purpose in the Zoom display. 
See "To display the zoomed time base" on page 56.

• Use the Main Scale controls in the Horizontal dialog box (that you can open by 
selecting the Horizontal badge or by choosing Setup > Horizontal... from the main 
menu (see page 40)).

Trigger
point

Sample
rate

Time
reference

Time/div,
Delay time

Trigger
source

Trigger level
or threshold

Zoomed
time base

Normal
time mode

Fine
control

Time
reference
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As you adjust the horizontal scale, notice how the time/div information in the 
Horizontal badge changes.

The ∇ symbol at the top of the waveform grid indicates the time reference point.

You can adjust the horizontal scale (in the Normal time mode) while acquisitions 
are running or when they are stopped. When running, adjusting the horizontal 
scale can change the sample rate and memory depth. When stopped, adjusting 
the horizontal scale lets you zoom into acquired data. See "Panning and Zooming 
Single or Stopped Acquisitions" on page 52.

To adjust the horizontal delay (position)

You can adjust the horizontal delay in these ways:

• Turn the horizontal delay (position) knob ( ).

Note that the horizontal position knob has a different purpose in the Zoom 
display. See "To display the zoomed time base" on page 56.

• In the Drag Waveforms mode (see "Select Draw Box or Drag Waveforms 
Mode" on page 44), drag waveforms left or right.

• Use the Main Delay controls in the Horizontal dialog box (that you can open by 
selecting the Horizontal badge or by choosing Setup > Horizontal... from the main 
menu (see page 40)).

Changing the delay time moves the trigger point (solid inverted triangle) 
horizontally and indicates how far it is from the time reference point (hollow 
inverted triangle ∇). These reference points are indicated along the top of the 
waveform grid. The trigger point pauses at 0.00 s, mimicking a mechanical detent. 
The delay value is displayed in the Horizontal badge.

The delay time value tells you how far the time reference point is located from the 
trigger point. When delay time is set to zero, the delay time indicator overlays the 
time reference indicator.

All events displayed left of the trigger point happened before the trigger occurred. 
These events are called pre-trigger information, and they show events that led up 
to the trigger point.

Everything to the right of the trigger point is called post-trigger information. The 
amount of delay range (pre-trigger and post-trigger information) available 
depends on the time/div selected and memory depth.

When acquisitions are running (in the Normal time mode), adjusting the horizontal 
position changes the amount of pre-trigger and post-trigger data. When stopped, 
adjusting the horizontal position pans through the last-acquired data. See 
"Panning and Zooming Single or Stopped Acquisitions" on page 52.
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Panning and Zooming Single or Stopped Acquisitions

When the oscilloscope is stopped, use the horizontal scale and position knobs to 
pan and zoom your waveform. The stopped display may contain several 
acquisitions worth of information, but only the last acquisition is available for pan 
and zoom.

The ability to pan (move horizontally) and scale (expand or compress horizontally) 
an acquired waveform is important because of the additional insight it can reveal 
about the captured waveform. This additional insight is often gained from seeing 
the waveform at different levels of abstraction. You may want to view both the big 
picture and the specific little picture details.

The ability to examine waveform detail after the waveform has been acquired is a 
benefit generally associated with digital oscilloscopes. Often, this is simply the 
ability to freeze the display for the purpose of measuring with markers or saving 
the screen. Some digital oscilloscopes go one step further by including the ability 
to further examine the signal details after acquiring them by panning through the 
waveform and changing the horizontal scale.

There is no limit imposed on the scaling ratio between the time/div used to acquire 
the data and the time/div used to view the data. There is, however, a useful limit. 
This useful limit is somewhat a function of the signal you are analyzing.

To change the horizontal time mode (Normal, XY, or Roll)

1 Open the Horizontal dialog box by selecting the Horizontal badge or by 
choosing Setup > Horizontal... from the main menu (see page 40).

2 In the Horizontal dialog box, select the Time Mode:

• Normal — the normal viewing mode for the oscilloscope.

In the Normal time mode, signal events occurring before the trigger are 
plotted to the left of the trigger point (▼) and signal events after the trigger 
plotted to the right of the trigger point.

• XY — XY mode changes the display from a volts-versus-time display to a 
volts-versus-volts display. The time base is turned off. Channel 1 amplitude 
is plotted on the X-axis and Channel 2 amplitude is plotted on the Y-axis.

NOTE Zooming into stopped acquisitions

The screen will still contain a relatively good display if you zoom-in horizontally by a factor of 
1000 and zoom-in vertically by a factor of 10 to display the information from where it was 
acquired. Remember that you can make automatic measurements on displayed data only.
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You can use XY mode to compare frequency and phase relationships 
between two signals. XY mode can also be used with transducers to display 
strain versus displacement, flow versus pressure, volts versus current, or 
voltage versus frequency.

When the XY time mode is selected, you can use the XY Color Scheme 
drop-down list to select the waveform's color scheme (and persistence 
color). In all schemes, waveform intensity is shown using a color gradient.

Use the markers to make measurements on XY mode waveforms.

For more information about using XY mode for measurements, refer to "XY 
Time Mode" on page 54.

• Roll — causes the waveform to move slowly across the screen from right to 
left. It only operates on time base settings of 50 ms/div and slower. If the 
current time base setting is faster than the 50 ms/div limit, it will be set to 
50 ms/div when Roll mode is entered.

Use Roll mode on low-frequency waveforms to yield a display much like a 
strip chart recorder. It allows the waveform to roll across the display.

In Roll mode there is no trigger. The fixed reference point on the screen is 
the right edge of the screen and refers to the current moment in time. Events 
that have occurred are scrolled to the left of the reference point. Because 
there is no trigger, no pre-trigger information is available.

Roll mode uses the oscilloscope's deep memory. This means you can 
capture multiple screens of data instead of the normal one screen. When 
you stop a Roll mode acquisition, you can pan and zoom (using the 
horizontal controls) to view the full captured data record. In the Normal 
acquisition mode (see "Selecting the Acquisition Mode" on page 183), you 
get 4 Mpts per screen. In the Peak Detect acquisition mode (which uses twice 
the memory per point, halving the effective sampling rate), you get 2 Mpts 
per screen. The following table shows the number of screens captured in 
Roll mode given the oscilloscope's memory depth and acquisition mode.

Input channel type, Roll 
memory depth (oscilloscope 
memory depth)

Screens captured in Normal 
acquisition mode (4 Mpts per 
screen)

Screens captured in Peak 
Detect acquisition mode 
(2 Mpts per screen)

Analog, 20 Mpts (20M 
standard)

5 10

Analog, 40 Mpts (with 50M 
option license)

10 20

Analog, 80 Mpts (with 100M 
option license)

20 20 (40 Mpts max. Roll depth in 
Peak Detect)

Digital, 20 Mpts capture max. 5 10
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When running, the sampling rate adjusts for the time/div and acquisition 
mode settings.

XY Time Mode

The XY time mode converts the oscilloscope from a volts-versus-time display to a 
volts-versus-volts display using two input channels. Channel 1 is the X-axis input, 
channel 2 is the Y-axis input. You can use various transducers so the display could 
show strain versus displacement, flow versus pressure, volts versus current, or 
voltage versus frequency.

Example This exercise shows a common use of the XY display mode by measuring the phase 
difference between two signals of the same frequency with the Lissajous method.

1 Connect a sine wave signal to channel 1, and a sine wave signal of the same 
frequency but out of phase to channel 2.

2 Press the [Auto Scale] key.

3 Open the Horizontal dialog box by selecting the Horizontal badge or by 
choosing Setup > Horizontal... from the main menu (see page 40).

4 From the Time Mode drop-down list, select XY.

5 Center the signal on the display with the channel 1 and 2 position ( ) knobs. 
Use the channel 1 and 2 volts/div knobs and the channel 1 and 2 Fine options 
to expand the signal for convenient viewing.

The phase difference angle (θ) can be calculated using the following formula 
(assuming the amplitude is the same on both channels):

6 Press the [Markers] key.

Figure 5 XY time mode signals, centered on display
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7 Set the Y2 marker to the top of the signal, and set Y1 to the bottom of the 
signal.

Note the ΔY value at the bottom of the display. In this example, we are using 
the Y markers, but you could have used the X markers instead.

8 Move the Y1 and Y2 markers to the intersection of the signal and the Y axis. 
Again, note the ΔY value.

9 Calculate the phase difference using the formula below.

For example, if the first ΔY value is 2.297 and the second ΔY value is 1.319:

Figure 6 Phase difference measurements, automatic and using markers

θ Δ
Δ θ

NOTE Z-Axis Input in XY Display Mode (Blanking)

When you select the XY display mode, the time base is turned off. Channel 1 is the X-axis 
input, channel 2 is the Y-axis input, and the AUX TRIG IN is the Z-axis input. If you only want to 
see portions of the Y versus X display, use the Z-axis input. Z-axis turns the trace on and off 
(analog oscilloscopes called this Z-axis blanking because it turned the beam on and off). 
When Z is low (<1.4 V), Y versus X is displayed; when Z is high (>1.4 V), the trace is turned off.
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To display the zoomed time base

Zoom, formerly called Delayed sweep mode, is a horizontally expanded version of 
the normal display. When Zoom is selected, the display divides into a normal 
time/div window and a faster Zoom time/div window.

The Zoom window is a magnified portion of the normal time/div window. You can 
use Zoom to locate and horizontally expand part of the normal window for a more 
detailed (higher-resolution) analysis of signals.

To turn on (or off) Zoom:

1 Press the [Zoom] key (or select Zoom in the Horizontal dialog box).

The area of the normal display that is expanded is outlined with a box. The box 
shows the portion of the normal sweep that is expanded in the lower window.

To change the time/div for the Zoom window, turn the horizontal scale (sweep 
speed) knob. As you turn the knob, the zoomed window time/div is highlighted in 
the Horizontal badge. The Horizontal scale (sweep speed) knob controls the size of 
the box.

These box edges show
the beginning and end
of the Zoom window

Normal
window

Time/div
for zoomed
window

Time/div
for normal
window

Zoom
window

Signal
anomaly
expanded
in zoom
window
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The Horizontal position (delay time) knob sets the left-to-right position of the 
zoom window. The delay value, which is the time displayed relative to the trigger 
point) is momentarily displayed in the upper-right portion of the display when the 
delay time ( ) knob is turned.

Negative delay values indicate you are looking at a portion of the waveform before 
the trigger event, and positive values indicate you're looking at the waveform after 
the trigger event.

To change the time/div of the normal window, turn off Zoom; then, turn the 
horizontal scale (sweep speed) knob.

For information about using zoom mode for measurements, refer to "To isolate a 
pulse for Top measurement" on page 206 and "To isolate an event for frequency 
measurement" on page 212.

To change the horizontal scale coarse/fine adjustment setting

You can do one of these things:

• Push the horizontal scale knob to toggle between fine and coarse adjustment 
of the horizontal scale.

• Select the Fine option in the Horizontal dialog box (that you can open by 
selecting the Horizontal badge or by choosing Setup > Horizontal... from the main 
menu (see page 40)).

When Fine is enabled, turning the horizontal scale knob changes the time/div 
(displayed in the status line at the top of the display) in smaller increments. The 
time/div remains fully calibrated when Fine is on.

When Fine is turned off, the Horizontal scale knob changes the time/div setting in 
a 1-2-5 step sequence.

To position the time reference (left, center, right, custom)

Time reference is the reference point on the display for delay time (horizontal 
position).

1 Open the Horizontal dial box by selecting the Horizontal badge or by choosing 
Setup > Horizontal... from the main menu (see page 40).

2 In the Horizontal Menu, press Time Reference; then, select:

• Left — the time reference is set to one major division from the left edge of the 
display.

• Center — the time reference is set to the center of the display.

• Right — the time reference is set to one major division from the right edge of 
the display.
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• Custom Location — lets you place the time reference location at a percent of 
the graticule width (where 0% is the left edge and 100% is the right edge).

A small hollow triangle (∇) at the top of the display grid marks the position of the 
time reference. When delay time is set to zero, the trigger point indicator (▼) 
overlays the time reference indicator.

The time reference position sets the initial position of the trigger event within 
acquisition memory and on the display, with delay set to 0.

Turning the Horizontal scale (sweep speed) knob expands or contracts the 
waveform about the time reference point (∇). See "To adjust the horizontal scale 
(time/div)" on page 50.

Turning the Horizontal position ( ) knob in Normal mode (not Zoom) moves the 
trigger point indicator (▼) to the left or right of the time reference point (∇). See 
"To adjust the horizontal delay (position)" on page 51.

Searching for Events

You can use the Analyze > Search... menu item and Search dialog box to search for 
Edge, Pulse Width, Rise/Fall Time, Runt, Frequency Peaks, and Protocol Decode 
events on the analog channels.

Setting up searches (see "To set up searches" on page 58) is similar to setting up 
triggers. In fact, except for Frequency Peaks and Protocol Decode events, you can 
copy search setups to trigger setups and vice-versa (see "To copy search setups" 
on page 59).

Searches are different than triggers in that they use the measurement threshold 
settings instead of trigger levels.

Found search events are marked with white triangles at the top of the grid, and the 
number of events found is displayed in the listing on the right side of the display.

To set up searches

1 From the menu, choose Analyze > Search....

2 In the Search dialog box, select On.

3 Select the Search Type, and use the additional controls to set up the selected 
search type.

In most cases, setting up searches is similar to setting up triggers:

• For setting up Edge searches, see "Edge Trigger" on page 151.

• For setting up Pulse Width searches, see "Pulse Width Trigger" on 
page 155.
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• For setting up Rise/Fall Time searches, see "Rise/Fall Time Trigger" on 
page 160.

• For setting up Runt searches, see "Runt Trigger" on page 162.

• For setting up Frequency Peak searches, see "Searching for FFT Peaks" on 
page 78.

• For setting up Protocol searches, see "Protocol Trigger" on page 165 and 
"Searching Lister Data" on page 132.

Remember that searches use the measurement threshold settings instead of 
trigger levels. Select Thresholds... to open the Measurement Threshold dialog box. 
See "Measurement Thresholds" on page 222.

To copy search setups

Except for Frequency Peak and Protocol event search setups, you can copy search 
setups to trigger setups and vice-versa.

1 From the menu, choose Analyze > Search....

2 In the Search dialog box, select On.

3 Select the Search Type, and use the additional controls to set up the selected 
search type.

4 Select Copy....

5 In the Copy dialog box:

• Select Copy to Trigger to copy the setup for the selected search type to the 
same trigger type. For example, if the current search type is Pulse Width, 
selecting Copy to Trigger copies the search settings to the Pulse Width trigger 
settings and selects the Pulse Width trigger.

• Select Copy from Trigger to copy the trigger setup for the selected search type 
to the search setup.

• To undo a copy, select Undo Copy.

The buttons in the Copy dialog box may not be available when one of the 
settings cannot be copied or there is no trigger type that corresponds to the 
search type.

Navigating the Time Base

You can use the Analyze > Navigate... menu item, Navigate dialog box, and 
navigation controls to navigate through:

• Captured data (see "To navigate time" on page 60).

• Search events (see "To navigate search events" on page 60).
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• Segments, when segmented memory acquisitions are turned on (see "To 
navigate segments" on page 60).

To navigate time

When acquisitions are stopped, you can use the navigation controls to play 
through the captured data.

1 From the menu, choose Analyze > Navigate....

2 In the Navigate dialog box, select the Time navigation type.

3 Select the    navigation buttons to play backward, stop, or play 

forward in time. You can select the  or  buttons multiple times to speed 
up the playback. There are three speed levels.

To navigate search events

When acquisitions are stopped, you can use the navigation controls to go to found 
search events (set using Analyze > Search... and the Search dialog box, see 
"Searching for Events" on page 58).

1 From the menu, choose Analyze > Navigate....

2 In the Navigate dialog box, select the Search navigation type.

3 Select the   back and forward navigation buttons to go to the previous or 
next search event.

When searching Protocol Decode:

• You can press the  stop key to set or clear a mark.

• The Auto zoom option specifies whether the waveform display is automatically 
zoomed to fit the marked row as you navigate.

• The Scroll Lister option lets you use the Entry knob to scroll through data rows in 
the Lister display.

To navigate segments

When the segmented memory acquisition is enabled and acquisitions are stopped, 
you can use the navigation controls to play through the acquired segments.

1 From the menu, choose Analyze > Navigate....

2 In the Navigate dialog box, select the Segments navigation type.

3 For the Play Mode, you can select:

• Manual — to play through segments manually.

In the Manual play mode:
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• Select the   back and forward buttons to go to the previous or next 
segment.

• Select the  button to go to the first segment.

• Select the  button to go to the last segment.

• Select the  button to go to the next page of segments.

• Select the  button to go to the previous page of segments.

• Auto — to play through segments in an automated fashion.

In the Auto play mode:

• Select the    navigation buttons to play backward, stop, or play 

forward in time. You can select the  or  buttons multiple times to 
speed up the playback. There are three speed levels.
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To turn waveforms on or off / 64
To adjust the vertical scale / 65
To adjust the vertical position / 65
To specify channel coupling / 65
To specify channel input impedance / 66
To limit bandwidth and improve vertical resolution / 67
To change the vertical scale knob's coarse/fine adjustment setting / 68
To invert a channel waveform / 68
Setting Analog Channel Probe Options / 68

The vertical controls include:

• Multiplexed vertical scale and position knobs for the analog input channels.

• The channel keys for turning a channel on or off.

• Touchscreen waveform badge controls for setting the vertical scale and 
position (offset) and accessing the settings dialog boxes.

The following figure shows vertical controls in the Channel dialog box.
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The ground level of the signal for each displayed analog channel is identified by 
the position of the  icon at the far-left side of the display.

To turn waveforms on or off

• Press an analog channel key turn the channel on or off.

When a channel is on, its key is lit.

• On the touchscreen, you can quickly turn waveforms on or off using the  
Quick Selection button and dialog box. Also, dialog boxes under the Sources > 
menu have controls for turning waveforms on or off.

Channel scale,
offset

Channel 1
ground
level

Trigger
source

Trigger level
or threshold 

Channel 2
ground
level

Trigger
level

Waveform quick
selection (on/off)

NOTE Turning channels off

A channel must be selected for vertical knob adjustment—as shown by the LED next to the 
channel key—before pressing the channel key will turn off the channel. For example, if channel 
1 and channel 2 are turned on and the vertical knobs are enabled for channel 2, to turn 
channel 1 off, press [1] to enable the vertical knobs for channel 1; then, press [1] again to turn 
channel 1 off.
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To adjust the vertical scale

You can do one of these things:

• Turn the large vertical scale knob marked  to set the vertical scale 
(units/division) for the selected channel.

• Use the Scale controls in the waveform dialog box (that you can open by 
selecting the waveform badge or by choosing Sources > (waveform)... from the 
main menu (see page 40)).

The vertical scale knob changes the analog channel scale in a 1-2-5 step 
sequence (with a 1:1 probe attached) unless fine adjustment is enabled (see "To 
change the vertical scale knob's coarse/fine adjustment setting" on page 68).

The analog channel Units/Div value is displayed in the status line.

The default mode for expanding the signal when you adjust the vertical scale is 
expansion about the ground level of the waveform; however, you can change this 
to expand about the center of the display. See "To choose "expand about" center 
or ground" on page 309.

To adjust the vertical position

You can do one of these things:

• Turn the small vertical position knob ( ) to move the selected channel's 
waveform up or down on the display.

• Use the Offset controls in the waveform dialog box (that you can open by 
selecting the waveform badge or by choosing Sources > (waveform)... from the 
main menu (see page 40)).

The offset voltage value represents the voltage difference between the vertical 
center of the display and the ground level ( ) icon. It also represents the voltage 
at the vertical center of the display if vertical expansion is set to expand about 
ground (see "To choose "expand about" center or ground" on page 309).

To specify channel coupling

Coupling changes the channel's input coupling to either AC (alternating current) or 
DC (direct current).
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1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, select Coupling to select the input channel coupling:

• DC — DC coupling is useful for viewing waveforms as low as 0 Hz that do not 
have large DC offsets.

• AC — AC coupling is useful for viewing waveforms with large DC offsets.

When AC coupling is chosen, you cannot select 50Ω mode. This is done to 
prevent damage to the oscilloscope.

AC coupling places a 10 Hz high-pass filter in series with the input 
waveform that removes any DC offset voltage from the waveform.

Note that Channel Coupling is independent of Trigger Coupling. To change trigger 
coupling see "To select the trigger coupling" on page 172.

To specify channel input impedance

1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, select the Impedance:

• 50 Ohm — matches 50 ohm cables commonly used in making high frequency 
measurements, and 50 ohm active probes.

When 50 Ohm input impedance is selected, it is displayed with the channel 
information on-screen.

When AC coupling is selected (see "To specify channel coupling" on 
page 65) or excessive voltage is applied to the input, the oscilloscope 
automatically switches to 1M Ohm mode to prevent possible damage.

• 1M Ohm — is for use with many passive probes and for general-purpose 
measurements. The higher impedance minimizes the loading effect of the 
oscilloscope on the device under test.

TIP If the channel is DC coupled, you can quickly measure the DC component of the signal by 
simply noting its distance from the ground symbol.

If the channel is AC coupled, the DC component of the signal is removed, allowing you to use 
greater sensitivity to display the AC component of the signal.

NOTE When you connect an AutoProbe, self-sensing probe, or a compatible InfiniiMax probe, the 
oscilloscope automatically configures the analog input channels to the correct impedance.
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Impedance matching gives you the most accurate measurements because 
reflections are minimized along the signal path.

See Also • For more information on probing, visit: www.keysight.com/find/scope_probes

• Information about selecting a probe can be found in document number 
Keysight Oscilloscope Probes and Accessories Selection Guide (part number 
5989-6162EN), available at www.keysight.com.

To limit bandwidth and improve vertical resolution

Limiting the channel bandwidth with digital filters lets you remove unwanted high 
frequency noise from the waveform and potentially increase the number of bits of 
vertical resolution.

To select the channel bandwidth limit and vertical resolution:

1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, use the Bandwidth/Resolution drop-down list to 
disable or enable channel bandwidth limiting.

The selections that improve the number of bits of vertical resolution are marked 
with "HD" (high-definition).

3 To apply the channel bandwidth limit selection to all analog input channels, 
select Apply To All.

NOTE The 5 MHz and 10 MHz selections are automatically applied to all analog input channels.

http://www.keysight.com/find/scope_probes
http://literature.cdn.keysight.com/litweb/pdf/5989-6162EN.pdf
http://www.keysight.com
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To change the vertical scale knob's coarse/fine adjustment setting

You can do one of these things:

• Push the vertical scale knob to toggle between fine and coarse adjustment of 
the vertical scale.

• Select the Fine option in the waveform's settings dialog box (that you can open 
by selecting the waveform badge or by choosing Sources > (waveform)... from the 
main menu (see page 40)).

When Fine adjustment is selected, you can change the channel's vertical sensitivity 
in smaller increments. The channel sensitivity remains fully calibrated when Fine is 
on.

The vertical scale value is displayed in the waveform badge at the top of the 
display.

When Fine is turned off, adjusting the vertical scale goes in a 1-2-5 step sequence.

To invert a channel waveform

1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, select Invert to invert the channel.

When Invert is selected, the voltage values of the displayed waveform are inverted.

Invert affects how a channel is displayed. However, when using basic triggers, the 
oscilloscope attempts to maintain the same trigger point by changing trigger 
settings.

Inverting a channel also changes the result of any math function using the channel 
(see the Analyze > Math... menu) or any measurement on the channel.

Setting Analog Channel Probe Options

1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, select Probe....

3 In the Probe dialog box, you select additional probe parameters such as units of 
measurement, attenuation factor, and skew for the connected probe.
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For passive probes (such as the N2862A/B, N2863A/B, N2889A, N2890A, 
10073C, 10074C, or 1165A probes), the Probe Check button appears; it guides 
you through the process of compensating probes.

For some active probes (such as InfiniiMax probes), the oscilloscope can 
accurately calibrate its analog channels for the probe. When you connect a 
probe that can be calibrated, the Calibrate Probe button appears (and the probe 
attenuation may change). See "To calibrate a probe" on page 71.

The Find Signal button appears with certain probes. Instead of Autoscale, use 
this button to automatically find the offset that places the signal on center 
screen. Autoscale may not work correctly with this probe for all signals.

See Also • "To specify the channel units" on page 69

• "To specify the probe attenuation" on page 69

• "To specify the probe skew" on page 70

• "To specify the channel external scaling" on page 72

To specify the channel units

1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, select Probe....

3 In the Probe dialog box, select the Units:

• Volts — for a voltage probe.

• Amps — for a current probe.

Channel sensitivity, trigger level, measurement results, and math functions will 
reflect the measurement units you have selected.

To specify the probe attenuation

This is set automatically if the oscilloscope can identify the connected probe. See 
Analog channel inputs (see page 26).
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The probe attenuation factor must be set properly for accurate measurement 
results.

If you connect a probe that is not automatically identified by the oscilloscope, you 
can manually set the attenuation factor as follows:

1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, select Probe....

3 In the Probe dialog box, select how you want to specify the Attenuation factor, 
choosing either Ratio or Decibels.

4 Select the attenuation factor field (either Ratio or Decibels), and turn the Entry 

knob  to set the attenuation factor for the connected probe.

When measuring voltage values, the attenuation factor can be set from 0.001:1 to 
10000:1 in a 1-2-5 sequence.

When measuring current values with a current probe, the attenuation factor can 
be set from 1.00 kV/A to 0.0001 V/A.

When specifying the attenuation factor in decibels, you can select values from 
-60 dB to 80 dB.

If Amps is chosen as the units and a manual attenuation factor is chosen, then the 
units as well as the attenuation factor are displayed in the Channel badge.

To specify the probe skew

When measuring time intervals in the nanoseconds (ns) range, small differences in 
cable length can affect the measurement. Use Skew to remove cable-delay errors 
between any two channels.

1 Probe the same point with both probes.

2 For one of the probes, open the Channel dialog box by selecting the Channel 
badge or by choosing Sources > Channel N... from the main menu (see page 40).

3 In the Channel dialog box, select Probe....

4 Select the Skew field, and turn the Entry knob  or enter the desired skew 
value.

Each analog channel can be adjusted ±100 ns in 2.5 ps increments for a total of 
200 ns difference.

The skew setting is not affected by pressing [Default Setup] or [Auto Scale].
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To calibrate a probe

The Probe Check button guides you through the process of calibrating probes.

For certain active probes, such as InfiniiMax probes, the oscilloscope can 
accurately calibrate its analog channels for the probe. When you connect a probe 
that can be calibrated, the Probe Check button in the Probe dialog box becomes 
active.

To calibrate one of these probes:

1 First, plug your probe into one of the oscilloscope channels.

This could be, for example, an InfiniiMax probe amplifier/probe head with 
attenuators attached.

2 Connect the probe to the Probe Comp terminal, and the probe ground to the 
ground terminal.

3 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

4 In the Channel dialog box, select Probe....

5 In the Probe dialog box, if there is a field for specifying your probe head (and 
attenuation), select the option that matches the attenuator you are using:

• 10:1 single-ended browser (no attenuator).

• 10:1 differential browser (no attenuator).

• 10:1 (+6 dB Atten) single-ended browser.

• 10:1 (+6 dB Atten) differential browser.

• 10:1 (+12 dB Atten) single-ended browser.

• 10:1 (+12 dB Atten) differential browser.

• 10:1 (+20 dB Atten) single-ended browser.

• 10:1 (+20 dB Atten) differential browser.

6 Select Probe Check and follow the instructions on the display.

For more information on InfiniiMax probes and accessories, see the probe's User's 
Guide.

NOTE When calibrating a differential probe, connect the positive lead to the Probe Comp terminal 
and the negative lead to the ground terminal. You may need to connect an alligator clip to the 
ground lug to allow a differential probe to span between the Probe Comp test point and 
ground. A good ground connection ensures the most accurate probe calibration.
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To specify the channel external scaling

External scaling lets you apply additional gain to the input channel to account for 
additional attenuators, adapters, etc., in the probing system.

1 Open the Channel dialog box by selecting the Channel badge or by choosing 
Sources > Channel N... from the main menu (see page 40).

2 In the Channel dialog box, select Probe....

3 In the Probe dialog box's External Scaling area:

a Select On to enable or disable external scaling.

b For External Gain, select either Ratio or Decibels to specify how you want to 
enter the attenuation factor.

c Select the attenuation factor field (either Ratio or Decibels), and turn the 

Entry knob  to set the attenuation factor for the connected probe.
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FFT is used to compute the fast Fourier transform using analog input channels or a 
lower math function. FFT takes the digitized time record of the specified source 
and transforms it to the frequency domain. When the FFT function is selected, the 
FFT spectrum is plotted on the oscilloscope display as magnitude in dBV versus 
frequency. The readout for the horizontal axis changes from time to frequency 
(Hertz) and the vertical readout changes from volts to dB.

Use the FFT function to find crosstalk problems, to find distortion problems in 
analog waveforms caused by amplifier non-linearity, or for adjusting analog filters.

To display a FFT waveform:

1 From the menu, choose Analyze > FFT....

2 In the FFT dialog box, select On.

The following FFT spectrum was obtained by connecting a 2.5 V, 100 kHz square 
wave to channel 3. The time domain horizontal scale is set to 50 µs/div. The 
channel 3 vertical scale is set to 500 mV/div. The FFT Center frequency is 500 kHz, 
the frequency Span is 1 MHz, and window is set to Hanning. The FFT waveform 
vertical scale is set to 20 dBV, and the vertical offset is set to -40.0 dBV.
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You can use the X1 and X2 markers to measure frequency values and difference 
between two frequency values (ΔX). Use the Y1 and Y2 markers to measure 
amplitude in dB and difference in amplitude (ΔY).

You can make peak-to-peak, maximum, minimum, and average dB measurements 
on the FFT waveform. You can also find the frequency value at the first occurrence 
of the waveform maximum by using the X at Max Y measurement.

The FFT dialog box has these controls:

• On — Turns the FFT waveform on or off.

• Auto Setup Only — When selected, the FFT waveform scale, offset, and horizontal 
scaling are automatically determined when the FFT waveform is turned on or 
whenever you select Auto Setup. The controls for manually changing these 
settings are grayed-out and unavailable. "Auto" is displayed in the FFT badge, 
and mouse wheel scaling of values in the badge is unavailable.

When cleared, no automatic setup occurs unless you select Auto Setup (which is 
always available). The controls for manually setting up the scale, offset, and 
horizontal scaling are available, and their settings will not automatically change 
when the waveform is turned on (or off and then back on).

• Auto Setup — Sets the frequency Span and Center to values that will cause at 
least 10% of the spectrum to be displayed. The maximum available frequency is 
half the FFT sample rate, which is a function of the time per division setting. 
The FFT resolution is the quotient of the sampling rate and the number of FFT 
points (fS/N). The current FFT Resolution is displayed on screen.
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• Y Scale — Adjusts the FFT waveform's vertical scale (units/division), making the 
waveform shorter or taller on the display. The vertical scale is displayed in the 
FFT badge at the top of the display.

You can also make this adjustment using a touchscreen vertical pinch gesture 
in waveform drag mode.

The default mode for expanding the signal when you adjust the vertical scale is 
vertical expansion about the ground level of the waveform; however, you can 
change this to expand about the center of the display. See "Setting 
Oscilloscope Preferences" on page 308.

When Fine is not selected (that is, coarse adjustment), the shorter and taller 
buttons in the dialog box change the vertical scale in a 1-2-5 step sequence. 
When Fine adjustment is selected, you can change the math function's vertical 
sensitivity in smaller increments.

• Y Offset — Adjusts the waveform's vertical offset, moving it up or down on the 
display. The vertical offset is displayed in the FFT badge at the top of the 
display.

You can also make this adjustment using the touchscreen in waveform drag 
mode.

The offset value is the value at the vertical center of the display.

• Analysis Precision... — Opens the Analysis Precision dialog box where you can 
specify the analysis record length (for measurements and math function 
waveforms). See "The Analysis Record and Waveform Math" on page 105.

• Math Gating — Specifies the input waveform data on which the FFT function is 
calculated:

• None — The FFT function is performed on input waveform data from the Main 
window and is displayed in the Main window.

If the Zoomed time base is displayed, the Zoom window shows "zoomed in" 
data from the Main window.

• Zoom — This option is available when the Zoom window is displayed. The FFT 
function is performed on input waveform data from the Zoom window and is 
displayed in the Zoom window only. The FFT function will have better 
resolution because less decimation is needed for the measurement record.

• Markers — The FFT function is performed on the input waveform data 
between the horizontal markers and is displayed in the Main window. The 
FFT function will have better resolution because less decimation is needed 
for the measurement record.

If the Zoomed time base is displayed, the Zoom window shows "zoomed in" 
data from the Main window, possibly containing the improved-resolution FFT 
function waveform, depending on the location of the Zoom window.
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Because this selection can affect the resolution of the FFT function waveform, it 
can also affect measurements made on the FFT function waveform, depending 
on the selected measurement window (see "Measurement Window" on 
page 224). When you improve the resolution of an FFT function using the Zoom 
or Markers options, you will likely want to match the measurement window to 
look at the improved-resolution data.

• Input — Selects how the displayed frequency range is entered:

• Center/Span — Span specifies the frequency range represented by the width 
of the display. Divide span by 10 to calculate the frequency scale per 
division. Center specifies the frequency at the center vertical grid line of the 
display.

• Start/Stop — Start Freq specifies the frequency at the left side of the display. 
Stop Freq specifies the frequency at the right side of the display.

• Source 1 — Select the analog channel, math function, or reference waveform on 
which to perform the FFT.

• Readout — Specifies how the FFT resolution is displayed: Off, Sample Rate, Bin 
Size, RBW (Resolution Bandwidth).

• Display Mode — selects one of these FFT waveform display modes:

• Normal — this is the FFT waveform without any averaging or hold functions 
applied. This is how FFT math function waveforms are displayed.

• Averaged Value — the FFT waveform is averaged the selected number of 
times. Averages are calculated using a "decaying average" approximation, 
where:

next_average = current_average + (new_data - current_average)/N

Where N starts at 1 for the first acquisition and increments for each 
following acquisition until it reaches the selected number of averages, where 
it holds.

• Max Hold — records the maximum vertical values found at each horizontal 
bucket across multiple analysis cycles and uses those values to build a 
waveform. This display mode is often referred to as Max Envelope.

• Min Hold — records the minimum vertical values found at each horizontal 
bucket across multiple analysis cycles and uses those values to build a 
waveform. This display mode is often referred to as Min Envelope.

• Add Max Function — Adds another math function waveform that is the Max Hold 
operator on the FFT math function waveform.

• Advanced FFT... — Opens the Advanced FFT dialog box where you can select a 
window, specify vertical units, select gating, or set up detectors.

• Search Peaks... — Opens the Search dialog box where you can set up a frequency 
peaks search. See "Searching for FFT Peaks" on page 78.

The Advanced FFT dialog box has these controls:
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• Window — Selects a window to apply to your FFT input signal:

• Hanning — window for making accurate frequency measurements or for 
resolving two frequencies that are close together.

• Flat Top — window for making accurate amplitude measurements of 
frequency peaks.

• Rectangular — good frequency resolution and amplitude accuracy, but use 
only where there will be no leakage effects. Use on self-windowing 
waveforms such as pseudo-random noise, impulses, sine bursts, and 
decaying sinusoids.

• Blackman Harris — window reduces time resolution compared to a rectangular 
window, but improves the capacity to detect smaller impulses due to lower 
secondary lobes.

• Bartlett — (triangular, with end points at zero) window is similar to the 
Hanning window in that it is good for making accurate frequency 
measurements, but its higher and wider secondary lobes make it not quite 
as good for resolving frequencies that are close together.

• Vertical Units — For the FFT (Magnitude) math function, you can select Logarithmic 
(decibels) or Linear (V RMS). For the FFT (Phase) math function, you can select 
Degrees or Radians.

• Detection Type — When the FFT (Magnitude) operator is selected, this option lets 
you set the FFT detector decimation type.

Detectors give you a way of manipulating the acquired data to emphasize 
different features of the data. Detectors reduce (decimate) the number of FFT 
points to at most the number of specified detector points. In this reduction, 
sampled FFT points are bucketized, that is, split into a number of groups that 
equals the specified number of detector points. Then, the points in each bucket 
are reduced to a single point according to the selected detection type. The 
detector types are:

• None — No detector is used.

• Sample — Takes the point nearest to the center of every bucket.

• + Peak — Takes the most positive point in every bucket.

• - Peak — Takes the most negative point in every bucket.

• Average — Takes the average of all points in every bucket.

• Normal — Implements a rosenfell algorithm. This method picks either the 
minimum or maximum sample in every bucket depending on whether the 
data is monotonically increasing, decreasing, or varying.
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When detectors are used, the FFT's output is decimated, and any analysis is 
performed on the reduced or detected data set.

• Points per Span — When the FFT (Magnitude) operator is selected and a detector is 
used, this field specifies the maximum number of points that detectors should 
decimate to. This is also the number of buckets that sampled FFT points are 
grouped into before the selected detection type reduction (decimation) is 
applied.

The minimum number of points is 640.

The maximum number of points is 64K.

See Also • "Searching for FFT Peaks" on page 78

• "FFT Measurement Hints" on page 79

• "FFT Units" on page 80

• "FFT DC Value" on page 80

• "FFT Aliasing" on page 80

• "FFT Aliasing Example" on page 81

• "FFT Spectral Leakage" on page 81

• "Units for Math Waveforms" on page 87

• For more information on the use of FFTs please refer to Keysight Application 
Note 243, The Fundamentals of Signal Analysis at 
http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf. Additional 
information can be obtained from Chapter 4 of the book Spectrum and Network 
Measurements by Robert A. Witte.

Searching for FFT Peaks

With frequency domain waveforms, you can use the Search analysis feature 
(Analyze > Search...) to search for frequency peaks.

In the Search dialog box with the Freq Peaks search selected, there are these 
controls:

• Max # Peaks — Specifies the maximum number of FFT peaks to find.

• Threshold — Specifies the threshold level necessary to be considered a peak.

• Excursion — Specifies the amplitude above the FFT waveform's noise floor 
necessary to be recognized as a peak.

Note that the FFT waveform's noise floor level differs when additional math 
functions are applied to the FFT:

• When Averaged Value, Max Hold, or Min Hold are applied, the FFT waveform's 
noise floor is more stable, and excursion level settings are more accurate.

http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf
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• When no additional math functions are applied (normal), the FFT 
waveform's noise floor is less stable and excursion level settings are less 
accurate.

• Results Order — Specifies whether the found FFT peaks should be ordered by 
frequency or by amplitude.

Your selection also affects the order of found FFT peaks in the "search events 
found" list.

White arrowheads at the top of the graticule show where FFT peaks are found.

When acquisitions are stopped, you can use the Navigate analysis feature (Analyze 
> Navigate...) to look at the search events found.

FFT Measurement Hints

The number of points acquired for the FFT record can be up to 32M, and when 
frequency span is at maximum, all points are displayed. Once the FFT spectrum is 
displayed, the frequency span and center frequency controls are used much like 
the controls of a spectrum analyzer to examine the frequency of interest in greater 
detail. Place the desired part of the waveform at the center of the screen and 
decrease frequency span to increase the display resolution. As frequency span is 
decreased, the number of points shown is reduced, and the display is magnified.

Decreasing the effective sampling rate by selecting a greater time/div setting will 
increase the low frequency resolution of the FFT display and also increase the 
chance that an alias will be displayed. The resolution of the FFT is the effective 
sample rate divided by the number of points in the FFT. The actual resolution of 
the display will not be this fine as the shape of the window will be the actual 
limiting factor in the FFTs ability to resolve two closely space frequencies. A good 
way to test the ability of the FFT to resolve two closely spaced frequencies is to 
examine the sidebands of an amplitude modulated sine wave.

For the best vertical accuracy on peak measurements:

• Make sure the probe attenuation is set correctly. The probe attenuation is set 
from the Channel Menu if the operand is a channel.

• Set the source sensitivity so that the input signal is near full screen, but not 
clipped.

• Use the Flat Top window.

NOTE FFT Resolution

The FFT resolution is the quotient of the sampling rate and the number of FFT points (fS/N). 
With a fixed number of FFT points (up to 32M), the lower the sampling rate, the better the 
resolution.
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• Set the FFT sensitivity to a sensitive range, such as 2 dB/division.

For best frequency accuracy on peaks:

• Use the Hanning window.

• Use Cursors to place an X cursor on the frequency of interest.

• Adjust frequency span for better cursor placement.

• Return to the Cursors Menu to fine tune the X cursor.

FFT Units

FFT (Magnitude)
Units

FFT units are displayed as dB.

FFT (Phase) Units In this case, the vertical units are degrees or radians.

FFT DC Value

The FFT computation produces a DC value that is incorrect. It does not take the 
offset at center screen into account. The DC value is not corrected in order to 
accurately represent frequency components near DC.

FFT Aliasing

When using FFTs, it is important to be aware of frequency aliasing. This requires 
that the operator have some knowledge as to what the frequency domain should 
contain, and also consider the sampling rate, frequency span, and oscilloscope 
vertical bandwidth when making FFT measurements. The FFT resolution (or RBW 
which is the quotient of the sampling rate and the number of FFT points), sample 
rate, or bin size can be displayed in the FFT waveform grid.

Aliasing happens when there are frequency components in the signal higher than 
half the sample rate. Because the FFT spectrum is limited by this frequency, any 
higher components are displayed at a lower (aliased) frequency.

NOTE Nyquist Frequency and Aliasing in the Frequency Domain

The Nyquist frequency is the highest frequency that any real-time digitizing oscilloscope can 
acquire without aliasing. This frequency is half of the sample rate. Frequencies above the 
Nyquist frequency will be under sampled, which causes aliasing. The Nyquist frequency is also 
called the folding frequency because aliased frequency components fold back from that 
frequency when viewing the frequency domain.
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Because the frequency span goes from ≈ 0 to the Nyquist frequency, the best way 
to prevent aliasing is to make sure that the frequency span is greater than the 
frequencies of significant energy present in the input signal.

FFT Aliasing Example

The following figure illustrates aliasing. This is the spectrum of a 990 Hz square 
wave, which has many harmonics. The horizontal time/div setting for the square 
wave sets the sample rate and results in a FFT resolution of 1.91 Hz. The displayed 
FFT spectrum waveform shows the components of the input signal above the 
Nyquist frequency to be mirrored (aliased) on the display and reflected off the right 
edge.

FFT Spectral Leakage

The FFT operation assumes that the time record repeats. Unless there is an 
integral number of cycles of the sampled waveform in the record, a discontinuity is 
created at the end of the record. This is referred to as leakage. In order to minimize 
spectral leakage, windows that approach zero smoothly at the beginning and end 
of the signal are employed as filters to the FFT. The FFT Menu provides these 
windows: Hanning, Flat Top, Rectangular, Blackman-Harris, and Bartlett.

Figure 7 FFT Aliasing
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FFT Max Function

The FFT Max function is a Max Hold function applied to the FFT function. The FFT 
function must be turned on before you can enable the FFT Max function.

The FFT Max Function dialog box has these controls:

• On — Enables or disables the FFT Max function.

• Reset Count — Clears the number of waveforms evaluated.
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In addition to the dedicated FFT function (see Chapter 4, “FFT Spectral Analysis,” 
starting on page 73), you can define four other math functions.

Math functions can be performed on analog channels or they can be performed on 
lower math functions when using operators other than add, subtract, multiply, or 
divide.

To display math waveforms

1 From the menu, choose Analyze > Math....

The Math dialog box has tabs for the four available math function waveforms, 
M1, M2, M3, and M4.

2 In the tab for the math function you want to use, select On.
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3 From the Operator list, select the arithmetic, transform, FFT, filter, or 
visualization math function you want to display.

To filter the operator list, you can select the Category of operators you want to 
select from:

• All — All math function operators.

• Arithmetic — Only arithmetic math function operators (add, subtract, 
multiply, or divide of two waveform sources). See "Arithmetic Math 
Functions" on page 87.

• Transforms — Only math function operators that transform a single waveform 
source (for example, differentiate, integrate, logarithm, exponential). See 
"Transforms Math Functions" on page 89.

• FFT — Only FFT math function operators (FFT magnitude or FFT phase). See 
"FFT Math Functions" on page 97.

• Filters — Only math function operators that apply filters to a single waveform 
source (for example, low-pass, high-pass, band-pass, smoothing). See 
"Filters Math Functions" on page 99.

• Visualizations — Only math function operators that plot selected values (for 
example, maximum, minimum, measurement trend, chart). See 
"Visualizations Math Functions" on page 102.

4 Use the Source 1 drop-down list to select the analog channel, lower math 
function, or reference waveform on which to perform math.

Higher math functions can operate on lower math functions when using 
operators other than the simple arithmetic operations (+, -, *, /). For example, if 
Math 1 is set up as a subtract operation between channels 1 and 2, the Math 2 
function could be set up as a FFT operation on the Math 1 function. These are 
called cascaded math functions.

To cascade math functions, select the lower math function using the Source 1 
drop-down-list.

5 If you selected an arithmetic operator for the math function, use the Source 2 
drop-down list to select the second source for the arithmetic operation.

6 To re-size and re-position the math waveform, use these controls:

• Auto Setup Only — When selected, the math function waveform scale and 
offset are automatically determined when the waveform is turned on, when 
a different operator is selected, or whenever you select Auto Setup. The 
controls for manually changing these settings are grayed-out and 
unavailable. "Auto" is displayed in the math function badge, and mouse 
wheel scaling of values in the badge is unavailable.

TIP When cascading math functions, to get the most accurate results, be sure to vertically scale 
lower math functions so that their waveforms take up the full screen without being clipped.
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When cleared, no automatic setup occurs unless you select Auto Setup 
(which is always available). The controls for manually setting up the scale 
and offset are available, and their settings will not automatically change 
when the waveform is turned on (or off and then back on) or when a different 
operator is selected.

• Auto Setup — Automatically sets the Y Scale and Y Offset to optimum values for 
the math function waveform.

• Y Scale — Adjusts the math function waveform's vertical scale 
(units/division), making the waveform shorter or taller on the display. The 
vertical scale is displayed in the math function badge at the top of the 
display.

You can also make this adjustment using a touchscreen vertical pinch 
gesture in waveform drag mode.

The default mode for expanding the signal when you adjust the vertical 
scale is vertical expansion about the ground level of the waveform; however, 
you can change this to expand about the center of the display. See "To 
choose "expand about" center or ground" on page 309.

When Fine is not selected (that is, coarse adjustment), the shorter and taller 
buttons in the dialog box change the vertical scale in a 1-2-5 step 
sequence. When Fine adjustment is selected, you can change the math 
function's vertical sensitivity in smaller increments.

• Y Offset — Adjusts the waveform's vertical offset, moving it up or down on the 
display. The vertical offset is displayed in the math function badge at the top 
of the display.

You can also make this adjustment using the touchscreen in waveform drag 
mode.

The offset voltage value represents the voltage difference between the 
vertical center of the display and the ground level () icon. It also represents 
the voltage at the vertical center of the display if vertical expansion is set to 
expand about ground (see "To choose "expand about" center or ground" on 
page 309).

7 To specify the analysis record length (for measurements and math function 
waveforms), select Analysis Precision.... See "The Analysis Record and Waveform 
Math" on page 105.

8 To specify the input waveform data on which the math function is calculated, 
select the Math Gating option:

• None — The math function is performed on input waveform data from the 
Main window and is displayed in the Main window.

If the Zoomed time base is displayed, the Zoom window shows "zoomed in" 
data from the Main window.
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• Zoom — This option is available when the Zoom window is displayed. The 
math function is performed on input waveform data from the Zoom window 
and is displayed in the Zoom window only. The math function will have 
better resolution because less decimation is needed for the measurement 
record.

• Main & Zoom — This option is available when the Zoom window is displayed. 
In the Main time base window, the math function is performed on input 
waveform data from the Main window and is displayed in the Main window. 
In the Zoomed time base window, the math function is performed on input 
waveform data from the Zoom window and is displayed in the Zoom window. 
In other words, separate math function waveforms are shown in each 
window (calculated from the data in the respective windows).

This is the default setting when the Zoom window is displayed.

• Markers — The math function is performed on the input waveform data 
between the horizontal markers and is displayed in the Main window. The 
math function will have better resolution because less decimation is needed 
for the measurement record.

If the Zoomed time base is displayed, the Zoom window shows "zoomed in" 
data from the Main window, possibly containing the improved-resolution 
math function waveform, depending on the location of the Zoom window.

Because this selection can affect the resolution of the math function waveform, 
it can also affect measurements made on the math function waveform, 
depending on the selected measurement window (see "Measurement Window" 
on page 224). When you improve the resolution of a math function using the 
Zoom or Markers options, you will likely want to match the measurement window 
to look at the improved-resolution data.

NOTE The Main & Zoom option is not available with FFT (Magnitude) or FFT (Phase) math functions 
because the FFT length is different in each window. However, you can set up two FFT math 
functions on the same source, setting the measurement window on one of them to Main, and 
setting the measurement window on the other one to Zoom.

TIP Math Operating Hints

If the analog channel or math function is clipped (not fully displayed on screen) the resulting 
displayed math function will also be clipped.

Once the function is displayed, the analog channel(s) may be turned off for better viewing of 
the math waveform.

The math function waveform can be measured using markers and/or measurements.
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Units for Math Waveforms

Units for each input channel can be set to Volts or Amps using the Units control in 
the Probe dialog box. Units for math function waveforms are:

A scale unit of U (undefined) will be displayed for math functions when two source 
channels are used and they are set to dissimilar units and the combination of units 
cannot be resolved.

Arithmetic Math Functions

Math operators perform arithmetic operations (like add, subtract, or multiply) on 
analog input channels.

• "Add or Subtract" on page 87

• "Multiply or Divide" on page 88

Add or Subtract

When you select add or subtract, the Source 1 and Source 2 values are added or 
subtracted point by point, and the result is displayed.

You can use subtract to make a differential measurement or to compare two 
waveforms.

If your waveforms' DC offsets are larger than the dynamic range of the 
oscilloscope's input channels you will need to use a differential probe instead.

Math function Units

add or subtract V or A

multiply V2, A2, or W (Volt-Amp)

d/dt V/s or A/s (V/second or A/second)

 dt Vs or As (V-seconds or A-seconds)

FFT dB* (decibels). See also "FFT Units" on 
page 80.

√(square root) V1/2, A1/2, or W1/2 (Volt-Amp)

* When the FFT source is channel 1, 2, 3 or 4, FFT units will be displayed in dBV when channel units 
is set to Volts and channel impedance is set to 1 MΩ. FFT units will be displayed in dBm when 
channel units is set to Volts and channel impedance is set to 50Ω. FFT units will be displayed as dB 
for all other FFT sources or when a source channel's units has been set to Amps.
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See Also • "Units for Math Waveforms" on page 87

Multiply or Divide

When you select the multiply or divide math function, the Source 1 and Source 2 
values are multiplied or divided point by point, and the result is displayed.

The divide by zero case places holes (that is, zero values) in the output waveform.

Multiply is useful for seeing power relationships when one of the channels is 
proportional to the current.

Figure 8 Example of Subtract Channel 2 from Channel 1
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See Also • "Units for Math Waveforms" on page 87

Transforms Math Functions

Math transforms perform a transform function (like differentiate, integrate, FFT, or 
square root) on an analog input channel or on the result of an arithmetic operation.

• "Absolute Value" on page 90

• "Ax + B" on page 90

• "Base 10 Exponential" on page 91

• "Common Logarithm" on page 92

• "Differentiate" on page 92

• "Exponential" on page 93

• "Integrate" on page 93

• "Natural Logarithm" on page 95

• "Square Root" on page 96

• "Square" on page 97

Figure 9 Example of Multiply Channel 1 by Channel 2
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Absolute Value

The absolute value function changes negative values in the input to positive values 
and displays the resulting waveform.

See Also • "Square" on page 97

Ax + B

The Ax + B function lets you apply a gain and offset to an existing input source.

Figure 10 Example of Absolute Value
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Use the Gain (A) field to specify the gain.

Use the Offset (B) field to specify the offset.

The Ax + B function differs from the Magnify math visualization function in that the 
output is likely different than the input.

See Also • "Magnify" on page 102

Base 10 Exponential

The Base 10 Exponential (10^x) function performs a transform of the input source.

Figure 11 Example of Ax + B
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See Also • "Exponential" on page 93

Common Logarithm

The Common Logarithm (log) function performs a transform of the input source. 
Where the transform is undefined for a particular input, holes (zero values) appear 
in the function output.

See Also • "Natural Logarithm" on page 95

Differentiate

d/dt (differentiate) calculates the discrete time derivative of the selected source.

You can use differentiate to measure the instantaneous slope of a waveform. For 
example, the slew rate of an operational amplifier may be measured using the 
differentiate function.

Because differentiation is very sensitive to noise, it is helpful to set acquisition 
mode to Averaging (see "Selecting the Acquisition Mode" on page 183).

d/dt plots the derivative of the selected source using the "average slope estimate 
at 4 points" formula. The equation is:

Figure 12 Example of Base 10 Exponential
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Where:

• d = differential waveform.

• y = channel 1, 2, 3, 4, or Math 1, Math 2, Math 3 (lower math function) data 
points.

• i = data point index.

• Δt = point-to-point time difference.

See Also • "Units for Math Waveforms" on page 87

Exponential

The Exponential (e^x) function performs a transform of the input source.

See Also • "Base 10 Exponential" on page 91

Integrate

 dt (integrate) calculates the integral of the selected source. It shows the 
accumulated amount of change.

Figure 13 Example of Differentiate Function

di
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You can use integrate to calculate the energy of a pulse in volt-seconds or 
measure the area under a waveform by measuring the difference in the integrate 
function value across the pulse or waveform.

 dt plots the integral of the source using the "Trapezoidal Rule". The equation is:

Where:

• I = integrated waveform.

• Δt = point-to-point time difference.

• y = channel 1, 2, 3, 4, or Math 1, Math 2, Math 3 (lower math function) data 
points.

• co = arbitrary constant.

• i = data point index.

The integrate operator provides an Offset field that lets you enter a DC offset 
correction factor for the input signal. Small DC offset in the integrate function 
input (or even small oscilloscope calibration errors) can cause the integrate 
function output to "ramp" up or down. This DC offset correction lets you level the 
integrate waveform.

Figure 14 Integrate Without Signal Offset
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 When Initial Condition is enabled, the integrate math waveform is vertically 
centered in the screen. In other words, the top and bottom of the math waveform 
are equal distances from the top and bottom of the screen. When Initial Condition is 
disabled, the integrate math waveform starts at the zero-level reference on the left 
side of the screen.

See Also • "Units for Math Waveforms" on page 87

Natural Logarithm

The Natural Logarithm (ln) function performs a transform of the input source. 
Where the transform is undefined for a particular input, holes (zero values) appear 
in the function output.

Figure 15 Integrate With Signal Offset
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See Also • "Common Logarithm" on page 92

Square Root

Square root (√) calculates the square root of the selected source.

Where the transform is undefined for a particular input, holes (zero values) appear 
in the function output.

Figure 16 Example of Natural Logarithm
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See Also • "Units for Math Waveforms" on page 87

Square

The squared function calculates the square of the selected source, point by point, 
and displays the result.

Use the Source 1 drop-down list to select the signal source.

See Also • "Square Root" on page 96

FFT Math Functions

The FFT math functions let you display a Fast Fourier Transform (FFT) (magnitude 
or phase) of an analog input channel or of the result of an arithmetic operation.

• "FFT Magnitude, FFT Phase" on page 97

FFT Magnitude, FFT Phase

Using the Fast Fourier Transform (FFT), the FFT (Magnitude) math function displays 
the magnitudes of the frequency content that makes up the source waveform, and 
the FFT (Phase) math function shows the phase relationships of the frequency 
content. The FFT takes the digitized time record of the specified source and 
transforms it to the frequency domain.

Figure 17 Example of √ (Square Root)
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The source of the FFT math functions can be analog input channels or a lower 
math function.

The horizontal axis of FFT math functions is frequency (Hertz). For the FFT 
(Magnitude) math function, the vertical axis is in decibels when Logarithmic vertical 
units are selected or V RMS when Linear vertical units are selected. For the FFT 
(Phase) math function, the vertical axis is in degrees or radians.

Use the FFT (Magnitude) function to find crosstalk problems, to find distortion 
problems in analog waveforms caused by amplifier non-linearity, or for adjusting 
analog filters.

When the FFT (Magnitude) or FFT (Phase) operators are selected, the Waveform Math 
dialog box has these additional controls:

• Input — Selects how the displayed frequency range is entered:

• Center/Span — Span specifies the frequency range represented by the width 
of the display. Divide span by 10 to calculate the frequency scale per 
division. Center specifies the frequency at the center vertical grid line of the 
display.

• Start/Stop — Start Freq specifies the frequency at the left side of the display. 
Stop Freq specifies the frequency at the right side of the display.

• Zero Phase Ref — When the FFT (Phase) operator is selected, this control sets the 
reference point for calculating the FFT Phase function:

• Trigger — the FFT phase is measured from the trigger (time=0) point of the 
waveform.

• Entire Display — the FFT phase is measured from the beginning of the 
displayed waveform.

• Readout — Specifies how the FFT resolution is displayed: Off, Sample Rate, Bin 
Size, RBW (Resolution Bandwidth).

• Auto Setup — Sets the frequency Span and Center to values that will cause at 
least 10% of the spectrum to be displayed. The maximum available frequency is 
half the FFT sample rate, which is a function of the time per division setting. 
The FFT resolution is the quotient of the sampling rate and the number of FFT 
points (fS/N). The current FFT Resolution is displayed on screen.

• Add Max Function — Adds another math function waveform that is the Max Hold 
operator on the FFT math function waveform.

• Advanced FFT... — Opens the Advanced FFT dialog box where you can select a 
window, specify vertical units, select gating, or set up detectors.
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You can use the X1 and X2 markers to measure frequency values and difference 
between two frequency values (ΔX). Use the Y1 and Y2 markers to measure 
amplitude in dB and difference in amplitude (ΔY).

You can make peak-to-peak, maximum, minimum, and average dB measurements 
on the FFT waveform. You can also find the frequency value at the first occurrence 
of the waveform maximum by using the X at Max Y measurement.

See Also • "Searching for FFT Peaks" on page 78

• "FFT Measurement Hints" on page 79

• "FFT Units" on page 80

• "FFT DC Value" on page 80

• "FFT Aliasing" on page 80

• "FFT Spectral Leakage" on page 81

• "Units for Math Waveforms" on page 87

Filters Math Functions

You can use math filters to create a waveform that is the result of a the filter on an 
analog input channel or on the result of an arithmetic operation.

• "Averaged Value" on page 99

• "Band Pass Filter" on page 100

• "Envelope" on page 100

• "High Pass and Low Pass Filter" on page 101

• "Smoothing" on page 101

Averaged Value

When the Averaged Value operator is selected, the math waveform becomes the 
selected source waveform, averaged the selected number of times.

NOTE Scale and offset considerations

If you do not manually change the FFT scale or offset settings, when you turn the horizontal 
scale knob, the span and center frequency settings will automatically change to allow 
optimum viewing of the full spectrum.

If you do manually set scale or offset, turning the horizontal scale knob will not change the 
span or center frequency settings, allowing you see better detail around a specific frequency.

Selecting the FFT Auto Setup button will automatically rescale the waveform and span and 
center will again automatically track the horizontal scale setting.
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The source waveform can be one of the analog input channels or one of the 
previous math function waveforms.

Unlike acquisition averaging, the math averaging operator can be used to average 
the data on a single analog input channel or math function.

If acquisition averaging is also used, the analog input channel data is averaged 
and the math function averages it again. You can use both types of averaging to 
get a certain number of averages on all waveforms and an increased number of 
averages on a particular waveform.

As with acquisition averaging, averages are calculated using a "decaying average" 
approximation, where:

next_average = current_average + (new_data - current_average)/N

Where N starts at 1 for the first acquisition and increments for each following 
acquisition until it reaches the selected number of averages, where it holds.

Select Reset Count to clear the number of waveforms evaluated.

See Also • "Averaging Acquisition Mode" on page 186

Band Pass Filter

The band-pass filter function applies the filter to the selected source waveform 
and displays the result in the math waveform.

Use the Center field to enter the center frequency of the band-pass filter.

Use the Width field to enter the frequency width of the band-pass filter. This 
specifies the filter's -3 dB cutoff frequencies (center frequency minus half the 
width and center frequency plus half the width).

Envelope

The resulting math waveform shows the amplitude envelope for an amplitude 
modulated (AM) input signal.

This function uses a Hilbert transform to get the real (in-phase, I) and imaginary 
(quadrature, Q) parts of the input signal and then performs a square root of the 
sum of the real and imaginary parts to get the demodulated amplitude envelope 
waveform.

NOTE The ratio of the input signal's Nyquist frequency and the selected -3 dB cutoff frequencies 
affects how many points are available in the output, and under some circumstances, there are 
no points in the output waveform.
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High Pass and Low Pass Filter

The high-pass or low-pass filter functions apply the filter to the selected source 
waveform and display the result in the math waveform.

The high-pass filter is a single-pole high-pass filter.

The low-pass filter is a 4th order Bessel-Thompson filter.

Use the Bandwidth field to select the filter's -3 dB cutoff frequency.

Smoothing

The resulting math waveform is the selected source with a normalized rectangular 
(boxcar) FIR filter applied.

The boxcar filter is a moving average of adjacent waveform points, where the 
number of adjacent points is specified by the Smoothing Points field. You can 
choose an odd number of points, from 3 up to half of the analysis record.

NOTE The ratio of the input signal's Nyquist frequency and the selected -3 dB cutoff frequency 
affects how many points are available in the output, and under some circumstances, there are 
no points in the output waveform.

Figure 18 Example of Low Pass Filter
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The smoothing operator limits the bandwidth of the source waveform. The 
smoothing operator can be used, for example, to smooth measurement trend 
waveforms.

Visualizations Math Functions

You can apply visualization math functions that give you different ways of viewing 
captured data and measurement values.

• "Magnify" on page 102

• "Max/Min Hold" on page 103

• "Maximum/Minimum" on page 103

• "Measurement Trend" on page 103

• "Peak-Peak" on page 104

• "Clock Recovery" on page 104

Magnify

The magnify math function lets you display an existing input source at different 
vertical settings to provide more vertical detail.

See Also • "Ax + B" on page 90

Figure 19 Example of Magnify
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Max/Min Hold

The Max Hold operator records the maximum vertical values found at each 
horizontal bucket across multiple analysis cycles and uses those values to build a 
waveform.

The Min Hold operator is the same, except it records the minimum vertical values.

When not used in a frequency analysis domain, these functions are often referred 
to as Max Envelope and Min Envelope.

Select Reset Count to clear the number of waveforms evaluated.

Maximum/Minimum

The Maximum operator is like the Max Hold operator without the hold. The maximum 
vertical values found at each horizontal bucket are used to build a waveform.

The Minimum operator is like the Min Hold operator without the hold. The minimum 
vertical values found at each horizontal bucket are used to build a waveform.

Measurement Trend

The measurement trend math function shows measurement values for a waveform 
(based on measurement threshold settings) as the waveform progresses across the 
screen. For every cycle, a measurement is made, and the value is displayed on the 
screen for the cycle.

Figure 20 Example of Measurement Trend
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Use the Measurement drop-down list to select the previously added measurement 
whose trend you want to look at. You can display trend values for these 
measurements:

• Average

• RMS - AC

• Ratio

• Period

• Frequency

• +Width

• -Width

• +Duty Cycle

• -Duty Cycle

• Rise Time

• Fall Time

Select Thresholds... to open the Measurement Thresholds dialog box where you can 
set up measurement thresholds for analog channels, math functions, and 
reference waveforms.

If a measurement cannot be made for part of a waveform, the trend function 
output is a hole (that is, no value) until a measurement can be made.

Peak-Peak

The Peak-Peak operator is like the Maximum operator minus the Minimum operator. 
At each horizontal bucket, the minimum vertical values found are subtracted from 
the maximum vertical values found to build a waveform.

Clock Recovery

Clock recovery is a feature that provides an ideal clock for comparison to actual 
signal edges. Clock recovery is used, for example, in Clock TIE and Data TIE (Time 
Interval Error) jitter measurements. You can also set up clock recovery and display 
the recovered ideal clock as a math function waveform.

Use the Setup... button to open a dialog box where you can set up clock recovery 
options. See "Setting Up Clock Recovery" on page 104.

Setting Up Clock Recovery

The Clock Recovery dialog box is used to select the clock recovery method and 
specify its options.
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You can choose:

• Constant Frequency — The clock is assumed to be a constant frequency, and the 
Data Rate recovery options are:

• Fully Automatic — The clock is recovered using the signal edge database only. 
The narrowest pulse is presumed to be an isolated one or zero.

• Semi Automatic — The clock is recovered using the expected Nominal Data Rate 
as a "seed" and the signal edge database.

• Manual — The expected Nominal Data Rate you enter is used. It should be the 
reciprocal of the signal's unit interval.

• First Order PLL — The clock is recovered using the DSP-modeled response of an 
ideal first-order hardware PLL. Enter these parameters:

• Nominal Data Rate — The signal's expected bits/second data rate.

• Loop Bandwidth — The -3 dB bandwidth specification of the PLL.

• Second Order PLL — The clock is recovered using the DSP-modeled response of 
an ideal Type II, second-order hardware PLL. Enter these parameters:

• Nominal Data Rate — The signal's expected bits/second data rate.

• Loop Bandwidth — The -3 dB bandwidth specification of the PLL.

• Damping Factor — The damping factor of the PLL's observed jitter transfer 
function (OJTF).

Typical damping factor values are 1.0, which is critically damped, and 0.707, 
which is considered ideal or optimal because of its fast settling time 
(optimally flat) and Butterworth type response. Values less than 1 are 
underdamped, and values greater than 1 are overdamped.

• Explicit Clock — The clock is recovered from a second signal in your device under 
test, with a multiplier from 1 to 1000 applied.

The Analysis Record and Waveform Math

Keysight InfiniiVision oscilloscopes are designed to provide high waveform update 
rates which give you an increased probability of capturing infrequent events. With 
high waveform update rates, there is less "dead time" between acquisitions.

To provide high waveform update rates, there are some things the oscilloscope 
does with memory:
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• When running, acquisition memory is split into two memories so that the 
processing of one acquisition can take place while another acquisition is being 
captured. For single acquisitions, the full memory is used. Waveform data in 
acquisition memory is called the raw acquisition record.

• There is a separate eavesdrop memory used for making measurements and for 
calculating math functions. Data in this memory is a reduced-sample 
decimation of the data in the raw acquisition record. Waveform data in 
eavesdrop memory is called the analysis record.

The default length of the analysis record is 64K points. To improve the precision 
of measurements and math functions (including FFT), at the expense of 
waveform update rate, you can also select deeper analysis record lengths.

(If you want to calculate math functions on a longer record, you can save the 
raw acquisition record and use programs like Excel or MATLAB to perform the 
analysis.)

Waveform data for the acquisition time (that is, the time per division setting 
multiplied by 10 divisions across the display) is saved to the memories. When the 
oscilloscope analog-to-digital converter's (ADC, or digitizer) sample period yields 
more data points than can be stored in the memory, some samples are thrown 
away (decimated), and the effective (or actual) sample rate is reduced. This is why, 
at greater time/div settings, the displayed sample rate decreases.

For example, suppose an oscilloscope's digitizer has a sample period of 1 ns 
(maximum sample rate of 1 GSa/s) and a 1 M memory depth. At that rate, memory 
is filled in 1 ms. If the acquisition time is 100 ms (10 ms/div), only 1 of every 100 
samples is needed to fill memory. The effective sample rate becomes 10 MSa/s.

The Analyze Peaks option in the Analysis Precision dialog box enables peak 
detection when decimating the raw acquisition record into the analysis record. For 
each block of samples that must be reduced, the maximum and minimum samples 
are kept. When disabled, the decimator is configured to provide a best-estimate of 
all the samples that each point in the record represents, with no filtering.

FFT (Spectral)
Analysis of

Analysis Record
Data

When the FFT operator is turned on, the decimation from the raw acquisition 
record to the analysis record works on integer rate down-sampling. For example, a 
raw acquisition record of 20M points and an analysis record of 64K points are 
already set up with an integer rate decimation of 320 (20M/320 = 64K).

For FFT analysis, the decimated record is then zero-padded to 2(X+1) where 2X >= 
record length. For the above example, the power of 2 greater than the record 
length is 65536, so the record is zero-padded to 131072 points.

You can look at the FFT math function results on the oscilloscope to work 
backward and find the un-zero-padded decimated record length as well as the FFT 
length used after the zero-padding:

• First, we know:

• The FFT algorithm translates a time record of N equally spaced samples into 
N/2 equally spaced lines in the frequency domain.
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• The width of the FFT on the display is the maximum frequency in the FFT. 
The maximum FFT frequency is also fS/2, where fS is the effective sample 
rate of the decimated data. (Use the center/span or start/stop frequency 
controls to display the maximum FFT frequency.)

• The FFT Resolution is displayed in the FFT menu. FFT resolution is also 
known as the FFT bin width or a line in the frequency domain.

• Therefore, the un-zero-padded decimated record length is: fS x the acquisition 
time (or 2 x max FFT freq x acquisition time).

• Also, the FFT length used after the zero-padding is: 2 x (maximum FFT 
frequency)/(FFT Resolution).

All this works the same with analysis records greater than the 64K-point default.

For more information on FFT transformation, see Keysight Application Note 243, 
The Fundamentals of Signal Analysis at 
http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf.

http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf
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6 Reference Waveforms

To save a waveform to a reference waveform location / 109
To display a reference waveform / 110
To scale and position reference waveforms / 110
To adjust reference waveform skew / 111
To display reference waveform summary information / 111
To save/recall reference waveform files to/from a USB storage device / 111

Analog channel or math waveforms can be saved to one of four reference 
waveform locations in the oscilloscope. Then, a reference waveform can be 
displayed and compared with other waveforms.

You can adjust the scale, position, and skew of reference waveforms, and you can 
display summary information for all reference waveforms.

Analog channel, math, or reference waveforms can be saved to a reference 
waveform file on a USB storage device. You can recall a reference waveform file 
from a USB storage device into one of the reference waveform locations.

To save a waveform to a reference waveform location

1 From the menu, choose Sources > Reference Waveforms....

The Reference Waveform dialog box has tabs for the four available reference 
waveforms: R1, R2, R3, and R4.

2 In the tab for the reference waveform location you want to use, select the Source 
you want to save.

3 Select Save to R1/R2/R3/R4 to save the waveform to the reference waveform 
location.

On is automatically selected and the reference waveform is displayed.

NOTE Reference waveforms are non-volatile — they remain after power cycling or performing a 
default setup.
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To clear a
reference

waveform location

1 From the menu, choose Sources > Reference Waveforms....

2 In the Reference Waveform dialog box tab for the location you want to clear, 
select Clear R1/R2/R3/R4 to clear the reference waveform location.

Reference waveforms are also cleared by a Factory Default or Secure Erase (see 
Chapter 23, “Save/Email/Recall (Setups, Screens, Data),” starting on page 291).

To display a reference waveform

1 From the menu, choose Sources > Reference Waveforms....

2 In the Reference Waveform dialog box tab for the waveform you want to 
display, select On to enable/disable the reference waveform display.

See Also • "To display reference waveform summary information" on page 111

To scale and position reference waveforms

1 From the menu, choose Sources > Reference Waveforms....

2 In the Reference Waveform dialog box tab for the waveform you want to scale 
or position, use the Scale and Offset controls.
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To adjust reference waveform skew

You can adjust the horizontal skew of reference waveforms.

1 From the menu, choose Sources > Reference Waveforms....

2 In the Reference Waveform dialog box tab for the waveform whose skew you 
want to adjust, use the Skew field to enter the value.

To display reference waveform summary information

1 From the menu, choose Sources > Reference Waveforms....

2 In the Reference Waveform dialog box, select Reference Summary....

The Reference Summary dialog box opens and displays the Scale, Offset, and 
Skew values for all reference waveforms.

You can use the values fields to make adjustments to the values.

To save/recall reference waveform files to/from a USB storage device

Analog channel, math, or reference waveforms can be saved to a reference 
waveform file on a USB storage device. See "To save reference waveform files to a 
USB storage device" on page 296.

You can recall a reference waveform file from a USB storage device into one of the 
reference waveform locations. See "To recall reference waveform files from a USB 
storage device" on page 300.
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To connect the digital probes to the device under test / 113
Acquiring waveforms using the digital channels / 116
To display digital channels using Autoscale / 116
Interpreting the digital waveform display / 117
To change the displayed size of the digital channels / 118
To switch a single channel on or off / 119
To switch multiple digital channels on or off / 119
To reposition a digital channel / 119
To change the logic threshold for digital channels / 120
To display digital channels as a bus / 120
Digital channel signal fidelity: Probe impedance and grounding / 123

This chapter describes how to use the digital channels of a mixed-signal 
oscilloscope (MSO).

The digital channels are enabled on all HD3-Series models. The digital channels 
probe cable is an orderable option.

To connect the digital probes to the device under test

1 If necessary, turn off the power supply to the device under test.

Turning off power to the device under test would only prevent damage that 
might occur if you accidentally short two lines together while connecting 
probes. You can leave the oscilloscope powered on because no voltage appears 
at the probes.
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2 Connect the digital probe cable to the DIGITAL Dn - D0 connector on the 
mixed-signal oscilloscope. The digital probe cable is keyed so you can connect 
it only one way. You do not need to power-off the oscilloscope.

The MSO cable operating temperature range is 0 °C to 55 °C, and its 
non-operating (storage) temperature range is -40 °C to 70 °C.

3 Connect the ground lead on each set of channels (each pod), using a probe 
grabber. The ground lead improves signal fidelity to the oscilloscope, ensuring 
accurate measurements.

Off

CAUTION  Probe cable for digital channels

Use only the Keysight logic probe and accessory kit supplied with the mixed-signal 
oscilloscope.
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4 Connect a grabber to one of the probe leads. (Other probe leads are omitted 
from the figure for clarity.)

5 Connect the grabber to a node in the circuit you want to test.
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6 For high-speed signals, connect a ground lead to the probe lead, connect a 
grabber to the ground lead, and attach the grabber to ground in the device 
under test.

7 Repeat these steps until you have connected all points of interest.

Acquiring waveforms using the digital channels

When you press [Run/Stop] or [Single] to run the oscilloscope, the oscilloscope 
examines the input voltage at each input probe. When the trigger conditions are 
met the oscilloscope triggers and displays the acquisition.

For digital channels, each time the oscilloscope takes a sample it compares the 
input voltage to the logic threshold. If the voltage is above the threshold, the 
oscilloscope stores a 1 in sample memory; otherwise, it stores a 0.

To display digital channels using Autoscale

When signals are connected to the digital channels — be sure to connect the 
ground leads — Autoscale quickly configures and displays the digital channels.

• To configure the instrument quickly, press the [Auto Scale] key.
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Any digital channel with an active signal will be displayed. Any digital channels 
without active signals will be turned off.

• If you want to return to the oscilloscope settings that existed before, select the 

 Undo button.

This is useful if you have unintentionally pressed the [Auto Scale] key or do not 
like the settings Autoscale has selected. This will return the oscilloscope to its 
previous settings. See also: "How Autoscale Works" on page 33.

To set the instrument to the factory-default configuration, press the [Default Setup] 
key.

Interpreting the digital waveform display

The following figure shows the Digital dialog box (select the digital channels 
badge or choose Sources > Digital Channels...) and displayed digital channels.

Figure 21 Example: Autoscale of digital channels
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Activity indicator When any digital channels are turned on, an activity indicator is displayed in the 

status line at the bottom of the display. A digital channel can be always high ( ), 

always low ( ), or actively toggling logic states ( ).

To change the displayed size of the digital channels

1 Open the Digital dialog box by selecting the digital channels badge or by 
choosing Sources > Digital Channels....

2 In the Channels tab, use the Waveform Size drop-down list to select the size of 
displayed digital channels.

The sizing control lets you spread out or compress the digital traces vertically on 
the display for more convenient viewing.

 

Activity
indicators

Delay
time

Time/
div

Trigger
type and
threshold

Digital channel
identifiers

Waveform
size

Turn individual
channels on/off

Thresholds
tab

Trigger
mode and
run status
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To switch a single channel on or off

1 Open the Digital dialog box by selecting the digital channels badge or by 
choosing Sources > Digital Channels....

2 In the Channels tab, select an individual digital channel cell to toggle its 
display.

To switch multiple digital channels on or off

1 Open the Digital dialog box by selecting the digital channels badge or by 
choosing Sources > Digital Channels....

2 In the Channels tab, swipe multiple digital channel cells to toggle their 
selection.

If you want to switch the digital channels off, clear the On check box or press 
[Digital] key.

To reposition a digital channel

1 Open the Digital dialog box by selecting the digital channels badge or by 
choosing Sources > Digital Channels....

2 In the Channels tab, select Display Order....

3 In the Display Order dialog box:

You can:

• Drag a digital channel to a new position in the list. The order in the list is the 
same that appears in the waveform grid.



120 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

7 Digital Channels
 

• Select Descending Order to reorder all channels from higher numbered 
channels to lower numbered channels.

• Select Ascending Order to reorder all channels from lower numbered channels 
to higher numbered channels.

To change the logic threshold for digital channels

1 Open the Digital dialog box by selecting the digital channels badge or by 
choosing Sources > Digital Channels....

2 In the Thresholds tab:

Use the D15 - D12, D11 - D8, D7 - D4, and D3 - D0 drop-down lists to select a 
logic family preset or select User to define your own threshold.

The threshold you select applies to all channels within the selected D15 - D12, 
D11 - D8, D7 - D4, or D3 - D0 group. Each channel group can be set to a different 
threshold if desired.

Values greater than the set threshold are high (1) and values less than the set 
threshold are low (0).

To display digital channels as a bus

Digital channels may be grouped and displayed as a bus, with each bus value 
displayed at the bottom of the display in hex or binary. You can create up to two 
buses.

Logic family Threshold Voltage

TTL +1.4 V

CMOS +2.5 V

ECL –1.3 V

User Variable from –8 V to +8 V
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To configure and display each bus:

1 Open the Digital dialog box by selecting the digital channels badge or by 
choosing Sources > Digital Channels....

2 In the Buses tab, select Bus1 or Bus2 to enable or disable the bus display.

3 In the drop-down list for a bus, select the Hex or Binary display format.

4 Select the channels in a bus by selecting or swiping cells.

The buses are shown at the bottom of the display.

If the bus display is blank, completely white, or if the display includes "...", you 
need to expand the horizontal scale to allow space for the data to be shown, or 
you can use the markers to display the values (see "Using markers to read bus 
values" on page 121).

Using markers to
read bus values

To read the digital bus value at any point using the markers:

1 Choose Measure > Markers... from the main menu (see page 40).

2 In the Markers dialog box, select On to enable markers.

3 From the Mode drop-down list, select Binary or Hex.

4 From the Source drop-down list, select Bus1 or Bus2.

5 Position the X1 and X2 markers to where you want to read the bus values (see 
"To make marker measurements" on page 192).
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Bus values are
displayed when

using Pattern
trigger

The bus values are also displayed when using the Pattern trigger function.

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Pattern.

3 Select the Pattern trigger type and the Entered qualifier.

4 In the Bus1 or Bus2 fields, enter the hex character values.

The dollar sign ($) will be displayed in the bus value when the bus value cannot be 
displayed as a hex value. This occurs when one or more "don't cares" (X) are 
combined with low (0) and high (1) logic levels in the pattern specification, or 
when a transition indicator — rising edge ( ) or falling edge ( ) — are included in 
the pattern specification. A byte that consists of all don't cares (X) will be 
displayed in the bus as a don't care (X).

Digital channel
values at marker

Analog channel
values at marker

Bus
values

Set markers mode
to Binary or Hex

Select Bus1
or Bus2 source

X2 markerX1 marker

NOTE If a digit is made up of less than four bits, the value of the digit is limited to the greatest 
number that can be represented by the number of bits.
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 See "Pattern Trigger" on page 157 for more information on Pattern triggering.

Digital channel signal fidelity: Probe impedance and grounding

When using the mixed-signal oscilloscope you may encounter problems that are 
related to probing. These problems fall into two categories: probe loading and 
probe grounding. Probe loading problems generally affect the device under test, 
while probe grounding problems affect the accuracy of the data to the 
measurement instrument. The design of the probes minimizes the first problem, 
while the second is easily addressed by good probing practices.

Input Impedance

The logic probes are passive probes, which offer high input impedance and high 
bandwidths. They usually provide some attenuation of the signal to the 
oscilloscope, typically 20 dB.

Passive probe input impedance is generally specified in terms of a parallel 
capacitance and resistance. The resistance is the sum of the tip resistor value and 
the input resistance of the test instrument (see the following figure). The 
capacitance is the series combination of the tip compensating capacitor and the 
cable, plus instrument capacitance in parallel with the stray tip capacitance to 

Pattern trigger
definition

Trigger on
bus values
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ground. While this results in an input impedance specification that is an accurate 
model for DC and low frequencies, the high-frequency model of the probe input is 
more useful (see the following figure). This high-frequency model takes into 
account pure tip capacitance to ground as well as series tip resistance, and the 
cable's characteristic impedance (Zo).

The impedance plots for the two models are shown in these figures. By comparing 
the two plots, you can see that both the series tip resistor and the cable's 
characteristic impedance extend the input impedance significantly. The stray tip 
capacitance, which is generally small (1 pF), sets the final break point on the 
impedance chart.

Figure 22 DC and Low-Frequency Probe Equivalent Circuit

Figure 23 High-Frequency Probe Equivalent Circuit
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The logic probes are represented by the high-frequency circuit model shown 
above. They are designed to provide as much series tip resistance as possible. 
Stray tip capacitance to ground is minimized by the proper mechanical design of 
the probe tip assembly. This provides the maximum input impedance at high 
frequencies.

Probe Grounding

A probe ground is the low-impedance path for current to return to the source from 
the probe. Increased length in this path will, at high frequencies, create large 
common mode voltages at the probe input. The voltage generated behaves as if 
this path were an inductor according to the equation:

Increasing the ground inductance (L), increasing the current (di) or decreasing the 
transition time (dt), will all result in increasing the voltage (V). When this voltage 
exceeds the threshold voltage defined in the oscilloscope, a false data 
measurement will occur.

Figure 24 Impedance versus Frequency for Both Probe Circuit Models
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Sharing one probe ground with many probes forces all the current that flows into 
each probe to return through the same common ground inductance of the probe 
whose ground return is used. The result is increased current (di) in the above 
equation, and, depending on the transition time (dt), the common mode voltage 
may increase to a level that causes false data generation.

In addition to the common mode voltage, longer ground returns also degrade the 
pulse fidelity of the probe system. Rise time is increased, and ringing, due to the 
undamped LC circuit at the input of the probe, is also increased. Because the 
digital channels display reconstructed waveforms, they do not show ringing and 
perturbations. You will not find ground problems through examination of the 
waveform display. In fact, it is likely you will discover the problem through random 
glitches or inconsistent data measurements. Use the analog channels to view 
ringing and perturbations.

Best Probing Practices

Because of the variables L, di, and dt, you may be unsure how much margin is 
available in your measurement setup. The following are guidelines for good 
probing practices:

• The ground lead from each digital channel group (D15–D8 and D7–D0) should 
be attached to the ground of the device under test if any channel within the 
group is being used for data capture.

Figure 25 Common Mode Input Voltage Model
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• When capturing data in a noisy environment, every third digital channel probe's 
ground should be used in addition to the channel group's ground.

• High-speed timing measurements (rise time < 3 ns) should make use of each 
digital channel probe's own ground.

When designing a high-speed digital system, you should consider designing 
dedicated test ports that interface directly to the instrument's probe system. This 
will ease measurement setup and ensure a repeatable method for obtaining test 
data. The 01650-61607 16-channel logic probe cable and the 01650-63203 
termination adapter are designed to make it easy to connect to industry-standard, 
20-pin board connectors. The cable is a 2 m logic analyzer probe cable, and the 
termination adapter provides the proper RC networks in a very convenient 
package. These parts, as well as the 1251-8106 20-pin, low-profile, straight board 
connector, can be ordered from Keysight Technologies.
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Protocol Decode Options / 129
Protocol Listing / 130
Searching Lister Data / 132

Protocol decode lets you trigger on and display decoded serial bus data in many 
protocols. As with other InfiniiVision oscilloscopes, serial decodes are 
hardware-accelerated for fast performance.

Triggering on
Protocol Data

In some cases, such as when triggering on a slow serial signal (for example, I2C, 
SENT, SPI, CAN, LIN, etc.) it may be necessary to switch from the Auto trigger 
mode to the Trig'd trigger mode to prevent the oscilloscope from Auto-triggering 
and stabilize the display. You can select the trigger mode by pressing the [Mode] 
key.

Also, the threshold voltage level must be set appropriately for each source 
channel. The threshold level for each serial signal can be set in the Trigger Levels 
dialog box. From the menu, select Trigger > Trigger Levels....

Protocol Decode Options

These license-enabled serial decode options are available:

Licensed Protocol Decode See:

Aerospace and Defense Serial Triggering and 
Analysis for HD3-Series

• Chapter 27, “ARINC 429 Triggering and 
Serial Decode,” starting on page 351.

• Chapter 31, “MIL-STD-1553 Triggering and 
Serial Decode,” starting on page 387.



130 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

8 Protocol Decode
 

To determine whether these licenses are installed on your oscilloscope, see "To 
display oscilloscope information" on page 321.

To order protocol triggering and decode licenses, go to www.keysight.com and 
search for the product number (see "Licensed Options Available" on page 340) or 
contact your local Keysight Technologies representative (see 
www.keysight.com/find/contactus).

Protocol Listing

The Protocol Listing window is a powerful tool for investigating protocol failures. 
You can use the Protocol Listing window to view large amounts of packet level 
serial data in a tabular format, including time tags and specific decoded values.

To use the Protocol Listing window:

1 Set up trigger and decode on the serial data signals to be analyzed.

2 Press [Protocol Decode].

3 In the Protocol Decode dialog box, select the Protocol Listing tab.

4 In the Protocol Listing tab, select On.

Automotive Serial Triggering and Analysis for 
HD3-Series

• Chapter 28, “CAN Triggering and Protocol 
Decode,” starting on page 359.

• Chapter 30, “LIN Triggering and Protocol 
Decode,” starting on page 379.

• Chapter 32, “SENT Triggering and Serial 
Decode,” starting on page 395.

Embedded Serial Triggering and Analysis for 
HD3-Series

• Chapter 29, “I2C Triggering and Protocol 
Decode,” starting on page 371.

• Chapter 33, “SPI Triggering and Protocol 
Decode,” starting on page 407.

• Chapter 34, “UART/RS232/422/485 
Triggering and Protocol Decode,” starting on 
page 415.

Licensed Protocol Decode See:

http://www.keysight.com/
http://www.keysight.com/find/contactus
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When multiple protocol decodes are enabled, the Show option selects the one 
displayed in the Protocol Listing window.

In the Protocol Listing tab, you can also:

• Enable or disable the Track Time option. When enabled, as you select 
different Lister rows, the horizontal delay changes to the Time of the 
selected row. Also, changing the horizontal delay will scroll the Lister.

• Use the Time Ref drop-down list to select whether the Time column in the 
Lister display shows times relative to the Trigger or relative to the Previous 
Row.

5 Before you can select a row or navigate through the Protocol Listing data, 
oscilloscope acquisitions must be stopped.

Press the [Single] key to stop the acquisition.

Pressing [Single] instead of [Stop] fills the maximum memory depth.

When zoomed out and viewing a large number of packets, the Protocol Listing 
may not be able to display information for all packets. However, when you 
press the [Single] key the Protocol Listing will contain all on-screen serial 
decode information.

6 When acquisitions are stopped, you can use the Event field to select a Protocol 
Listing row (or if the row is displayed, you can directly select it), and then select 
Zoom to Selection to center the waveform display and zoom the horizontal scale 
to the selected Protocol Listing row.

7 Select Undo Zoom to return to the horizontal scale and delay (position) settings 
before the last Zoom to Selection.
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Searching Lister Data

When protocol decode is enabled, you can use the Search feature to find and 
place marks on rows in the Lister.

The Search dialog box lets you specify events to find. It is similar to specifying 
protocol triggers.

Events found are marked in orange in the far left Lister column. The total number 
of events found is displayed with the Search events found table title.
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Each serial decode option lets you find protocol-specific headers, data, errors, etc. 
See:

• "Searching for ARINC 429 Data in the Lister" on page 357

• "Searching for CAN Data in the Lister" on page 368

• "Searching for I2C Data in the Lister" on page 377

• "Searching for LIN Data in the Lister" on page 386

• "Searching for MIL-STD-1553 Data in the Lister" on page 392

• "Searching for SENT Data in the Lister" on page 405

• "Searching for SPI Data in the Lister" on page 412

• "Searching for UART/RS232/422/485 Data in the Lister" on page 421

• "Searching for USB 2.0 Data in the Lister" on page 430

• "Searching for USB PD Data in the Lister" on page 435
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To change the waveform layout / 135
To display waveforms as vectors or dots / 136
To disable/enable antialiasing / 137
To set or clear persistence / 138
To clear the display / 139
To select the grid options / 139
To adjust the grid intensity / 140
To display and edit waveform labels / 141
To add an annotation / 143
To adjust waveform intensity / 145

See Also • Chapter 16, “Color Grade Waveform,” starting on page 237

• "Setting the Oscilloscope's Clock" on page 311

To change the waveform layout

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Waveform Layout tab.

3 Select the Waveform Layout drop-down list, and select between:

• Stack Waveforms Vertically — Waveforms appear in individual grids that are 
vertically stacked.

• Tile Waveforms Horizontally — Waveforms appear in individual grids that are 
horizontally tiled and perhaps vertically stacked, depending on the number 
of waveforms that are displayed.

• Overlay Waveforms — Waveforms are overlaid in one grid.

• Custom Layout — Lets you specify the number of grids, their orientation, and 
which waveforms appear in which grid.
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Select Custom Layout... to open the Custom Layout dialog box:

• # of Grids — Lets you select from one to four grids.

• Grid Orientation — You can choose from:

• Vertical — Vertically stacked grids.

• Horizontal — Horizontally tiled and perhaps vertically stacked grids, 
depending on the number of grids.

• Grid 1-4 — These boxes are oriented as specified. You can drag waveforms 
to whichever grid box you like.

4 The Waveform Layout tab (in the Display dialog box) also lets you:

• Select Full Screen to make the waveform grid(s) take up the whole screen.

• Select Clear Display to clear acquisition data from the oscilloscope display. 
This is the same as pressing the front panel [Clear Display] key.

You can also specify the waveform layout in the Quick Selection dialog box (select 

 or choose Sources > Quick Selection... from the main menu (see page 40)).

For examples of different waveform layouts, see "Lay Out Waveform Grids" on 
page 41.

To display waveforms as vectors or dots

The HD3-Series oscilloscope is designed to operate optimally with vectors 
(connect the dots) on. This mode produces the most insightful waveforms for most 
situations.

However, you can disable vectors to view just waveform data points.

To disable or re-enable vectors:

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Waveform Display tab.



Display Settings 9

Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide 137

 

3 Clear or select the Vectors check box.

When enabled, Vectors draws a line between consecutive waveform data points.

• Vectors give an analog look to a digitized waveform. Complex analog signals 
like video and modulated signals show analog-like intensity information with 
vectors on.

• Vectors allow you to see steep edges on waveforms, such as square waves.

• Vectors allow subtle detail of complex waveforms to be viewed, much like an 
analog oscilloscope trace, even when the detail is just a small number of pixels 
in size.

You may want to turn vectors off when highly complex or multivalued waveforms 
are displayed. Turning vectors off may aid the display of multivalued waveforms 
such as eye diagrams.

Having vectors on does not slow down the display rate.

Digital channels on a mixed-signal oscilloscope are not affected by the Vectors 
setting. They are always displayed with vectors on. They also only contain one 
acquisition worth of information.

To disable/enable antialiasing

At slower sweep speeds, the sample rate is reduced and a proprietary display 
algorithm is used to minimize the likelihood of aliasing.

By default, Antialiasing is enabled. You should leave Antialiasing enabled unless 
there is a specific reason to switch it off.

Anti-aliasing is turned off automatically, even though the Antialiasing control 
appears to be enabled when FFTs are on, when the Envelope or Differentiate math 
functions are on, or when Jitter analysis is on.

If you need to switch Antialiasing off:

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Waveform Display tab.

3 Clear the Antialiasing check box.

The displayed waveforms will be more susceptible to aliasing.
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To set or clear persistence

With persistence, the oscilloscope updates the display with new acquisitions, but 
does not immediately erase the results of previous acquisitions. All previous 
acquisitions are displayed with reduced intensity. New acquisitions are shown in 
their normal color with normal intensity.

Waveform persistence is kept only for the current display area; you cannot pan and 
zoom the persistence display.

To use persistence:

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Persistence tab.

3 Select the Persistence field, and select between:

• Off — Turns off persistence.

When persistence is off, you can select Capture Waveforms to perform a 
single-shot infinite persistence. A single acquisition's data is displayed with 
reduced intensity, and it remains on the display until you clear persistence or 
clear the display.

Included in the persistence data are active analog channels and digital 
channels.

• ∞ Persistence — (infinite persistence) Results of previous acquisitions are 
never erased.

Use infinite persistence to measure noise and jitter, to see the worst-case 
extremes of varying waveforms, to look for timing violations, or to capture 
events that occur infrequently.

• Variable Persistence — Results of previous acquisitions are erased after a 
certain amount of time.

Variable persistence gives you a view of acquired data that is similar to 
analog oscilloscopes.

When variable persistence is selected, enter the amount of Time that 
previous acquisitions are to be displayed.

The display will begin accumulating multiple acquisitions.

When Digital is selected, persistence of digital channel waveforms is also 
displayed.
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4 To erase the results of previous acquisitions from the display, select Clear 
Persistence.

The oscilloscope will start to accumulate acquisitions again.

5 To return the oscilloscope to the normal display mode, turn off persistence; 
then, select Clear Persistence.

Turning off persistence does not clear the display. The display is cleared if you 
select Clear Display, press the [Clear Display] key, or if you press the [Auto Scale] 
key (which also turns off persistence).

For another method of seeing worst-case extremes of varying waveforms, see 
"Glitch or Narrow Pulse Capture" on page 184.

To clear the display

Do one of the following:

• Press the [Clear Display] key.

• From the menu, choose Control > Clear Display.

• From the menu, choose Setup > Display.... In the Display dialog box's Waveform 
Layout, Persistence, or Grids tabs, select Clear Display.

You can also configure the Setup > (Quick Action) menu item to clear the display. See 
"Configuring the (Quick Action) Menu Item" on page 322.

To select the grid options

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Grids tab.

3 You can use the following controls:

• Grid Intensity — Enter a value from 0 to 100%.

NOTE Persistence is not available for math or FFT functions.
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Each major vertical division in the grid corresponds to the vertical sensitivity 
shown in the status line at the top of the display.

Each major horizontal division in the grid corresponds to the time/div shown 
in the status line at the top of the display.

• Grid — This drop-down menu lets you select from these grid types:

• Full — the normal oscilloscope grid.

• Clear Display — Clears acquisition data from the oscilloscope display. This is 
the same as pressing the front panel [Clear Display] key.

• Show Scales — When selected, grid value labels are shown along the grid's 
horizontal and vertical axes.

• Show Dual Scales — When multiple waveforms are displayed in a grid, you can 
enable dual vertical scales for the top two waveforms in the Z-order. Select 
the dual scales for a pop-up dialog box that lets you specify the waveform 
Z-order.

• Show Scales in Grid — You can show scales within the grid to make the grid 
areas a little larger. In this case, waveforms can be drawn over grid values at 
the right side and bottom of the grid.

To adjust the grid intensity

To adjust the display grid (graticule) intensity:

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Grids tab.

3 In the Grid Intensity field, enter a value from 0 to 100%.

Each major vertical division in the grid corresponds to the vertical sensitivity 
shown in the status line at the top of the display.

Each major horizontal division in the grid corresponds to the time/div shown in 
the status line at the top of the display.
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To display and edit waveform labels

You can define labels and assign them to analog input channels, math functions, 
reference waveforms, digital channels, and buses.

• "To turn the label display on or off" on page 141

• "To assign a predefined label to a waveform" on page 142

• "To define a new label" on page 142

• "To load a list of labels from a text file you create" on page 142

• "To reset the label library to the factory default" on page 143

To turn the label display on or off

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Labels tab.

3 Select On to turn the labels on or off for the displayed waveforms.

Labels are displayed at the left edge of the displayed traces.

4 To adjust the vertical Y position of the label with respect to the reference level, 
use the Offset field.
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To assign a predefined label to a waveform

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Labels tab.

3 Select the Source for label assignment.

The waveform does not have to be turned on to have a label assigned to it.

4 From the Library drop-down list, select the predefined label.

5 Select Apply New Label to assign the label to the selected waveform.

To define a new label

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Labels tab.

3 Select the New Label field.

4 In the Enter New Label dialog box, select keys to enter the text of the label:

• When the front panel [Touch] key is lit, you can touch the screen to select.

• If a USB mouse is connected, you can click to select.

• If a USB keyboard is connected, you can type to enter text.

When you are done entering text, select OK.

5 The new label can be assigned to the selected Source and added to the library 
by selecting Apply New Label.

Label Assignment
Auto-Increment

When you assign a label ending in a digit, such as ADDR0 or DATA0, the 
oscilloscope automatically increments the digit and displays the modified label in 
the "New Label" field after you select Apply New Label. Therefore, you only need to 
select a new Source and select Apply New Label again to assign the label to the 
waveform. Only the original label is saved in the label list. This feature makes it 
easier to assign successive labels to numbered control lines and data bus lines.

To load a list of labels from a text file you create

It may be convenient to create a list of labels using a text editor, then load the 
label list into the oscilloscope. The list can have up to 75 labels. When loaded, 
labels are added to the beginning of the oscilloscope's list. If more than 75 labels 
are loaded, only the first 75 are stored.

To load labels from a text file into the oscilloscope:

1 Use a text editor to create each label. Each label can be up to 32 characters in 
length. Separate each label with a line feed.

2 Name the file labellist.txt and save it on a USB mass storage device such as a 
thumb drive.
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3 Load the list into the oscilloscope using the File Explorer (from the menu 
choose File > File Explorer...).

To reset the label library to the factory default

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Labels tab.

3 Select Reset Library.

This will delete all user-defined labels from the library and set the labels in the 
library back to the factory default. However, this does not default the labels 
currently assigned to the waveforms (those labels that appear in the waveform 
area).

To add an annotation

You can add annotations to the oscilloscope's display. Annotations are useful for 
documentation purposes, to add notes before capturing screens.

NOTE Label List Management

When you select the Library drop-down list, you will see a list of the last 75 labels used. The 
list does not save duplicate labels. Labels can end in any number of trailing digits. As long as 
the base string is the same as an existing label in the library, the new label will not be put in 
the library. For example, if label A0 is in the library and you make a new label called A12345, 
the new label is not added to the library.

When you save a new user-defined label, the new label will replace the oldest label in the list. 
Oldest is defined as the longest time since the label was last assigned to a waveform. Any time 
you assign any label to a waveform, that label will move to the newest in the list. Thus, after 
you use the label list for a while, your labels will predominate, making it easier to customize 
the instrument display for your needs.

When you reset the label library list (see next topic), all of your custom labels will be deleted, 
and the label list will be returned to its factory configuration.

NOTE Selecting Reset Library will remove all user-defined labels from the library and set the labels 
back to the factory default. Once deleted, these user-defined labels cannot be recovered.

NOTE Defaulting labels without erasing the default library

Pressing [Default Setup] sets all waveform labels back to the default labels but does not 
erase the list of user-defined labels in the library.
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To add an annotation:

1 From the menu, choose Setup > Display....

2 In the Display dialog box, select the Annotations tab.

3 In the Annotations tab, in the Select Annotation list, select the desired 
annotation.

You can define up to 20 annotations.

4 Select the Text field.

5 In the Enter Text dialog box, select keys to enter the text of the annotation:

• When the front panel [Touch] key is lit, you can touch the screen to select.

• If a USB mouse is connected, you can click to select.

• If a USB keyboard is connected, you can type to enter text.

When you are done entering text, select OK.

6 Select the annotation options:

• Mode — Specifies the selected annotation's assignment:

• Grid — The annotation is assigned to a grid. Use the Grid drop-down menu 
to select the grid.
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Use the Text Color drop-down menu to select the annotation's color. You 
can choose white, red, or colors that match analog channels, digital 
channels, math waveforms, reference waveforms, or markers (markers).

• Source — The annotation is assigned to a source waveform. Use the Source 
drop-down menu to select the source waveform.

The annotation's color matches the selected Source waveform.

• Background — Specify the annotation's background:

• Opaque — The annotation has a solid background.

• Inverted — The annotation's foreground and background colors are 
switched.

• Transparent — The annotation has a transparent background.

7 Then, select On to enable/disable the annotation display.

When enabled, you can drag the annotation anywhere in the grid.

See Also • "To save BMP or PNG image files" on page 293

To adjust waveform intensity

You can adjust the intensity of displayed waveforms to account for various signal 
characteristics, such as fast time/div settings and low trigger rates.

Increasing the intensity lets you see the maximum amount of noise and 
infrequently occurring events.
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Reducing the intensity can expose more detail in complex signals as shown in the 
following figures.

1 From the menu, choose Setup > Waveform Intensity....

2 In the Intensity dialog box, to adjust the waveform intensity, either drag the 
slider, select the up or down buttons, or select the Waveform Intensity field to 
enter the percent value or turn the Entry knob.

Waveform intensity adjustment affects analog channel waveforms only (not math 
waveforms, reference waveforms, digital waveforms, etc.).

Figure 26 Amplitude Modulation Shown at 100% Intensity
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Figure 27 Amplitude Modulation Shown at 20% Intensity
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Adjusting the Trigger Level / 150
Forcing a Trigger / 151
Edge Trigger / 151
Edge Then Edge Trigger / 153
Pulse Width Trigger / 155
Pattern Trigger / 157
OR Trigger / 160
Rise/Fall Time Trigger / 160
Runt Trigger / 162
Setup and Hold Trigger / 163
Protocol Trigger / 165
Zone Qualified Trigger / 165

A trigger setup tells the oscilloscope when to acquire and display data. For 
example, you can set up to trigger on the rising edge of the analog channel 1 input 
signal.

You can use any input channel or the "External Trigger Input" on page 175 BNC as 
the source for most trigger types.

You can adjust the vertical level used for analog channel edge detection by turning 
the Trigger Level knob.

In addition to the edge trigger type, you can also set up triggers on rise/fall times, 
patterns, pulse widths, runt pulses, setup and hold violations, and protocol signals 
(if option licenses are installed).

Changes to the trigger setup are applied immediately. If the oscilloscope is 
stopped when you change a trigger setup, the oscilloscope uses the new 
specification when you press [Run/Stop] or [Single]. If the oscilloscope is running 
when you change a trigger setup, it uses the new trigger definition when it starts 
the next acquisition. You can save trigger setups along with the oscilloscope setup 
(see Chapter 23, “Save/Email/Recall (Setups, Screens, Data),” starting on page 
291).

Options that apply to all trigger types are:
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• Mode — Select Auto to automatically trigger when the specified trigger 
condition has not occurred for some period of time. Select Trig'd to turn off 
automatic triggering.

When triggers are not occurring, you can use the [Force] key to trigger on 
anything, acquire, and display captured data.

• Conditioning... — These options include coupling (similar to analog input channel 
coupling but affecting the trigger input only), holdoff, and external 
(AUX TRIG IN) input options.

See Chapter 11, “Trigger Mode and Conditioning,” starting on page 169 for more 
information on these options.

Triggers - General
Information

A triggered waveform is one in which the oscilloscope begins tracing (displaying) 
the waveform, from the left side of the display to the right, each time a particular 
trigger condition is met. This provides stable display of periodic signals such as 
sine waves and square waves, as well as nonperiodic signals such as serial data 
streams.

The figure below shows the conceptual representation of acquisition memory. You 
can think of the trigger event as dividing acquisition memory into a pre-trigger and 
post-trigger buffer. The position of the trigger event in acquisition memory is 
defined by the time reference point and the delay (horizontal position) setting (see 
"To adjust the horizontal delay (position)" on page 51).

Adjusting the Trigger Level

The position of the trigger level for an analog channel is indicated by the trigger 
level icon  at the far left side of the display (if the analog channel is on). The 
value of the analog channel trigger level is displayed in the trigger badge.

To adjust the trigger level, you can do any of these:

• Turn the Trigger Level knob.

You can also push the Trigger Level knob to set the level of all displayed analog 
channels to the waveform's 50% value. If AC coupling is used, pushing the 
Trigger Level knob sets the trigger level to about 0 V.

Pre-Trigger Buffer Post-Trigger Buffer

Acquisition Memory

Trigger Event

T
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When High and Low (dual) trigger levels are used (as with the Rise/Fall Time 
and Runt triggers, for example), pushing the Level knob toggles between high 
and low level adjustment.

• Drag the trigger level icon (on the left side of the waveform grid) up or down.

• Use the Trigger Level controls in the Trigger dialog box (that you can open by 
selecting the trigger badge or by choosing Trigger > Setup... from the main menu 
(see page 40)).

• Use the Trigger Level controls in the Trigger Levels dialog box (that you can open 
by choosing Trigger > Trigger Levels... from the main menu (see page 40)).

The Trigger Levels dialog box lets you change the trigger levels of all input 
channels.

The trigger level for digital channels is set in the Thresholds tab of the Digital dialog 
box. The [Digital] key on the front panel turns digital channels on or off. To open the 
Digital dialog box, choose Sources > Digital Channels... from the main menu (see 
page 40) or select the digital channels badge (when digital channels are on). In 
the Thresholds tab, you can specify TTL, CMOS, ECL, or user-defined threshold 
levels for digital channel groups.

For the Line input source, the trigger level is not adjustable because the trigger is 
synchronized with the power line supplied to the oscilloscope.

Forcing a Trigger

The [Force] key causes a trigger (on anything) and displays the acquisition.

This key is useful in the Trig'd trigger mode (see "To select the Auto or Trig'd 
trigger mode" on page 170) where acquisitions are made only when the trigger 
condition is met. In this mode, if no triggers are occurring (that is, the "Trig'd?" 
indicator is displayed), you can press [Force] to force a trigger and see what the 
input signals look like.

In the Auto trigger mode, when the trigger condition does not occur within a 
certain period of time, triggers are forced and the "Auto?" indicator is displayed.

Edge Trigger

The Edge trigger type identifies a trigger by looking for a specified edge (slope) 
and voltage level on a waveform. The trigger type, source, and level are displayed 
in the trigger badge.

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Edge.
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3 Select the trigger Source:

• Analog channel, 1 to the number of channels

• External — triggers on the AUX TRIG IN signal.

• Line — triggers at the 50% level of the rising or falling edge of the AC power 
source signal.

• WaveGen — triggers at the 50% level of the rising edge of the waveform 
generator output signal. (Not available when the DC, Noise, or Cardiac 
waveforms are selected.)

• WaveGen Mod (FM) — when waveform generator FM modulation is used, 
triggers at the 50% level of the rising edge of the modulating signal.

• Digital channel (on mixed-signal oscilloscopes), D0 to the number of digital 
channels minus one.

You can choose a channel that is turned off (not displayed) as the source for the 
edge trigger.

The selected trigger source is indicated in the upper-right corner of the display 
next to the slope symbol:

• 1 through 4 = analog channels.

• D0 through Dn = digital channels.

• E = External trigger input.

• L = Line trigger.

• W = Waveform generator.

4 In the Slope drop-down list, select:

• Rising edge.

• Falling edge.

• Alternating edges — Useful when you want to trigger on both edges of a 
clock (for example, DDR signals).

• Either edge — Useful when you want to trigger on any activity of a selected 
source.

Rising and Falling edge modes operate up to the bandwidth of the 
oscilloscope. Other modes operate up to the bandwidth of the oscilloscope or 
1 GHz, whichever is smaller.

The selected slope is displayed in the trigger badge.
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Using Autoscale to
Set Up Edge

Triggers

The easiest way to set up an Edge trigger on a waveform is to use Autoscale. 
Simply press the [Auto Scale] key and the oscilloscope will attempt to trigger on the 
waveform using a simple Edge trigger type. See "Use Autoscale" on page 32.

Edge Then Edge Trigger

The Edge Then Edge trigger mode triggers when the trigger edge occurs after an 
arming edge within the minimum and maximum delay times without any 
intervening arming or triggering edges. The sequence is restarted without a trigger 
if:

• An arming or triggering edge occurs while waiting for the minimum delay time 
to complete.

• An arming edge occurs before a triggering edge during the maximum delay 
time.

• The maximum delay time completes with no triggering edge.

NOTE MegaZoom Technology Simplifies Triggering

With the built-in MegaZoom technology, you can simply Autoscale the waveforms, then stop 
the oscilloscope to capture a waveform. You can then pan and zoom through the data using 
the Horizontal and Vertical knobs to find a stable trigger point. Autoscale often produces a 
triggered display.
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The arm and trigger edges can be specified as  (Rising) or  (Falling) edges on 
analog or digital channels.

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Edge Then Edge.

3 Select the Arm A channel on which the arming edge will occur.

4 Select the Slope A edge of the Arm A signal that will arm the oscilloscope.

5 Select the Trigger B channel on which the trigger edge will occur.

6 Select the Slope B edge of the Trigger B signal that will trigger the oscilloscope.

7 Select Trigger Levels... to open the Trigger Levels dialog box where you can 
adjust the trigger levels for the input channels being used. The value of the 
trigger level or digital threshold is displayed in the trigger badge.

8 Select the Min Delay field and enter the minimum delay time between the Arm A 
edge and the Trigger B edge.

9 Select the Max Delay field and enter the maximum delay time between the 
Arm A edge and the Trigger B edge.

NOTE This Edge Then Edge trigger mode differs from previous InfiniiVision X-Series oscilloscopes 
where intervening edges were allowed (you could trigger on an Nth triggering edge) and there 
was no maximum delay time.

NOTE Entered delay times automatically adjust to the nearest valid increment of ~156.5 ps.
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In this example, the arming edge is the rising edge of a 100 ns pulse, and the 
triggering edge is the rising edge of a 50 ns pulse. You can see the oscilloscope is 
triggering anywhere from 200 ns to 800 ns after the arming edge.

Pulse Width Trigger

Pulse Width (glitch) triggering sets the oscilloscope to trigger on a positive or 
negative pulse of a specified width. If you want to trigger on a specific timeout 
value, use Pattern trigger (see "Pattern Trigger" on page 157).

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Pulse Width.

3 Select the Source channel.

The channel you select is shown in the trigger badge next to the polarity 
symbol.

The source can be any analog or digital channel available on your oscilloscope.

4 Adjust the trigger level:

• For analog channel sources, use Trigger Level field to enter the value.

• For digital channel sources, use the Logic drop-down list to select the 
threshold level.

The value of the trigger level or digital threshold is displayed in the upper-right 
corner of the display.
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5 Use the Slope drop-down list to select positive ( ) or negative ( ) polarity for 
the pulse width you want to capture.

The selected pulse polarity is displayed in the trigger badge. A positive pulse is 
higher than the current trigger level or threshold and a negative pulse is lower 
than the current trigger level or threshold.

When triggering on a positive pulse, the trigger will occur on the high to low 
transition of the pulse if the qualifying condition is true. When triggering on a 
negative pulse, the trigger will occur on the low to high transition of the pulse if 
the qualifying condition is true.

6 Use the Qualifier drop-down list to select the time qualifier:

• Less than a time value (<).

For example, for a positive pulse, if you set t<10 ns:

Use the < (Less than) field to enter the pulse width qualifier time.

The time value can be from 2 ns to 10 s (5 ns to 10 s for 350 MHz and lower 
bandwidth models).

• Greater than a time value (>).

For example, for a positive pulse, if you set t>10 ns:

Use the > (Greater than) field to enter the pulse width qualifier time.

The time value can be from 2 ns to 10 s (5 ns to 10 s for 350 MHz and lower 
bandwidth models).

• Within a range of time values (><).

For example, for a positive pulse, if you set t>10 ns and t<15 ns:

Use the > (Greater than) field to enter the lower time range value.

Use the < (Less than) field to enter the upper time range value.

10 ns 10 ns Trigger

10 ns 10 ns Trigger

10 ns 15 ns Trigger12 ns
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The time values can be from 10 ns to 10 s, with minimum difference of 5 ns 
between upper and lower settings.

Pattern Trigger

The Pattern trigger identifies a trigger condition by looking for a specified pattern. 
This pattern is a logical AND combination of the channels. Each channel can have 
a value of 0 (low), 1 (high), or don't care (X). A rising or falling edge can be 
specified for one channel included in the pattern.

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Pattern.

3 From the Qualifier drop-down list, select from the pattern duration qualifier 
options:

• Entered — when the pattern is entered.

• < (Less Than) — when the pattern is present for less than a time value.

• > (Greater Than) — when the pattern is present for greater than a time value. 
The trigger occurs when the pattern exits (not when the > time value is 
exceeded).

• Timeout — when the pattern is present for greater than a time value. In this 
case, the trigger occurs when the > time value is exceeded (not when the 
pattern exits).
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• >< (In Range) — when the pattern is present for a time within a range of 
values.

• <> (Out of Range) — when the pattern is present for a time outside of range of 
values.

Pattern durations are evaluated using a timer. The timer starts on the last edge 
that makes the pattern (logical AND) true. Except when the Timeout qualifier is 
selected, the trigger occurs on the first edge that makes the pattern false, 
provided the time qualifier criteria has been met.

The time values for the selected qualifier are set using the < and > qualifier time 
set fields.

4 Use the Set All buttons to set the pattern for all channels to 1, 0, or X (don't 
care).

5 To set the pattern for individual channels, select the channel; then, select one 
of the Set Selected Channel buttons:

• 0 sets the pattern to zero (low) on the selected channel. A low is a voltage 
level that is less than the channel's trigger level or threshold level.

• 1 sets the pattern to 1 (high) on the selected channel. A high is a voltage 
level that is greater than the channel's trigger level or threshold level.

• X sets the pattern to don't care on the selected channel. Any channel set to 
don't care is ignored and is not used as part of the pattern. However, if all 
channels in the pattern are set to don't care, the oscilloscope will not 
trigger.

• The rising edge ( ) or falling edge ( ) selections set the pattern to an edge 
on the selected channel. Only one rising or falling edge can be specified in 
the entire pattern. When an edge is specified, the oscilloscope will trigger at 
the edge specified if the pattern set for the other channels is true.

If no edge is specified in the entire pattern, the oscilloscope will trigger on 
the last edge that makes the pattern true.

When the Entered qualifier is selected, you can also specify patterns for digital 
channels using the Bus1 and Bus2 fields and entering hexadecimal values. See 
"Hex Bus Pattern Trigger" on page 159.

6 Select Trigger Levels... to open the Trigger Levels dialog box where you can 
adjust the trigger levels for the input channels being used.

NOTE Specifying an Edge in a Pattern

You can specify only one rising or falling edge term in the pattern. If you select an edge for a 
channel and then select an edge for a different channel, the selection for the first channel is 
changed to a don't care.
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Hex Bus Pattern Trigger

You can specify a bus value on which to trigger. To do this, first define the bus. See 
"To display digital channels as a bus" on page 120 for details. You can trigger on 
a bus value whether you are displaying the bus or not.

To trigger on a bus value:

1 Select the Pattern trigger type and the Entered qualifier as described in "Pattern 
Trigger" on page 157.

2 In the Bus1 or Bus2 fields, enter the hex character values.

When a hex bus digit contains one or more don't care (X) bits and one or more bits 
with a value or 0 or 1, the "$" sign will be displayed for the digit.

For information regarding digital bus display when Pattern triggering see "Bus 
values are displayed when using Pattern trigger" on page 122.

NOTE If a digit is made up of less than four bits, the value of the digit is limited to the greatest 
number that can be represented by the number of bits.
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OR Trigger

The OR trigger mode triggers when any one (or more) of the specified edges on 
analog or digital channels is found.

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select OR.

3 Use the Set All buttons to set the edges for all channels to  (Rising),  

(Falling),  (Either), or X (Don't Care).

4 To set the edges for individual channels, select the channel; then, select one of 

the Set Selected Channel buttons:  (Rising),  (Falling),  (Either), or X (Don't 
Care).

If all channels in the OR trigger are set to don't care, the oscilloscope will not 
trigger.

5 Select Trigger Levels... to open the Trigger Levels dialog box where you can 
adjust the trigger levels for the input channels being used.

Rise/Fall Time Trigger

The Rise/Fall Time trigger looks for a rising or falling transition from one level to 
another level in greater than or less than a certain amount of time.
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1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Rise/Fall Time.

3 Select the Source analog channel on which to look for edges.

4 From the Slope drop-down list, select whether to look for a  Rising or  Falling 
edge.

5 From the Qualifier drop-down list, select:

• < — When looking for an edge that is less than a time value.

• > — When looking for an edge that is greater than a time value.

6 Select the Time field and enter the "less than" or "greater than" time value.

7 From the Level Select drop-down list, select which level, High or Low, the Trigger 
Level knob will adjust.

You can also push the Trigger Level knob to toggle between High and Low 
selection.

8 In addition to turning the Trigger Level knob to specify high and low levels, you 
can also:

• Select the Trigger Level: Low field and enter the low level value.

• Select the Trigger Level: High field and enter the high level value.

High level

Low level

Rising edge time Falling edge time
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Runt Trigger

The Runt trigger looks for pulses that cross one threshold but not another.

• A positive runt pulse crosses through a lower threshold but not an upper 
threshold.

• A negative runt pulse crosses through an upper threshold but not a lower 
threshold.

To trigger on runt pulses:

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Runt.

3 Select the Source analog channel on which to look for runt pulses.

High level

Low level

Positive runt pulse Negative runt pulse
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4 From the Slope drop-down list, select whether to look for Positive runt pulses or 
Negative runt pulses.

5 From the Qualifier drop-down list, select:

• None — When not concerned about the width of the runt pulse.

• < — When looking for a runt pulse that is less than a certain width.

• > — When looking for a runt pulse that is greater than a certain width.

6 When the "less than" or "greater than" pulse width qualifier is selected, select 
the Time field and enter the time value.

7 From the Level Select drop-down list, select which level, High or Low, the Trigger 
Level knob will adjust.

You can also push the Trigger Level knob to toggle between High and Low 
selection.

8 In addition to turning the Trigger Level knob to specify high and low levels, you 
can also:

• Select the Trigger Level: Low field and enter the low level value.

• Select the Trigger Level: High field and enter the high level value.

Setup and Hold Trigger

The Setup and Hold trigger looks for setup and hold violations.



164 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

10 Triggers
 

One oscilloscope channel probes the clock signal and another channel probes the 
data signal.

To trigger on setup and hold violations:

1 Open the Trigger dialog box by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40).

2 In the Trigger Type drop-down list, select Setup and Hold.

3 Select the Clock analog or digital channel with the clock signal.

4 From the Slope drop-down list, select a  Rising or  Falling clock edge.

5 Select the Data analog or digital channel with the data signal.

6 Select the < Setup field and enter the setup time value.

7 Select the < Hold field and enter the hold time value.

8 Select Trigger Levels... to open the Trigger Levels dialog box where you can 
adjust the trigger levels for the input channels being used.

Data

Clock
(rising
edge)

Setup time Hold time
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Protocol Trigger

With serial decode option licenses (see "Protocol Decode Options" on page 129), 
you can enable serial trigger types. To set up these triggers, see:

• "ARINC 429 Triggering" on page 354

• "CAN/CAN FD Triggering" on page 364

• "I2C Triggering" on page 373

• "LIN Triggering" on page 382

• "MIL-STD-1553 Triggering" on page 389

• "SENT Triggering" on page 399

• "SPI Triggering" on page 410

• "UART/RS232/422/485 Triggering" on page 418

• "USB 2.0 Triggering" on page 425

• "USB PD Triggering" on page 432

Zone Qualified Trigger

The zone qualified trigger feature gives you up to four rectangular areas, Zone 1 
through Zone 4, that a waveform either must intersect or must not intersect in 
order for an acquisition to be displayed and stored in memory.

The zone qualified trigger feature is applied after the oscilloscope's hardware 
trigger, which determines the acquisitions whose waveforms are then evaluated 
for zone intersection.

To set up a zone qualified trigger:

1 Touch the upper-right corner to select the  draw box mode.

2 Drag your finger (or connected USB mouse pointer) across the screen to draw a 
rectangular zone that the waveform must either intersect or not intersect.

3 Take your finger off the screen (or release the mouse button).

4 In the pop-up menu, select one of these options:

• Add Zone Trigger - Must Intersect — Adds a new "Must Intersect" zone.

• Add Zone Trigger - Must Not Intersect — Adds a new "Must Not Intersect" zone.

• Replace Zone Trigger - Must Intersect — Replaces an existing zone with a "Must 
Intersect" zone.

• Replace Zone Trigger - Must Not Intersect — Replaces an existing zone with a 
"Must Intersect" zone.
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5 If there are multiple waveforms in a grid or existing zones, a dialog box appears:

• Zone — When replacing an existing zone, this drop-down list lets you select 
the zone being replaced.

• Source — Selects the analog channel input source that the zone is associated 
with.

• Logic — When combined with other zones, specifies whether this zone is 
ANDed or ORed with the previous zone.

Zones can be dragged on the screen using the center handle. Zones can be 
resized using the lower-right corner handle.

The upper-right corner edit (pencil) icon opens the full Zone Trigger dialog box.
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The Zone Trigger dialog box has these controls:

• Zone N On — Enables or disables the Zone.

• Source — Selects the analog channel input source the Zones is associated with.

Zone colors match the selected analog input channel. "Must Not Intersect" 
zones are shaded differently than the solid "Must Intersect" zones.

The zone qualified trigger source does not have to be the same as the hardware 
trigger source.

• Qualifier — Specifies whether the Zone is a Must Intersect zone or Must Not 
Intersect zone.

• Logic — When combined with other zones, specifies whether the Zone is ANDed 
or ORed with the previous zone.

The Zone Logic is displayed at the top of the grid.

Disabling all zones disables the zone qualified trigger feature. When the zone 
qualified trigger feature is enabled, at least one zone must be enabled.

The zone qualified trigger feature is incompatible with, and will disable, the XY and 
Roll horizontal time modes and the Averaging acquisition mode.

NOTE Keep in mind that the AUX OUT signal comes from the oscilloscope's hardware trigger. The 
AUX OUT signal indicates when there is a trigger (acquisition) that is evaluated for zone 
intersection, not when an acquisition meets the zone qualification and is plotted on the 
oscilloscope's display.
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To select the Auto or Trig'd trigger mode / 170
To select the trigger coupling / 172
To enable or disable trigger noise rejection / 173
To enable or disable trigger HF Reject / 173
To disable or reenable trigger hysteresis / 174
To set the trigger holdoff / 174
External Trigger Input / 175

The trigger Mode and Conditioning... options are available in the Trigger dialog box 
with all trigger types:

• Mode — Select Auto to automatically trigger when the specified trigger 
condition has not occurred for some period of time. Select Trig'd to turn off 
automatic triggering.

When triggers are not occurring, you can use the [Force] key to trigger on 
anything, acquire, and display captured data.

• Conditioning... — These options include coupling (similar to analog input channel 
coupling but affecting the trigger input only), holdoff, and external 
(AUX TRIG IN) input options.

You can also open the Conditioning dialog box by choosing Trigger > 
Conditioning... from the main menu (see page 40).
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Noisy Signals If the signal you are probing is noisy, you can set up the oscilloscope to reduce the 
noise in the trigger path and on the displayed waveform. First, stabilize the 
displayed waveform by removing the noise from the trigger path. Second, reduce 
the noise on the displayed waveform.

1 Connect a signal to the oscilloscope and obtain a stable display.

2 Remove the noise from the trigger path by turning on high-frequency rejection 
("To enable or disable trigger HF Reject" on page 173), low-frequency 
rejection ("To select the trigger coupling" on page 172), or "To enable or 
disable trigger noise rejection" on page 173.

3 Use "Averaging Acquisition Mode" on page 186 to reduce noise on the 
displayed waveform.

To select the Auto or Trig'd trigger mode

When the oscilloscope is running, the trigger mode tells the oscilloscope what to 
do when triggers are not occurring.

In the Auto trigger mode (the default setting), if the specified trigger conditions are 
not found, triggers are forced and acquisitions are made so that signal activity is 
displayed on the oscilloscope.

In the Trig'd trigger mode, triggers and acquisitions only occur when the specified 
trigger conditions are found.

To select the trigger mode:

1 Open the Trigger dialog box (by selecting the trigger badge or by choosing 
Trigger > Setup... from the main menu (see page 40)).

2 Select the Mode drop-down list; then, select either Auto or Trig'd.

See the following "When to Use Auto Trigger Mode" on page 171 and "When 
to Use Trig'd Trigger Mode" on page 171 descriptions.

You can also configure the Setup > (Quick Action) menu item to toggle between the 
Auto and Trig'd trigger modes. See "Configuring the (Quick Action) Menu Item" on 
page 322.

Triggering and the
Pre- and

Post-Trigger
Buffers

After the oscilloscope starts running (after pressing [Run] or [Single] or changing 
the trigger condition), the oscilloscope first fills the pre-trigger buffer. Then, after 
the pre-trigger buffer is filled, the oscilloscope starts searching for a trigger, and 
sampled data continues to flow data through the pre-trigger buffer in a first-in 
first-out (FIFO) manner.

When a trigger is found, the pre-trigger buffer contains the events that occurred 
just before the trigger. Then, the oscilloscope fills the post-trigger buffer and 
displays the acquisition memory. If the acquisition was initiated by [Run/Stop], the 
process repeats. If the acquisition was initiated by pressing [Single], the acquisition 
stops (and you can Pan and Zoom the waveform).
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In either Auto or Trig'd trigger mode, a trigger may be missed if the event occurs 
while the pre-trigger buffer is being filled. This may be more likely, for example, 
when the horizontal scale knob is set to a slow time/div setting, such as 
500 ms/div.

Trigger Indicator The trigger indicator in the trigger badge shows whether triggers are occurring.

In the Auto trigger mode, the trigger indicator can show:

• Auto? — the trigger condition is not found (after the pre-trigger buffer has 
filled), and forced triggers and acquisitions are occurring.

• Auto — the trigger condition is found (or the pre-trigger buffer is being filled).

In the Trig'd trigger mode, the trigger indicator can show:

• Trig'd? — the trigger condition is not found (after the pre-trigger buffer has 
filled), and no acquisitions are occurring.

• Trig'd — trigger condition is found (or pre-trigger buffer is being filled).

When the oscilloscope is not running, the trigger indicator area shows Stop.

When to Use Auto
Trigger Mode

The Auto trigger mode is appropriate when:

• Checking DC signals or signals with unknown levels or activity.

• When trigger conditions occur often enough that forced triggers are 
unnecessary.

When to Use Trig'd
Trigger Mode

The Trig'd trigger mode is appropriate when:

• You only want to acquire specific events specified by the trigger settings.

• Triggering on an infrequent signal from a serial bus (for example, I2C, SPI, CAN, 
LIN, etc.) or another signal that arrives in bursts. The Trig'd trigger mode lets 
you stabilize the display by preventing the oscilloscope from auto-triggering.

• Making single-shot acquisitions with the [Single] key.

Often with single-shot acquisitions, you must initiate some action in the device 
under test, and you don't want the oscilloscope to auto-trigger before that 
happens. Before initiating the action in the circuit, wait for the trigger condition 
indicator Trig'd? to display (this tells you the pre-trigger buffer is filled).

See Also • "Forcing a Trigger" on page 151

• "To set the trigger holdoff" on page 174

• "To position the time reference (left, center, right, custom)" on page 57
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To select the trigger coupling

1 Open the Conditioning dialog box by selecting Conditioning... in the Trigger 
dialog box or by choosing choose Trigger > Conditioning... from the main menu 
(see page 40).

2 In the Conditioning dialog box, select the Coupling tab.

3 From the Coupling drop-down list. select:

• DC coupling — Allows DC and AC signals into the trigger path.

• AC coupling — Places a 10 Hz high-pass filter in the trigger path removing 
any DC offset voltage from the trigger waveform.

The high-pass filter in the External Trigger input path is 50 Hz for all models.

Use AC coupling to get a stable edge trigger when your waveform has a 
large DC offset.

• LF (low frequency) Reject coupling — Adds a high-pass filter with the 3-dB 
point at 50 kHz in series with the trigger waveform.

Low frequency reject removes any unwanted low frequency components 
from a trigger waveform, such as power line frequencies, etc., that can 
interfere with proper triggering.

Use LF Reject coupling to get a stable edge trigger when your waveform has 
low frequency noise.

Note that Trigger Coupling is independent of Channel Coupling (see "To specify 
channel coupling" on page 65).

Pass
Band

50 kHz

0 dB

3 dB down point

DC
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To enable or disable trigger noise rejection

Noise Rej adds additional hysteresis to the trigger circuitry. By increasing the 
trigger hysteresis band, you reduce the possibility of triggering on noise. However, 
this also decreases the trigger sensitivity so that a slightly larger signal is required 
to trigger the oscilloscope.

1 Open the Conditioning dialog box by selecting Conditioning... in the Trigger 
dialog box or by choosing choose Trigger > Conditioning... from the main menu 
(see page 40).

2 In the Conditioning dialog box, select the Coupling tab.

3 Select the Noise Reject check box to enable or disable.

To enable or disable trigger HF Reject

HF Reject adds a 50 kHz low-pass filter in the trigger path to remove high 
frequency components from the trigger waveform.

You can use HF Reject to remove high-frequency noise, such as AM or FM 
broadcast stations or noise from fast system clocks, from the trigger path.

1 Open the Conditioning dialog box by selecting Conditioning... in the Trigger 
dialog box or by choosing choose Trigger > Conditioning... from the main menu 
(see page 40).

2 In the Conditioning dialog box, select the Coupling tab.

Pass
Band

50 kHzDC

0 dB

-3 dB
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3 Select the HF Reject check box to enable or disable.

To disable or reenable trigger hysteresis

Oscilloscope triggers use hysteresis techniques to reduce false triggering on noisy 
signals. This oscilloscope's fully digital triggers implement hysteresis as a 
sensitivity limit. The default hysteresis setting (enabled) delivers optimal triggering 
performance for almost all signals.

By disabling hysteresis, the sensitivity of the trigger drops to one least significant 
bit (LSB). It is limited only by the noise floor of the signal and oscilloscope. You 
must be mindful of signal and measurement noise to avoid false triggers. This 
mode is often paired with Bandwidth Limit filters or Averaging (see "To limit 
bandwidth and improve vertical resolution" on page 67 or "Averaging Acquisition 
Mode" on page 186).

1 Open the Conditioning dialog box by selecting Conditioning... in the Trigger 
dialog box or by choosing choose Trigger > Conditioning... from the main menu 
(see page 40).

2 In the Conditioning dialog box, select the Coupling tab.

3 Clear or select the Hysteresis check box to disable or reenable.

To set the trigger holdoff

Trigger holdoff sets the amount of time the oscilloscope waits after a trigger 
before re-arming the trigger circuitry.

Use the holdoff to trigger on repetitive waveforms that have multiple edges (or 
other events) between waveform repetitions. You can also use holdoff to trigger on 
the first edge of a burst when you know the minimum time between bursts.

For example, to get a stable trigger on the repetitive pulse burst shown below, set 
the holdoff time to be >200 ns but <600 ns.
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To set the trigger holdoff:

1 Open the Conditioning dialog box by selecting Conditioning... in the Trigger 
dialog box or by choosing choose Trigger > Conditioning... from the main menu 
(see page 40).

2 In the Conditioning dialog box, select the Holdoff tab.

3 Select the Random check box to enable or disable the random trigger holdoff 
mode.

The random trigger holdoff mode ensures that the oscilloscope re-arms after 
each acquisition in a manner that minimizes or eliminates the likelihood of 
triggering at the beginning of a DDR burst. Randomizing the holdoff time 
increases the likelihood that the oscilloscope will trigger on different data 
phases of a multi-phase (8 data transfer) burst. This mode mixes up the traffic 
pattern the oscilloscope triggers on and is very effective when used on 
repeating patterns.

4 If random trigger holdoff is disabled, select the Holdoff field and enter the 
trigger holdoff time.

If random trigger holdoff is enabled, select the Min and Max fields and enter the 
minimum and maximum trigger holdoff times.

Trigger Holdoff
Operating Hints

The correct holdoff setting is typically slightly less than one repetition of the 
waveform. Set the holdoff to this time to generate a unique trigger point for a 
repetitive waveform.

Changing the time base settings does not affect the trigger holdoff time.

With Keysight's MegaZoom technology, you can press [Stop], then pan and zoom 
through the data to find where the waveform repeats. Measure this time using 
markers; then, set the holdoff.

External Trigger Input

The external trigger input can be used as a source in several of the trigger types. 
The external trigger BNC input is labeled AUX TRIG IN.

200 ns

Oscilloscope triggers hereHoldoff

600 ns
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The external trigger input impedance is 50 Ohms.

To set the AUX TRIG IN units and probe attenuation:

1 Open the Conditioning dialog box by selecting Conditioning... in the Trigger 
dialog box or by choosing choose Trigger > Conditioning... from the main menu 
(see page 40).

2 In the Conditioning dialog box, select the External tab.

3 From the Units drop-down list, select between:

• Volts — For a voltage probe.

• Amps — For a current probe.

Measurement results, channel sensitivity, and the trigger level will reflect the 
measurement units you have selected.

4 Select how you want to specify the Attenuation factor, choosing either Ratio or 
Decibels.

5 Select the Probe attenuation factor field; then, turn the Entry knob  to set 
the attenuation factor for the connected probe.

The attenuation factor can be set from 0.001:1 to 10000:1 in a 1-2-5 sequence.

When specifying the attenuation factor in decibels, you can select values from 
-20 dB to 80 dB.

The probe attenuation factor must be set properly for measurements to be 
made correctly.

As you adjust the Probe attenuation factor, the Range field shows you the range 
of values that can appear on the external trigger input.

CAUTION  Maximum voltage at oscilloscope external trigger input

±5 V
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This chapter shows how to use the oscilloscope's acquisition and run controls.

Running, Stopping, and Making Single Acquisitions (Run Control)

There are two front panel keys for starting and stopping the oscilloscope's 
acquisition system: [Run/Stop] and [Single].

• When the [Run/Stop] key is green, the oscilloscope is running, that is, acquiring 
data when trigger conditions are met.

To stop acquiring data, press [Run/Stop]. When stopped, the last acquired 
waveform is displayed.

• When the [Run/Stop] key is red, data acquisition is stopped.

"Stop" is displayed next to the trigger type in the trigger badge.

To start acquiring data, press [Run/Stop].

• To capture and display a single acquisition (whether the oscilloscope is running 
or stopped), press [Single].

The [Single] run control lets you view single-shot events without subsequent 
waveform data overwriting the display. Use [Single] when you want maximum 
memory depth for pan and zoom.

When you press [Single], the trigger mode is temporarily set to Trig'd (to keep 
the oscilloscope from auto-triggering immediately), the trigger circuitry is 
armed, the [Single] key is illuminated, and the oscilloscope waits until a trigger 
condition occurs before it displays a waveform.
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When the oscilloscope triggers, the single acquisition is displayed and the 
oscilloscope is stopped (the [Run/Stop] key is illuminated in red). Press [Single] 
again to acquire another waveform.

If the oscilloscope does not trigger, you can press the [Force] key to trigger on 
anything and make a single acquisition.

To display the results of multiple acquisitions, use persistence. See "To set or clear 
persistence" on page 138.

Single vs. Running
and Record Length

The maximum data record length is greater for a single acquisition than when the 
oscilloscope is running (or when the oscilloscope is stopped after running).

To acquire data with the longest possible record length, press the [Single] key.

For more information on settings that affect record length, see "Length Control" 
on page 295.

Overview of Sampling

To understand the oscilloscope's sampling and acquisition modes, it is helpful to 
understand sampling theory, aliasing, oscilloscope bandwidth and sample rate, 
oscilloscope rise time, oscilloscope bandwidth required, and how memory depth 
affects sample rate.

Sampling Theory

The Nyquist sampling theorem states that for a limited bandwidth (band-limited) 
signal with maximum frequency fMAX, the equally spaced sampling frequency fS 
must be greater than twice the maximum frequency fMAX, in order to have the 
signal be uniquely reconstructed without aliasing.

fMAX = fS/2 = Nyquist frequency (fN) = folding frequency

Aliasing

Aliasing occurs when signals are under-sampled (fS < 2fMAX). Aliasing is the signal 
distortion caused by low frequencies falsely reconstructed from an insufficient 
number of sample points.
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Oscilloscope Bandwidth and Sample Rate

An oscilloscope's bandwidth is typically described as the lowest frequency at 
which input signal sine waves are attenuated by 3 dB (-30% amplitude error).

At the oscilloscope bandwidth, sampling theory says the required sample rate is fS 
= 2fBW. However, the theory assumes there are no frequency components above 
fMAX (fBW in this case) and it requires a system with an ideal brick-wall frequency 
response.

Figure 28 Aliasing

Figure 29 Theoretical Brick-Wall Frequency Response
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However, digital signals have frequency components above the fundamental 
frequency (square waves are made up of sine waves at the fundamental frequency 
and an infinite number of odd harmonics), and typically, for 500 MHz bandwidths 
and below, oscilloscopes have a Gaussian frequency response.

So, in practice, an oscilloscope's sample rate should be four or more times its 
bandwidth: fS = 4fBW. This way, there is less aliasing, and aliased frequency 
components have a greater amount of attenuation.

Note that 1 GHz bandwidth HD3-Series oscilloscope models have more of a 
brick-wall type frequency response than the Gaussian response of lower 
bandwidth HD3-Series oscilloscope models. To understand the characteristics of 
each type of oscilloscope frequency response, see Understanding Oscilloscope 
Frequency Response and Its Effect on Rise-Time Accuracy, Keysight Application 
Note 1420 (http://literature.cdn.keysight.com/litweb/pdf/5988-8008EN.pdf).

See Also Evaluating Oscilloscope Sample Rates vs. Sampling Fidelity: How to Make the 
Most Accurate Digital Measurements, Keysight Application Note 1587 
(http://literature.cdn.keysight.com/litweb/pdf/5989-5732EN.pdf)

Oscilloscope Rise Time

Closely related to an oscilloscope's bandwidth specification is its rise time 
specification. Oscilloscopes with a Gaussian-type frequency response have an 
approximate rise time of 0.35/fBW based on a 10% to 90% criterion.

Figure 30 Sample Rate and Oscilloscope Bandwidth

Limiting oscilloscope bandwidth (fBW) to 1/4 the sample rate (fS/4)
reduces frequency components above the Nyquist frequency (fN).
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An oscilloscope's rise time is not the fastest edge speed that the oscilloscope can 
accurately measure. It is the fastest edge speed the oscilloscope can possibly 
produce.

Oscilloscope Bandwidth Required

The oscilloscope bandwidth required to accurately measure a signal is primarily 
determined by the signal's rise time, not the signal's frequency. You can use these 
steps to calculate the oscilloscope bandwidth required:

1 Determine the fastest edge speeds.

You can usually obtain rise time information from published specifications for 
devices used in your designs.

2 Compute the maximum "practical" frequency component.

From Dr. Howard W. Johnson's book, High-Speed Digital Design – A 
Handbook of Black Magic, all fast edges have an infinite spectrum of frequency 
components. However, there is an inflection (or "knee") in the frequency 
spectrum of fast edges where frequency components higher than fknee are 
insignificant in determining the shape of the signal.

fknee = 0.5 / signal rise time (based on 10% - 90% thresholds)

fknee = 0.4 / signal rise time (based on 20% - 80% thresholds)

3 Use a multiplication factor for the required accuracy to determine the 
oscilloscope bandwidth required.

See Also Choosing an Oscilloscope with the Right Bandwidth for your Application, Keysight 
Application Note 1588 
(http://literature.cdn.keysight.com/litweb/pdf/5989-5733EN.pdf)

Memory Depth and Sample Rate

In the Acquire dialog box, you can clear or select the Auto controls for Memory 
Depth and Sample Rate to either manually specify desired values or have them 
automatically determined.

Required accuracy Oscilloscope bandwidth required

20% fBW = 1.0 x fknee

10% fBW = 1.3 x fknee

3% fBW = 1.9 x fknee

http://literature.cdn.keysight.com/litweb/pdf/5989-5733EN.pdf
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The sample rate and memory depth controls are independent, and they let you set 
up four modes:

When User Values
Are Not Available

Only the Auto selection is allowed for Memory Depth and Sample Rate when:

• When digital channels are on.

Sample Rate

Auto User (manual)

Memory 
Depth

Auto This is called Automatic mode. It is the 
oscilloscope's default. While the oscilloscope is 
running (continuously making acquisitions), the 
oscilloscope's time per division setting 
determines the sample rate and memory depth 
so as to fill the screen2 with data.

For single acquisitions, the time/division setting 
still determines the sample rate, but the 
maximum amount of acquisition memory is 
used.

You choose the desired sample rate1 and the 
memory depth is adjusted to fill the screen2 
with data at the current time/div setting.

The time/div limits are adjusted so that the 
display can be filled with data at the specified 
sample rate without exceeding the memory 
depth.

For single acquisitions, the maximum amount of 
acquisition memory is used.

User 
(manual)

You choose the desired memory depth and the 
sample rate is calculated to be as fast as 
possible while still being able to fill the screen 
with data at the current time/div setting.

The specified number of points is acquired when 
running or when making single acquisitions.

This is called Digitizer mode. You choose the 
desired acquisition sample rate1 and memory 
depth, and the time/div setting is adjusted, if 
necessary, to fill the screen with data.

The specified number of points is acquired when 
running or when making single acquisitions.

The actual sample rate and memory depth used 
are displayed in the dialog box.

Digitizer mode primarily aids external software 
that controls and combines data from multiple 
instruments.

1 Rounded up to the nearest valid sample rate. Sample rates must be a power-of-two factor of the maximum sample rate (for 
example, 3.2 GSa/s, 1.6 GSa/s, 800 MSa/s, etc.).

2 At least two screens of data are acquired at 2 μs/div and below. One screen of data is acquired above 2 μs/div.
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• When the XY or Roll time modes are selected.

• When segmented memory is on.

• When mask test is on.

Selecting the Acquisition Mode

When selecting the oscilloscope acquisition mode, keep in mind that samples are 
normally decimated at slower time/div settings.

At slower time/div settings, the effective sample rate drops (and the effective 
sample period increases) because the acquisition time increases and the 
oscilloscope's digitizer is sampling faster than is required to fill memory.

For example, suppose an oscilloscope's digitizer has a sample period of 1 ns 
(maximum sample rate of 1 GSa/s) and a 1 M memory depth. At that rate, memory 
is filled in 1 ms. If the acquisition time is 100 ms (10 ms/div), only 1 of every 100 
samples is needed to fill memory.

To select the acquisition mode:

1 Open the Acquire dialog box by selecting the sample rate and memory depth 
(Acquire) badge or by choosing Setup > Acquire... from the main menu (see 
page 40).

2 In the Acquire dialog box, from the Acq Mode drop-down list, select the 
acquisition mode:

• Normal — at slower time/div settings, normal decimation occurs, and there is 
no averaging. Use this mode for most waveforms. See "Normal Acquisition 
Mode" on page 183.

• Peak Detect — at slower time/div settings, the maximum and minimum 
samples in the effective sample period are stored. Use this mode for 
displaying narrow pulses that occur infrequently. See "Peak Detect 
Acquisition Mode" on page 184.

• Averaging — at all time/div settings, the specified number of triggers are 
averaged together. Use this mode for reducing noise and increasing 
resolution of periodic signals without bandwidth or rise time degradation. 
See "Averaging Acquisition Mode" on page 186.

Normal Acquisition Mode

In Normal mode at slower time/div settings, extra samples are decimated (in other 
words, some are thrown away). This mode yields the best display for most 
waveforms.
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Peak Detect Acquisition Mode

In Peak Detect mode at slower time/div settings, minimum and maximum samples 
are kept in order to capture infrequent and narrow events (at the expense of 
exaggerating any noise). This mode displays all pulses that are at least 100 ps 
wide.

See Also • "Glitch or Narrow Pulse Capture" on page 184

• "Using Peak Detect Mode to Find a Glitch" on page 185

Glitch or Narrow Pulse Capture

A glitch is a rapid change in the waveform that is usually narrow as compared to 
the waveform. Peak Detect acquisition mode can be used to more easily view 
glitches or narrow pulses. In Peak Detect mode, narrow glitches and sharp edges 
are displayed more brightly than when in Normal acquisition mode, making them 
easier to see.

To characterize the glitch, use the markers or the automatic measurement 
capabilities of the oscilloscope.

Figure 31 Sine With Glitch, Normal Mode
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Using Peak Detect Mode to Find a Glitch

1 Connect a signal to the oscilloscope and obtain a stable display.

2 Open the Acquire dialog box by selecting the sample rate and memory depth 
(Acquire) badge or by choosing Setup > Acquire... from the main menu (see 
page 40).

3 In the Acquire dialog box, from the Acq Mode drop-down list, select the Peak 
Detect acquisition mode.

4 From the menu, choose Setup > Display....

5 In the Display dialog box, select the Persistence tab.

6 Select the Persistence field, and select ∞ Persistence.

Infinite persistence updates the display with new acquisitions but does not 
erase previous acquisitions. New sample points are shown at normal intensity 
while previous acquisitions are displayed at reduced intensity. Waveform 
persistence is not kept beyond the display area boundary.

Press [Clear Display] key to erase previously acquired points. The display will 
accumulate points until ∞ Persistence is turned off.

7 Characterize the glitch with Zoom mode:

a Press the [Zoom] key.

b To obtain a better resolution of the glitch, expand the time base.

Figure 32 Sine With Glitch, Peak Detect Mode
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Use the horizontal position knob ( ) to pan through the waveform to set the 
expanded portion of the normal window around the glitch.

Averaging Acquisition Mode

The Averaging mode lets you average multiple acquisitions together to reduce 
noise and increase vertical resolution (at all time/div settings). Averaging requires 
a stable trigger.

The number of averages can be set from 2 to 65536 in power-of-2 increments.

A higher number of averages reduces noise more and increases vertical resolution.

The higher the number of averages, the slower the displayed waveform responds 
to waveform changes. You must compromise between how quickly the waveform 
responds to changes and how much you want to reduce the displayed noise on the 
signal.

To use the Averaging mode:

1 Open the Acquire dialog box by selecting the sample rate and memory depth 
(Acquire) badge or by choosing Setup > Acquire... from the main menu (see 
page 40).

2 In the Acquire dialog box, from the Acq Mode drop-down list, select the Averaging 
acquisition mode.

3 Select the # of Averages field and turn the Entry knob to set the number of 
averages that best eliminates the noise from the displayed waveform.

# Avgs Bits of resolution

2 14

≥ 4 16
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When the Averaging acquisition mode is enabled, a Single acquisition will perform 
the selected number of averages and then stop.

See Also • Chapter 11, “Trigger Mode and Conditioning,” starting on page 169

Figure 33 Random noise on the displayed waveform

Figure 34 128 Averages used to reduce random noise
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• "Averaged Value" on page 99

Acquiring to Segmented Memory

When capturing multiple infrequent trigger events it is advantageous to divide the 
oscilloscope's memory into segments. This lets you capture signal activity without 
capturing long periods of signal inactivity.

Each segment is complete with all analog channel, digital channel, and serial 
decode data.

When using segmented memory, use the Analyze Segments feature (see 
"Measurements, Statistics, and Infinite Persistence with Segmented Memory" on 
page 189) to show infinite persistence across all acquired segments. See also "To 
set or clear persistence" on page 138 for details.

To acquire to
segmented

memory

1 Set up a trigger condition. (See Chapter 10, “Triggers,” starting on page 149 
for details.)

2 Open the Acquire dialog box by selecting the sample rate and memory depth 
(Acquire) badge or by choosing Setup > Acquire... from the main menu (see 
page 40).

3 In the Acquire dialog box, select Segmented....

4 In the Segmented dialog box, select the # of Segments field and turn the Entry 
knob to select the number of segments into which you would like to divide the 
oscilloscope's memory.

Memory can be divided into as few as two segments and as many as 1000 
segments, depending on the oscilloscope model.

5 Select the Segmented check box to enable segmented memory acquisitions.

6 Press the [Run] or [Single] key.

The oscilloscope runs and fills a memory segment for each trigger event. When 
the oscilloscope is busy acquiring multiple segments, the progress is displayed on 
screen. The oscilloscope continues to trigger until memory is filled, then the 
oscilloscope stops.

If the signal you are measuring has more than about 1 s of inactivity, consider 
selecting the Trig'd trigger mode to prevent Auto triggering. See "To select the 
Auto or Trig'd trigger mode" on page 170.

See Also • "Navigating Segments" on page 189

• "Measurements, Statistics, and Infinite Persistence with Segmented Memory" 
on page 189

• "Segmented Memory Re-Arm Time" on page 189

• "Saving Data from Segmented Memory" on page 190
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Navigating Segments

1 In the Segmented dialog box, select the Current Seg field, and turn the Entry 
knob to display the desired segment along with a time tag indicating the time 
from the first trigger event.

You can also navigate segments using the Analyze > Navigate... menu item, the 
Navigate dialog box, and its controls. See "To navigate segments" on page 60.

Measurements, Statistics, and Infinite Persistence with Segmented 
Memory

To perform measurements and view statistical information, choose Measure > 
Measurements... from the main menu (see page 40) and set up your desired 
measurements (see Chapter 14, “Measurements,” starting on page 199). Then, in 
the Segmented dialog box, select Analyze Segments. Statistical data will be 
accumulated for the measurements you have chosen.

When the segmented memory feature is on and acquisitions is stopped, the 
Analyze Segments button is available when features like measurements, infinite 
persistence, histograms, or protocol listing are on.

Segmented Memory Re-Arm Time

After each segment fills, the oscilloscope re-arms and is ready to trigger in about 
1 µs.
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Remember though, for example: if the horizontal time per division control is set to 
5 µs/div, and the Time Reference is set to Center, it will take at least 50 µs to fill all 
ten divisions and re-arm. (That is 25 µs to capture pre-trigger data and 25 µs to 
capture post-trigger data.)

Saving Data from Segmented Memory

You can save either the currently displayed segment (Save Segment - Current), or all 
segments (Save Segment - All) in the following data formats: CSV, ASCII XY, and 
BIN.

Be sure to set the Length control to capture enough points to accurately represent 
the captured data. When the oscilloscope is busy saving multiple segments, 
progress is displayed.

For more information, see "To save CSV, ASCII XY, or BIN data files" on page 294.
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Markers are horizontal and vertical markers that indicate X-axis values and Y-axis 
values on a selected waveform source. You can use markers to make custom 
voltage, time, phase, or ratio measurements on oscilloscope signals.

Marker information is displayed in the Results area.

Markers are not always limited to the visible display. If you set a marker, then pan 
and zoom the waveform until the marker is off screen, its value will not be 
changed. It will still be there when you return to its original location.

X Markers X markers are vertical dashed lines that adjust horizontally and can be used to 
measure time (s), frequency (1/s), phase (°), and ratio (%).

When used with the FFT math function as a source, the X markers indicate 
frequency.

In XY horizontal mode, the X cursors display channel 1 values (Volts or Amps).

The Markers tab/list in the Results pane shows:

• X1 and X2 marker values for the selected waveform source

• ΔX (the difference between X1 and X2)

• 1/ΔX

• ΔY/ΔX

Y Markers Y markers are horizontal dashed lines that adjust vertically and can be used to 
measure Volts or Amps, dependent on the channel Probe Units setting, or they can 
measure ratios (%). When math functions are used as a source, the measurement 
units correspond to that math function.

The Y markers adjust vertically and typically indicate values relative to the 
waveform's ground point, except for math FFT where the values are relative to 
0 dB.

In XY horizontal mode, the Y cursors display channel 2 values (Volts or Amps).
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The Markers tab/list in the Results pane shows:

• Y1 and Y2 marker values for the selected waveform source

• ΔY (the difference between Y1 and Y2)

• ΔY/ΔX

To make marker measurements

1 Connect a signal to the oscilloscope and obtain a stable display.

2 To enable markers:

• Press the front panel [Markers] key to enable or disable markers.

• Or, in the Markers dialog box, select On to enable or disable markers.

3 To open the Markers dialog box:

• Choose Measure > Markers... from the main menu (see page 40).

• When markers are enabled and displayed in the Results area, select the 

 Edit button in the Markers window.

4 In the Markers dialog box, from the Mode drop-down list, you can select:

• Manual — ΔX, 1/ΔX, ΔY, and ΔY/ΔX values are displayed. ΔX is the difference 
between the X1 and X2 markers and ΔY is the difference between the Y1 and 
Y2 markers.

• Track Waveform — As you move a marker horizontally, the vertical amplitude 
of the waveform is tracked and measured. The time and voltage positions 
are shown for the markers. The vertical (Y) and horizontal (X) differences 
between the markers are shown as ΔX and ΔY values.

• Measure — When measurements are displayed, this mode shows the marker 
locations used to make the measurement. When you add a measurement, it 
becomes the one that markers are displayed for.

You can change the measurement whose marker locations are displayed by 
selecting it in the Measurements results list.
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• Binary — Logic levels of displayed waveforms at the current X1 and X2 
marker positions are displayed in the Markers results window in binary. The 
display is color coded to match the color of the related channel's waveform.

• Hex — Logic levels of displayed waveforms at the current X1 and X2 marker 
positions are displayed in the Markers results window in hexadecimal.

Manual and Track Waveform modes can be used on waveforms that are displayed 
on the analog input channels (including math functions).

Binary and Hex modes apply to digital signals.

In Hex and Binary modes, a level can be displayed as 1 (higher than trigger 
level), 0 (lower than trigger level), indeterminate state (-), or X (don't care).

In Binary mode, X is displayed if the channel is turned off.

In Hex mode, the channel is interpreted as 0 if turned off.

5 Select Source (or X1 Source, X2 Source in the Track Waveform mode); then, select 
the input source for marker values.

6 Select the X1, X2, Y1, and/or Y2 check boxes to enable or disable individual 
markers and the fields used to specify their locations.

7 Select the Show Readout check box to enable or disable the display of marker 
value annotations.

8 Select the marker(s) to be adjusted:

• Push the vertical Markers knob to cycle through the selection of Y1, Y2, or 
both Y1 Y2 (to be adjusted as a pair).

You can also make these selections in the Markers dialog box using the 
Selected Y drop-down list.

• Push the horizontal Markers knob to cycle through the selection of X1, X2, or 
both X1 X2 (to be adjusted as a pair).

You can also make these selections in the Markers dialog box using the 
Selected X drop-down list.

Selecting pairs of markers lets you adjust them both at the same time, while the 
delta value remains the same. This can be useful, for example, for checking 
pulse width variations in a pulse train.

The currently selected marker(s) are highlighted on the display and in the 
Markers dialog box.

9 Adjust the the selected marker(s):

• Turn the vertical Markers knob to move the selected marker(s) up or down 
on the screen.

You can also select the Y1 and Y2 fields in the Markers dialog box and use 
the associated controls to adjust the vertical markers.
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• Turn the horizontal Markers knob to move the selected marker(s) left or right 
on the screen.

You can also select the X1 and X2 fields in the Markers dialog box and use 
the associated controls to adjust the horizontal markers.

You can also select and position markers by dragging them on the touchscreen.

10 To change the marker measurement units, select Units....

In the Marker Units dialog box:

From the X Units drop-down list, you can select:

• Seconds (s).

• Hz (1/s).

• Phase (°) — When selected, select Use X Markers As 360° to set the current X1 
location as 0 degrees and the current X2 location as 360 degrees.

• Ratio (%) — When selected, select Use X Markers as 100% to set the current X1 
location as 0% and the current X2 location as 100%.

From the Y Units drop-down list, you can select:

• Base — The Y marker units are the same as used for the source waveform.

• Ratio (%) — When selected, select Use Y Markers as 100% to set the current Y1 
location as 0% and the current Y2 location as 100%.

For phase or ratio units, once the 0 and 360 degree or 0 and 100% locations are 
set, adjusting markers will display measurements relative to the set locations.

11 Select the Global X Markers check box to, when there are multiple grids, enable 
or disable the placement of X markers in all grids. When disabled, X markers 
appear in the same grid as the source waveform.
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Marker Examples

Figure 35 Markers used to measure pulse widths other than middle threshold points

Figure 36 Markers measure frequency of pulse ringing
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Expand the display with Zoom mode, then characterize the event of interest with 
the markers.

Put the X1 marker on one side of a pulse and the X2 marker on the other side of the 
pulse.

Figure 37 Markers track Zoom window



Markers 13

Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide 197

 

With X1 X2 selected, move the markers together to check for pulse width 
variations in a pulse train.

Figure 38 Measuring pulse width with markers

Figure 39 Moving the markers together to check pulse width variations
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To quickly add 10 common measurements / 200
To make automatic measurements / 201
To edit measurements / 202
Measurements Summary / 203
Voltage Measurements / 204
Time Measurements / 211
Count Measurements / 218
Mixed Measurements / 219
FFT Analysis Measurements / 220
Measurement Thresholds / 222
Measurement Window / 224
Measurement Hysteresis / 224
Measurement Statistics / 225
Measurement Limit Testing / 227

The Measure > menu lets you make automatic measurements on waveforms. Some 
measurements can only be made on analog input channels.

The results of the last 10 selected measurements are displayed in the 
Measurements window in the Results area.

When you add a measurement, it appears at the bottom of the Measurements list 
dialog, and markers that show the portion of the waveform being measured are 
automatically displayed. You can change the measurement for which markers are 
displayed by selecting the measurement in the list or by selecting the 
measurement in the Markers dialog box.
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To quickly add 10 common measurements

1 From the menu, choose Measure > Quick Measure > Channel N.

Ten common measurements are added for the selected channel and displayed 
in the Results area.

Statistics are displayed if they are enabled in the Settings tab of the 
Measurements dialog box. See "Measurement Statistics" on page 225.

Markers are displayed for a selected measurement to show the portion of the 
waveform being measured. To view the markers for a different measurement, 
select it in the Results area.

In the Results area, you can right-click a measurement to:

• Delete the selected measurement.

• Delete all measurements.

NOTE Post Acquisition Processing

In addition to changing display parameters after the acquisition, you can perform all of the 
measurements and math functions after the acquisition. Measurements and math functions 
will be recalculated as you pan and zoom and turn channels on and off. As you zoom in and out 
on a signal using the horizontal scale knob and vertical volts/division knob, you affect the 
resolution of the display. Because measurements and math functions are performed on 
displayed data, you affect the resolution of functions and measurements.
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• Show or hide statistics.

• Reset statistics.

• Move the measurement up in the list.

• Move the measurement down in the list.

To make automatic measurements

1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Add, Edit & Delete tab.

3 From the Type list, select the measurement you want to add.

To filter the type list, you can select the Category of measurements you want to 
select from:

• All — All measurements.

• Voltage — Only voltage (vertical) measurements.

• Time — Only time (horizontal) measurements.

• Count — Only pulse or edge count measurements.

• Mixed — Measurements that consider vertical and horizontal values.

• FFT Analysis — Measurements for FFT frequency domain waveforms.

For more information on the types of measurements, see "Measurements 
Summary" on page 203.

4 In the Add Measurement area, select the Source channel, running math function, 
or reference waveform being measured.

All measurements have at least one Source waveform parameter.

Only channels, math functions, or reference waveforms that are displayed are 
available for measurements.
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5 Specify any other parameters for the selected measurement.

6 Select Add (measurement) to add the measurement selected in the Type list.

Markers are turned on to show the portion of the waveform being measured for 
the most recently added measurement (bottom-most on the display). To view 
the markers for a previously added measurement (but not the last one), select 
the measurement in the Results area.

By default, measurement statistics are displayed. See "Measurement 
Statistics" on page 225.

7 To edit a measurement, select it in the Active Measurements list; then select Edit 
(measurement).

8 To show or hide the Measurements window in the Results area, select or clear 
On.

9 To delete a measurement, select it in the Active Measurements list; then select 
Delete (measurement).

The measurement is removed from the Active Measurements list and from the 
Results area.

10 To delete all measurements, select Delete All.

All measurements are removed from the Active Measurements list and from the 
Results area.

To edit measurements

When added measurements have parameters that can be edited (like the Delay, 
Phase, Occupied Bandwidth, ACPR, or THD measurements), you can edit the 
parameters of those measurements.

1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Add, Edit & Delete tab.

3 Select the measurement in the Active Measurements list; then select Edit 
(measurement).

NOTE If a portion of the waveform required for a measurement is not displayed or does not display 
enough resolution to make the measurement (approximately 4% of full scale), the result will 
display "No Edges", "Clipped", "Low Signal" (not enough amplitude), "< value", or "> value", or 
a similar message to indicate that the measurement may not be reliable.
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Measurements Summary

The automatic measurements provided by the oscilloscope are listed in the 
following table. All measurements are available for analog channel waveforms. All 
measurements except Counter are available for reference waveforms and math 
waveforms other than FFT. A limited set of measurements is available for math FFT 
waveforms and for digital channel waveforms (as described in the following table).

Measurement Valid 
for 
Math 
FFT*

Valid for 
Digital 
Channels

Notes

"Amplitude" on page 206

"Area" on page 219

"Average" on page 209 Yes, Full 
Screen

"Base" on page 207

"Bit Rate" on page 214 Yes

"Burst Width" on page 214

"Counter" on page 213 Yes Not valid for math waveforms.

"Delay" on page 215 Yes Measures between two sources.

"Duty Cycle" on page 214 Yes

"Fall Time" on page 215

"Frequency" on page 212 Yes

"Maximum" on page 205 Yes

"Minimum" on page 205 Yes

"Rising Edge Count" on 
page 219

"Falling Edges Count" on 
page 219

"Positive Pulse Count" on 
page 218

Yes

"Negative Pulse Count" on 
page 218

Yes

"Overshoot" on page 207

"Peak-Peak" on page 205 Yes

"Period" on page 212 Yes
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Power App
Measurements

Note that additional Power App measurements are available when the power 
measurement and analysis license is installed and the Power application is 
enabled. For more information, see the Power Measurement Application User's 
Guide at: www.keysight.com/find/HD3-Series-manual

Jitter Analysis
Measurements

Note that additional Jitter Analysis measurements are available when the Jitter 
analysis license is installed and the feature is enabled. See "Jitter Measurements" 
on page 244.

Voltage Measurements

The following figure shows the voltage measurement points.

"Phase" on page 216 Measures between two sources.

"Preshoot" on page 208

"Ratio" on page 211 Measures between two sources.

"Rise Time" on page 214

"Slew Rate" on page 220

"DC RMS" on page 209

"AC RMS" on page 210

"Time at Edge" on page 215 Yes

"Top" on page 206

"+ Width" on page 213 Yes

"– Width" on page 214 Yes

"X at Max Y" on page 217 Yes The resultant units are in Hertz.

"X at Min Y" on page 218 Yes The resultant units are in Hertz.

"Y at X" on page 206 Yes Yes With FFT waveforms, X is a frequency 
value.

* Use the markers to make other measurements on FFT.

Measurement Valid 
for 
Math 
FFT*

Valid for 
Digital 
Channels

Notes

https://www.keysight.com/find/HD3-Series-manual
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Measurement units for each input channel can be set to Volts or Amps using the 
Units selection in the Probe dialog box. See "To specify the channel units" on 
page 69.

The units of math waveforms are described in "Units for Math Waveforms" on 
page 87.

• "Peak-Peak" on page 205

• "Maximum" on page 205

• "Minimum" on page 205

• "Amplitude" on page 206

• "Top" on page 206

• "Base" on page 207

• "Overshoot" on page 207

• "Preshoot" on page 208

• "Average" on page 209

• "DC RMS" on page 209

• "AC RMS" on page 210

• "Ratio" on page 211

Peak-Peak

The peak-to-peak value is the difference between Maximum and Minimum values. 
The Y markers show the values being measured.

Maximum

Maximum is the highest value in the waveform display. The Y marker shows the 
value being measured.

Minimum

Minimum is the lowest value in the waveform display. The Y marker shows the 
value being measured.

Amplitude

Maximum

Minimum
Base

Top

Peak-Peak
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Y at X

Y at X measures the vertical value at a specified horizontal location on the specified 
source waveform. The horizontal location must be on the screen.

When the horizontal axis is time, the horizontal location is a time value referenced 
to the trigger event.

When the source is an FFT (Fast Fourier Transform) waveform, the horizontal axis 
is frequency instead of time, and the horizontal location is a frequency value.

Amplitude

The Amplitude of a waveform is the difference between its Top and Base values. 
The Y markers show the values being measured.

Top

The Top of a waveform is the mode (most common value) of the upper part of the 
waveform, or if the mode is not well defined, the top is the same as Maximum. The 
Y marker shows the value being measured.

See Also • "To isolate a pulse for Top measurement" on page 206

To isolate a pulse for Top measurement

The following figure shows how to use Zoom mode to isolate a pulse for a Top 
measurement.

You may need to change the measurement window setting so that the 
measurement is made in the lower, Zoom window. See "Measurement Window" 
on page 224.
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Base

The Base of a waveform is the mode (most common value) of the lower part of the 
waveform, or if the mode is not well defined, the base is the same as Minimum. 
The Y marker shows the value being measured.

Overshoot

Overshoot is distortion that follows a major edge transition expressed as a 
percentage of Amplitude. The X markers show which edge is being measured 
(edge closest to the trigger reference point).

Figure 40 Isolating area for Top measurement
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Preshoot

Preshoot is distortion that precedes a major edge transition expressed as a 
percentage of Amplitude. The X markers show which edge is being measured 
(edge closest to the trigger reference point).

Figure 41 Automatic Overshoot measurement

Overshoot
local Maximum

local Minimum

Base

Top

Overshoot
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Average

Average is the sum of the levels of the waveform samples divided by the number of 
samples.

Where xi = value at ith point being measured, n = number of points in 
measurement interval.

The Full Screen measurement interval variation measures the value on all 
displayed data points.

The N Cycles measurement interval variation measures the value on an integral 
number of periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X markers show what interval of the waveform is being measured.

DC RMS

DC RMS is the root-mean-square value of the waveform over one or more full 
periods.

Where xi = value at ith point being measured, n = number of points in 
measurement interval.

The Full Screen measurement interval variation measures the value on all 
displayed data points.

The N Cycles measurement interval variation measures the value on an integral 
number of periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X markers show the interval of the waveform being measured.

Preshootlocal Maximum

local Minimum

Base

Top

Preshoot

Average
xi
n

i

n
xi
n
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AC RMS

AC RMS is the root-mean-square value of the waveform, with the DC component 
removed. It is useful, for example, for measuring power supply noise.

The N Cycles measurement interval measures the value on an integral number of 
periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X markers show the interval of the waveform being measured.

The Full Screen (Std Deviation) measurement interval variation is an RMS 
measurement across the full screen with the DC component removed. It shows the 
standard deviation of the displayed voltage values.

The standard deviation of a measurement is the amount that a measurement 
varies from the mean value. The Mean value of a measurement is the statistical 
average of the measurement.

The following figure graphically shows the mean and standard deviation. Standard 
deviation is represented by the Greek letter sigma: σ. For a Gaussian distribution, 
two sigma (± 1σ) from the mean, is where 68.3 percent of the measurement results 
reside. Six sigma (± 3σ) from is where 99.7 percent of the measurement results 
reside.

The mean is calculated as follows:

where:

• x = the mean.

• N = the number of measurements taken.

• xi = the ith measurement result.

-2σ

mean

-1σ 1σ 2σ
68.3%

-3σ
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0 3σ
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The standard deviation is calculated as follows:

where:

• σ = the standard deviation.

• N = the number of measurements taken.

• xi = the ith measurement result.

• x = the mean.

Ratio

The Ratio measurement displays the ratio of the AC RMS voltages of two sources, 
expressed in dB. Use the Source 1 and Source 2 drop-down lists to select the source 
channels for the measurement.

Time Measurements

The following figure shows time measurement points.

The default lower, middle, and upper measurement thresholds are 10%, 50%, and 
90% between Top and Base values. See "Measurement Thresholds" on page 222 
for other percentage threshold and absolute value threshold settings.

• "Period" on page 212

• "Frequency" on page 212

• "Counter" on page 213

• "+ Width" on page 213

• "– Width" on page 214

• "Burst Width" on page 214

• "Duty Cycle" on page 214

• "Bit Rate" on page 214

σ i
N xi x
N

Rise Time

+ Width

Fall Time

- Width
Period
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Upper

Thresholds

Lower



212 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

14 Measurements
 

• "Rise Time" on page 214

• "Fall Time" on page 215

• "Delay" on page 215

• "Phase" on page 216

• "X at Max Y" on page 217

• "X at Min Y" on page 218

Period

Period is the time period of the complete waveform cycle. The time is measured 
between the middle threshold points of two consecutive, like-polarity edges. A 
middle threshold crossing must also travel through the lower and upper threshold 
levels which eliminates runt pulses. The X markers show what portion of the 
waveform is being measured. The Y marker shows the middle threshold point.

Frequency

Frequency is defined as 1/Period. Period is defined as the time between the middle 
threshold crossings of two consecutive, like-polarity edges. A middle threshold 
crossing must also travel through the lower and upper threshold levels which 
eliminates runt pulses. The X markers show what portion of the waveform is being 
measured. The Y marker shows the middle threshold point.

See Also • "To isolate an event for frequency measurement" on page 212

To isolate an event for frequency measurement

The following figure shows how to use Zoom mode to isolate an event for a 
frequency measurement.

You may need to change the measurement window setting so that the 
measurement is made in the lower, Zoom window. See "Measurement Window" 
on page 224.

If the waveform is clipped, it may not be possible to make the measurement.
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Counter

The InfiniiVision HD3-Series oscilloscopes have an integrated hardware frequency 
counter which counts the number of cycles that occur within a period of time 
(known as the gate time) to measure the frequency of a signal.

The gate time is the horizontal range of the oscilloscope but is limited to >= 0.1 s 
and <= 10 s. Unlike other measurements, the Zoom horizontal timebase window 
does not gate the Counter measurement.

The Counter measurement can measure frequencies up to the bandwidth of the 
oscilloscope. The minimum frequency supported is 2.0 / gateTime.

The hardware counter uses the trigger comparator output. Therefore, the counted 
channel's trigger level (or threshold for digital channels) must be set correctly.

Analog and digital channels can be selected as the source.

Only one Counter measurement can be displayed at a time.

+ Width

+ Width is the time from the middle threshold of the rising edge to the middle 
threshold of the next falling edge. The X markers show the pulse being measured. 
The Y marker shows the middle threshold point.

Figure 42 Isolating an event for Frequency measurement
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– Width

– Width is the time from the middle threshold of the falling edge to the middle 
threshold of the next rising edge. The X markers show the pulse being measured. 
The Y marker shows the middle threshold point.

Burst Width

The Burst Width measurement is the time from the first edge to the last edge on 
screen.

Duty Cycle

The duty cycle of a repetitive pulse train is the ratio of the pulse width to the 
period, expressed as a percentage. The X markers show the time period being 
measured. The Y marker shows the middle threshold point.

Bit Rate

The bit rate measurement measures all positive and negative pulse widths on the 
waveform, takes the minimum value found of either width type and inverts that 
minimum width to give a value in Hertz.

Rise Time

The rise time of a signal is the time difference between the crossing of the lower 
threshold and the crossing of the upper threshold for a positive-going edge. The X 
marker shows the edge being measured. For maximum measurement accuracy, 
set the horizontal time/div as fast as possible while leaving the complete rising 
edge of the waveform on the display. The Y markers show the lower and upper 
threshold points.

Burst width
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Fall Time

The fall time of a signal is the time difference between the crossing of the upper 
threshold and the crossing of the lower threshold for a negative-going edge. The X 
marker shows the edge being measured. For maximum measurement accuracy, 
set the horizontal time/div as fast as possible while leaving the complete falling 
edge of the waveform on the display. The Y markers show the lower and upper 
threshold points.

Time at Edge

Time at Edge measures the horizontal time of the edge location specified by the 
Source, Slope, and Edge # parameters.

The threshold voltage used for this measurement is the 50% point with a small 
amount of hysteresis added. (The "middle" measurement threshold setting for the 
source waveform does not affect this measurement.)

When the specified slope and edge number threshold crossing is found, the 
oscilloscope reports the time of that crossing in seconds, with the trigger point 
(time=zero) as the reference.

If the specified crossing cannot be found, that is, if the waveform does not cross 
the 50% vertical value, or if the waveform does not cross the 50% vertical value for 
the specific number of times at the slope specified, the oscilloscope reports "No 
edges".

When Auto is selected as the Edge #, the edge closest to the timebase reference 
point is used. When you specify an edge number, edges are counted from the left 
side of the display.

FFT (Fast Fourier Transform) waveforms cannot be selected as the source.

Delay

Delay measures the time difference between two waveform edges using the 
specified threshold points of the waveforms.

Negative delay values indicate that the selected edge of source 1 occurred after 
the selected edge of source 2.

1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Add, Edit & Delete tab.

3 From the Type list, select the Delay measurement.

Source 2

Source 1

Delay
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4 In the Add Parameter area, select:

• Source 1, Source 2 — Waveform sources.

• Source 1 Slope, Source 2 Slope — Rising edge or falling edge on.

• Auto — Uncheck so that edge numbers can be specified.

• Source 1 Edge #, Source 2 Edge # — Edge number for the selected source.

When Auto is selected for the Source 1 Edge #, the edge closest to the 
timebase reference point is used. Auto is also automatically selected for the 
Source 2 Edge #, and cannot be changed. In this case, the source 2 edge 
closest to the source 1 edge is used.

When edge numbers are selected, edges are counted from the left side of 
the display for both sources.

• Source 1 Threshold, Source 2 Threshold — Specifies whether the measurement 
should be made using the Upper, Middle, or Lower threshold level on the 
source.

5 Select Add Delay to activate the measurement.

The example below shows a delay measurement between the rising edge of 
channel 1 and the rising edge of channel 2.

Phase

Phase is the calculated phase shift from source 1 to source 2, expressed in 
degrees. Negative phase shift values indicate that the rising edge of source 1 
occurred after the rising edge of source 2.
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1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Add, Edit & Delete tab.

3 From the Type list, select the Phase measurement.

4 In the Add Parameter area, select:

• Source 1, Source 2 — Waveform sources.

5 Select Add Phase to activate the measurement.

The example below shows a phase measurement between the channel 1 and the 
math d/dt function on channel 1.

X at Max Y

X at Max Y is the X axis value (usually time) at the first displayed occurrence of the 
waveform Maximum, starting from the left-side of the display. For periodic signals, 
the position of the maximum may vary throughout the waveform. The X marker 
shows where the current X at Max Y value is being measured.

Source 2

Source 1
Delay

Period
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See Also • "To measure the peak of an FFT" on page 218

To measure the peak of an FFT

1 Select FFT as the Operator in the Waveform Math Menu.

2 Choose Math N as the source in the Measurement Menu.

3 Choose Maximum and X at Max Y measurements.

Maximum units are in dB and X at Max Y units are in Hertz for FFT.

X at Min Y

X at Min Y is the X axis value (usually time) at the first displayed occurrence of the 
waveform Minimum, starting from the left-side of the display. For periodic signals, 
the position of the minimum may vary throughout the waveform. The X marker 
shows where the current X at Min Y value is being measured.

Count Measurements

• "Positive Pulse Count" on page 218

• "Negative Pulse Count" on page 218

• "Rising Edge Count" on page 219

• "Falling Edges Count" on page 219

Positive Pulse Count

The Positive Pulse Count measurement is a pulse count for the selected waveform 
source.

Negative Pulse Count

The Negative Pulse Count measurement is a pulse count for the selected waveform 
source.

Positive pulse count
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Rising Edge Count

The Rising Edge Count measurement is an edge count for the selected waveform 
source.

This measurement is available for analog channels.

Falling Edges Count

The Falling Edges Count measurement is an edge count for the selected waveform 
source.

This measurement is available for analog channels.

Mixed Measurements

• "Area" on page 219

Area

Area measures the area between the waveform and the ground level. Area below 
the ground level is subtracted from area above the ground level.

The Full Screen measurement interval variation measures the value on all 
displayed data points.

Negative pulse count

T

Negative area
N cycles

Positive area
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The N Cycles measurement interval variation measures the value on an integral 
number of periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X markers show what interval of the waveform is being measured.

Slew Rate

Slew Rate measures the change in vertical value (ΔY) divided by the change in 
horizontal value (ΔX) for the edge closest to the timebase reference point specified 
by the Source and Slope parameters.

The lower and upper thresholds for the measurement are specified by the 
measurement threshold setting for the source waveform.

FFT (Fast Fourier Transform) waveforms cannot be selected as the source.

FFT Analysis Measurements

• "Channel Power" on page 220

• "Occupied Bandwidth" on page 220

• "Adjacent Channel Power Ratio (ACPR)" on page 221

• "Total Harmonic Distortion (THD)" on page 221

Channel Power

Channel Power measures the spectral power across a frequency range.

The center frequency used in the measurement is the one defined for the FFT 
function, and the FFT span specifies the frequency range.

When this measurement is tracked with markers, the markers are at the far left 
and right edges of the graticule.

Occupied Bandwidth

Occupied Bandwidth measures the bandwidth (frequency range) containing some 
percent (usually 99%) of the total spectral power. While 99% is the industry norm, 
you can specify the percent you want to use in the measurement.

The center frequency used in the measurement is the one defined for the FFT 
function, and the FFT span represents the total spectral power.

When this measurement is tracked with markers, the markers show the measured 
bandwidth (frequency range).
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Adjacent Channel Power Ratio (ACPR)

Adjacent Channel Power Ratio or just Adjacent Power Ratio (or channel leakage 
ratio) measures the ratio of the power contained in one or more sidebands to the 
power in the main frequency range.

The main range is specified by a channel width and a center frequency. The 
Channel Width is one of the measurement's parameters. The center frequency 
used in the measurement is the one defined for the FFT function.

Sidebands (with the same width as the main range) exist above and below the 
main range separated by the channel spacing width. The Channel Spacing width 
is another measurement parameter.

The sideband used for the measurement is selected with the Channel Select 
parameter. You can select the first through fifth sidebands above or below the 
main range (1H through 5H above and 1L through 5L below). The full sideband 
must be in the graticule to be measured. Otherwise, the measurement results will 
be "Incomplete".

When this measurement is tracked with markers, the markers show the sideband 
being measured.

Total Harmonic Distortion (THD)

Total Harmonic Distortion (THD) is the ratio of power in the fundamental frequency to 
the power contained in the rest of the harmonics and noise. THD is a measure of 
signal purity.

Main 1H 2H 3H 4H 5H5L 4L 3L 2L 1L

WidthSpacing
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Total Harmonic Distortion (THD) measures the power contained in the bands 
surrounding each harmonic and compares it to the power in the band surrounding 
the fundamental frequency. The width of the bands measured is the same for the 
fundamental frequency and each harmonic. That width is 1/2 of the fundamental 
frequency.

You can either enter the fundamental frequency as a measurement parameter and 
have the fundamental frequency and harmonics be tracked manually, or you can 
allow the fundamental frequency and harmonics to be tracked automatically, 
where the highest peak is assumed to be the fundamental frequency.

When this measurement is tracked with markers, the markers show the band 
surrounding the fundamental frequency that is being measured (at ±1/4 of the 
fundamental frequency).

Measurement Thresholds

Setting measurement thresholds defines the vertical levels where measurements 
will be taken on an analog channel or math waveform.

1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Settings tab.

3 Select Thresholds....

4 In the Measurement Thresholds dialog box:

• There are tabs for Channels, Math, and Reference waveforms.

Each analog channel, math function, and reference waveform can be 
assigned unique threshold values.

NOTE Changing default thresholds may change measurement results

The default lower, middle, and upper threshold values are 10%, 50%, and 90% of the value 
between Top and Base. Changing these threshold definitions from the default values may 
change the returned measurement results for Average, Delay, Duty Cycle, Fall Time, 
Frequency, Overshoot, Period, Phase, Preshoot, Rise Time, +Width, and -Width.
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• In the Type column, select:

• Percent — To set the measurement threshold as a % (percentage) of the 
Top and Base values.

Percentage thresholds can be set from 0% to 100%.

• Absolute — To set the measurement threshold as an absolute value.

The units for absolute threshold for each channel is set in the channel 
probe dialog box.

• In the Lower column, select the field and enter the lower measurement 
threshold value.

Increasing the lower value beyond the set middle value will automatically 
increase the middle value to be more than the lower value. The default lower 
threshold is 10% or 800 mV.

If threshold Type is set to %, the lower threshold value can be set from 0% to 
98%.

• In the Middle column, select the field and enter the middle measurement 
threshold value.

The middle value is bounded by the values set for lower and upper 
thresholds. The default middle threshold is 50% or 1.20 V.

If threshold Type is set to %, the middle threshold value can be set from 1% 
to 99%.

• In the Upper column, select the field and enter the upper measurement 
threshold value.

Decreasing the upper value below the set middle value will automatically 
decrease the middle value to be less than the upper value. The default upper 
threshold is 90% or 1.50 V.

If threshold Type is set to %, the upper threshold value can be set from 2% to 
100%.

TIP Absolute threshold hints

• Absolute thresholds are dependent on channel scaling, probe attenuation, and probe units. Always 
set these values first before setting absolute thresholds.

• The minimum and maximum threshold values are limited to on-screen values.

• If any of the absolute threshold values are above or below the minimum or maximum waveform 
values, the measurement may not be valid.
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Measurement Window

You can choose whether measurements are made in the Main window portion of 
the display, the Zoom window portion of the display (when the zoomed time base 
is displayed), or gated by the X1 and X2 markers.

1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Settings tab.

3 From the Meas Window drop-down list, you can select:

• Auto Select — When the zoomed time base is displayed, the measurement is 
attempted in the zoomed time base window; if it cannot be made there, or if 
the zoomed time base is not displayed, the Main window is used.

• Main — The measurement window is the Main window.

• Zoom — The measurement window is the zoomed time base window.

• Gated by Markers — The measurement window is between the X1 and X2 
markers. When the zoomed time base is displayed, the X1 and X2 markers in 
the Zoom window portion of the display are used.

Measurement Hysteresis

When the oscilloscope makes automatic parametric measurements on captured 
waveform data, it builds a vertical histogram, recording how many times each 
Q-level (quantization level, an internal voltage representation) is present in the 
data record. From the histogram, the absolute maximum and minimum voltage 
levels, as well as relative maximum (top) and minimum (base) voltage levels, are 
determined. Using the top and base levels, threshold levels are calculated. The 
waveform data record is again analyzed using the thresholds to determine signal 
edges.

To prevent the oscilloscope from making incorrect measurements on system noise, 
there is a minimum signal amplitude (in Q-levels, as a fraction of the vertical 
division) below which the measurement process does not take place, and "Low 
signal" is reported in the measurement results.
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However, with the ability to limit channel bandwidth, the amount of system noise 
can vary, and with the oscilloscope's low noise floor, it is possible to get a very 
small amplitude signal on screen that is stable, and therefore, theoretically 
measureable, even though it falls below the minimum signal amplitude limit. In 
these cases, you can turn off the measurement hysteresis limit to remove the "Low 
signal" result and make measurements.

The default measurement hysteresis setting (enabled) delivers optimal 
measurement performance for almost all signals.

To disable or reenable the measurement hysteresis limit:

1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Settings tab.

3 Clear the Hysteresis check box to turn off the minimum signal amplitude limit for 
making measurements.

Select the Hysteresis check box to reenable the minimum signal amplitude limit 
for making measurements.

Measurement Statistics

To display measurement statistics:

1 From the menu, choose Measure > Measurements....

2 In the Measurements dialog box, select the Settings tab.

3 In the Statistics area, select On to enable or disable the display of measurement 
statistics.

When enabled, measurement statistics appear in the Measurements window in 
the Results pane.
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The source channel of the measurement is shown in parenthesis after the 
measurement name. For example: "Freq(1)" indicates a frequency measurement 
on channel 1.

The following statistics are shown: Name of the measurement, current 
measured value, mean, minimum measured value, maximum measured value, 
standard deviation, and the number of times the measurement has been made 
(count). Statistics are based on the total number of captured waveforms 
(count).

The standard deviation shown in Statistics is calculated using the same formula 
used for calculating the standard deviation measurement. The formula is shown 
in the section titled "AC RMS" on page 210.

Statistics continue to accumulate even when the statistics display is disabled.

4 To reset the statistics measurements, select Reset Statistics. This resets all 
statistics and begins recording statistical data again.

Each time a new measurement (for example: frequency, period, or amplitude) is 
added the statistics are reset and accumulation of statistical data begins again.

5 To enable or disable a relative standard deviation, select Relative σ.

When enabled, the standard deviation shown in measurement statistics 
becomes the standard deviation/mean.

6 To specify the number of values used when calculating measurement statistics, 
select the Max Count field and enter the desired value.
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Statistics are calculated on the most recent "N" number of values, where N is 
the either the total number of acquisitions measured or a limited Max Count 
number of acquisitions measured.

Other things to know about measurement statistics:

• When the [Single] key is pressed, statistics are reset and a single measurement 
is done (count = 1). Successive [Single] acquisitions accumulate statistical data 
(and the count is incremented).

Measurement Limit Testing

Measurement limit testing lets you test measurement values to see whether they 
are inside or outside specified limits. You can display limit test results, and you can 
stop running oscilloscope acquisitions when there is a failure. You can specify 
whether measured values inside the limits or outside the limits are considered 
failures.

To enable measurement limit testing and add measurements to the limit test, 
specify limits, and specify whether failures are inside or outside the limits:

1 First, add the measurements whose limits you want to test.

In the Limit Test dialog box (opened in the next step), if measurements have not 
already been added, there is a Measurements... button that opens the 
Measurements dialog box where you can add, edit, and delete measurements, 
specify measurement thresholds, specify the measurement window, display 
measurement statistics, and display measurement histograms.

2 From the main menu (see page 40), choose Measure > Limit Test....

3 In the Limit Test dialog box, select On to enable or disable limit testing.

Measurement limit results are reset whenever Measurement Limit Test is 
re-enabled.

4 Active measurements whose limits can be tested appear in the Measurement 
column. Select a measurement to enable or disable it in the limit test.

5 Use the drop-down list in the Fail When column to select whether values Outside 
Limits or Inside Limits are considered failures.

6 Specify the measurement limits:

• To directly enter measurement limits, select the Lower Limit and Upper Limit 
fields, and enter the values.

• To create measurement limits from the last measured value plus or minus a 
percent margin, select the field in the Copy Margin column and enter the 
percent margin. Then, select the Copy button in the Copy From Results 
column.

Limit test results are displayed with measurement statistics (which are forced on).
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Added to the usual measurement statistics are columns for:

• The number of failures on the lower limit (Fail Min)

• The number of failures on the upper limit (Fail Max)

To stop running acquisitions when there are measurement limit test failures, select 
Stop On Failure.

To reset all measurement statistics and begins recording statistical data again, 
select Reset Statistics.
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Waveform Histogram Set Up / 230
Measurement Histogram Set Up / 233
Histogram Data Graph / 234
Histogram Data Statistics / 235

The histogram analysis feature provides a statistical view of a waveform or a 
measurement's results.

Waveform histograms show the number of times a waveform crosses into (or hits) 
a row or column of a user-defined window. For vertical histograms, the window is 
divided into rows. For horizontal histograms, the window is divided into columns.

Measurement histograms show the distribution of a measurement's results similar 
to ordinary measurement statistics.

As waveforms are acquired and displayed, or as measurements are made, a 
counter database accumulates the total number of hits (or measurements), and 
the histogram data is displayed as a bar graph on the graticule.

When the oscilloscope is stopped, that counter database remains intact until the 
acquired data display is modified, usually horizontally or vertically. At that time, 
the database is reset and the last displayed acquisition is used to start a new 
database.

Histogram results statistics are displayed in the Histogram results window.

The following screen shows a horizontal histogram looking at edge times:
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Histogram
Interaction With

Other Oscilloscope
Features

When you enable a histogram, horizontal zoom, XY time mode, or Roll time mode 
are automatically disabled.

When using segmented memory acquisitions, histograms perform similarly to 
math waveforms and measurements. The histogram is reset at the start of a 
segmented acquisition and all segments are histogrammed at the end of the 
acquisition.

Because it is not possible to histogram every waveform, be aware that persistence 
can show a peak or glitch that does not show up in the histogram data.

Histograms do not wait for the specified number of averaged acquisitions to be 
acquired before starting analysis, so intermediate results could be erratic.

Waveform Histogram Set Up

To set up a waveform histogram:

1 Turn on histogram analysis.

A quick way to do this is by drawing a rectangle:

a Touch the upper-right corner to select the  draw box mode.

b Drag your finger (or connected USB mouse pointer) across the screen to 
draw a rectangular over the waveform you want to histogram.

c Take your finger off the screen (or release the mouse button).

d In the pop-up menu, select Histogram.
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The Histogram dialog box opens with On selected, and the rectangle you 
drew becomes the limits window.

Or, you can:

a From the menu, choose Analyze > Histogram....

b In the Histogram dialog box, select On.

2 From the Type drop-down list, you can select:

• Horizontal — The limits window is divided into columns, and the number of 
hits in each column is displayed in a histogram bar graph at the bottom of 
the graticule.

• Vertical — The limits window is divided into rows, and the number of hits in 
each row is displayed in a histogram bar graph at the left of the graticule.

3 From the Source drop-down list, you can select the analog channel, running 
math function, or reference waveform to analyze.

4 Define the limits window in which waveform crossings (hits) are measured. See 
"Defining the Histogram Limits Window" on page 232.

5 In the Histogram Size field, specify the number of divisions the histogram bar 
graph should use:

• For horizontal histograms, you can choose whole and half divisions from 1 to 
4.

• For vertical histograms, you can choose whole and half divisions from 1 to 5.

You can select Reset Histogram to zero the histogram counters.

The following screen shows a vertical histogram:
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Defining the Histogram Limits Window

You can define the histogram limits window using the Limits area controls in the 
Histogram dialog box.

Use the Top Limit, Bottom Limit, Left Limit, and Right Limit fields to define the limits 
window in which waveform crossings (hits) measured. Selecting the field name lets 

you use the Entry knob  to adjust the field value.

Select Default Window to set up a limits window that is six divisions tall and eight 
divisions wide, centered on the graticule.

You can also define the histogram limits window using the touchscreen. When you 
select the limits window, you can drag it on the screen.

The lower right corner touch handle changes the size of the window.

The upper right corner edit (pencil) icon opens the Histogram dialog box.
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Measurement Histogram Set Up

Measurement histograms show the distribution of a measurement's results similar 
to ordinary measurement statistics.

To set up a measurement histogram:

1 First, add the measurement whose results you want to display as a histogram. 
See "To make automatic measurements" on page 201.

2 Turn on measurement histogram analysis.

You can:

a From the menu, choose Measure > Measurements....

b In the Measurements dialog box, select the Histogram tab.

Or, you can:

a From the menu, choose Analyze > Histogram....

b In the Histogram dialog box, select On.

c From the Type drop-down list, select Measurements.

3 From the Measurement drop-down list, select the measurement to analyze.

4 In the Histogram Size field, specify the number of divisions the histogram bar 
graph should use. You can choose whole and half divisions from 1 to 4.

For measurement histograms, information about the scale of the bar graph 
appears in the grid. This scale is automatically determined.

You can select Reset Histogram to zero the histogram counters.
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Histogram Data Graph

The visual component of a histogram is the bar graph on the display.

This graph appears on the left side of the graticule area for a vertical waveform 
histogram or on the graticule bottom for a horizontal waveform histogram or a 
measurement histogram.

For measurement histograms, information about the scale of the bar graph 
appears in the grid. This scale is automatically determined.

As waveforms are acquired and displayed, or as measurements are made, the bar 
graph scale changes so that the peak number of hits is displayed at the histogram 
size specified.

The Reset Histogram button zeros the histogram counters.

Markers on
Histogram Data

When the histogram analysis feature is enabled and when markers are in Manual or 
Track Waveform mode, Histogram is added to the list of sources you can select for 
markers.

If you are doing a measurement on a histogram, markers track that measurement 
on the histogram waveform.

When markers are in the Track Waveform mode, the X or the Y marker is moveable 
depending on whether the histogram type is horizontal, vertical, or measurement.
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Histogram Data Statistics

Histogram data results appear in the Histogram window in the Results pane.

There are several standard results that can be derived from the histogram 
database.

The basic units of histograms are hits, and there are some results that are 
expressed as hits:

• Hits — The sum of all bins (buckets) in the histogram.

• Peak — Maximum number of hits in any single bin.

Some results are expressed in the source's (vertical, horizontal or measurement) 
units:

• Max — The value corresponding to the maximum bin that has any hits.

• Min — The value corresponding to the minimum bin that has any hits.

• Pk-Pk — Delta between the Max and Min.

• Mean — Mean of the histogram.

• Median — Median of the histogram.

• Mode — Mode of the histogram.

• Bin Width — The width of each bin (bucket) in the histogram.

• Std Dev — Standard deviation of the histogram.

Some results are derived from other results:

• u±1σ — Percentage of histogram hits that lie within ±1 Std Dev of the mean.

• u±2σ — Percentage of histogram hits that lie within ±2 Std Dev of the mean.

• u±3σ — Percentage of histogram hits that lie within ±3 Std Dev of the mean.

In the Histogram results window, you can select the edit (pencil) icon to open the 
Histogram dialog box.
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Enabling a Color Grade Waveform / 238
Color Grade Themes / 239

The color grade analysis feature shows how often a waveform crosses into (or hits) 
pixels on the display. As waveforms are acquired and displayed, a counter 
database accumulates the number of hits, and pixels in the color grade analysis 
waveform are displayed using one of seven graduated colors that indicate a 
relative number of hits. You can choose temperature, intensity, or other color 
grade scales (themes).

When the oscilloscope is stopped, the counter database remains intact until the 
acquired data display is modified, usually horizontally or vertically. At that time, 
the database is reset and the last displayed acquisition is used to start a new 
database.

The following screen shows a color grade analysis waveform:
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Over time, you can see the nominal waveform as well as the waveform's envelope.

When any of the database counters saturate, the message The color grade database 
is saturated is displayed.

Color grade analysis works best on repetitive waveforms.

Color Grade
Interaction With

Other Oscilloscope
Features

When you enable a color grade waveform display, horizontal zoom, XY time mode, 
or roll time mode are automatically disabled.

Enabling a Color Grade Waveform

To set up color grade analysis of a waveform:

1 From the main menu (see page 40), choose Analyze > Color Grade....

2 In the Color Grade tab of the Display dialog box, select On.

3 Use the Source control to select the analog channel, math function, or reference 
waveform to analyze.

Color grade analysis is performed on one waveform unless you select All Analog 
Channels.

When All Analog Channels is selected, color grade analysis is performed on all 
analog input channel waveforms, and you can enable the Math Source control 
(which replaces the Source control) to select one other math function or 
reference waveform to include in the color grade analysis.

4 Use the Show Color Key control to see the color grade theme's seven colors and 
the range of database counts that each color represents.

NOTE Analog input channel color grade analysis is performed in hardware and is faster than math 
function or reference waveform color grade analysis which is performed in software.
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When multiple waveforms are included in the color grade analysis and the Show 
Color Key control is selected, the Color Key Source control appears, letting you 
choose which waveform's database counts are displayed in the color key.

5 Use the Invert control to reverse the color mapping in the selected Theme.

6 Use the Theme control and select Intensity, Temperature, Viridis, Hot, Abyss, Sky, or 
Inferno. For a description of the ranges used in these themes, see "Color Grade 
Themes" on page 239.

You can select Reset Color Grade to zero the color grade counters.

Changing the horizontal time/div or delay settings, or the channel's vertical V/div 
or offset settings, or the source waveform will also zero the color grade counters.

Color Grade Themes

When color grade analysis is enabled, a database is created that has the same 
number of memory locations as there are pixel locations in the waveform viewing 
area. Each database memory location is a counter. These counters are 
incremented when sampled waveform data crosses (or "hits") the associated pixel.

The color grade theme specifies seven colors that represent the ranges of counter 
values (hits) in the database. The color used for the greatest number of hits (white 
in the Intensity and Temperature color grade themes) represents pixels with the 
greatest number to about half that number. The next color represents half as many 
hits, and so on, until the last range (for example, green in the Intensity theme or 
dark blue in the Temperature theme) represents the remaining range of hits.
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The following table shows the approximate counter ranges of each color in the 
color grade themes.

Color Grade Theme (for example) Range (MH = most hits)

Intensity Temperature Upper Limit to Lower Limit (0 if Upper 
Limit is 0, Else)

MH to MH/2

MH/2 to MH/4

MH/4 to MH/8

MH/8 to MH/16

MH/16 to MH/32

MH/32 to MH/64

MH/64 to 1
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Setting Up Jitter Analysis / 242
Jitter Measurements / 244

Jitter analysis measures the variance of a measurement over time. The principal 
measurement used with jitter analysis is time interval error (TIE), but several other 
measurements can be analyzed as well.

The TIE measurement recovers an ideal clock frequency from the source waveform 
and compares it against measured transitions to generate error statistics. Several 
different clock recovery methods are available.

Jitter measurements can be visualized in these ways:

• Meas Histogram — Shows the distribution of jitter measurement results. Gaussian 
distributions indicate random jitter. Non-Gaussian distributions usually 
indicate that the jitter has deterministic components. Measurement statistics 
are displayed along with the histogram.

• Meas Trend — Shows the trend of jitter measurement results. The trend 
waveform over a greater time can show shapes or patterns that indicate what 
might be affecting jitter.

• Jitter Spectrum — Shows the jitter measurement trend in the frequency domain. 
Spikes in the FFT show frequencies of what might be affecting jitter.
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For more information, see Measuring Jitter in Digital Systems, Application Note 
(http://literature.cdn.keysight.com/litweb/pdf/5988-9109EN.pdf)

Setting Up Jitter Analysis

To set up jitter analysis:

1 From the main menu (see page 40), choose Analyze > Jitter....

2 In the Jitter dialog box, select On.

When jitter analysis is enabled, these oscilloscope settings are forced on:

• Measurements with a 1M analysis record length (see "The Analysis Record 
and Waveform Math" on page 105), which gives better accuracy.

• All edges in each acquisition are measured (instead of a single edge per 
acquisition, as is normally the case). For each acquisition, the measurement 
count increases by the number of edges in the acquisition. This applies to all 
measurements that look at edges, not just jitter analysis measurements.

http://literature.cdn.keysight.com/litweb/pdf/5988-9109EN.pdf
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3 To change the measurement thresholds settings, select Thresholds... and use 
the controls in the Measurement Threshold dialog box to change the settings 
(see "Measurement Thresholds" on page 222).

4 To add a jitter measurement:

a Select Add Measurement...; then, in the Add Measurement dialog box, select 
the jitter measurement you want.

b In the Add Measurement dialog box, select the Source to be measured and 
select any other measurement options (see "Jitter Measurements" on 
page 244 or "Duty Cycle" on page 214).

The source can be analog channels, math waveforms, or reference 
waveforms.

c Select OK.

When jitter analysis is enabled, you can also add or modify jitter measurements 
using the [Measure] key and the Measurements dialog box (see "To make 
automatic measurements" on page 201).

5 Back in the Jitter dialog box, touch the Analysis Measurement drop-down and 
choose the jitter measurement you want to analyze.

6 In the Auto Setup & Configuration area, set up the jitter measurement visualization 
options using these controls:

• Meas Histogram — The Auto Setup button enables a histogram on the selected 
jitter analysis measurement. The edit (pencil) icon opens the Histogram 
dialog box (see "Measurement Histogram Set Up" on page 233).

• Meas Trend — The Auto Setup button sets up a measurement trend waveform 
on the selected jitter analysis measurement. The edit (pencil) icon opens the 
Math dialog box for the measurement trend math waveform (see 
"Measurement Trend" on page 103).

NOTE It is important to set up absolute thresholds for the integrity of jitter measurements from 
acquisition to acquisition.
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• Jitter Spectrum — The Auto Setup button sets up an FFT of the measurement 
trend waveform on the selected jitter measurement. The edit (pencil) icon 
opens the Math dialog box for the FFT math waveform (see "FFT Magnitude, 
FFT Phase" on page 97).

Note that another math function is set up to perform smoothing on the 
measurement trend waveform. You can change the FFT's source to be the 
smoothed trend waveform if you like.

7 When you are done setting up the jitter analysis options, close the Jitter dialog 
box.

To disable jitter analysis:

1 In the Jitter dialog box (choose Analyze > Jitter... if the dialog box is not currently 
displayed), deselect On.

When jitter analysis is disabled:

• If less than 1M analysis record length was set when jitter analysis was 
enabled, the analysis record length setting is returned to the setting present 
when jitter analysis was enabled.

• The oscilloscope returns to measuring a specific edge in each acquisition 
(generally around the horizontal time reference) and ignoring all other edges 
in the acquisition, as is normally the case. For each acquisition, the 
measurement count increases by one.

Jitter Measurements

• "Data TIE" on page 244

• "Clock TIE" on page 245

• "N-Period" on page 245

• "Period-Period" on page 246

• "+Width to +Width" on page 246

• "-Width to -Width" on page 247

Data TIE

The Data TIE (Time Interval Error) jitter measurement compares edges in a data 
signal with the edges in an ideal data signal determined by the clock recovery 
feature (see "Setting Up Clock Recovery" on page 104).

Once the ideal data rate is determined, all of the data intervals are measured with 
respect to the ideal data rate and the error statistics are computed. The following 
figure shows how the Data TIE is measured on rising edges of the data.
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The measurement is made on all the cycles of the waveform. Even in Zoom mode, 
all the cycles of the waveform in the Main window will be measured.

Clock TIE

The Clock TIE (Time Interval Error) jitter measurement compares edges in a clock 
signal with the edges in an ideal clock signal determined by the clock recovery 
feature (see "Setting Up Clock Recovery" on page 104). You can measure rising, 
falling, or both rising and falling edges.

Once the ideal clock frequency is determined, all of the cycles of your waveform 
are compared to the ideal clock frequency and the error statistics are computed. 
The following figure shows how the Clock TIE is measured on rising edges of the 
clock.

The measurement is made on all the cycles of the waveform. Even in Zoom mode, 
all the cycles of the waveform in the Main window will be measured.

N-Period

The N-Period jitter measurement measures the time span of N consecutive 
periods. Then, it shifts ahead one period and measures the time span of the next N 
consecutive periods, and so on.

Data TIE

Measured Data

Ideal Clock

t1 t2 t3

Clock TIE

Measured Clock

Ideal Clock

t2t1 t3 t4 t5 t6



246 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

17 Jitter Analysis
 

Period-Period

The Period-Period jitter measurement takes a group of cycles and measures the 
period from the first edge of the first cycle of the group to the final edge of the last 
cycle of the group. The N-period of the first group is measured and subtracted 
from the N-period of the second group. After shifting ahead one cycle the next 
measurement is made. The following figure shows how an N-cycle jitter 
measurement is made for N=3.

Once all of the groups of cycles of the waveform are measured, the statistics are 
calculated. The statistics are the values accumulated over all of the trigger cycles 
that have occurred.

To perform a cycle-cycle jitter measurement, use Period-Period and set N=1.

The measurement is made on all the cycles of the waveform. Even in Zoom mode, 
all the cycles of the waveform in the Main window will be measured.

+Width to +Width

The +Width to +Width jitter measurement subtracts the first cycle's positive pulse 
width from the second cycle's positive pulse width for the first measurement 
result. Then, the second cycle's positive pulse width is subtracted from the third 
cycle's positive pulse width for the second measurement result, and so on, until all 
of the cycles of the waveform have been measured. The following figure shows the 
first two +Width to +Width measurements.

N = 3

Period 1

Period 2

N = 3

Period 1

Period 3

Period 2

Period 4

1st Measurement = Period 2 - Period 1

2nd Measurement = Period 4 - Period 3
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All of the measurement results are used to compute the statistics. The statistics 
are the values accumulated over all of the trigger cycles that have occurred.

The measurement is made on all the cycles of the waveform. Even in Zoom mode, 
all the cycles of the waveform in the Main window will be measured.

-Width to -Width

The -Width to -Width jitter measurement subtracts the first cycle's negative pulse 
width from the second cycle's negative pulse width for the first measurement 
result. Then, the second cycle's negative pulse width is subtracted from the third 
cycle's negative pulse width for the second measurement result, and so on, until 
all of the cycles of the waveform have been measured. The following figure shows 
the first two -Width to -Width measurements.

All of the measurement results are used to compute the statistics. The statistics 
are the values accumulated over all of the trigger cycles that have occurred.

The measurement is made on all the cycles of the waveform. Even in Zoom mode, 
all the cycles of the waveform in the Main window will be measured.

+Width1 +Width2
1st Measurement = +Width2 - +Width1

+Width2 +Width3
2nd Measurement = +Width3 - +Width2

-Width1 -Width2
1st Measurement = -Width2 - -Width1

-Width2 -Width3
2nd Measurement = -Width3 - -Width2
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To create a mask from a "golden" waveform (Automask) / 249
Mask Test Setup Options / 251
Mask Statistics / 253
To manually modify a mask file / 254
Building a Mask File / 257

One way to verify a waveform's compliance to a particular set of parameters is to 
use mask testing. A mask defines a region of the oscilloscope's display in which 
the waveform must remain in order to comply with chosen parameters. 
Compliance to the mask is verified point-by-point across the display. Mask test 
operates on displayed analog channels; it does not operate on channels that are 
not displayed.

Mask test is included as a standard feature.

To create a mask from a "golden" waveform (Automask)

A golden waveform meets all chosen parameters, and it is the waveform to which 
all others will be compared.

1 Configure the oscilloscope to display the golden waveform.

2 From the main menu (see page 40), choose Analyze > Mask Test....

3 In the Mask Test dialog box, select On to enable mask testing.
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(The Persistence controls are the same as in Persistence tab of the Display dialog 
box. See "To set or clear persistence" on page 138.)

4 Select Automask....

5 In the Automask dialog box, from the Source drop-down list, select the analog 
channel to test.

6 Adjust the mask's horizontal tolerance (± Y) and vertical tolerance (± X). These 
are adjustable in graticule divisions or in absolute units (volts or seconds), 
selectable using the Units option.

7 Select Create Mask.

The mask is created and testing begins.

Whenever Create Mask is selected, the old mask is erased and a new mask is 
created.
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8 To clear the mask and switch off mask testing, in the Mask Test results window, 

select the  Edit (pencil) icon button to open the Mask Test dialog box. Then 
select Clear Mask.

If infinite persistence display mode (see "To set or clear persistence" on page 138) 
is "on" when mask test is enabled, it stays on. If infinite persistence is "off" when 
mask test is enabled, it is switched on when mask test is switched on, then infinite 
persistence is switched off when mask test is switched off.

Troubleshooting
Mask Setup

If you select Create Mask and the mask appears to cover the entire screen, check 
the ± Y and ± X settings in the Automask dialog box. If these are set to zero the 
resulting mask will be extremely tight around the waveform.

If you select Create Mask and it appears that no mask was created, check the ± Y 
and ± X settings. They may be set so large that the mask is not visible.

Mask Test Setup Options

In the Setup area of the Mask Test dialog box, you can select these options:
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Run Until The Run Until drop-down list lets you specify a condition on which to terminate 
testing.

• Forever — The oscilloscope runs continuously. However, if an error occurs, 
the On Error action(s) will occur.

• Minimum # of Tests — Choose this option and then use the # of Tests field to 
enter the number of times the oscilloscope will trigger, display the 
waveform(s), and compare them to the mask. The oscilloscope will stop after 
the specified number of tests have been completed. The specified minimum 
number of tests may be exceeded. If an error occurs, the On Error action(s) 
will occur. The actual number of tests completed is displayed in the Mask 
Test results window.

• Minimum Time — Choose this option and then use the Test Time field to 
enter how long the oscilloscope will run. When the selected time has passed 
the oscilloscope will stop. The specified time may be exceeded. If an error 
occurs, the On Error action(s) will occur. The actual test time is displayed in 
the Mask Test results window.

• Minimum Sigma — Choose this option and then use the Sigma field to enter a 
minimum sigma. The mask test runs until enough waveforms are tested to 
achieve a minimum test sigma. (If an error occurs, the On Error action(s) will 
occur.)

Note that this is a test sigma (the max achievable process sigma, assuming 
no defects, for a certain number of tested waveforms) as opposed to a 
process sigma (which is tied to the amount of failures per test). The sigma 
value may exceed the selected value when a small sigma value is chosen. 
The actual sigma is displayed.

On Error The On Error options specify the action(s) to take when the input waveform does 
not conform to the mask. This setting supersedes the Run Until setting.

• Stop — The oscilloscope will stop when the first error is detected (on the first 
waveform that does not conform to the mask). This setting supersedes the 
Minimum # of Tests and Minimum Time settings.

• Save — The oscilloscope saves the screen image when an error is detected. 
In the Save dialog box (choose File > Save...), select an image format (*.bmp 
or *.png), destination (on a USB storage device), and file name (which can be 
auto-incrementing). If errors occur too frequently and the oscilloscope 
spends all its time saving images, press the [Stop] key to stop acquisitions.

• Meas — Measurements and measurement statistics run only on waveforms 
that contain a mask violation. Measurements are not affected by passing 
waveforms. This mode is not available when the acquisition mode is set to 
Averaging.

All actions may be selected at the same time. For example, you can select both 
Stop and Meas to cause the oscilloscope to measure and stop on the first error..

You can also output a signal on the rear panel AUX OUT BNC connector when 
there is a mask test failure. See "Setting the Rear Panel AUX OUT Source" 
on page 312.
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Mask Statistics

Statistics are shown in the Mask Test results window.

The following information is displayed:

• Current mask, name of mask, Channel number, date and time.

• Status (Passing, Failing, or Untested).

• Accumulated test time (in hours, minutes, seconds, and tenths of seconds).

Source Lock When you turn on Source Lock, the mask is redrawn to match the source 
whenever you move the waveform. For example, if you change the horizontal 
timebase or the vertical gain, the mask is redrawn with the new settings.

When you turn off Source Lock, the mask is not redrawn when horizontal or 
vertical settings are changed.

Source If you change the Source channel, the mask is not erased. It is re-scaled to the 
vertical gain and offset settings of the channel to which it is assigned. To create 
a new mask for the selected source channel, select Automask..., and in the 
Automask dialog box, select Create Mask.

The Source drop-down list in the Mask Test dialog box is the same as the 
Source drop-down list in the Automask dialog box.

Test All When enabled, and waveforms are overlaid, all displayed analog channels are 
included in the mask test. When disabled, just the selected source channel is 
included in the test.
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• # of Tests (total number of mask tests executed).

And for each analog channel:

• The Source channel.

• Number of failures (acquisitions in which the signal excursion went beyond the 
mask).

• Failure rate (percentage of failures).

• Sigma (the ratio of process sigma to maximum achievable sigma, based on 
number of waveforms tested).

You can select Reset Statistics in the Mask Test dialog box. Note that statistics are 
also reset when:

• Mask Test is switched on after being switched off.

• Clear Mask is selected.

• Create Mask is selected in the Automask dialog box.

Additionally, the accumulated time counter continues whenever the oscilloscope 
is run after the acquisition was stopped.

To manually modify a mask file

You can manually modify a mask file that you created using the Automask 
function.

1 Follow the steps 1-7 in "To create a mask from a "golden" waveform 
(Automask)" on page 249. Do not clear the mask after creating it.

2 Attach a USB mass storage device to the oscilloscope.

3 From the main menu (see page 40), choose File > Save....

4 In the Save dialog box, from the Format drop-down list, select Mask (*.msk).

5 Enter a File Name, and select a destination folder on your USB mass storage 
device.

6 Select Save.

This creates an ASCII text file that describes the mask.

7 Remove the USB mass storage device and connect it to a PC.

8 Open the .msk file your created using a text editor (such as Notepad).

9 Edit, save, and close the file.

The mask file contains the following sections:

• Mask File Identifier.

• Mask Title.

• Mask Violation Regions.
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• Oscilloscope Setup Information.

Mask File Identifier The Mask File Identifier is MASK_FILE_548XX.

Mask Title The Mask Title is a string of ASCII characters. Example: autoMask CH1 OCT 03 
09:40:26 2008

When a mask file contains the keyword "autoMask" in the title, the edge of the 
mask is passing by definition. Otherwise, the edge of the mask is defined as a 
failure.

Mask Violation
Regions

Up to 8 regions can be defined for a mask. They can be numbered 1-8. They can 
appear in any order in the .msk file. The numbering of the regions must go from top 
to bottom, left to right.

An Automask file contains two special regions: the region "glued" to the top of the 
display, and the region that is "glued" to the bottom. The top region is indicated by 
y-values of "MAX" for the first and last points. The bottom region is indicated by 
y-values of "MIN" for the first and last points.

The top region must be the lowest numbered region in the file. The bottom region 
must be the highest numbered region in the file.

Region number 1 is the top mask region. The vertices in Region 1 describe points 
along a line; that line is the bottom edge of the top portion of the mask.

 

Region 1

Region 2
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Similarly, the vertices in Region 2 describe the line that forms the top of the 
bottom part of the mask.

The vertices in a mask file are normalized. There are four parameters that define 
how values are normalized:

• X1

• ΔX

• Y1

• Y2

These four parameters are defined in the Oscilloscope Setup portion of the mask 
file.

The Y-values (normally voltage) are normalized in the file using the following 
equation:

Ynorm = (Y - Y1)/ΔY

where ΔY = Y2 - Y1

To convert the normalized Y-values in the mask file to voltage:

Y = (Ynorm * ΔY) + Y1

where ΔY = Y2 - Y1

The X-values (normally time) are normalized in the file using the following 
equation:

Xnorm = (X - X1)/ΔX

To convert the normalized X-values to time:

X = (Xnorm * ΔX) + X1

Oscilloscope
Setup Information

The keywords "setup" and "end_setup" (appearing alone on a line) define the 
beginning and end of the oscilloscope setup region of the mask file. The 
oscilloscope setup information contains remote programming language 
commands that the oscilloscope executes when the mask file is loaded.

Any legal remote programming command can be entered in this section.

The mask scaling controls how the normalized vectors are interpreted. This in turn 
controls how the mask is drawn on the display. The remote programming 
commands that control mask scaling are:

:MTES:SCAL:BIND 0
:MTES:SCAL:X1 -400.000E-06
:MTES:SCAL:XDEL +800.000E-06
:MTES:SCAL:Y1 +359.000E-03
:MTES:SCAL:Y2 +2.35900E+00
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Building a Mask File

The following display shows a mask that uses all eight regions.

This mask is created by recalling the following mask file:

MASK_FILE_548XX

"All Regions"

/* Region Number */ 1
/* Number of vertices */ 4
-12.50, MAX
-10.00, 1.750
10.00, 1.750
12.50, MAX

/* Region Number */ 2
/* Number of vertices */ 5
-10.00, 1.000
-12.50, 0.500
-15.00, 0.500
-15.00, 1.500
-12.50, 1.500

/* Region Number */ 3
/* Number of vertices */ 6
-05.00, 1.000
-02.50, 0.500

1

8

2 3 4

5 6 7
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02.50, 0.500
05.00, 1.000
02.50, 1.500
-02.50, 1.500

/* Region Number */ 4
/* Number of vertices */ 5
10.00, 1.000
12.50, 0.500
15.00, 0.500
15.00, 1.500
12.50, 1.500

/* Region Number */ 5
/* Number of vertices */ 5
-10.00, -1.000
-12.50, -0.500
-15.00, -0.500
-15.00, -1.500
-12.50, -1.500

/* Region Number */ 6
/* Number of vertices */ 6
-05.00, -1.000
-02.50, -0.500
02.50, -0.500
05.00, -1.000
02.50, -1.500
-02.50, -1.500

/* Region Number */ 7
/* Number of vertices */ 5
10.00, -1.000
12.50, -0.500
15.00, -0.500
15.00, -1.500
12.50, -1.500

/* Region Number */ 8
/* Number of vertices */ 4
-12.50, MIN
-10.00, -1.750
10.00, -1.750
12.50, MIN

setup
:CHANnel1:RANGe +8.00E+00
:CHANnel1:OFFSet +2.0E+00
:CHANnel1:DISPlay 1
:TIMebase:MODE MAIN
:TIMebase:REFerence CENTer
:TIMebase:RANGe +50.00E-09
:TIMebase:POSition +10.0E-09
:MTESt:SOURce CHANnel1
:MTESt:ENABle 1
:MTESt:LOCK 1
:MTESt:SCALe:X1 +10.0E-09
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:MTESt:SCALe:XDELta +1.0000E-09
:MTESt:SCALe:Y1 +2.0E+00
:MTESt:SCALe:Y2 +4.00000E+00
end_setup

In a mask file, all region definitions need to be separated by a blank line.

Mask regions are defined by a number of (x,y) coordinate vertices (as on an 
ordinary x,y graph). A "y" value of "MAX" specifies the top of the graticule, and a 
"y" value of "MIN" specifies the bottom of the graticule.

The mask x,y graph is related to the oscilloscope graticule using the :MTESt:SCALe 
setup commands.

The oscilloscope's graticule has a time reference location (at the left, center, or 
right of the screen) and a trigger (t=0) position/delay value relative to the 
reference. The graticule also has a vertical ground 0 V reference (offset relative to 
the center of the screen) location.

The X1 and Y1 setup commands relate the mask region's x,y graph origin to the 
oscilloscope graticule's t=0 and V=0 reference locations, and the XDELta and Y2 
setup commands specify the size of the graph's x and y units.

• The X1 setup command specifies the time location of the x,y graph's x origin.

• The Y1 setup command specifies the vertical location of the x,y graph's y origin.

• The XDELta setup command specifies the amount of time associated with each 
x unit.

• The Y2 setup command is the vertical location of the x,y graph's y=1 value (so 
in effect, Y2 – Y1 is the YDELta value).

For example:

• With a graticule whose trigger position is 10 ns (before a center screen 
reference) and whose ground reference (offset) is 2 V below the center of the 
screen, to place the mask region's x,y graph's origin at center screen, you would 
set X1 = 10 ns and Y1 = 2 V.

• If the XDELta parameter is set to 5 ns and Y2 is set to 4 V, a mask region whose 
vertices are (-1, 1), (1, 1), (1, -1), and (-1, -1) goes from 5 ns to 15 ns and from 
0 V to 4 V.

• If you move the mask region's x,y graph origin to the t=0 and V=0 location by 
setting X1 = 0 and Y1 = 0, the same vertices define a region that goes from 
-5 ns to 5 ns and from -2 V to 2 V.

NOTE If there are more than 1000 vertices in a mask region, only the first 1000 vertices will be 
processed.
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Mask Region Limit Per Pixel Column

In a mask:

• A maximum of eight regions can be defined.

• However, any given pixel column can intersect a maximum of four different 
regions.

• If there are four regions in a pixel column, one of the regions must include the 
top pixel (the MAX y value) and another region must include the bottom pixel 
(the MIN y value).

Here is an example of a valid eight-region mask:

Note that there is no pixel column that intersects more than four of the regions. 
Any column that has four regions includes the regions that are tied to the top and 
bottom, respectively.

How is mask testing done?

InfiniiVision oscilloscopes start mask testing by creating a database that is 200 x 
640 for the waveform viewing area. Each location in the array is designated as 
either a violation or a pass area. Each time a data point from a waveform occurs in 
a violation area a failure is logged. If Test All was selected, every active analog 
channel is tested against the mask database for each acquisition. Over 2 billion 
failures can be logged per-channel. The number of acquisitions tested is also 
logged and displayed as "# of Tests".

This pixel column intersects four regions
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The mask file allows greater resolution than the 200 X 640 database. Some 
quantization of data occurs to reduce the mask file data for display on-screen.



262 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

18 Mask Testing
 



263

 

Keysight InfiniiVision HD3-Series Oscilloscopes 
User's Guide

19 Digital Voltmeter and 
Counters

Digital Voltmeter / 263
Counters / 265

The Digital Voltmeter (DVM) and Counter analysis features are standard on the 
HD3-Series oscilloscopes.

Digital Voltmeter

The digital voltmeter (DVM) analysis feature provides 3-digit voltage 
measurements on any analog channel. DVM measurements are asynchronous from 
the oscilloscope's acquisition system and are always acquiring.
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The DVM display is a seven-segment readout like you would see on a digital 
voltmeter. It shows the selected mode as well as the units. Units are specified in 
the channel's Probe dialog box.

The DVM display also has a scale that is determined by the channel's vertical scale 
and reference level. The scale's blue triangle pointer shows the most recent 
measurement. The bar above that shows the measurement extrema over the last 3 
seconds.

The DVM makes accurate RMS measurements when the signal frequency is 
between 20 Hz and 100 kHz. When the signal frequency is outside this range, 
"<BW Limit?" or ">BW Limit?" appears in the DVM display to caution you about 
inaccurate RMS measurement results.

To use the digital voltmeter:

1 From the main menu (see page 40), choose Measure > Digital Voltmeter (DVM)....

2 In the DVM dialog box, select On to enable or disable the digital voltmeter.

3 From the Source drop-down list, select the analog channel on which digital 
voltmeter (DVM) measurements are made.

The selected channel does not have to be on (displaying a waveform) in order 
for DVM measurements to be made.

4 From the Mode drop-down list, select:

• AC RMS — Displays the root-mean-square value of the acquired data, with 
the DC component removed.

• DC — Displays the DC value of the acquired data.

• DC RMS — Displays the root-mean-square value of the acquired data.

5 If the selected source channel is not used in oscilloscope triggering, select Auto 
Range to disable or enable automatic adjustment of the DVM channel's vertical 
scale, vertical (ground level) position, and trigger (threshold voltage) level (used 
for the counter frequency measurement).

When enabled, Auto Range overrides attempted adjustments of the channel's 
vertical scale and position knobs.

When disabled, you can use the channel's vertical scale and position knobs 
normally.
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Counters

The counter analysis feature provides up to four frequency, period, or edge event 
(totalize) counter measurements on any analog or digital input channel, and there 
is a fifth counter for triggers.

There are two basic types of frequency counters:

• Direct counting frequency counters — These simply count cycles (trigger level 
crossings) of a signal over a known period called the gate time and display the 
results. With a given gate time, the number of digits of resolution depends on 
the frequency of the input (a higher number of crossings within the gate time 
gives better resolution). A direct counter's resolution is specified in Hertz.

• Reciprocal counting frequency counters — These measure the input signal's 
period and then reciprocate it to get frequency. The counter's resolution is 
specified in digits-per-second, so the frequency of the input does not affect the 
resolution, rather an increased gate time gives better resolution. With a given 
gate time, a reciprocal frequency counter will always have same number of 
digits of resolution.

The HD3-Series oscilloscopes have reciprocal counting frequency counters.

For frequency and period counter measurements:

• The gate time is specified indirectly by the selected number of digits of 
resolution, from 3 to 12. For higher resolutions, the gate time is greater.

• Up to 1 GHz (1.2 GHz typical) frequencies can be measured.

• When the oscilloscope polls counter data at the maximum gate time interval of 
10 seconds and waits up to 10 intervals for enough data to measure (that is, 
three edges guaranteed within 100 seconds, which means a signal period of 
66.66… seconds), the minimum frequency that can be reliably measured is 
15 mHz. If there is not enough data to measure at each gate time interval, "---" 
is displayed.

For totalize measurements:

• A running count of edges is kept. You can choose whether to count positive or 
negative edges.

• Edge events with up to 1 GHz (1.2 GHz typical) frequencies can be counted.

The counter is asynchronous from the oscilloscope's acquisition system and is 
always acquiring.

To use a counter:

1 From the main menu (see page 40), choose Measure > Counters....

2 The Counters dialog box has tabs for the available counters, A, B, C, D, and T. 
Select the tab for the counter you want to use.
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With the T counter and the Trigger Qualified Event source, you can see how often 
trigger events are detected. This can be more often than when triggers actually 
occur, due to the oscilloscope's acquisition time or update rate capabilities. 
(The AUX OUT signal can show when triggers actually occur.) Remember that 
the oscilloscope's trigger circuitry does not re-arm until the holdoff time occurs 
and that the minimum holdoff time is 40 ns; therefore, the maximum trigger 
qualified event frequency that can be counted is 25 MHz.

3 Select On to enable or disable the counter.

4 From the Measure drop-down list, select what the counter measures:

• Frequency — Measures the cycles per second (Hz, kHz, or MHz) of the signal.

• Period — Measures the time periods of the signal's cycles.

• Totalize — Measures the count of edge events on the signal.

When Totalize is selected:

• The Event Slope drop-down list, selects whether  Rising or  Falling edge 
events are counted.

• The Clear Count button lets you restart the counter.

5 From the Source drop-down list, select the analog or digital input channel on 
which to make counter measurements.

The selected channel does not have to be on (displaying a waveform) in order 
for counter measurements to be made.

6 Select the # of Digits field, and enter the maximum resolution of the counter. You 
can choose from 3 to 12 digit maximum resolutions.

The full number of digits may not be displayed when counter analysis begins. 
However, as more measurements are made to improve the precision of the 
results, more digits are displayed. This is called Auto Precision.

7 The Threshold field shows the threshold voltage (trigger) level for the selected 
source. To adjust a trigger level, select Trigger Levels....

Counter analysis results can look something like:
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The  button appears when the variance of a counter measurement is high. 
Selecting the button displays a full message.

A display of "---" means there is no valid data.
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Statisticians say values more than three standard deviations away from the mean 
are outliers. With digital signals, outliers can indicate errors, faults, or anomalies. 
Oscilloscope measurements already include mean and standard deviation 
statistics. Given a statistically significant number of samples (acquisitions), limits 
can be determined from the mean and standard deviation values. With the 
determined limits, tests to find anomalies can be automatically set up. These tests 
use the available triggers.

This is what Fault Hunter does:

1 Adds some key measurements.

2 Runs the oscilloscope long enough to get thousands of measurements.

3 Uses the mean and standard deviation statistics to set up tests (using trigger 
modes).

4 Let you run the tests to find anomalies.

Fault Hunter saves you time by automatically determining limits and by 
automatically setting up tests.

To set up and run Fault Hunter:

1 First, make sure the digital signal is being captured appropriately:

• Make sure there is a stable edge trigger for the waveform.

• Make sure that more than four pulses of the waveform are being captured.

If these conditions are not true, you will get errors during the Fault Hunter 
automatic set up.

2 From the main menu (see page 40), choose Analyze > Fault Hunter....

3 In the Fault Hunter dialog box, for the purposes of this description, de-select 
the Run All After Auto Setup check box.
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4 Select Auto Setup.

This will add a set of measurements on the signal that are used to determine 
the measurement limits. For more about this process, see "More About Fault 
Hunter Auto Setup" on page 272.

When Fault Hunter is done setting up the measurement limits, you will see limit 
values populated in the test table.

If the signal under test changes, select Auto Setup again to re-calculate the 
measurement limits.

Note that you can manually adjust the determined limits.

NOTE Auto Setup is the most important step in using Fault Hunter.
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5 Select the Duration, that is, whether you want to run the tests for a few minutes, 
an hour, eight hours, or two days.

6 Select Run All Tests.

When the run is completed, you will see "Passed" or "Failed" test results.

The Result column shows "Failed" when that type of anomaly was found or 
"Passed" when that type of anomaly was not found.

The Result column shows "Not Run Yet" if the test cannot be run for some 
reason. For example, if the range of the pulse is less than what can be detected 
by the triggering hardware, "Not Run Yet" will appear.

7 To copy the trigger that found an anomaly, select the associated Copy to Trigger 
button.

After the trigger is copied, you can select the T (trigger) badge to view the 
Trigger dialog box, and you can select Run to acquire waveforms using this 
trigger.
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8 You can always adjust the limits for an individual test in the Fault Hunter dialog 
box and select the test's Run button to re-run the test.

Errors that cannot
be detected

Fault Hunter cannot detect these types of errors:

• Errors that are so common they happen almost as often as good waveforms.

• Errors that do not match up well with existing trigger modes, such as 
non-monotonic edges.

• Errors that are so rare they do not occur during the duration of the test runs.

More About Fault Hunter Auto Setup

The Fault Hunter Auto Setup process consists of these stages:

• Adding Measurements

• Getting Top and Base Measurements

• Getting Measurement Values

Adding
Measurements

For the digital signal source that Fault Hunter is operating on, these 
measurements are added:

• + width

• - width

• Rise time

• Fall time

• Pulse amplitude
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• Pulse base

• Pulse top

• Data rate

Getting Top and
Base

Measurements

First, acquisitions are collected long enough to get a significant number of top and 
base measurements. The top and base measurements are used to set 
measurement thresholds for the other measurements.

Getting
Measurement

Values

Once measurement thresholds are determined, additional acquisitions are made to 
get a significant number of values for the other added measurements. The means 
and standard deviations of these measurements are used to determine the 
acceptable ranges for the Fault Hunter tests:

Fault Hunter Test Acceptable Range Determination

Positive Glitch Positive pulses whose width is less than half the data rate's period are 
identified as positive glitches.

Negative Glitch Negative pulses whose width is less than half the data rate's period are 
identified as negative glitches.

Slow Rising Edge Rising edges that are 3 standard deviations longer than the mean are 
identified as slow edges.

Slow Falling Edge Falling edges that are 3 standard deviations longer than the mean are 
identified as slow edges.

Positive Runt 
(Triggering method 
only)

The high runt threshold is set at the top value minus 20% of the pulse 
amplitude. Positive pulses lower than the high threshold are identified as 
positive runts.

Negative Runt 
(Triggering method 
only)

The low runt threshold is set at the base value plus 20% of the pulse 
amplitude. Negative pulses higher than the low threshold are identified as 
negative runts.
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To make connections / 275
To set up and run the analysis / 276
To view and save the analysis results / 277

The Frequency Response Analysis (FRA) feature controls the built-in waveform 
generator to sweep a sine wave across a range of frequencies while measuring the 
input to and output from a device under test (DUT). At each frequency, gain (A) 
and phase are measured and plotted on a frequency response Bode chart.

When the frequency response analysis completes, you can move a marker across 
the chart to see the measured gain and phase values at each frequency point. You 
can also adjust the chart's scale and offset settings for the gain and phase plots.

To make connections

The waveform generator output is connected to a device under test (DUT). The 
input to the device and the output from the device are probed by the oscilloscope's 
input channels.
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To set up and run the analysis

1 From the main menu (see page 40), choose Analyze > Frequency Response....

2 In the Frequency Response dialog box, select Enable.

3 In the Setup tab:

There are settings for:

• The Frequency Mode. Normally, you Sweep through a range of frequencies, 
making measurements. However, when debugging, you can select Single to 
make measurements at a single frequency.

DUT
(Transfer Function)

Input Output

Wave
Gen

1 2 3 4

Oscilloscope
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• The start and stop frequencies in the sweep, as well as the total number of 
points.

• The channels probing the input and output.

• The waveform generator amplitude and expected output load impedance.

To specify different amplitudes for different decades, select Amplitude Profile.

The output impedance of the Gen Out signal is fixed at 50 ohms. However, 
the output load selection lets the waveform generator display the correct 
amplitude and offset levels for the expected output load. If the actual load 
impedance is different than the selected value, the displayed amplitude and 
offset levels will be incorrect.

4 To run the frequency response analysis, click the Run Analysis.

Gain and Phase measurements are plotted and added to a results table as the 
frequency sweeps from the start frequency to the stop frequency.

To view and save the analysis results

When the frequency response analysis completes, Gain and Phase measurement 
results versus frequency are plotted in a Bode plot, log-scaled frequency grid and 
listed in a Results area table.

In the Frequency Response dialog box's Waveforms tab, there are controls for:

• Enabling or disabling the gain or phase plot and table results.
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• Adjusting the chart's horizontal frequency scale (Start Freq and Stop Freq). The 
Adj Mode drop-down selections let you make normal, fine, or decade (coarse) 
adjustments to the chart's starting and ending frequencies.

• Adjusting the gain plot's vertical scale and offset.

• Adjusting the phase plot's vertical scale and offset.

• Adjusting the scroll markers in the plot to see the values measured at particular 
locations.

The Results area table shows: the data point number, the frequency, the waveform 
generator output amplitude, the measured gain, and the measured phase. You can 
scroll the data.

To save the frequency response analysis results:

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select Frequency 
Response Analysis data (*.csv).

3 Select the File Name field, and enter the name of the file you want to save.

4 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

5 Select Save.

To email the frequency response analysis results, see "Emailing Setups, Screen 
Images, or Data" on page 297. At the point where you choose the Format of 
information to be emailed, select Frequency Response Analysis data (*.csv).
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To select generated waveform types and settings / 279
To specify the output settings / 283
To edit arbitrary waveforms / 284
To add modulation to the waveform generator output / 287

A waveform generator is built into the oscilloscope. It is enabled by the 
HD3WAVEGEN upgrade license. The waveform generator gives you an easy way to 
provide input signals when testing circuitry with the oscilloscope.

Waveform generator settings can be saved and recalled with oscilloscope setups. 
See Chapter 23, “Save/Email/Recall (Setups, Screens, Data),” starting on page 
291.

To select generated waveform types and settings

1 To access the Waveform Generator Menu and enable or disable the waveform 
generator output on the back panel Gen Out BNC, press the [Wave Gen] key.

Or, you can:

a From the menu, choose Sources > Waveform Generator....

b In the Waveform Generator dialog box, select On.

When waveform generator output is enabled, the [Wave Gen] key is illuminated. 
When waveform generator output is disabled, the [Wave Gen] key is off.

The waveform generator output is always disabled when the instrument is first 
turned on.

The waveform generator output is automatically disabled if excessive voltage is 
applied to the Gen Out BNC.

2 In the Waveform Generator dialog box, from the Waveform drop-down list, 
select the waveform type.
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Waveform 
Type

Characteristics Frequency 
Range1

Max. 
Amplitude 
(High-Z)2

Offset Range (High-Z)2

Arbitrary Use the Frequency/Period, 
Amplitude/High-Level, and 
Offset/Low-Level fields to set the arbitrary 
waveform signal parameters.

Select Edit Waveform... to define the 
arbitrary waveform shape. See "To edit 
arbitrary waveforms" on page 284.

300 mHz to 
5 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)

Sine Use the Frequency/Period, 
Amplitude/High-Level, and 
Offset/Low-Level fields to set the sine signal 
parameters.

10 mHz to 
100 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)

Square Use the Frequency/Period, 
Amplitude/High-Level, Offset/Low-Level, 
and Duty Cycle fields to set the square wave 
signal parameters.

The duty cycle can be adjusted from 0.5% to 
99.5% depending on the square wave 
frequency. The resolution of the percentages 
that can be selected is finer at lower 
frequencies and coarser at higher 
frequencies.

10 mHz to 
50 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)
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Ramp Use the Frequency/Period, 
Amplitude/High-Level, Offset/Low-Level, 
and Symmetry fields to set the ramp signal 
parameters.

Symmetry represents the amount of time per 
cycle that the ramp waveform is rising and 
can be adjusted from 0% to 100%.

300 mHz to 
5 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)

Pulse Use the Frequency/Period, 
Amplitude/High-Level, Offset/Low-Level, 
and Width/Width Fine fields to set the pulse 
signal parameters.

The minimum pulse width is 10 ns at all 
frequencies. The pulse width can be 
adjusted in 5 ns increments from the 
minimum to the period minus the minimum.

10 mHz to 
50 MHz.

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)

DC Use the Offset field to set the DC level.

Use the DC Mode drop-down list to select 
Precise levels (with a ±1.00 V range) or Wide 
range (of ±8.00 V).

n/a n/a ±8.00 V or ±1.00 V, 
depending on the DC Mode 
selection

Noise Use the Amplitude/High-Level and 
Offset/Low-Level to set the noise signal 
parameters.

n/a 2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)

Sine 
Cardinal

Use the Frequency/Period, Amplitude, and 
Offset fields to set the sinc signal 
parameters.

300 mHz to 
1 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(400 mV - 0.25 * 
amplitude)

When amplitude ≥50 mV: 
±(4 V - 0.25 * amplitude)

Exponential 
Rise

Use the Frequency/Period, 
Amplitude/High-Level, and 
Offset/Low-Level fields to set the 
exponential rise signal parameters.

300 mHz to 
5 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)

Exponential 
Fall

Use the Frequency/Period, 
Amplitude/High-Level, and 
Offset/Low-Level fields to set the 
exponential fall signal parameters.

300 mHz to 
5 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(800 mV - 0.5 * amplitude)

When amplitude ≥50 mV: 
±(8 V - 0.5 * amplitude)

Waveform 
Type

Characteristics Frequency 
Range1

Max. 
Amplitude 
(High-Z)2

Offset Range (High-Z)2
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3 Depending on the selected waveform type, use the remaining controls in the 
Waveform Generator dialog box to set the waveform's characteristics.

• X Input — Select between entering the Frequency or Period of the output 
waveform. Use the Frequency or Period field to enter the value.

• Y Input — Select between entering Amplitude/Offset or High/Low values to 
specify the output waveform's voltage swing. Use the Amplitude and Offset or 
Low-Level and high-Level fields to enter the values.

• Logic Presets — Sets the output voltage to TTL, CMOS (5.0V), CMOS (3.3V), 
CMOS (2.5V), or ECL compatible Low and High levels.

• Add Noise — Specifies the amount of white noise to add to the waveform 
generator output.

Cardiac Use the Frequency/Period, Amplitude, and 
Offset fields to set the cardiac signal 
parameters.

300 mHz to 
2.5 MHz

2 mVpp to 
10 Vpp

When amplitude <50 mV: 
±(400 mV - 0.25 * 
amplitude)

When amplitude ≥50 mV: 
±(4 V - 0.25 * amplitude)

Gaussian 
Pulse

Use the Frequency/Period, Amplitude, and 
Offset fields to set the Gaussian pulse signal 
parameters.

300 mHz to 
5 MHz

2 mVpp to 
8 Vpp

When amplitude <50 mV: 
±(400 mV - 0.25 * 
amplitude)

When amplitude ≥50 mV: 
±(4 V - 0.25 * amplitude)

1When burst output mode is selected, the maximum frequency is limited to 5 MHz.

2When the output load is 50 Ω, these values are halved.

Waveform 
Type

Characteristics Frequency 
Range1

Max. 
Amplitude 
(High-Z)2

Offset Range (High-Z)2

Logic Preset Low level High level

TTL 0 V +5 V (or a TTL-compatible 
high level if +5 V cannot 
be reached)

CMOS (5.0V) 0 V +5 V

CMOS (3.3V) 0 V +3.3 V

CMOS (2.5V) 0 V +2.5 V

ECL -1.7 V -0.9 V
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Note that adding noise affects edge triggering on the waveform generator 
source (see "Edge Trigger" on page 151) as well as the waveform generator 
sync pulse output signal (which can be sent to AUX OUT, see "Setting the 
Rear Panel AUX OUT Source" on page 312). This is because the trigger 
comparator is located after the noise source.

• Output Settings... — Opens the Output Settings dialog box where you can 
specify the expected output load, invert the output, and output the 
waveform generator sync pulse. See "To specify the output settings" on 
page 283.

• Edit Waveform... — Opens the "To edit arbitrary waveforms" on page 284 
where you can edit arbitrary waveforms.

• Modulation... — Opens the Modulation dialog box where you can add 
modulation to the waveform generator output. See "To add modulation to 
the waveform generator output" on page 287.

• Default Wave Gen — Returns the waveform generator to its default settings.

The waveform generator factory default settings (1 kHz sine wave, 
500 mVpp, 0 V offset, High-Z output load) are restored.

See: • "To specify the output settings" on page 283

• "To edit arbitrary waveforms" on page 284

• "To add modulation to the waveform generator output" on page 287

To specify the output settings

In the Waveform Generator dialog box, click Output Settings... to open the Output 
Settings dialog box.

The Output Settings dialog box has these controls:

• Output Load — The expected output load can be 50 Ω or High-Z.

The output impedance of the Gen Out BNC is fixed at 50 ohms. However, the 
output load selection lets the waveform generator display the correct 
amplitude and offset levels for the expected output load.

If the actual load impedance is different than the selected value, the displayed 
amplitude and offset levels will be incorrect.

• Invert Output — Lets you enable or disable an inverted output.
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Note that when inverted output is enabled, the waveform's offset is not 
inverted.

• Output Mode — Specifies how often the defined waveform is output:

• Normal — Repetitively outputs the defined waveform.

• Burst — Outputs the Burst Count number of cycles of the defined waveform 
when Transmit Burst is selected.

Selecting Transmit Burst multiple times will interrupt a slow signal output 
before its cycle is completed.

When burst output mode is selected, the maximum frequency is limited to 
5 MHz.

Note that the transmit burst action can also be mapped to the Quick Action 
menu item (see "Configuring the (Quick Action) Menu Item" on page 322).

• Aux Out — Specifies the signal that is output on the oscilloscope's rear panel 
AUX OUT BNC connector:

• Triggers — Each time the oscilloscope triggers, a pulse occurs on AUX OUT. 
The pulse is delayed 1.06 μs from the oscilloscope's trigger point. The 
output level is 0-5 V into an open circuit, and 0-2.5 V into 50 Ω.

• Mask — The pass/fail status is evaluated periodically. When the evaluation of 
the testing period results in a failure, the trigger output pulses high (+5 V). 
Otherwise, the trigger output remains at low (0 V).

• Waveform Generator Sync Pulse — All of the waveform generator output 
functions (except DC, Noise, and Cardiac) have an associated Sync signal:

To edit arbitrary waveforms

When Arbitrary is selected as the generated waveform type (see "To select 
generated waveform types and settings" on page 279), select Edit Waveform... to 
open the WaveGen: Arbitrary Waveform Editor dialog box.

This dialog box has two formats depending on whether there are currently defined 
arbitrary waveform points.

When No Points
Exist

The WaveGen: Arbitrary Waveform Editor dialog box lets you set up an arbitrary 
waveform in one of these ways:

• Set initial number of points — When selected, to create a new arbitrary waveform:

Waveform Type Sync Signal Characteristics

All waveforms except 
DC, Noise, and Cardiac

The Sync signal is a TTL positive pulse that occurs when the waveform 
rises above zero volts (or the DC offset value).

DC, Noise, and Cardiac N/A
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a Enter the number of Initial Points.

The new waveform will be a square wave with the number of points you 
specify. The points are evenly spaced over the time period.

b Enter the Min Time Between Pts, that is, the minimum time between points.

The resolution is specified during arbitrary waveform creation only. To 
change the resolution of an arbitrary waveform, you must clear all arbitrary 
waveform points (with a Reset when editing points), and create the waveform 
again.

c When you are ready to create the new arbitrary waveform, select Apply & 
Edit....

The new waveform is created and the Arbitrary Waveform Editor dialog box 
is opened.

• Import waveforms from channel — When selected, to capture another waveform to 
the arbitrary waveform:

a From the Source drop-down list, select the analog channel, math, or 
reference location whose waveform you wish to capture.

b Select Copy Waveform....

The source waveform is decimated into 8192 (maximum) or fewer arbitrary 
waveform points.

NOTE If the source waveform frequency and/or voltage exceed the capabilities of the waveform 
generator, the arbitrary waveform will be limited to the capabilities of the waveform generator. 
For example, a 50 MHz waveform captured as the arbitrary waveform, becomes a 25 MHz 
waveform.
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• Import waveforms from file — When selected,

a Select Open... to open a file browser dialog box.

b Select the file to import.

c Select Open.

When Points Exist The WaveGen: Arbitrary Waveform Editor dialog box has these controls:

• Full arbitrary waveform grid — Shows the full arbitrary waveform.

The voltage and time period you see in the grid are the bounding parameters — 
they come from the frequency and amplitude settings in the main Waveform 
Generator dialog box.

If the lower, windowed points grid's X Scale is less than the full scale, a shaded 
area appears, highlighting the points that are displayed in the lower grid. You 
can drag the shaded area to show different arbitrary waveform points in the 
lower grid; this changes the windowed points grid's X Position.

• Windowed points grid — Shows a window of points in the arbitrary waveform.

Arbitrary waveform points appear as solid boxes that can be selected. When a 
point is selected, it is highlighted and has horizontal and vertical markers with 
handles that can be dragged to set the point's time and voltage value.

You can draw a box in this grid (and let up) to select a region, cut points, copy 
points, paste points, or zoom in (change the X Scale).

• X Scale — Changes the time/div in the lower, windowed points grid.
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• X Position — Sets the lower, windowed points grid's beginning (left side) time. 
The maximum X Position value is the full grid's width minus the width of the 
windowed points grid.

•  Insert, Cut, Copy, Paste, Undo — Arbitrary waveform points editing 
buttons.

• Interpolate — Specifies how lines are drawn between arbitrary waveform points.

When enabled, lines are drawn between points in the waveform editor. Voltage 
levels change linearly between one point and the next.

When disabled, all line segments in the waveform editor are horizontal. The 
voltage level of one point remains until the next point.

• Reset — Clears all the arbitrary waveform points.

• Selected Point X — Lets you enter an exact time value for a point.

• Selected Point Y — Lets you enter an exact voltage value for a point.

• Arbitrary waveform points table — Shows the X and Y values of the arbitrary 
waveform points.

Selecting rows in this table is another way of selecting arbitrary waveform 
points.

To add modulation to the waveform generator output

Modulation is where an original carrier signal is modified according to the 
amplitude of a second modulating signal. The modulation type (AM or FM) 
specifies how the carrier signal is modified.

To enable and set up modulation for the waveform generator output:

1 In the Waveform Generator dialog box, click Modulation... to open the 
Modulation dialog box.

2 In the Modulation dialog box:

• Select Modulation to enable or disable modulated waveform generator 
output.

NOTE You can save arbitrary waveforms to internal storage locations or to a USB storage device, and 
you can recall them later. See "To save arbitrary waveforms" on page 297 and "To recall 
arbitrary waveforms" on page 301.
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You can enable modulation for all waveform generator function types except 
arbitrary, square, pulse, DC, noise, and Gaussian pulse.

• From the Type drop-down list, select the modulation type:

• Amplitude Modulation (AM) — the amplitude of the original carrier signal is 
modified according to the amplitude of the modulating signal. See "To 
set up Amplitude Modulation (AM)" on page 288.

• Frequency Modulation (FM) — the frequency of the original carrier signal is 
modified according to the amplitude of the modulating signal. See "To 
set up Frequency Modulation (FM)" on page 289.

To set up Amplitude Modulation (AM)

In the Modulation dialog box when Amplitude Modulation (AM) is selected:

1 From the Waveform drop-down list, select the shape of the modulating signal:

• Sine

2 In the AM Freq field, enter the frequency of the modulating signal.

3 In the AM Depth field, enter the amount of amplitude modulation.

AM Depth refers to the portion of the amplitude range that will be used by the 
modulation. For example, a depth setting of 80% causes the output amplitude 
to vary from 10% to 90% (90% – 10% = 80%) of the original amplitude as the 
modulating signal goes from its minimum to maximum amplitude.

The following screen shows an AM modulation of a 100 kHz sine wave carrier 
signal.
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To set up Frequency Modulation (FM)

In the Modulation dialog box when Frequency Modulation (FM) is selected:

1 From the Waveform drop-down list, select the shape of the modulating signal:

• Sine

2 In the FM Freq field, enter the frequency of the modulating signal.

3 In the FM Dev field, enter the frequency deviation from the original carrier signal 
frequency.

When the modulating signal is at its maximum amplitude, the output frequency 
is the carrier signal frequency plus the deviation amount, and when the 
modulating signal is at its minimum amplitude, the output frequency is the 
carrier signal frequency minus the deviation amount.

The frequency deviation cannot be greater than the original carrier signal 
frequency.

Also, the sum of the original carrier signal frequency and the frequency 
deviation must be less than or equal to the maximum frequency for the selected 
waveform generator function plus 100 kHz.
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The following screen shows an FM modulation of a 100 kHz sine wave carrier 
signal.
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23 Save/Email/Recall (Setups, 
Screens, Data)

Saving Setups, Screen Images, or Data / 291
Emailing Setups, Screen Images, or Data / 297
Recalling Setups, Masks, or Data / 299
Recalling Default Setups / 301
Performing a Secure Erase / 302

Oscilloscope setups, reference waveforms, and mask files can be saved to internal 
oscilloscope memory or to a USB storage device and recalled later. You can also 
recall default or factory default setups.

Oscilloscope screen images can be saved to a USB storage device in BMP or PNG 
formats.

Acquired waveform data can be saved to a USB storage device in 
comma-separated value (CSV), ASCII XY, and binary (BIN) formats.

Any file that can be saved to a USB storage device can also be e-mailed over the 
network.

There is also a command to securely erase all the oscilloscope's non-volatile 
internal memory.

Saving Setups, Screen Images, or Data

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select the type of file 
you want to save:

• Setup (*.scp) — The oscilloscope's horizontal timebase, vertical sensitivity, 
trigger mode, trigger level, measurements, markers, and math function 
settings that tell the oscilloscope how to make a particular measurement. 
See "To save setup files" on page 293.
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• 24-bit Bitmap image (*.bmp) — The complete screen image in a 24-bit color 
bitmap format. See "To save BMP or PNG image files" on page 293.

• PNG 24-bit image (*.png) — The complete screen image in a 24-bit color PNG 
format that uses lossless compression. Files are much smaller than the BMP 
format. See "To save BMP or PNG image files" on page 293.

• CSV data (*.csv) — This creates a file of comma-separated values of all 
displayed channels and math waveforms. This format is suitable for 
spreadsheet analysis. See "To save CSV, ASCII XY, or BIN data files" on 
page 294.

• ASCII XY data (*.csv) — This creates separate files of comma-separated values 
for each displayed channel. This format is also suitable for spreadsheets. 
See "To save CSV, ASCII XY, or BIN data files" on page 294.

• Binary data (*.bin) — This creates a binary file, with a header, and data in the 
form of time and voltage pairs. This file is much smaller than the ASCII XY 
data file. See "To save CSV, ASCII XY, or BIN data files" on page 294.

• Reference Waveform data (*.h5) — Saves waveform data in a format that can be 
recalled to one of the oscilloscope's reference waveform locations. See "To 
save reference waveform files to a USB storage device" on page 296.

• Multi Channel Waveform data (*.h5) — Saves multiple channels of waveform 
data in a format that can be opened by the N8900A Infiniium Offline 
oscilloscope analysis software. You can recall the first Analog or Math 
channel from a multi channel waveform data file.

• Mask (*.msk) — This creates a mask file in a Keysight proprietary format that 
can be read by Keysight InfiniiVision oscilloscopes. A mask data file includes 
some oscilloscope setup information, but not all setup information. To save 
all setup information including the mask data file, choose "Setup (*.scp)" 
format instead. See "To save masks" on page 296.

• Arbitrary Waveform data (*.csv) — This creates a file of comma-separated 
values for the arbitrary waveform points' time and voltage values. See "To 
save arbitrary waveforms" on page 297.

• Analysis Results (*.csv) — A file of comma-separated values is saved for the 
analysis types selected using the Save from: drop-down menu.

• Current Harmonics data (*.csv), Power Supply Rejection Ration (PSRR) data (*.csv) , 
Control Loop Response (Bode) data (*.csv) — When the power analysis 
application is licensed, these options create a file of comma-separated 
values for the different types of analysis results. See the Power 
Measurement Application User's Guide for more information.

• Frequency Response Analysis data (*.csv) — This creates a file of 
comma-separated values for the Frequency Response Analysis results table 
values. In the saved file, there are three data columns: frequency (Hz), gain 
(dB), and phase (degrees). See "To view and save the analysis results" on 
page 277.

3 Select any options for the type of file you want to save.
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4 Select the File Name field, and enter the name of the file you want to save.

The Increment option enables or disables automatically incremented file names. 
Auto increment adds a numeric suffix to your file name and increments the 
number with each successive save. It will truncate characters as necessary 
when the file name length is at maximum and more digits are required for the 
numeric portion of the file name.

5 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

6 Select Save.

A message indicating whether the save was successful is displayed.

You can also configure the Setup > (Quick Action) menu item to save setups, screen 
images, or data. See "Configuring the (Quick Action) Menu Item" on page 322.

To save setup files

Setup files can be saved to internal hard drive (\User Files) locations or to an 
external USB storage device.

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select Setup (*.scp).

3 Select the File Name field, and enter the name of the file you want to save.

4 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

5 Select Save.

To save BMP or PNG image files

Image files can be saved to an external USB storage device.

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select one of:

• 24-bit Bitmap image (*.bmp)

• PNG 24-bit image (*.png)

3 With image files, you can select these options:

• Setup Info — Setup information (vertical, horizontal, trigger, acquisition, 
math, and display settings) is also saved in a separate file with a TXT 
extension.

4 Select the File Name field, and enter the name of the file you want to save.

5 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

6 Select Save.
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See Also • "To add an annotation" on page 143

To save CSV, ASCII XY, or BIN data files

Data files can be saved to an external USB storage device.

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select one of:

• CSV data (*.csv) — See "CSV Data" on page 295.

• ASCII XY data (*.csv) — See "ASCII XY Data" on page 295.

• Binary data (*.bin)

3 With data files files, you can select these options:

• Setup Info — Setup information (vertical, horizontal, trigger, acquisition, 
math, and display settings) is also saved in a separate file with a TXT 
extension.

• Max Length — Specifies that the maximum number of waveform data points 
be saved. See "Length Control" on page 295.

• Length — Sets the number of data points that will be output to the file. For 
more information, see "Length Control" on page 295.

• Save Segment — When data is acquired to segmented memory, you can 
specify whether the Current displayed segment is saved or All acquired 
segments are saved. (See also "Saving Data from Segmented Memory" on 
page 190.)

4 Select the File Name field, and enter the name of the file you want to save.

5 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

6 Select Save.

See Also • "Binary Data (.bin) Format" on page 341

• "CSV and ASCII XY files" on page 347

• "Minimum and Maximum Values in CSV Files" on page 348

NOTE When saving screen images, the oscilloscope uses the screen before the Save dialog box was 
opened.

To save a screen image showing the Save dialog box, press the [Save Screen] instead.

NOTE You can also save the oscilloscope's display image using a web browser. See "Get Image" on 
page 330 for details.
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CSV Data

When the CSV data (*.csv) file format is selected, comma-separated values for 
each displayed waveform and digital channel pod are saved as multiple columns 
in a single file. Math FFT waveforms, whose values are in the frequency domain, 
are appended at the bottom of the .csv file. Pod names (for example, D0-D7) or 
waveform labels are used as column headers. This format is suitable for 
spreadsheet analysis.

For CSV data, length "N" value-at-time measurements are performed across the 
entire screen (using the analysis record data) for each active source. Interpolation 
between analysis record data points is performed as needed.

ASCII XY Data

When the ASCII XY data (*.csv) file format is selected, comma-separated value 
files for each displayed waveform, digital channel pod, digital bus, and serial bus 
are saved. For digital pods, an underscore (_) and the pod name (for example, 
D0-D7) are appended to the specified file name; otherwise, an underscore and the 
waveform's label are appended.

If the oscilloscope acquisition is stopped, data from the raw acquisition record 
(which has more points than the analysis record) can be written. Press the [Single] 
key to obtain maximum memory depth with current settings. If enabled, serial 
decode data is saved.

When you want to save less than the maximum number of data points, a 1-of-N 
decimation is performed to produce an output whose length is less than or equal 
to the requested length. For example, if there are 100k points of data, and you 
specify a length of 2k, 1 of every 50 data points is saved.

Length Control

The Length control is available when saving data to CSV, ASCII XY, or BIN format 
files. It limits the maximum number of data points that can be saved.

When Max Length is enabled, the maximum number of waveform data points is 
saved.

The actual number of data points saved depends on displayed data and on these 
factors:

• Whether acquisitions are running. When stopped, data comes from the raw 
acquisition record. When running, data comes from a smaller running 
acquisition record.

• Whether the oscilloscope was stopped using [Stop] or [Single]. Running 
acquisitions use less memory to provide fast waveform update rates. Single 
acquisitions use full memory.

• The horizontal time/div (sweep speed) setting when stopped using [Stop]. At 
faster settings, fewer data points appear on the display.
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• Whether segmented memory is on. Acquisition memory is divided by the 
number of segments.

• When saving to a CSV format file, the maximum number of data points is 
1 Mpts.

When necessary, the Length control performs a "1 of n" decimation of the data . 
For example: if the Length is set to 1000, and you are displaying a record that is 
5000 data points in length, four of each five data points will be decimated, creating 
an output file 1000 data points in length.

When saving waveform data, the save times depend on the chosen format:

To save reference waveform files to a USB storage device

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select Reference 
Waveform data (*.h5).

3 From the Source drop-down list, select the source waveform.

4 Select the File Name field, and enter the name of the file you want to save.

5 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

6 Select Save.

To save masks

Mask files can be saved to one of four internal (\User Files) locations or to an 
external USB storage device.

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select Mask (*.msk).

3 Select the File Name field, and enter the name of the file you want to save.

4 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

5 Select Save.

Mask files have the extension MSK.

Data File Format Save Times

BIN fastest

ASCII XY medium

CSV slowest
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See Also • Chapter 18, “Mask Testing,” starting on page 249

To save arbitrary waveforms

Arbitrary waveform files can be saved to internal (\User Files) locations or to an 
external USB storage device.

1 From the main menu (see page 40), choose File > Save....

2 In the Save dialog box, from the Format drop-down menu, select Arbitrary 
Waveform data (*.csv).

3 Select the File Name field, and enter the name of the file you want to save.

4 Use the controls in the bottom of the dialog box to navigate to the location of 
the file to be saved.

5 Select Save.

See Also • "To edit arbitrary waveforms" on page 284

Emailing Setups, Screen Images, or Data

You can send oscilloscope files over the network via e-mail. You can e-mail any file 
that can be saved.

To e-mail a setup, screen image, or data file:

1 Make sure the oscilloscope is connected to the local area network (see "To 
establish a LAN connection" on page 305).

2 From the main menu (see page 40), choose File > Email....

3 In the Email dialog box, select the Configure tab:

NOTE Masks are also saved as part of setup files. See "To save setup files" on page 293.
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In the Server area:

a Select the SMTP Server and Port fields and enter the name and port number 
of your SMTP server. If you do not know these values, ask your Network 
Administrator.

b if your SMTP server requires authentication, select Server requires 
authentication. Then, enter the Username and Password.

For encrypted email, select Use TLS encryption.

In the Header Fields area:

a Select the To field and enter the destination email address(es).

You can specify multiple e-mail addresses by separating each address by a 
semi-colon.

b Select the From field and enter the sender email address.

c Select the Subject field enter the message subject.

d Select Send Test Email to send a test email using these settings.

4 Select the Send Email tab:
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a Select the Attachment Name field and enter the name of the file that will be 
attached in the email.

b From the Format drop-down list, select the type of information that will be 
emailed.

You can select from the same formats that are available when saving files. 
Settings for the selected format are also the same. See "Saving Setups, 
Screen Images, or Data" on page 291.

c Select Send Email to send the file to the server and recipients set up in the 
Configure tab.

You can also configure the Setup > (Quick Action) menu item to e-mail setups, screen 
images, or data. See "Configuring the (Quick Action) Menu Item" on page 322.

Recalling Setups, Masks, or Data

1 From the main menu (see page 40), choose File > Open....

2 In the Open dialog box, from the Format drop-down menu, select the type of file 
you want to recall:

• Setup (*.scp) — See "To recall setup files" on page 300.

• Mask (*.msk) — See "To recall mask files" on page 300.

• Reference Waveform data (*.h5) — See "To recall reference waveform files from 
a USB storage device" on page 300.

• Arbitrary Waveform data (*.csv) — See "To recall arbitrary waveforms" on 
page 301.

• CAN Symbolic data (*.dbc) — For CAN serial decode.

• LIN Symbolic data (*.ldf) — For LIN serial decode.

3 Select any options for the type of file you want to recall.

4 Use the controls in the bottom of the dialog box to select the file to be recalled.

5 Select Open.

A message indicating whether the open was successful is displayed.
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You can also recall setups and mask files by loading them using the File Explorer. 
See "File Explorer" on page 307.

You can also configure the Setup > (Quick Action) menu item to recall setups, masks, 
or reference waveforms. See "Configuring the (Quick Action) Menu Item" on 
page 322.

To recall setup files

Setup files can be recalled from internal (\User Files) locations or from an external 
USB storage device.

1 From the main menu (see page 40), choose File > Open....

2 In the Open dialog box, from the Format drop-down menu, select Setup (*.scp).

3 If you would like to clear the display, select Clear Display.

4 Use the controls in the bottom of the dialog box to select the file to be recalled.

5 Select Open.

To recall mask files

Mask files can be recalled from one of four internal (\User Files) locations or from 
an external USB storage device.

1 From the main menu (see page 40), choose File > Open....

2 In the Open dialog box, from the Format drop-down menu, select Mask (*.msk).

3 If you would like to clear the display or clear the recalled mask, select Clear 
Display or Clear Mask.

4 Use the controls in the bottom of the dialog box to select the file to be recalled.

5 Select Open.

To recall reference waveform files from a USB storage device

1 From the main menu (see page 40), choose File > Open....

2 In the Open dialog box, from the Format drop-down menu, select Reference 
Waveform data (*.h5).

3 From the To Ref: drop-down list, select the desired reference waveform location.

4 If you would like to clear the display of everything except the reference 
waveform, select Clear Display.

5 Use the controls in the bottom of the dialog box to select the file to be recalled.

6 Select Open.
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To recall arbitrary waveforms

Arbitrary waveform files can be recalled from internal (\User Files) locations or 
from an external USB storage device.

When recalling arbitrary waveforms (from an external USB storage device) that 
were not saved from the oscilloscope, be aware that:

• If the file contains two columns, the second column is automatically chosen.

• If the file contains more than two columns, you are prompted to select which 
column to load. Up to five columns are parsed by the oscilloscope; columns 
above the fifth are ignored.

• The oscilloscope uses a maximum of 8192 points for an arbitrary waveform. For 
more efficient recalls, make sure your arbitrary waveforms are 8192 points or 
less.

To recall an arbitrary waveform:

1 From the main menu (see page 40), choose File > Open....

2 In the Open dialog box, from the Format drop-down menu, select Arbitrary 
Waveform data (*.csv).

3 Use the controls in the bottom of the dialog box to select the file to be recalled.

4 Select Open.

See Also • "To edit arbitrary waveforms" on page 284

Recalling Default Setups

1 From the main menu (see page 40), choose Control > Default....

2 In the Default dialog box, you can select:

• Undo Default Setup — Returns to the oscilloscope settings that were present 
before the last Default Setup.

• Default Setup — Restores the oscilloscope's default settings. This places the 
oscilloscope in a known operating condition. See "Recall the Default 
Oscilloscope Setup" on page 31.

This is the same as pressing the front panel [Default Setup] key.

Some user settings are not changed when recalling the default setup.

• Default GUI Layout — Returns to the default graphical user interface (GUI) 
layout.

• Factory Default — Recalls the oscilloscope's factory default settings.

You must confirm the recall because there are no user settings that are left 
unchanged.
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• Factory Reset — Wipes the oscilloscope's non-volatile storage like Secure 
Erase, but it does not perform the National Industrial Security Program 
Operation Manual (NISPOM) Chapter 8 procedure and is much faster.

You must confirm the factory reset, and the oscilloscope will reboot when 
finished.

• Secure Erase — This performs a secure erase of all non-volatile memory in 
compliance with the JEDEC standard conforming to DoD 5220.22-M and 
National Industrial Security Program Operation Manual (NISPOM) Chapter 8 
as a short wipe (1 to 3 passes).

You must confirm the secure erase, and the oscilloscope will reboot when 
finished.

Performing a Secure Erase

1 From the main menu (see page 40), choose Control > Default....

2 In the Default dialog box, select Secure Erase.

This performs a secure erase of all non-volatile memory in compliance with the 
JEDEC standard conforming to DoD 5220.22-M and National Industrial 
Security Program Operation Manual (NISPOM) Chapter 8 as a short wipe (1 to 3 
passes).

You must confirm the secure erase, and the oscilloscope will reboot when 
finished.
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This chapter explains oscilloscope utility functions.

I/O Interface Settings

The oscilloscope can be accessed and/or controlled remotely via these I/O 
interfaces:

• USB device port on the rear panel (square shaped USB port).

• LAN interface on the rear panel.

When an I/O interface is installed, remote control over that interface is always 
enabled. Also, the oscilloscope can be controlled via multiple I/O interfaces (for 
example, USB and LAN) at the same time.

To configure the I/O interfaces:

1 From the main menu (see page 40), choose Utilities > I/O....

2 In the I/O dialog box, select the LAN Setup tab.
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3 In the LAN Setup tab of the I/O dialog box, you can select:

• LAN Settings... — Opens the LAN Settings dialog box where you can set up the 
oscilloscope's LAN settings. See "Setting up the Oscilloscope's LAN 
Connection" on page 304.

• LAN Reset — Resets the oscilloscope's LAN settings.

• Turn off LAN Identify — Turns off the oscilloscope's identification function. The 
identification function can be turned on via the instrument's web interface, 
on the Home tab.

Using the oscilloscope's rear panel LAN (local area network) port, you can place 
the oscilloscope on the network and set up its LAN connection. Once that is done, 
you can use the oscilloscope's web interface (see Chapter 25, “Web Interface,” 
starting on page 325), or remotely control the oscilloscope via the LAN interface.

See Also • Chapter 25, “Web Interface,” starting on page 325 (when the oscilloscope is 
connected to a LAN).

• "Remote Programming via the Web Interface" on page 327

• The oscilloscope's Programmer's Guide.

• "Remote Programming with Keysight IO Libraries" on page 328

Setting up the Oscilloscope's LAN Connection

Using the rear panel LAN port, you can place the oscilloscope on the network and 
set up its LAN connection. Once that is done, you can use the oscilloscope's web 
interface or remotely control the oscilloscope via the LAN interface.

The oscilloscope supports methods for automated LAN configuration or manual 
LAN configuration (see "To establish a LAN connection" on page 305). It is also 
possible to set up a point-to-point LAN connection between a PC and the 
oscilloscope (see "Stand-alone (Point-to-Point) Connection to a PC" on 
page 306).

NOTE When you connect the oscilloscope to a LAN, it is a good practice to limit access to the 
oscilloscope by setting a password using the web interface. By default, the oscilloscope is not 
password protected.
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Once the oscilloscope is set up on the network, you can use the oscilloscope's web 
page to view or change its network configuration and access additional settings 
(like the network password). See Chapter 25, “Web Interface,” starting on page 
325.

To establish a LAN connection

Open the LAN
Settings Dialog

Box

1 From the main menu (see page 40), choose Utilities > I/O....

2 In the I/O dialog box, select the LAN Setup tab.

3 Select LAN Settings... to open the LAN Settings dialog box.

Automatic
Configuration

1 In the LAN Settings dialog box, select Automatic.

If your network supports DHCP or AutoIP, enabling Automatic lets the 
oscilloscope use those services to get its LAN configuration settings

2 You can enable the Multicast DNS option to let the oscilloscope use Multicast 
DNS for name resolution on small networks without a conventional DNS server.

3 Connect the oscilloscope to the local area network (LAN) by inserting the LAN 
cable into the "LAN" port on the rear panel of the oscilloscope.

In a few moments the oscilloscope will connect to the network automatically.

If the oscilloscope does not automatically connect to the network, select LAN 
Reset in the I/O dialog box's LAN Setup tab. In a few moments the oscilloscope 
will connect to the network.

NOTE When you connect the oscilloscope to a LAN it is a good practice to limit access to the 
oscilloscope by setting a password. By default, the oscilloscope is not password protected. 
See "Setting a Password" on page 334 to set a password.

NOTE Any time you modify the oscilloscope's hostname, it breaks the connection between the 
oscilloscope and the LAN. You need to re-establish communication to the oscilloscope using 
the new hostname.
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Manual
Configuration

1 Get the oscilloscope's network parameters (host name, IP address, subnet 
mask, gateway IP, DNS IP, etc.) from your network administrator.

2 In the LAN Settings dialog box, select and enter values in these fields:

• IP Address — The oscilloscope's IP address.

• Subnet Mask — The oscilloscope's subnet mask.

• Gateway IP — The gateway IP address.

• DNS IP — You can enter the IP address of the Domain Name Server (DNS).

• Host Name — Lets you enter the oscilloscope's hostname.

The lower part of the LAN Settings dialog box shows the oscilloscope's Current 
LAN Configuration.

3 Select Apply to apply the LAN settings changes.

Stand-alone (Point-to-Point) Connection to a PC

The following procedure describes how to establish a point-to-point (stand alone) 
connection to the oscilloscope. This is useful if you want to control the 
oscilloscope using a laptop computer or a stand-alone computer.

1 From the main menu (see page 40), choose Utilities > I/O....

2 In the I/O dialog box, select the LAN Setup tab.

3 Select LAN Settings....

4 In the LAN Settings dialog box, select Automatic.

If your network supports DHCP or AutoIP, enabling Automatic lets the 
oscilloscope use those services to get its LAN configuration settings

5 Connect your PC to the oscilloscope using a cross-over LAN cable such as 
Keysight part number 5061-0701, available on the web at 
www.keysight.com/find/parts.

6 Cycle power on the oscilloscope.

Wait until the LAN connection status shows "configured" in the I/O dialog box's 
I/O Overview tab.

This may take a few minutes.

Now, the instrument is connected, and the instrument's web interface or remote 
control via LAN may be used.

NOTE Any time you modify the oscilloscope's hostname, it breaks the connection between the 
oscilloscope and the LAN. You need to re-establish communication to the oscilloscope using 
the new hostname.

http://www.keysight.com/find/parts
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File Explorer

The File Explorer lets you navigate the oscilloscope's internal file system and the 
file systems of connected USB storage devices.

From the internal file system, you can load oscilloscope setup files or mask files.

From a connected USB storage device, you can load setup files, mask files, license 
(*.lic) files, firmware update (*.swu) files, label files, etc. Also, you can delete files 
on a connected USB storage device.

The oscilloscope's internal file system, under "\User Files", consists of 10 locations 
for oscilloscope setup files, four locations for mask files, and four locations for 
waveform generator arbitrary waveform files.

To use the File Explorer:

1 From the main menu (see page 40), choose File > File Explorer... or Utilities > File 
Explorer....

2 To navigate in the File Explorer dialog box, select devices, folders, and files.

3 When file(s) are selected, you can:

• Select Open File (or Install File) to load (or install) the file selected in the 
bottom portion of the dialog box.

The button label changes from Open File to Install File when a file that can be 
installed is selected, like a license (*.lic) file or a firmware update (*.swu) file.

NOTE The USB port on the front panel, and the USB port on the rear panel labeled "HOST" are USB 
Series A ports. These are the ports to which you can connect USB mass storage devices.

The square port on the rear panel labeled "DEVICE" is provided for controlling the oscilloscope 
over USB. See the Programmer's Guide for more information.
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• Select Delete File to deletes the file(s) selected in the bottom portion of the 
dialog box.

• Select Copy File(s)... to opens the "Copy File(s) to" dialog box where you can 
select the destination folder for file(s) selected in the bottom portion of the 
dialog box.

4 To properly unmount a USB storage device before removal, select Eject.

If you remove the device without selecting Eject first, the device will be marked 
as needing repair when connecting to a computer with the Windows operating 
system (even though there are no harmful effects to the device).

Use your PC to create directories on a USB storage device.

See Also • Chapter 23, “Save/Email/Recall (Setups, Screens, Data),” starting on page 291

• "USB Storage Devices" on page 308

USB Storage Devices

Most USB mass storage devices are compatible with the oscilloscope. However, 
certain devices may be incompatible, and may not be able to be read or written to. 
USB storage devices must be formatted with the FAT/FAT16, FAT32, NTFS, EXT2, 
EXT3, or EXT4 file system format. The exFAT format is not supported. Any given 
storage device may not support all of these formats.

You must "eject" a USB mass storage device before unplugging it; otherwise, the 
device will be marked as needing repair when connecting to a computer with the 
Windows operating system (even though there are no harmful effects to the 
device).

Do not connect USB storage devices that identify themselves as hardware type 
"CD" because these devices are not compatible with the InfiniiVision HD3-Series 
oscilloscopes.

Setting Oscilloscope Preferences

The Preferences tab of the User Options dialog box (opened by choosing Utility > 
User Options... from the main menu (see page 40)) lets you specify oscilloscope 
preferences:
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• "To choose "expand about" center or ground" on page 309

• "To disable/enable transparent backgrounds" on page 309

• "To set up the screen saver" on page 310

• "To set Autoscale preferences" on page 310

• "To scale the GUI larger or smaller" on page 311

To choose "expand about" center or ground

When you change a channel's volts/division setting, the waveform display can be 
set to expand (or compress) about the signal ground level or the center of the 
display.

To set the waveform expansion reference point:

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Preferences tab.

3 From the Expand drop-down list, select:

• Ground — The displayed waveform will expand about the position of the 
channel's ground. This is the default setting.

The ground level of the signal is identified by the position of the ground level 
( ) icon at the far-left side of the display.

The ground level will not move when you adjust the vertical sensitivity 
(volts/division) control.

If the ground level is off screen, the waveform will expand about the top or 
bottom edge of the screen based on where the ground is off screen.

• Center — The displayed waveform will expand about the center of the 
display.

To disable/enable transparent backgrounds

There is a preference setting for whether measurements, statistics, reference 
waveform information, and other text displays have transparent or solid 
backgrounds.

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Preferences tab.

3 Select Transparent to toggle between transparent and solid text display 
backgrounds.
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To set up the screen saver

The oscilloscope can be configured to turn on a display screen saver when the 
oscilloscope has been idle for a specified length of time.

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Preferences tab.

3 Select Screen Saver....

4 In the Screen Saver dialog box, from the Screen Saver drop-down list, select:

• Off — No screen saver is used.

• Blank Screen — A blank screen saver is used.

• Keysight Logo — A screen saver with the Keysight logo is used.

• User Text — A screen saver with user-defined text is used. Enter the text in the 
Text field.

5 Select Wait and enter the number of minutes to wait before the selected screen 
saver activates.

6 Select Preview to view the selected screen saver.

7 To view the normal display after the screen saver has started, press any key or 
turn any knob.

To set Autoscale preferences

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Preferences tab.

3 Select Autoscale....

4 In the Autoscale dialog box:

• Select Undo Autoscale to return the oscilloscope to settings that were present 
before the last Autoscale.

• Select Fast Debug for a quicker autoscale that lets you make quick visual 
comparisons to determine whether the signal being probed is a DC voltage, 
ground, or an active AC signal.

Channel coupling is maintained to allow easy viewing of oscillating signals.
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• From the Channels drop-down list, select the channels to be autoscaled:

• All Channels — The next time you press [Auto Scale], all channels that meet 
the requirements of Autoscale will be displayed.

• Only Displayed Channels — The next time you press [Auto Scale], only the 
channels that are turned on will be examined for signal activity. This is 
useful if you only want to view specific active channels after pressing 
[Auto Scale].

• From the Acq Mode drop-down list, select whether the acquisition mode 
should be preserved during autoscale:

• Normal — Switches to Normal acquisition mode whenever the [Auto Scale] 
key is pressed. This is the default mode.

• Preserve — Causes the oscilloscope to keep the acquisition mode setting 
selected when the [Auto Scale] key is pressed.

Jitter-Free Trigger

Oscilloscope trigger circuitry introduces a certain amount of noise and jitter that 
result in horizontal error. To correct for this error, in certain trigger modes and at 
certain timebase ranges, hardware Jitter-Free Trigger correction is used to 
minimize trigger jitter at the trigger point.

The effect seen on the oscilloscope display is that all plotted acquisitions cross 
through the same pixel location at the intersection of the trigger level and time=0.

Jitter-Free Trigger correction works well for fast digital edges, but you may want 
to turn it off for some slow slew rate analog signals.

To scale the GUI larger or smaller

You can select between larger or smaller fonts and dialog boxes in the graphical 
user interface.

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Preferences tab.

3 In the GUI Scale Factor area, select Scale GUI Larger or Scale GUI Smaller.

Setting the Oscilloscope's Clock

Because screen captures and other items show the oscilloscope clock (date/time) 
settings, you want the oscilloscope clock to be correct. Licenses also rely on 
correct oscilloscope clock settings.
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To set the date and time:

1 From the main menu (see page 40), choose Utility > User Options....

2 In the User Options dialog box, select the Clock tab.

3 The Clock tab of the User Options dialog box has these controls for setting up 
and displaying the oscilloscope's date and time:

• Show — When selected, the oscilloscope's date and time appear on the 
display.

• Show Date & Time in Grid — When selected, the oscilloscope's date and time 
appear in the first waveform grid; otherwise, the date and time appear in the 
badges bar at the top of the display.

• Time Zone — Select the oscilloscope's time zone.

The options beginning with "UTC" are Standard Time and may or may not 
automatically adjust for Daylight Savings Time (most do not). The options 
without "UTC" automatically adjust for Daylight Savings Time.

• Network Time Protocol — The oscilloscope's time is synchronized with the 
network time.

• Automatically adjust clock for Daylight Savings Time — For the selected Time 
Zone, this shows whether time will automatically adjust for Daylight Savings 
Time.

• Year, Month, Day, Hour, Minute — When not synchronized with the network 
time, you can enter these values.

• Refresh — Updates the oscilloscope's date and time display with setting 
changes.

Setting the Rear Panel AUX OUT Source

You can choose the source of the AUX OUT BNC connector on the rear panel of the 
oscilloscope:

1 From the main menu (see page 40), choose Utility > User Options....

2 In the User Options dialog box, select the Rear Panel tab.
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3 From the Aux Out drop-down list, select:

• Triggers — Each time the oscilloscope triggers, a pulse occurs on AUX OUT. 
The pulse is delayed 1.06 μs from the oscilloscope's trigger point. The 
output level is 0-5 V into an open circuit, and 0-2.5 V into 50 Ω. See 
Chapter 10, “Triggers,” starting on page 149.

• Mask — The pass/fail status is evaluated periodically. When the evaluation of 
the testing period results in a failure, the trigger output pulses high (+5 V). 
Otherwise, the trigger output remains at low (0 V). See Chapter 18, “Mask 
Testing,” starting on page 249.

• Waveform Generator Sync Pulse — All of the waveform generator output 
functions (except DC, Noise, and Cardiac) have an associated Sync signal:

The Sync signal is a TTL positive pulse that occurs when the waveform rises 
above zero volts (or the DC offset value).

See Chapter 22, “Waveform Generator,” starting on page 279.

Enabling Remote Command Logging

When remote command logging is enabled, remote commands sent to the 
instrument (and results returned by the instrument) can be logged to the screen, 
to a text file on a USB storage device, or to both the screen and a text file.

To enable remote command logging:

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Remote Log tab.

3 Select Enable to enable or disable the remote command logging feature.

When remote logging is enabled, additional debug information can be included 
in the returned error string. If the error is detected by the SCPI command 
parser, such as a header error or other syntax error, the extra debug 
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information is generated and included. But if the error is detected by the 
oscilloscope system, such as when an out-of-range value is sent, then no extra 
debug information is included.

4 From the Destination drop-down list, select whether remote commands are 
logged to a text file (on a connected USB storage device), logged to the screen, 
or both.

5 From the Write Mode drop-down list, select whether logged commands will be 
created in a new list or appended to existing logged commands.

Your selection takes effect when remote command logging is enabled.

This option applies to both screen and file logging.

6 Select File Name to open the Remote Log Filename dialog box where you can 
specify the name of the file (on the USB storage device) to which remote 
commands are logged.

7 Select Remote Log to open the Remote Log dialog box that contains the logged 
commands.

8 Select Transparent to disable or enable a transparent background for the 
Remote Log dialog box.

Enable to make the background transparent. This lets you view underlying 
waveforms.

Disable for a solid background which makes the logged remote commands 
easier to read.

Setting Enhanced Security Options

With the Enhanced Security license, you can disable features to further secure the 
oscilloscope.

A password is required to make enhanced security changes.

To make enhanced security changes:

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Enhanced Security tab.
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3 Select Unlock Panel.

4 If you are setting the password for the first time:

a In the Password dialog box, select New Password.

b In the New Password dialog box, select the New Password field and enter the 
new password.

c Select the Repeat Password field and re-enter the new password.

d Select Set Password.

e In the confirmation dialog, read the warning information. Then, select OK.

If there is an existing password:

a In the Password dialog box, select the Password field and enter the existing 
password.

Once a password is set or entered, you are automatically taken back to the 
unlocked Enhanced Security tab where you can change these options:
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LAN Port Use this drop-down list to disable or enable the oscilloscope's LAN port. The 
LAN port lets you access the oscilloscope's built-in web interface and issue 
remote commands.

When the LAN port is disabled, the oscilloscope cannot be pinged and is 
essentially invisible over Ethernet to any device, even if an Ethernet cable in 
plugged into the oscilloscope's LAN port.

USB Device Port Use this drop-down list to disable or enable the oscilloscope's USB Device port. 
The USB Device port is the square shaped USB port for connecting the 
oscilloscope to a host PC for remote communication.

USB Host Ports Use this drop-down list to disable or enable the oscilloscope's USB Host ports. 
The USB Host ports are the rectangular shaped USB ports used for connecting a 
USB mass storage device, mouse, or keyboard to the oscilloscope.

Non-Volatile 
Memory

Use this drop-down list to disable or enable the oscilloscope's non-volatile 
memory. The contents of non-volatile memory are kept when the oscilloscope is 
powered off.

Normally, the oscilloscope's internal storage for setup files, mask files, and 
arbitrary waveforms (under "\User files") and for symbolic decoding files, etc., is 
non-volatile; however, when the non-volatile memory is disabled, this internal 
storage becomes volatile and is not kept when the oscilloscope is powered off.

Also, when non-volatile memory is disabled:

• The oscilloscope is restored to a factory default setup when powered on.

• Licenses and calibration factors, which are not user-accessible, are retained.

• Web-based firmware upgrades are disabled, even if the oscilloscope's LAN 
Port and Firmware Upgrade options are enabled.

Firmware 
Upgrade

Use this drop-down list to disable or enable the ability to upgrade firmware.

When firmware upgrades are disabled:

• Firmware installers (.swu files) are prevented from being loaded into, or run 
in, the oscilloscope. This applies to firmware upgrades from external USB 
mass storage devices as well as web-based firmware upgrades.

• Licenses can still be installed

• Recallable files (setup files, mask files, etc.) can still be accessed from 
external media if the appropriate communication ports are enabled.

Note that web-based firmware upgrades are disabled when non-volatile 
memory is disabled, even when this and the LAN Port options are enabled.

SCPI Use this drop-down list to disable or enable the ability to send SCPI commands 
and queries to the oscilloscope over LAN or USB connections.
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Disabled settings are secure, and enabled settings are insecure.

When changing the non-volatile memory, LAN Port, USB Device Port, or USB Host 
Ports settings, you must reboot the oscilloscope for the change to take place.

Select Lock Panel to lock the enhanced security options panel.

To change the enhanced security password:

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Enhanced Security tab.

3 Select Unlock Panel.

4 In the Password dialog box, select New Password.

5 In the New Password dialog box, select the Current Password field and enter the 
existing password.

6 Select the New Password field and enter the new password.

7 Select the Repeat Password field and re-enter the new password.

8 Select Set Password.

9 In the confirmation dialog, read the warning information. Then, select OK.

To reset (clear) the enhanced security password:

1 From the main menu (see page 40), choose Utilities > User Options....

2 In the User Options dialog box, select the Enhanced Security tab.

3 Select Unlock Panel.

4 In the Password dialog box, select Reset Password.

VNC 
Authentication

Use this to set or reset (clear) a password for VNC (Virtual Network Computing) 
client access (as described in "Remote GUI Access Using VNC" on 
page 329).

VNC Server 
Enabled

This check box enables or disables the oscilloscope's VNC (Virtual Network 
Computing) server.

When disabled, you are not able to access the oscilloscope's graphical user 
interface (GUI) on a remote computer using VNC client software (as described in 
"Remote GUI Access Using VNC" on page 329).
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5 In the Reset Password dialog box, select the Current Password field and enter the 
existing password.

6 Select Reset Password.

7 In the confirmation dialog, select OK.

Performing Service Tasks

The Service dialog box (choose Utilities > Service... from the main menu (see 
page 40)) lets you perform service-related tasks:

• "To display the user calibration status" on page 318

• "To perform user calibration" on page 319

• "To perform hardware self test" on page 320

• "To perform front panel self test" on page 320

• "To display oscilloscope information" on page 321

For other information related to oscilloscope maintenance and service, see:

• "To clean the oscilloscope" on page 321

• "To check warranty and extended services status" on page 321

• "To contact Keysight" on page 321

• "To return the instrument" on page 322

To display the user calibration status

To display the summary results of the previous User Calibration and the status of 
probe calibrations for probes that can be calibrated:

1 From the main menu (see page 40), choose Utilities > Service....

2 In the Service dialog box, select the Calibration tab.
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Note that passive probes do not need to be calibrated, but InfiniiMax probes can 
be calibrated. For more information about calibrating probes see "To calibrate a 
probe" on page 71.

To perform user calibration

Perform user-calibration:

• Every three years or after 6000 hours of operation.

• If the ambient temperature is >10° C from the calibration temperature.

• If you want to maximize the measurement accuracy.

The amount of use, environmental conditions, and experience with other 
instruments help determine if you need shorter User Calibration intervals.

User Calibration performs an internal self-alignment routine to optimize the signal 
path in the oscilloscope. The routine uses internally generated signals to optimize 
circuits that affect channel sensitivity, offset, and trigger parameters.

Performing User Calibration will invalidate your Certificate of Calibration. If NIST 
(National Institute of Standards and Technology) traceability is required, perform 
the "Performance Verification" procedure in the Service Guide using traceable 
sources.

To perform user calibration:

1 Disconnect all inputs from the front and rear panels, including the digital 
channels cable. Disconnect the waveform generator output. No cables are 
needed. 

2 Allow the oscilloscope to warm up 30 minutes before performing this 
procedure.

3 From the main menu, choose Utilities > Service....

4 In the Service dialog box, select the Calibration tab.

5 Clear the Cal Protect check box.

6 Select Start User Calibration.

CAUTION Disconnecting oscilloscope inputs and the waveform generator output before user 
calibration is important because the oscilloscope's measurement accuracy depends 
on proper calibration. 
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To perform hardware self test

To perform a series of internal procedures to verify that the oscilloscope is 
operating properly:

1 From the main menu, choose Utilities > Service....

2 In the Service dialog box, select the Diagnostics tab.

3 Select Hardware Self Test.

It is recommended you run Hardware Self Test:

• After experiencing abnormal operation.

• For additional information to better describe an oscilloscope failure.

• To verify proper operation after the oscilloscope has been repaired.

Successfully passing Hardware Self Test does not guarantee 100% of the 
oscilloscope's functionality. Hardware Self Test is designed to provide an 80% 
confidence level that the oscilloscope is operating properly.

To perform front panel self test

To test the front panel keys and knobs, LEDs, display, and touch screen:

1 From the main menu, choose Utilities > Service....

2 In the Service dialog box, select the Diagnostics tab.

3 From the Front Panel Self Test drop-down list, select the test you want to 
perform:

• Keyboard Test — Tests the front panel keys and knobs.

• LED Test — Test the front panel LEDs.
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• Display Test — Tests the display's ability to output basic colors.

• Touch Screen Test — Tests the touch screen.

4 Select Start.

Follow the on-screen instructions.

When the test is complete, status information appears in the Test Summary box.

To display oscilloscope information

From the main menu (see page 40), choose Help > About This Oscilloscope.... The 
About dialog box contains information about your oscilloscope:

• Model number.

• Serial number.

• Bandwidth.

• Host ID.

• Module installed.

• Firmware version.

• Installed licenses. See also "Loading Licenses and Displaying License 
Information" on page 340.

To clean the oscilloscope

1 Remove power from the instrument by shutting down and disconnecting the 
power cord.

2 Clean the external surfaces of the oscilloscope with a soft cloth dampened with 
a mixture of mild detergent and water.

3 Make sure that the instrument is completely dry before reconnecting it to a 
power source.

To check warranty and extended services status

To learn the warranty status of your oscilloscope:

1 Point your web browser to: www.keysight.com/find/warrantystatus

2 Enter your product's model number and serial number. The system will search 
for the warranty status of your product and display the results. If the system 
cannot find your product's warranty status, select Contact Us and speak with a 
Keysight Technologies representative.

To contact Keysight

Information on contacting Keysight Technologies can be found at: 
www.keysight.com/find/contactus

http://www.keysight.com/find/warrantystatus
http://www.keysight.com/find/contactus
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To return the instrument

Before shipping the oscilloscope to Keysight Technologies, contact your nearest 
Keysight Technologies sales or service office for additional details. Information on 
contacting Keysight Technologies can be found at: 
www.keysight.com/find/contactus

1 Write the following information on a tag and attach it to the oscilloscope.

• Name and address of owner.

• Model number.

• Serial number.

• Description of service required or failure indication.

2 Remove accessories from the oscilloscope.

Only return accessories to Keysight Technologies if they are associated with the 
failure symptoms.

3 Package the oscilloscope.

You can use the original shipping container, or provide your own materials 
sufficient to protect the instrument during shipping.

4 Seal the shipping container securely, and mark it FRAGILE.

Configuring the (Quick Action) Menu Item

The Setup > (Quick Action) menu item lets you quickly perform common, repetitive 
actions. The (Quick Action) menu item can also be added to the Favorites menu for 
even faster access.

To configure the (Quick Action) menu item:

1 From the main menu (see page 40), choose Setup > Quick Action Setup....

2 From the Quick Action Setup dialog box's Action drop-down list, select:

• Off — disables the (Quick Action) menu item.

• Quick Measure — quickly adds 10 common measurements. The Source 
pull-down list lets you select the waveform source (which also becomes the 
source selection in the Measurements dialog box). See "To quickly add 10 
common measurements" on page 200.

• Quick Measure Statistics Reset — resets all measurement statistics and the 
measurement count. See "Measurement Statistics" on page 225.

• Quick Mask Statistics Reset — resets mask statistics and counters. See "Mask 
Statistics" on page 253.

• Quick Histogram Statistics Reset — resets all histogram statistics. See 
"Histogram Data Statistics" on page 235.

http://www.keysight.com/find/contactus
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• Quick Save — saves the current image, waveform data, or setup. Press 
Settings to set up the save options. See Chapter 23, “Save/Email/Recall 
(Setups, Screens, Data),” starting on page 291.

• Quick Email — e-mails the current setup, screen image, or data file. Press 
Settings to set up the e-mail options. See "Emailing Setups, Screen Images, 
or Data" on page 297.

• Quick Recall — recalls a setup, mask, or reference waveform. Press Settings to 
set up the recall options. See Chapter 23, “Save/Email/Recall (Setups, 
Screens, Data),” starting on page 291.

• Quick Trigger Mode — toggles the trigger mode between Auto and Trig'd, see 
"To select the Auto or Trig'd trigger mode" on page 170.

• Quick Clear Display — clears the display, see "To clear the display" on 
page 139.

• Quick WaveGen Burst — outputs the Burst Count number of cycles of the 
waveform generator's defined waveform, see "To specify the output 
settings" on page 283.

Once the (Quick Action) menu item is configured, choose Setup > (Quick Action) to 
perform the selected action.
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When Keysight InfiniiVision HD3-Series oscilloscopes are set up on the LAN, you 
can access the oscilloscope's built-in web server using a web browser. The 
oscilloscope's web interface lets you:

• View information about the oscilloscope like its model number, serial number, 
host name, IP address, and VISA (address) connect string.

• Send SCPI (Standard Commands for Programmable Instrumentation) remote 
programming commands via the SCPI Commands applet window.

• Control the oscilloscope's graphical user interface using a remote VNC (Virtual 
Network Computing) client.

• Get screen images and save or print them from the browser.

• Save setup files, mask files, screen images, or Reference waveform data.

• Recall setup files, mask files, or Reference waveform data.

• Activate the Identification function to identify a particular instrument by 
causing a message to be displayed or a front panel light to blink.

• View installed options, view firmware versions and install firmware upgrade 
files, install license files, and view calibration status (via the Instrument Utilities 
page).

• View and modify the oscilloscope's network configuration.

The web interface for InfiniiVision HD3-Series oscilloscopes also provides help for 
each of its pages.

Before you can use the web interface, you must place the oscilloscope on the 
network and set up its LAN connection.
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Accessing the Web Interface

To access the oscilloscope's web interface:

1 Connect the oscilloscope to your LAN (see "To establish a LAN connection" on 
page 305) or establish a point-to-point connection (see "Stand-alone 
(Point-to-Point) Connection to a PC" on page 306).

It is possible to use a point-to-point connection, but using a normal LAN 
connection is the preferred method.

2 Type the oscilloscope's hostname or IP address in the web browser.

The oscilloscope's web interface Welcome Page is displayed.
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Control Instrument

The web interface's Instrument Control page gives you access to the SCPI 
Command window applet for Remote Programming (see "Remote Programming 
via the Web Interface" on page 327).

Also, the HD3-Series oscilloscopes support remote access to the graphical user 
interface using VNC (Virtual Network Computing) client software (see "Remote 
GUI Access Using VNC" on page 329).

Remote Programming via the Web Interface

The SCPI Command window is useful for testing commands or entering a few 
commands interactively. When creating automated programs for controlling the 
oscilloscope, you will typically use the Keysight IO Libraries from within a 
programming environment like Microsoft Visual Studio (see "Remote 
Programming with Keysight IO Libraries" on page 328).

To send remote programming commands to the oscilloscope via the SCPI 
Commands applet window:

1 Access the oscilloscope's web interface (see "Accessing the Web Interface" on 
page 326).

2 When the oscilloscope's web interface is displayed, select the Control Instrument 
tab, then select Use Instrument IO.

The SCPI Commands applet appears within the browser web page.

NOTE If Java is not installed on your PC, you will be prompted to install the Java Plug-in. This 
plug-in must be installed on the controlling PC for the web interface's Remote Programming 
operations.
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Remote Programming with Keysight IO Libraries

While the SCPI Commands applet window lets you enter and remote programming 
commands, remote programming for automated test and data acquisition is 
typically done using the Keysight IO Libraries, which are separate from the 
instrument's web interface.

The Keysight IO Libraries let a controller PC communicate with Keysight 
InfiniiVision oscilloscopes via their USB or LAN interfaces.

The Keysight IO Libraries Suite connectivity software enables communication over 
these interfaces. You can download the Keysight IO Libraries Suite from 
www.keysight.com/find/iolib.

Information about controlling the oscilloscope through remote commands is 
contained in the Programmer's Guide.

For more information about connecting to the oscilloscope, refer to the Keysight 
Technologies USB/LAN/GPIB Interfaces Connectivity Guide. For a printable 
electronic copy of the Connectivity Guide, direct your Web browser to 
www.keysight.com and search for "Connectivity Guide".

http://www.keysight.com/find/iolib
http://www.keysight.com
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Remote GUI Access Using VNC

To access the oscilloscope's graphical user interface (GUI) on a remote computer 
using VNC (Virtual Network Computing) client software:

1 If VNC viewer software is not installed on your remote computer, do that first.

2 If you are using the oscilloscope's Enhanced Security options (see "Setting 
Enhanced Security Options" on page 314), make sure the oscilloscope's VNC 
server is enabled.

3 Run the VNC viewer software.

4 Give the oscilloscope's hostname or IP address as the name of the VNC server 
to connect with.

5 Connect.

6 If you are using the oscilloscope's Enhanced Security options (see "Setting 
Enhanced Security Options" on page 314) and have set up a password for VNC 
authentication, enter the password.

7 Once the VNC viewer connection opens, you can interact with the 
oscilloscope's GUI like you would on the oscilloscope.
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Get Image

To save (or print) the oscilloscope's display from the web interface:

1 Access the oscilloscope's web interface (see "Accessing the Web Interface" on 
page 326).

2 When the oscilloscope's web interface is displayed, select the Get Image tab. 
After a delay of several seconds, the oscilloscope's screen image will be 
displayed.

Click Refresh Image to get an updated screen image.

3 Right-click on the image and select Save Picture As... (or Print Picture...).

4 Select a storage location for the image file and click Save.

Save/Recall

You can save setup files, mask files, screen images, or Reference waveform data to 
your PC via the oscilloscope's web interface (see "Saving Files via the Web 
Interface" on page 330).

You can recall setup files, mask files, or Reference waveform data from your PC via 
the oscilloscope's web interface (see "Recalling Files via the Web Interface" on 
page 331).

Saving Files via the Web Interface

To save setup files, mask files, screen images, or Reference waveform data to your 
PC via the oscilloscope's web interface:

1 Access the oscilloscope's web interface (see "Accessing the Web Interface" on 
page 326).

2 When the oscilloscope's web interface is displayed, select the Save tab.

3 On the Save page:

a Enter the name of the file you are saving to.

b Select the format.
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You can click Preview to view the oscilloscope's current screen image.

With some formats, you can click Save Setup Info to save setup information to 
an ASCII .txt format file.

c Click Save.

The selected information is saved.

d In the File Download dialog, click Save.

e In the Save As dialog, navigate to the folder where you want to save the file; 
then, click Save.

Recalling Files via the Web Interface

To recall setup files, mask files, screen images, or Reference waveform data from 
your PC via the oscilloscope's web interface:

1 Access the oscilloscope's web interface (see "Accessing the Web Interface" on 
page 326).

2 When the oscilloscope's web interface is displayed, select the Recall tab.

3 On the Recall page:

a Click Browse....

b In the "Choose file" dialog, select the file you want to recall; then, click 
Recall.

c When recalling reference waveform data files, select the Recall to Reference 
Waveform option.
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d Click Recall.

Identification Function

The Identification web interface feature is useful when trying to locate a specific 
instrument in a rack of equipment.

1 Access the oscilloscope's web interface (see "Accessing the Web Interface" on 
page 326).

2 When the oscilloscope's web interface Welcome Page is displayed, select the 
Enable front panel identification indicator check box.

An "Identify" status dialog box is displayed on the oscilloscope.

You can either clear the Enable front panel identification indicator check box or 
close the dialog box on the oscilloscope to continue.
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Instrument Utilities

The Instrument Utilities page of the web interface lets you:

• View installed options.

• View firmware versions.

• Install firmware upgrade files.

• Install license files.

• View calibration status.

You can select these capabilities via a drop-down menu.

Identification option
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Setting a Password

Whenever you connect the oscilloscope to a LAN, it is good practice to set a 
password. The password prevents someone from remotely accessing the 
oscilloscope via a Web browser and modifying its settings. Remote users can still 
view the Welcome screen, view network status, etc., but they cannot modify 
instrument settings without the password.
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To set a password:

1 Access the oscilloscope's web interface (see "Accessing the Web Interface" on 
page 326).

2 When the oscilloscope's web interface is displayed, select the gear icon in the 
upper-right corner of the web page.

3 Click the Enable password button.

4 Enter your desired password in the New Password field. Enter the password 
again in the Confirm Password field. Click Enable Password.

When a password is enabled for the web interface, Log out or Log in appears in 
the upper-right corner next to the gear icon.

To change or
disable the

password

Do one of these things:

• Select the gear icon in the upper-right corner of the web page. In the Password 
Options page, click Change Password or Disable Password.

• Another way to disable the password is to reset the oscilloscope's LAN settings. 
To do this, select the Configure LAN tab, select Advanced options, and select 
LAN Reset.

• You can also reset the oscilloscope's LAN settings from the oscilloscope's 
graphical user interface:

a Choose Utility > I/O....

b In the I/O dialog box, select the LAN Setup tab.

c Select LAN Reset.
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Specifications and Characteristics

Please see the InfiniiVision oscilloscope data sheets for complete, up-to-date 
specifications and characteristics. To download a data sheet, please visit: 
www.keysight.com/find/HD3-Series

Measurement Category

• "Oscilloscope Measurement Category" on page 337

• "Measurement Category Definitions" on page 338

• "Maximum Input Voltages" on page 338

Oscilloscope Measurement Category

The InfiniiVision oscilloscopes are not intended to be used for measurements in 
Measurement Category II, III, or IV.

WARNING Use this instrument only for measurements within its specified measurement 
category (not rated for CAT II, III, IV). No transient overvoltages allowed.

http://www.keysight.com/find/HD3-Series
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Measurement Category Definitions

The "Not rated for CAT II, III, IV" measurement category is for measurements 
performed on circuits not directly connected to MAINS. Examples are 
measurements on circuits not derived from MAINS, and specially protected 
(internal) MAINS derived circuits. In the latter case, transient stresses are variable; 
for that reason, the transient withstand capability of the equipment is made known 
to the user.

Measurement category II is for measurements performed on circuits directly 
connected to the low voltage installation. Examples are measurements on 
household appliances, portable tools and similar equipment.

Measurement category III is for measurements performed in the building 
installation. Examples are measurements on distribution boards, circuit-breakers, 
wiring, including cables, bus-bars, junction boxes, switches, socket-outlets in the 
fixed installation, and equipment for industrial use and some other equipment, for 
example, stationary motors with permanent connection to the fixed installation.

Measurement category IV is for measurements performed at the source of the 
low-voltage installation. Examples are electricity meters and measurements on 
primary overcurrent protection devices and ripple control units.

Maximum Input Voltages

CAUTION  Maximum input voltage at analog inputs

1 MΩ input: 135 Vrms, 190 Vpk

50 Ω input: ≤104 mV/div: ±1.5 Vpk, >104 mV/div: 5 Vrms, 15 Vpk

With the 50 Ω input protection, the 50 Ω load will disconnect when 
greater-than-specified voltages are detected. However, the inputs could still be 
damaged, depending on the time constant of the signal. The 50 Ω input protection 
functions only when the oscilloscope is powered on.

When using Keysight PP0001A, PP0002A, or PP0003A probes, input voltages at the 
oscilloscope are ≤30 Vrms.

CAUTION When measuring voltages over 80 V, use a 10:1 probe.

CAUTION  Maximum input voltage at digital channels

±40 V peak
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Environmental Conditions

Probes and Accessories

For a list of the probes and accessories that are compatible with the HD3-Series 
oscilloscopes, see the data sheet at: www.keysight.com/find/HD3-Series

AutoProbe
Interface

Most Keysight single-ended active, differential, and current probes are compatible 
with the AutoProbe interface. Active probes that do not have their own external 
power supply require substantial power from the AutoProbe interface.

If too much current is drawn from the AutoProbe interface, an error message will 
be displayed, indicating that you must momentarily disconnect all probes to reset 
the AutoProbe interface, then connect only the supported quantity of active 
probes.

See Also For more information on probes and accessories, see www.keysight.com for:

• Probes and Accessories Selection Guide (5989-6162EN)

• InfiniiVision Oscilloscope Probes and Accessories Selection Guide Data Sheet 
(5968-8153EN)

Environment Indoor use only.

Ambient 
temperature

0 to 50 °C

Humidity Maximum Relative Humidity (non-condensing): 95% RH up to 40 °C

From 40 °C to 50 °C, the maximum % Relative Humidity follows the line of 
constant dew point

Altitude 3,000 m max

Overvoltage 
Category

This product is intended to be powered by MAINS that comply to Overvoltage 
Category II, which is typical of cord-and-plug connected equipment.

Pollution Degree The InfiniiVision HD3-Series oscilloscopes may be operated in environments of 
Pollution Degree 2 (or Pollution Degree 1).

Pollution Degree 
Definitions

Pollution Degree 1: No pollution or only dry, non-conductive pollution occurs. 
The pollution has no influence. Example: A clean room or climate controlled 
office environment.

Pollution Degree 2. Normally only dry non-conductive pollution occurs. 
Occasionally a temporary conductivity caused by condensation may occur. 
Example: General indoor environment.

Pollution Degree 3: Conductive pollution occurs, or dry, non-conductive 
pollution occurs which becomes conductive due to condensation which is 
expected. Example: Sheltered outdoor environment.

http://www.keysight.com/find/HD3-Series
http://www.keysight.com
http://literature.cdn.keysight.com/litweb/pdf/5989-6162EN.pdf
http://literature.cdn.keysight.com/litweb/pdf/5968-8153EN.pdf
http://literature.cdn.keysight.com/litweb/pdf/5968-8153EN.pdf
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• For compatibility information, manuals, application notes, data sheets, 
selection guides, SPICE models, and more for oscilloscope probes, see the 
Probe Resource Center at: www.keysight.com/find/PRC

Loading Licenses and Displaying License Information

License files are loaded from a USB storage device using the File Explorer (see 
"File Explorer" on page 307).

License information is displayed with other oscilloscope information (see "To 
display oscilloscope information" on page 321).

For more information about the licenses and other oscilloscope options available, 
see:

• "Licensed Options Available" on page 340

• "Other Options Available" on page 341

Licensed Options Available

The following licensed options can be easily installed without returning the 
oscilloscope to a Service Center. See data sheets for details.

Table 2 Licensed Options Available

License Description Upgrade model number, notes

HD300AERA Aerospace Serial Triggering and Analysis for HD3-Series Order HD300AERA.

HD300AUTA Automotive Serial Triggering and Analysis for HD3-Series Order HD300AUTA.

HD300BDLA Ultimate Bundle Software for HD3-Series (enables all 
features included in HD300AERA, HD300AUTA, 
HD300EMBA, and HD300PWRA)

Order HD300BDLA.

HD300BDLB Ultimate Bundle Software for HD3-Series (enables all 
features included in HD300AERA, HD300AUTA, 
HD300EMBA, HD300PWRA, HD300QJTA, and 
HD300USBA)

Order HD300BDLB.

HD300EMBA Embedded Serial Triggering and Analysis for HD3-Series Order HD300EMBA.

HD300PWRA Power Supply Test Software for HD3-Series Order HD300PWRA.

You can find the Power Measurement 
Application User's Guide at: 
www.keysight.com/find/HD3-Series-
manual

HD300QJTA Jitter Analysis for HD3-Series Order HD300QJTA.

HD300USBA USB Serial Triggering and Analysis for HD3-Series Order HD300USBA.

http://www.keysight.com/find/HD3-Series-manual
http://www.keysight.com/find/PRC
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Other Options Available

Software and Firmware Updates

From time to time Keysight Technologies releases software and firmware updates 
for its products. To search for firmware updates for your oscilloscope, direct your 
web browser to www.keysight.com/find/HD3-Series-sw.

To view the currently installed software and firmware press [Help] > About 
Oscilloscope.

Once you have downloaded a firmware update file, you can place it on a USB 
storage device and load the file using File Explorer (see "File Explorer" on 
page 307), or you can use the Instrument Utilities page of the oscilloscope's web 
interface (see "Instrument Utilities" on page 333).

Binary Data (.bin) Format

The binary data format stores waveform data in binary format and provides data 
headers that describe that data.

Because the data is in binary format, the size of the file is approximately 5 times 
smaller than the ASCII XY format.

If more than one source is on, all displayed sources will be saved, except math 
functions.

When using segmented memory, each segment is treated as a separate waveform. 
All segments for a channel are saved, then all segments of the next (higher 
numbered) channel are saved. This continues until all displayed channels are 
saved.

When the oscilloscope is in the Peak Detect acquisition mode, the minimum and 
maximum value waveform data points are saved to the file in separate waveform 
buffers. The minimum value data points are saved first; then, the maximum value 
data points are saved.

Table 3 Calibration Option

Option Order

1A7 17025 Compliant Calibration without 
Accreditation

AMG 17025 Compliant Calibration with Accreditation

http://www.keysight.com/find/HD3-Series-sw
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BIN data - using
segmented

memory

When saving all segments, each segment has its own waveform header (see 
"Binary Header Format" on page 342).

In BIN file format, data are presented as follows:

• Channel 1 data (all segments)

• Channel 2 data (all segments)

• Channel 3 data (all segments)

• Channel 4 data (all segments)

• Digital channel data (all segments)

• Math waveform data (all segments)

When not saving all segments, the number of waveforms is equivalent to the 
number of active channels (including math and digital channels, with up to seven 
waveforms for each digital pod). When saving all segments, the number of 
waveforms is equal to the number of active channels multiplied by the number of 
segments acquired.

Binary Data in MATLAB

Binary data from an InfiniiVision oscilloscope can be imported to The MathWorks 
MATLAB®. You can download the appropriate MATLAB functions from the 
Keysight Technologies web site at 
www.keysight.com/find/HD3-Series-examples.

Keysight provides the .m files, which need to be copied into the work directory for 
MATLAB. The default work directory is C:\MATLAB7\work.

Binary Header Format

File Header There is only one file header in a binary file. The file header consists of the 
following information.

Waveform Header It is possible to store more than one waveform in the file, and each waveform 
stored will have a waveform header. When using segmented memory, each 
segment is treated as a separate waveform. The waveform header contains 
information about the type of waveform data that is stored following the waveform 
data header.

Cookie Two byte characters, AG, that indicate the file is in the Keysight Binary Data file 
format.

Version Two bytes that represent the file version.

File Size A 32-bit integer that is the number of bytes that are in the file.

Number of 
Waveforms

A 32-bit integer that is the number of waveforms that are stored in the file.

http://www.keysight.com/find/HD3-Series-examples
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Header Size A 32-bit integer that is the number of bytes in the header.

Waveform Type A 32-bit integer that is the type of waveform stored in the file:

• 0 = Unknown.

• 1 = Normal.

• 2 = Peak Detect.

• 3 = Average.

• 4 = Not used in InfiniiVision oscilloscopes.

• 5 = Not used in InfiniiVision oscilloscopes.

• 6 = Logic.

Number of 
Waveform 
Buffers

A 32-bit integer that is the number of waveform buffers required to read the 
data.

Points A 32-bit integer that is the number of waveform points in the data.

Count A 32-bit integer that is the number of hits at each time bucket in the waveform 
record when the waveform was created using an acquisition mode like 
averaging. For example, when averaging, a count of four would mean every 
waveform data point in the waveform record has been averaged at least four 
times. The default value is 0.

X Display Range A 32-bit float that is the X-axis duration of the waveform that is displayed. For 
time domain waveforms, it is the duration of time across the display. If the value 
is zero then no data has been acquired.

X Display Origin A 64-bit double that is the X-axis value at the left edge of the display. For time 
domain waveforms, it is the time at the start of the display. This value is treated 
as a double precision 64-bit floating point number. If the value is zero then no 
data has been acquired.

X Increment A 64-bit double that is the duration between data points on the X axis. For time 
domain waveforms, this is the time between points. If the value is zero then no 
data has been acquired.

X Origin A 64-bit double that is the X-axis value of the first data point in the data record. 
For time domain waveforms, it is the time of the first point. This value is treated 
as a double precision 64-bit floating point number. If the value is zero then no 
data has been acquired.
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Waveform Data
Header

A waveform may have more than one data set. Each waveform data set will have a 
waveform data header. The waveform data header consists of information about 
the waveform data set. This header is stored immediately before the data set.

X Units A 32-bit integer that identifies the unit of measure for X values in the acquired 
data:

• 0 = Unknown.

• 1 = Volts.

• 2 = Seconds.

• 3 = Constant.

• 4 = Amps.

• 5 = dB.

• 6 = Hz.

Y Units A 32-bit integer that identifies the unit of measure for Y values in the acquired 
data. The possible values are listed above under X Units.

Date A 16-byte character array, left blank in InfiniiVision oscilloscopes.

Time A 16-byte character array, left blank in the InfiniiVision oscilloscopes.

Frame A 24 byte character array that is the model number and serial number of the 
oscilloscope in the format of: MODEL#:SERIAL#.

Waveform Label A 16 byte character array that contains the label assigned to the waveform.

Time Tags A 64-bit double, only used when saving multiple segments (requires segmented 
memory option). This is the time (in seconds) since the first trigger.

Segment Index A 32-bit unsigned integer. This is the segment number. Only used when saving 
multiple segments.

Waveform Data 
Header Size

A 32-bit integer that is the size of the waveform data header.

Buffer Type A 16-bit short that is the type of waveform data stored in the file:

• 0 = Unknown data.

• 1 = Normal 32-bit float data.

• 2 = Maximum float data.

• 3 = Minimum float data.

• 4 = Not used in InfiniiVision oscilloscopes.

• 5 = Not used in InfiniiVision oscilloscopes.

• 6 = Digital unsigned 8-bit char data (for digital channels).

Bytes Per Point A 16-bit short that is the number of bytes per data point.

Buffer Size A 32-bit integer that is the size of the buffer required to hold the data points.
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Example Program for Reading Binary Data

To find an example program for reading binary data, direct your web browser to 
www.keysight.com/find/HD3-Series-examples, and select "Example Program for 
Reading Binary Data".

Examples of Binary Files

Single Acquisition
Multiple Analog

Channels

The following picture shows a binary file of a single acquisition with multiple 
analog channels.

Single Acquisition
All Pods Logic

Channels

The following picture shows a binary file of a single acquisition with all pods for the 
logic channels saved.

File Header
12 bytes

Number of Waveforms = N

Number of Waveform Buffers = 1

Buffer Type = 1 (floating point)
Bytes per Point = 4

Waveform Header 1
140 bytes

Waveform Data
Header 1
12 bytes

Voltage Data 1
buffer size

Waveform Header 2
140 bytes

Waveform Data
Header 2
12 bytes

Voltage Data 2
buffer size

Waveform Header N
140 bytes

Waveform Data
Header N
12 bytes

Voltage Data N
buffer size

Number of Waveform Buffers = 1

Buffer Type = 1 (floating point)
Bytes per Point = 4

Number of Waveform Buffers = 1

Buffer Type = 1 (floating point)
Bytes per Point = 4

http://www.keysight.com/find/HD3-Series-examples
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Segmented
Memory

Acquisition on One
Analog Channel

The following picture shows a binary file of a segmented memory acquisition on 
one analog channel.

File Header
12 bytes

Waveform Header 2
140 bytes

Waveform Data
Header 1
12 bytes

Pod 1 Timing Data
buffer size

Waveform Data
Header 2
12 bytes

Pod 2 Timing Data
buffer size

Number of Waveforms = 2

Number of Waveform Buffers = 1

Buffer Type = 6 (unsigned char)
Bytes per Point = 1

Buffer Type = 6 (unsigned char)
Bytes per Point = 1

Waveform Header 1
140 bytes

Number of Waveform Buffers = 1
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CSV and ASCII XY files

• "CSV and ASCII XY file structure" on page 347

• "Minimum and Maximum Values in CSV Files" on page 348

• "Frequency Data in CSV Files" on page 348

CSV and ASCII XY file structure

In CSV or ASCII XY format the Length control selects the number of points per 
segment. All segments are contained in the CSV file or in each ASCII XY data file.

File Header
12 bytes

Waveform Header 1
140 bytes

Waveform Data
Header 1
12 bytes

Voltage Data 1
buffer size

Waveform Header 2
140 bytes

Waveform Data
Header 2
12 bytes

Voltage Data 2
buffer size

Waveform Header N
140 bytes

Waveform Data
Header N
12 bytes

Voltage Data N
buffer size

Number of Waveforms = N = Number of Segments

Number of Waveform Buffers = 1
Index = 1
Time Tag = 0.0

Buffer Type = 1 (floating point)
Bytes per Point = 4

Number of Waveform Buffers = 1
Index = 2
Time Tag = time between segment 1 and 2

Buffer Type = 1 (floating point)
Bytes per Point = 4

Number of Waveform Buffers = 1
Index = N
Time Tag = time between segment 1 and N

Buffer Type = 1 (floating point)
Bytes per Point = 4
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For example: If the Length control is set to 1000 points, there will be 1000 points 
(rows in the spreadsheet) per segment. When saving all segments there are three 
header rows, so the data for the first segment starts at row 4. The second 
segment's data starts at row 1004. The time column shows the time since the 
trigger on the first segment. The top row shows the selected number of points per 
segment.

BIN files are a more efficient data transfer format than CSV or ASCII XY. Use this 
file format for fastest data transfer.

Minimum and Maximum Values in CSV Files

If you are running a Minimum or Maximum measurement, the minimum and 
maximum values shown in the measurement display may not appear in the CSV 
file.

Explanation: When the oscilloscope's sample rate is 4 GSa/s, a sample will be taken every 
250 ps. If the horizontal scale is set to 10 us/div, there will be 100 us of data 
displayed (because there are ten divisions across the screen). To find the total 
number of samples the oscilloscope will take:

100 us x 4 GSa/s = 400K samples

The oscilloscope is required to display those 400K samples using 640 pixel 
columns. The oscilloscope will decimate the 400K samples to 640 pixel columns, 
and this decimation keeps track of the min and max values of all the points that 
are represented by any given column. Those min and max values will be displayed 
in that screen column.

A similar process is used to reduce the acquired data to produce a record usable 
for various analysis needs such as measurements and CSV data. This analysis 
record is much larger than 640 and can contain 65536 or more points. Still, once 
the # of acquired points is greater than the analysis record length, some form of 
decimation is required. The decimator used to produce a CSV record is configured 
to provide a best-estimate of all the samples that each point in the record 
represents. Therefore, the min and max values may not appear in the CSV file.

Frequency Data in CSV Files

When data for multiple frequency sources is saved to a CSV file, this data is saved 
as one set (with multiple columns) using a horizontal (X) range that covers all 
sources.

Acknowledgements

Third-party software acknowledgements and licenses for these InfiniiVision 
HD3-Series oscilloscopes are located at 
www.keysight.com/find/HD3-Series-third-party-software.

http://www.keysight.com/find/HD3-Series-third-party-software
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Product Markings and Regulatory Information

These symbols are used on the HD3-Series oscilloscopes.

Compliance with
German Noise
Requirements

This is to declare that this instrument is in conformance with the German 
Regulation on Noise Declaration for Machines (Laermangabe nach der 
Maschinenlaermrerordnung -3.GSGV Deutschland).

Symbol Description

Caution, refer to accompanying documentation

The crossed out wheeled bin symbol indicates that separate collection 
for waste electric and electronic equipment (WEEE) is required, as 
obligated by the EU DIRECTIVE and other National legislation.

Please refer to keysight.com/go/takeback to understand your Trade 
in options with Keysight in addition to product takeback instructions.

Indicates the time period during which no hazardous or toxic substance 
elements are expected to leak or deteriorate during normal use. Forty 
years is the expected useful life of the product.

The RCM mark is a registered trademark of the Australian 
Communications and Media Authority.

The CE mark is a registered trademark of the European Community.

ICES / NMB-001 Cet appareil ISM est conforme a la norme NMB du 
Canada. This is a marking to indicate product compliance with the 
Industry Canadian Interference-Causing Equipment Standard 
(ICES-001).

This is also a symbol of an Industrial Scientific and Medical Group 1 Class 
A product (CISPR 11, Clause 4).

The CSA mark is a registered trademark of the CSA International.

This mark denotes compliance with the essential requirements of the 
following applicable UK regulations:

• Electromagnetic Compatibility Regulations 2016 No. 1091 (as 
amended)

• Electrical Equipment (Safety) Regulations 2016 No. 1101 (as 
amended)

• The Restriction of the Use of Certain Hazardous Substances in 
Electrical and Electronic Equipment Regulations 2012 No. 3032 (as 
amended)

ICES/NMB-001

ISM GRP 1-A

http://www.keysight.com/go/takeback
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Product and Solution Cybersecurity

Keysight is committed to providing information to assist you in protecting your 
products and solutions from external cyber threats.

Cybersecurity Incident Monitoring and Response

Keysight maintains a product security response process that is utilized when new 
vulnerabilities or exploits are discovered that can impact our products and 
solutions. We also maintain a Product Security page providing:

• Information regarding security advisories for Keysight products.

• Information to help customers use our products securely.

• Information to assist Aerospace Defense customers using Keysight products in 
secure environments.

Security Incident/Vulnerability Reporting

Customers can contact Keysight to report a Keysight product or solution that has 
been impacted by a cybersecurity issue by sending an email with the details of the 
issue to productsecurity@keysight.com, or by visiting Keysight's Report a Product 
Cybersecurity Issue page.

Keysight recognizes the importance of documenting memory types and 
sanitization procedures for many of our products. Documents of Volatility (aka 
Letters of Volatility) can be found on the Keysight Instrument Security page.

Acoustic Noise Emission/Geraeuschemission

LpA <70 dB

Operator position

Normal position

per ISO 7779

LpA <70 dB

am Arbeitsplatz

normaler Betrieb

nach DIN 45635 t.19

https://about.keysight.com/en/quality/security
https://about.keysight.com/en/quality/security/report.shtml
https://about.keysight.com/en/quality/security/report.shtml
https://www.keysight.com/find/security
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ARINC 429 Protocol Setup / 351
ARINC 429 Triggering / 354
Interpreting ARINC 429 Decode / 355
Interpreting ARINC 429 Lister Data / 356
Searching for ARINC 429 Data in the Lister / 357

ARINC 429 triggering and protocol decode option is included with the Aerospace 
and Defense Serial Analysis license.

ARINC 429 Protocol Setup

Setup consists of first connecting the oscilloscope to a ARINC 429 signal using a 
differential active probe (the Keysight N2791A is recommended).

To enable ARINC 429 protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

2 From the Mode drop-down list, select ARINC 429.

Below the Mode selection are vertical tabs for specifying Signals and Settings.

NOTE Aerospace protocol decodes (ARINC 429 or MIL-STD-155) and Automotive protocol decodes 
(CAN, LIN, or SENT) cannot be used at the same time. Protocol decode mode choices on 
Protocol2 are limited by the last Aerospace or Automotive protocol decode mode selected on 
Protocol1.
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Signals The ARINC 429 protocol decode mode Signals subtab has these controls for 
setting up the signals:

• Source — Select the channel for the ARINC 429 signal.

Analog channels or digital channels can be used.

The label for the ARINC 429 source channel is automatically set.

• Speed — Specify the speed of the ARINC 429 signal:

• High — 100 kb/s.

• Low — 12.5 kb/s.

• User Defined — Use the User Baud field to enter the user-defined speed value.

• Signal Type — Specify the signal type of the ARINC 429 signal:

• Line A (non-inverted).

• Line B (inverted).

• Differential (A-B).

• Auto Setup — Select to automatically set these options for decoding and 
triggering on ARINC 429 signals:

• High Trigger Threshold: 3.0 V.

• Low Trigger Threshold: -3.0 V.

• Noise Reject: Off.

• Probe Attenuation: 10.0.

• Vertical Scale: 4 V/div.

• Serial Decode: On.

• Base: Hex.

• Word Format: Label/SDI/Data/SSM.

• Trigger: currently active serial bus.

• Trigger Mode: Word Start.

If the high and low thresholds are not set correctly by Auto Setup:

• Use the High Threshold field to set the high trigger threshold voltage level.
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• Use the Low Threshold field to set the low trigger threshold voltage level.

The threshold voltage levels are used in decoding and will become the trigger 
levels when the trigger type is set to the selected serial decode (Protocol 1 or 
Protocol 2).

Settings The ARINC 429 protocol decode mode Settings subtab has these controls for 
decode settings:

• Word Format — Specify the word decode format:

• Label/SDI/Data/SSM:

• Label - 8 bits.

• SDI - 2 bits.

• Data - 19 bits.

• SSM - 2 bits.

• Label/Data/SSM:

• Label - 8 bits.

• Data - 21 bits.

• SSM - 2 bits.

• Label/Data:

• Label - 8 bits.

• Data - 23 bits.

• Base — Select between hexadecimal and binary display of the decoded data.

The base setting is used for data display in both the decode line and in the 
Lister.

Label values are always displayed in octal, and SSM and SDI values are always 
displayed in binary.

Notes • The ARINC 429 triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.
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• If the setup does not produce a stable trigger, the ARINC 429 signal may be 
slow enough that the oscilloscope is Auto triggering. Press the [Mode] key to set 
the trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

ARINC 429 Triggering

To set up the oscilloscope to capture ARINC 429 signals, see "ARINC 429 Protocol 
Setup" on page 351.

After you have set up the oscilloscope to capture ARINC 429 signals, you can then 
set up triggers.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
ARINC 429 or Protocol 2: ARINC 429.

The Trigger dialog box controls unique to the PN: ARINC 429 trigger type are:

• Trigger on: — Selects the ARINC 429 trigger condition:

• Word Start — Triggers on the start of a word.

• Word Stop — Triggers at the end of a word.

• Label — Triggers on the specified label value.

• Label + Bits — Triggers on the label and the other word fields as specified.

• Label Range — Triggers on a label following in a min/max range.

• Parity Error — Triggers on words with a parity error.

• Word Error — Triggers on an intra-word coding error.

• Gap Error — Triggers on an inter-word gap error.

• Word or Gap Error — Triggers on either a Word or Gap Error.

• All Errors — Triggers on any of the above errors.
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• All Bits (Eye) — Triggers on any bit, which will therefore form an eye diagram.

• All 0 Bits — Triggers on any bit with a value of zero.

• All 1 Bits — Triggers on any bit with a value of one.

• If you select the Label or Label + Bits condition, use the Label field to specify the 
label value.

Label values are always displayed in octal.

• If you select the Label + Bits condition, use the Data, SSM, and/or SSM fields to 
enter the 0, 1, or X (don't care) values.

The SSM or SDI fields may not be available, depending on the Word Format 
setting in the Protocol Decode dialog box.

• If you select the Label Range condition, use the Label Min and Label Max fields to 
specify the ends of the range.

Again, label values are always displayed in octal.

Interpreting ARINC 429 Decode

Depending on the selected word decode format, the ARINC 429 decode display is 
color coded as follows:

• When the decode format is Label/SDI/Data/SSM:

• Label (yellow) (8 bits) – displayed in octal.

• SDI (blue) (2 bits) – displayed in binary.
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• Data (white, red if parity error) (19 bits) – displayed in the selected Base.

• SSM (green) (2 bits) – displayed in binary.

• When the decode format is Label/Data/SSM:

• Label (yellow) (8 bits) – displayed in octal.

• Data (white, red if parity error) (21 bits) – displayed in the selected Base.

• SSM (green) (2 bits) – displayed in binary.

• When the decode format is Label/Data:

• Label (yellow) (8 bits) – displayed in octal.

• Data (white, red if parity error) (23 bits) – displayed in the selected Base.

The Label bits are displayed in the same order as they are received on the wire. For 
the Data, SSM, and SDI bits, the fields are displayed in the order received; 
however, the bits within those fields are displayed in reverse order. In other words, 
the non-Label fields are displayed in the ARINC 429 Word Format, while the bits 
for those fields have the opposite transfer order on the wire.

Interpreting ARINC 429 Lister Data

In addition to the standard Time column, the ARINC 429 Lister contains these 
columns:

• Label — the 5-bit label value in octal format.

• SDI — the bit values (if included in the word decode format).

• Data — the data value in binary or hex, depending on the base setting.
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• SSM — the bit values (if included in the word decode format).

• Errors — highlighted in red. Errors can be Parity, Word, or Gap.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for ARINC 429 Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
ARINC 429 data in the Lister (see "Searching Lister Data" on page 132). Then, you 
can use the navigation controls to navigate through the marked rows (see 
"Navigating the Time Base" on page 59).

The Search dialog box controls unique to the PN: ARINC 429 search type selection 
are:

• Search for — Selects the decode value to find:

• Label — Finds the specified label value.

Label values are always displayed in octal.

• Label + Bits — Finds the label and the other word fields as specified.

• Parity Error — Finds words with a parity error.

• Word Error — Finds an intra-word coding error.

• Gap Error — Finds an inter-word gap error.

• Word or Gap Error — Finds either a Word or Gap Error.

• All Errors — Finds any of the above errors.
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CAN triggering and protocol decode option is included with the Automotive Serial 
Analysis license.

CAN/CAN FD Protocol Decode Setup

To enable CAN/CAN FD protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

2 From the Mode drop-down list, select CAN.

Below the Mode selection are vertical tabs for specifying Signals and Settings.

NOTE Aerospace protocol decodes (ARINC 429 or MIL-STD-155) and Automotive protocol decodes 
(CAN, LIN, or SENT) cannot be used at the same time. Protocol decode mode choices on 
Protocol2 are limited by the last Aerospace or Automotive protocol decode mode selected on 
Protocol1.
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Signals Setup consists of connecting the oscilloscope to a CAN signal, using the Signals 
subtab controls to specify the signal source, threshold voltage level, baud rate, 
and sample point.

Connect the oscilloscope to a CAN signal that has a dominant-low polarity. If you 
are connecting to the CAN signal using a differential probe, connect the probe's 
positive lead to the dominant-low CAN signal and connect the negative lead to the 
dominant-high CAN signal.

The CAN protocol decode mode has these controls for setting up the signal:

• Source — Selects the channel for the CAN signal.

The label for the CAN source channel is automatically set.

• Threshold — Specifies the CAN signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the trigger 
level when the trigger type is set to the selected protocol decode bus.

• Signal — Selects the type and polarity of the CAN signal. This also automatically 
sets the channel label for the source channel.

• CAN_H — The actual CAN_H differential bus.

• Differential (H-L) — The CAN differential bus signals connected to an analog 
source channel using a differential probe. Connect the probe's positive lead 
to the dominant-high CAN signal (CAN_H) and connect the negative lead to 
the dominant-low CAN signal (CAN_L).

Dominant low signals:

• Rx — The Receive signal from the CAN bus transceiver.

• Tx — The Transmit signal from the CAN bus transceiver.

• CAN_L — The actual CAN_L differential bus signal.
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• Differential (L-H) — The CAN differential bus signals connected to an analog 
source channel using a differential probe. Connect the probe's positive lead 
to the dominant-low CAN signal (CAN_L) and connect the negative lead to 
the dominant-high CAN signal (CAN_H).

• Std. Rate Settings — :

• Baud — Select the baud rate that matches match your CAN bus signal.

The CAN baud rate can be set to predefined baud rates from 10 kb/s up to 
5 Mb/s or a user-defined baud rate from 10.0 kb/s to 4 Mb/s in increments 
of 100 b/s. Fractional user-defined baud rates between 4 Mb/s and 5 Mb/s 
are not allowed.

The default baud rate is 125 kb/s

If none of the pre-defined selections match your CAN bus signal, select User 
Defined and use the User Baud field to enter the baud rate.

• Sample Point — Select the point between phase segments 1 and 2 where the 
state of the bus is measured. This controls the point within the bit's time 
where the bit value is captured.

• FD Rate Settings — When decoding CAN FD:

• Baud — Select the CAN FD baud rate of the signal from your device under 
test.

If the desired baud rate is not shown in the list, select User Defined and use 
the User Baud field to enter the baud rate.

The CAN FD baud rate can be set to predefined baud rates from 1-10 Mb/s 
or a user-defined baud rate from 10.0 kb/s to 10 Mb/s in increments of 
100 b/s.

If the baud rate you select does not match the CAN FD baud rate, false 
triggers and decoding may occur.

• Sample Point — Specify the sample point.

60%
70%

80%
Sample Point

One Bit

NOTE For standard CAN, only the Standard Rate Settings must be set correctly. For CAN FD, both the 
Standard Rate Settings and the FD Rate Settings must be set correctly.
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The sample point is the point during the bit time where the bit level is 
sampled to determine whether it is dominant or recessive. The sample point 
represents the percentage of time between the beginning of the bit time to 
the end of the bit time.

You may need to adjust the sample point to get a reliable trigger and 
decode, depending on your CAN FD network topology and where the 
oscilloscope probe is located in the network.

• Standard — Select the standard that will be used when decoding or 
triggering on FD frames, ISO, or non-ISO.

This setting has no effect on the processing of non-FD (classical) frames.

• XL Rate Settings — When decoding CAN XL:

• Baud — Select the CAN XL baud rate of the signal from your device under 
test.

If the desired baud rate is not shown in the list, select User Defined and use 
the User Baud field to enter the baud rate.

The CAN XL baud rate can be set to predefined baud rates from 1-10 Mb/s 
or a user-defined baud rate from 10.0 kb/s to 10 Mb/s in increments of 
100 b/s.

If the baud rate you select does not match the CAN XL baud rate, false 
triggers and decoding may occur.

• Sample Point — Specify the sample point.

The sample point is the point during the bit time where the bit level is 
sampled to determine whether it is dominant or recessive. The sample point 
represents the percentage of time between the beginning of the bit time to 
the end of the bit time.

You may need to adjust the sample point to get a reliable trigger and 
decode, depending on your CAN XL network topology and where the 
oscilloscope probe is located in the network.

• Standard — Select the standard that will be used when decoding or 
triggering on FD frames, ISO, or non-ISO.

This setting has no effect on the processing of CAN and CAN FD frames.

Settings The CAN protocol decode mode has these controls for decode settings:

NOTE For CAN XL, the Standard Rate Settings, the FD Rate Settings, and the XL Rate Settings must 
be set correctly.
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• Display — When CAN symbolic information is loaded, you can select between 
Hex and Symbolic display of the decoded data.

Notes • The CAN triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the CAN signal may be slow 
enough that the oscilloscope is Auto triggering. Press the [Mode] key to set the 
trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

See Also • "Loading and Displaying CAN Symbolic Data" on page 363

• "CAN/CAN FD Triggering" on page 364

• "Interpreting CAN/CAN FD Decode" on page 366

• "Interpreting CAN Lister Data" on page 368

• "Searching for CAN Data in the Lister" on page 368

Loading and Displaying CAN Symbolic Data

When you load (recall) a CAN DBC communication database (*.dbc) file into the 
oscilloscope, its symbolic information can be:

• Displayed in the decode waveform and Lister window.

• Used when setting up CAN triggering.

• Used when searching for CAN data in the decode.

To recall a DBC file into the oscilloscope:

1 From the main menu (see page 40), choose File > Open....

2 In the Open dialog box, from the Format drop-down menu, select CAN Symbolic 
data (*.dbc).
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3 From the Load to: drop-down list, select which protocol decode (P1 or P2) the 
symbolic information will be used with.

4 Use the controls in the bottom of the dialog box to select the file to be recalled.

5 Select Open.

A message indicating whether the open was successful is displayed.

The DBC file remains in the oscilloscope until it is overwritten or a secure erase is 
performed.

To display CAN symbolic data:

1 Press [Protocol Decode].

2 In the Settings controls, from the Display drop-down list, select Symbolic (instead 
of Hexadecimal).

Your choice affects both the decode waveform and the Lister window.

CAN/CAN FD Triggering

To set up the oscilloscope to capture a CAN signal, see "CAN/CAN FD Protocol 
Decode Setup" on page 359.

The Controller Area Network (CAN) trigger allows triggering on CAN version 2.0A, 
2.0B, and CAN FD (Flexible Data-rate) signals.

A CAN message frame in CAN_L signal type is shown below:

After setting up the oscilloscope to capture a CAN signal:

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
CAN or Protocol 2: CAN.

The Trigger dialog box controls unique to the PN: CAN trigger type are:

NOTE For CAN FD frames, symbolic decoding is limited to the first eight bytes.

Arbitration
Field

Bus
Idle

Data
Field

SOF edge

Control
Field

ACK
Field

IntermissionCRC
Field

EOF
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• Trigger on: — Selects the trigger condition:

• SOF - Start of Frame — Triggers at the start bit for both data and overload 
frames.

• EOF - End of Frame — Triggers at the end of any frame. *

• Frame ID — Triggers on any standard CAN (data or remote) or CAN FD frame 
at the end of the 11- or 29-bit ID field.

• Data Frame ID (non-FD) — Triggers on standard CAN data frames at the end of 
the 11- or 29-bit ID field.

• Data Frame ID and Data (non-FD) — Triggers on any standard CAN data frame at 
the end of the last data byte defined in the trigger. The DLC of the packet 
must must match the number of bytes specified.

• Data Frame ID and Data (FD) — Triggers on CAN FD frames at the end of the last 
data byte defined in the trigger. You can trigger on up to 8 bytes of data 
anywhere within the CAN FD data, which can be up to 64 bytes long.

• Remote Frame ID — Triggers on standard CAN remote frames at the end of the 
11- or 29-bit ID field.

• Error Frame — Triggers after 6 consecutive 0s while in a data frame, at the 
EOF. *

• Acknowledge Error — Triggers on the acknowledge bit if the polarity is 
incorrect. *

• Form Error — Triggers on reserved bit errors. *

• Stuff Error — Triggers on 6 consecutive 1s or 6 consecutive 0s, while in a 
non-error or non overload frame. *

• CRC Field Error — Triggers when the calculated CRC does not match the 
transmitted CRC. In addition, for FD frames, will also trigger if the Stuff 
Count is in error. *

• Spec Error (Ack or Form or Stuff or CRC) — Triggers on Ack, Form, Stuff, or CRC 
errors. *

• All Errors — Triggers on all Spec errors and error frames. *

• BRS Bit (FD) — Triggers on the BRS bit of CAN FD frames. *

• CRC Delimiter Bit (FD) — Triggers on the CRC delimiter bit in CAN FD frames. *

• ESI Bit Active (FD) — Triggers on the ESI bit if set active. *

• ESI Bit Passive (FD) — Triggers on the ESI bit if set passive. *
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• Overload Frame — Triggers on an overload frame.

* You can optionally qualify the trigger for frames whose ID you specify.

If you select a condition that lets you qualify by ID or trigger on ID or data 
values, select the Filter by ID check box and use the Define, Extended ID, and CAN 
ID controls to specify the ID values.

When CAN symbolic data is loaded into the oscilloscope (see "Loading and 
Displaying CAN Symbolic Data" on page 363), you can trigger on:

• Message — A symbolic message.

• Message and Signal (non-FD) — A symbolic message and a signal value.

• Message and Signal (FD, first 8 bytes only) — A symbolic message and a signal 
value, limited to the first 8 bytes of FD data.

Symbolic messages, signals, and values are defined in the DBC communication 
database file.

A message is the symbolic name for a CAN frame ID, a signal is the symbolic 
name for a bit or set of bits within the CAN data, and a value can be a symbolic 
representation of the signal bit values or it can be a decimal number with units.

Interpreting CAN/CAN FD Decode

The CAN decode display is color coded as follows:

• Blue angled waveforms show an active bus (inside a packet/frame).
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• Blue mid-level lines show an idle bus.

• Frame ID — yellow.

• Data bytes — white hex digits.

• CAN frame type and Data Length Code (DLC) — blue for data frames, green for 
remote frames. The DLC is always a decimal value. CAN frame types can be:

• FD — a CAN FD frame whose bit rate does not switch during the data phase.

• BRS — a CAN FD frame whose bit rate switches during the data phase.

• RMT — a standard CAN remote frame.

• Data — a standard CAN data frame.

The status of the Error State Indicator (ESI) flag is shown in the "Type" column 
of the Lister. If the ESI bit is recessive, indicating error passive, the background 
of the "Type" column will be yellow. If the ESI bit indicates error active, the 
"Type" column's background will be unshaded.

The DLC field will always be displayed in decimal, and will indicate the number 
of bytes in the frame. So for example, for an FD frame that has the DLC code 
0xF, which represents a packet with 64 bytes, "DLC=64" will be displayed on 
the decode line, and "64" will be displayed in the DLC column of the Lister.

• Overload frame — blue with the text "OVRLD". An overload condition may occur 
before an end of frame condition. If so, the frame is closed and opened with 
blue brackets at the start of the overload condition.

• Stuff Count — green hex digit when valid, red when error detected. The hex digit 
shows the gray-coded with parity bit stuff count.

• CRC — blue hex digits when valid, red when error detected.

• Red angled waveforms — Unknown or error condition.

• Flagged error frames — red with "ERR FRAME", "STUFF ERR", "FORM ERR", 
"ACK ERR", "GLITCH ERR", or "?" (unknown).

• Pink vertical bars — Expand horizontal scale (and run again) to see decode.

• Red Dot — More information is available. Decoded text is truncated to fit. 
Expand the horizontal scale to view the information.
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Interpreting CAN Lister Data

In addition to the standard Time column, the CAN Lister contains these columns:

• ID — frame ID. Can be displayed as hex digits or symbolic information (see 
"Loading and Displaying CAN Symbolic Data" on page 363).

• Type — frame type (RMT remote frame or Data).

• DLC — data length code.

• Data — data bytes. Can be displayed as hex digits or symbolic information.

• CRC — cyclic redundancy check.

• Errors — highlighted in red. Errors can be Acknowledge (Ack, A), Form (Fo), or 
Frame (Fr). Different kinds of errors can be combined like "Fo,Fr" in the above 
example.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for CAN Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
CAN data in the Lister (see "Searching Lister Data" on page 132). Then, you can 
use the navigation controls to navigate through the marked rows (see "Navigating 
the Time Base" on page 59).

The Search dialog box controls unique to the PN: CAN search type selection are:
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• Search for — Selects the decode value to find:

• Frame ID — Finds remote or data frames matching the specified ID.

• Data Frame ID — Finds data frames matching the specified ID.

• Data Frame ID and Data — Finds data frames matching the specified ID and 
data.

• Remote Frame ID — Finds remote frames with the specified ID.

• Error Frame — Finds CAN active error frames.

• Acknowledge Error — Finds the acknowledge bit if the polarity is incorrect.

• Form Error — Finds reserved bit errors.

• Stuff Error — Finds 6 consecutive 1s or 6 consecutive 0s, while in a non-error 
or non overload frame.

• CRC Field Error — Finds when the calculated CRC does not match the 
transmitted CRC.

• All Errors — Finds any form error or active error.

• Overload Frame — Finds CAN overload frames.

When CAN symbolic data is loaded into the oscilloscope (see "Loading and 
Displaying CAN Symbolic Data" on page 363), you can search for:

• Message — A symbolic message.

• Message and Signal — A symbolic message and a signal value.
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I2C triggering and protocol decode is included with the Embedded Serial Analysis 
license.

I2C Protocol Decode Setup

To enable I2C protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

2 From the Mode drop-down list, select I2C.

Below the Mode selection are vertical tabs for specifying Signals and Settings.

Signals I2C (Inter-IC bus) signals setup consists of connecting the oscilloscope to the 
serial data (SDA) line and the serial clock (SCL) line and then specifying the input 
signal threshold voltage levels.

The I2C protocol decode mode Signals subtab has these controls for setting up the 
signal:
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• SCL, SDA — Select the channel for the signal.

The SCL and SDA labels for the source channels are automatically set.

• Threshold — Select the signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the trigger 
level when the trigger type is set to the selected serial decode slot.

Data must be stable during the whole high clock cycle or it will be interpreted 
as a start or stop condition (data transitioning while the clock is high).

Settings The I2C protocol decode mode Settings subtab has these controls for decode 
settings:

• Address Size — Choose 7 Bit or 8 Bit address size.

Use 8-bit address size to include the R/W bit as part of the address value, or 
choose 7-bit address size to exclude the R/W bit from the address value.

• Base — Selects between Hex or Binary data value display.

Notes • The I2C triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the I2C signals may be slow 
enough that the oscilloscope is Auto triggering. Press the [Mode] key to set the 
trigger mode from Auto to Trig'd.
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• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

See Also • "I2C Triggering" on page 373

• "Interpreting I2C Decode" on page 376

• "Interpreting I2C Lister Data" on page 377

• "Searching for I2C Data in the Lister" on page 377

I2C Triggering

To set up the oscilloscope to capture I2C signals, see "I2C Protocol Decode Setup" 
on page 371.

After the oscilloscope has been set up to capture I2C signals, you can trigger on a 
stop/start condition, a restart, a missing acknowledge, an EEPROM data read, or 
on a read/write frame with a specific device address and data value.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
I2C or Protocol 2: I2C.

The Trigger dialog box controls unique to the PN: I2C trigger type are:

• Trigger on: — Selects the trigger condition:

• Start Condition — Triggers when SDA data transitions from high to low while 
the SCL clock is high. For triggering purposes (including frame triggers), a 
restart is treated as a start condition.

• Stop Condition — Triggers when data (SDA) transitions from low to high while 
the clock (SCL) is high.
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• Restart — Triggers when another start condition occurs before a stop 
condition.

• Address — triggers on the selected address. The R/W bit is ignored.

• Address with no Ack — The oscilloscope triggers when the acknowledge of the 
selected address field is false. The R/W bit is ignored.

• Write Data with no Ack — Triggers if a write data byte is not acknowledged. 
Note that this trigger mode will not trigger if the ack following the R/W bit is 
missing, but will only trigger on missing acks following data bytes.

• Missing Acknowledge — Triggers when SDA data is high during any Ack SCL 
clock bit.

• EEPROM Data Read — The trigger looks for EEPROM control byte value 
1010xxx on the SDA line, followed by a Read bit and an Ack bit. It then looks 
for the data value and qualifier set by the Data is and Data controls. When 
this event occurs, the oscilloscope will trigger on the clock edge for the Ack 
bit after the data byte. This data byte does not need to occur directly after 
the control byte. The oscilloscope will trigger on any data byte that meets 
the criteria defined by the Data is and Data controls during a current address 
read or a random read or a sequential read cycle.

• Data is — Set the oscilloscope to trigger when data is = (equal to), ≠ (not 
equal to), < (less than), or > (greater than) the data value set in the Data field.

• Frame (Start: Addr7: Read: Ack: Data) or Frame (Start: Addr7: Write: Ack: Data) — 
The oscilloscope triggers on a read or write frame in 7-bit addressing mode 
on the 17th clock edge if all bits in the pattern match. For triggering 
purposes, a restart is treated as a start condition.

• Frame (Start: Addr7: Read: Ack: Data: Ack: Data2) or Frame (Start: Addr7: Write: Ack: 
Data: Ack: Data2) — The oscilloscope triggers on a read or write frame in 7-bit 
addressing mode on the 26th clock edge if all bits in the pattern match. For 
triggering purposes, a restart is treated as a start condition.



I2C Triggering and Protocol Decode 29

Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide 375

 

• 10-bit Write — The oscilloscope triggers on a 10-bit write frame on the 26th 
clock edge if all bits in the pattern match. The frame is in the format:

Frame (Start: Address byte 1: Write: Address byte 2: Ack: Data)

For triggering purposes, a restart is treated as a start condition.

If you have set the oscilloscope to trigger on a 7-bit address read or write frame 
condition or a 10-bit write frame condition:

• Address — Select the 7-bit or 10-bit device address.

You can select from an address range of 0x00 to 0x7F (7-bit) or 0x3FF 
(10-bit) hexadecimal. When triggering on a read/write frame, the 
oscilloscope will trigger after the start, address, read/write, acknowledge, 
and data events occur.

If don't care is selected (0xXX or 0xXXX) for the address, the address will be 
ignored. The trigger will always occur on the 17th clock for 7-bit addressing 
or 26th clock for 10-bit addressing.

• Data — Enter the 8-bit data pattern on which to trigger.

You can select a data value in the range of 0x00 to 0xFF (hexadecimal). The 
oscilloscope will trigger after the start, address, read/write, acknowledge, 
and data events occur.

If don't care (0xXX) is selected for data, the data will be ignored. The trigger 
will always occur on the 17th clock for 7-bit addressing or 26th clock for 
10-bit addressing.

• Data2 — If you have selected a three-byte trigger, enter the 8-bit data 
pattern on which to trigger.
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Interpreting I2C Decode

• Angled waveforms show an active bus (inside a packet/frame).

• Mid-level blue lines show an idle bus.

• In the decoded hexadecimal data:

• Address values appear at the start of a frame.

• Write addresses appear in light-blue along with the "W" character.

• Read addresses appear in yellow along with the "R" character.

• Restart addresses appear in green along with the "S" character.

• Data values appear in white.

• "a" indicates Ack (low), "~a" indicates No Ack (high).

• Decoded text is truncated at the end of the associated frame when there is 
insufficient space within frame boundaries.

• Pink vertical bars indicate you need to expand the horizontal scale (and run 
again) to see decode.

• Red dots in the decode line indicate that more data can be displayed. Scroll or 
expand the horizontal scale to view the data.

• Aliased bus values (undersampled or indeterminate) are drawn in pink.

• Unknown bus values (undefined or error conditions) are drawn in red.
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Interpreting I2C Lister Data

In addition to the standard Time column, the I2C Lister contains these columns:

• Restart — indicated with an "X".

• Address — colored blue for writes, yellow for reads.

• Data — data bytes.

• Missing Ack — indicated by an "X", highlighted in red if an error.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for I2C Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
I2C data in the Lister (see "Searching Lister Data" on page 132). Then, you can use 
the navigation controls to navigate through the marked rows (see "Navigating the 
Time Base" on page 59).

The Search dialog box controls unique to the PN: I2C search type selection are:

• Search for — Selects the decode value to find:

• Restart — Finds when another start condition occurs before a stop condition.

• Address — Finds a packet with the specified address, ignoring the R/W bit.
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• Address with no Ack — Finds when the acknowledge of the selected address 
field is false. The R/W bit is ignored.

• Missing Acknowledge — Finds SDA data is high during any Ack SCL clock bit.

• EEPROM Data Read — Finds EEPROM control byte value 1010xxx on the SDA 
line, followed by a Read bit and an Ack bit. It then looks for the data value 
and qualifier set by the Data is and the Data controls.

• Frame(Start:Address7:Read:Ack:Data) — Finds a read frame on the 17th clock 
edge if all bits in the pattern match.

• Frame(Start:Address7:Write:Ack:Data) — Finds a write frame on the 17th clock 
edge if all bits in the pattern match.

• Frame(Start:Address7:Read:Ack:Data:Ack:Data2) — Finds a read frame on the 
26th clock edge if all bits in the pattern match.

• Frame(Start:Address7:Write:Ack:Data:Ack:Data2) — Finds a write frame on the 
26th clock edge if all bits in the pattern match.
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LIN triggering and protocol decode option is included with the Automotive Serial 
Analysis license.

LIN Protocol Decode Setup

To enable LIN protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

2 From the Mode drop-down list, select LIN.

Below the Mode selection are vertical tabs for specifying Signals and Settings.

NOTE Aerospace protocol decodes (ARINC 429 or MIL-STD-155) and Automotive protocol decodes 
(CAN, LIN, or SENT) cannot be used at the same time. Protocol decode mode choices on 
Protocol2 are limited by the last Aerospace or Automotive protocol decode mode selected on 
Protocol1.
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Signals LIN (Local Interconnect Network) signal setup consists of connecting the 
oscilloscope to a serial LIN signal, specifying the signal source, threshold voltage 
level, baud rate, sample point, and other LIN signal parameters.

The LIN protocol decode mode Signals subtab has these controls for setting up the 
signal:

• Source — Selects the channel for the LIN signal.

The label for the LIN source channel is automatically set.

• Threshold — Specifies the LIN signal threshold voltage level to the middle of the 
LIN signal.

The threshold voltage level is used in decoding, and it will become the trigger 
level when the trigger type is set to the selected protocol decode bus.

• Baud — Select the baud rate that matches match your LIN bus signal.

The default baud rate is 19.2 kb/s.

If none of the pre-defined selections match your CAN bus signal, select User 
Defined and use the User Baud field to enter the baud rate.

You can set the LIN baud rate from 2.4 kb/s to 625 kb/s in increments of 
100 b/s.

• Sample Point — Select the sample point at which the oscilloscope will sample 
the bit value.

• Standard — Select the LIN standard you are measuring:

• LIN 1.3
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• LIN 1.3 (no length control) — Select this for systems where length control is not 
used and all nodes have knowledge of the data packet size. In LIN 1.3, the 
ID may or may not be used to indicate the number of bytes. (In LIN 2.X, there 
is no length control.)

• LIN 2.X

For LIN 1.2 signals, use the LIN 1.3 setting. The LIN 1.3 setting assumes the 
signal follows the "Table of Valid ID Values" as shown in section A.2 of the LIN 
Specification dated December 12, 2002. If your signal does not comply with the 
table, use the LIN 2.X setting.

• Sync Break — Select the minimum number of clocks that define a sync break in 
your LIN signal.

Settings The LIN protocol decode mode Settings subtab has these controls for decode 
settings:

• Show Parity — Choose whether to include the parity bits in the identifier field.

a If you want to mask the upper two parity bits, ensure that the Show Parity 
check box is not selected.

b If you want to include the parity bits in the identifier field, ensure that the 
Show Parity check box is selected.

• Display — When LIN symbolic information is loaded, you can select between Hex 
and Symbolic display of the decoded data.

Notes • The LIN triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the LIN signal may be slow 
enough that the oscilloscope is Auto triggering. Press the [Mode] key to set the 
trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

See Also • "Loading and Displaying LIN Symbolic Data" on page 382
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• "LIN Triggering" on page 382

• "Interpreting LIN Decode" on page 384

• "Interpreting LIN Lister Data" on page 385

• "Searching for LIN Data in the Lister" on page 386

Loading and Displaying LIN Symbolic Data

When you load (recall) a LIN description file (*.ldf) into the oscilloscope, its 
symbolic information can be:

• Displayed in the decode waveform and Lister window.

• Used when setting up LIN triggering.

• Used when searching for LIN data in the decode.

To recall a LIN description file into the oscilloscope:

1 From the main menu (see page 40), choose File > Open....

2 In the Open dialog box, from the Format drop-down menu, select LIN Symbolic 
data (*.ldf).

3 From the Load to: drop-down list, select which protocol decode (P1 or P2) the 
symbolic information will be used with.

4 Use the controls in the bottom of the dialog box to select the file to be recalled.

5 Select Open.

A message indicating whether the open was successful is displayed.

The LIN description file remains in the oscilloscope until it is overwritten or a 
secure erase is performed.

To display LIN symbolic data:

1 Press [Protocol Decode].

2 In the Settings controls, from the Display drop-down list, select Symbolic (instead 
of Hexadecimal).

Your choice affects both the decode waveform and the Lister window.

LIN Triggering

To set up the oscilloscope to capture a LIN signal, see "LIN Protocol Decode 
Setup" on page 379.

A LIN signal message frame is shown below:
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LIN triggering can trigger on the rising edge at the Sync Break exit of the LIN 
single-wire bus signal (that marks the beginning of the message frame), the 
Frame ID, or the Frame ID and Data.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
LIN or Protocol 2: LIN.

The Trigger dialog box controls unique to the PN: LIN trigger type are:

• Trigger on: — Selects the trigger condition:

• Sync (Sync Break) — The oscilloscope triggers on the rising edge at the Sync 
Break exit of the LIN single-wire bus signal that marks the beginning the 
message frame.

• ID (Frame ID) — The oscilloscope triggers when a frame with an ID equal to 
the selected value is detected. Enter the value in the Frame ID field.

• ID & Data (Frame ID and Data) — The oscilloscope triggers when a frame with 
an ID and data equal to the selected values is detected. When triggering on 
a frame ID and data:

• Enter the frame ID value in the Frame ID field.

Note that you can enter a "don't care" value for the frame ID and trigger 
on data values only.

• To set up the number of data bytes and enter their values (in hexadecimal 
or binary), use the remaining fields.

• Parity Error — The oscilloscope triggers on parity errors.

• Checksum Error — The oscilloscope triggers on checksum errors.

When a LIN description file (*.ldf) is loaded (recalled) into the oscilloscope (see 
"Loading and Displaying LIN Symbolic Data" on page 382), you can trigger on:

• Frame (Symbolic) — A symbolic frame value.

Sync
Break

Identifier
Break

Sync Break Exit

Sync
Field

Checksum
Field

Data
Fields
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• Frame and Signal — A symbolic frame value and a signal value.

Symbolic frames, signals, and values are defined in the LIN description file.

A frame is the symbolic name for a LIN frame ID, a signal is the symbolic name 
for a bit or set of bits within the LIN data, and a value can be a symbolic 
representation of the signal bit values or it can be a decimal number with units.

Interpreting LIN Decode

• Angled waveforms show an active bus (inside a packet/frame).

• Mid-level blue lines show an idle bus.

• The hexadecimal ID and parity bits (if enabled) appear in yellow. If a parity error 
is detected the hexadecimal ID and parity bits (if enabled) appear in red.

• Decoded hexadecimal data values appear in white.

• The checksum appears in blue if correct, or red if incorrect.

• Decoded text is truncated at the end of the associated frame when there is 
insufficient space within frame boundaries.

• Pink vertical bars indicate you need to expand the horizontal scale (and run 
again) to see decode.

• Red dots in the decode line indicate that there is data that is not being 
displayed. Scroll or expand the horizontal scale to view the information.

• Unknown bus values (undefined or error conditions) are drawn in red.

• If there is an error in the sync field, SYNC will appear in red.
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• If the header exceeds the length specified in the standard, THM will appear red.

• If the total frame count exceeds the length specified in the standard, TFM will 
appear red (LIN 1.3 only).

• For LIN 1.3 a wakeup signal is indicated by WAKE in blue. If the wakeup signal 
is not followed by a valid wakeup delimiter a wakeup error is detected and 
displayed as WUP in red.

Interpreting LIN Lister Data

In addition to the standard Time column, the LIN Lister contains these columns:

• ID — frame ID. Can be displayed as hex digits or symbolic information (see 
"Loading and Displaying LIN Symbolic Data" on page 382).

• Data — data bytes. Can be displayed as hex digits or symbolic information.

• Checksum.

• Errors — highlighted in red.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.
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Searching for LIN Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
LIN data in the Lister (see "Searching Lister Data" on page 132). Then, you can 
use the navigation controls to navigate through the marked rows (see "Navigating 
the Time Base" on page 59).

The Search dialog box controls unique to the PN: LIN search type selection are:

• Search for — Selects the decode value to find:

• ID — Finds frames with the specified ID. Enter the ID in the Frame ID field.

• ID & Data — Finds frames with the specified ID and data. Enter the ID in the 
Frame ID field. Enter the number of data bytes in the #Bytes field and the byte 
values in the Data field.

• Errors — Finds all errors.
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MIL-STD-1553 triggering and protocol decode option is included with the 
Aerospace and Defense Serial Analysis license.

The MIL-STD-1553 triggering and decode solution supports bi-phase 
MIL-STD-1553 signaling by using dual threshold triggering. The solution supports 
the standard 1553 Manchester II encoding, data rate of 1 Mb/s, and word length 
of 20 bits.

MIL-STD-1553 Protocol Setup

To enable MIL-STD-1553 protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

NOTE Aerospace protocol decodes (ARINC 429 or MIL-STD-155) and Automotive protocol decodes 
(CAN, LIN, or SENT) cannot be used at the same time. Protocol decode mode choices on 
Protocol2 are limited by the last Aerospace or Automotive protocol decode mode selected on 
Protocol1.



388 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

31 MIL-STD-1553 Triggering and Serial Decode
 

2 From the Mode drop-down list, select MIL-STD-1553.

Below the Mode selection are vertical tabs for specifying Signals and Settings.

Signals The MIL-STD-1553 protocol decode mode Signals subtab has these controls for 
setting up the signals:

• Source — Select the channel connected to the MIL-STD-1553 signal line.

Analog channels or digital channels can be used.

The label for the MIL-STD-1553 source channel is automatically set.

• High Threshold and Low Threshold — Enter the high and low trigger threshold 
voltage level.

The threshold voltage levels are used in decoding and will become the trigger 
levels when the trigger type is set to the selected protocol decode bus.

Settings The MIL-STD-1553 protocol decode mode Settings subtab has these controls for 
decode settings:

• Base — Selects between Hex and Binary display of the decoded data.

The base setting is used for the display of the remote terminal address and the 
data, in both the decode line and in the Lister.

• Auto Setup — Select to automatically perform these setup actions:

• Sets the probe attenuation factor of the input Source channel to 10:1.

• Sets upper and lower thresholds to a voltage value equal to ±1/3 division 
based on the current V/div setting.
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If the upper and lower thresholds are not set correctly by Auto Setup, use the 
High Threshold and Low Threshold controls in the Signals subtab to enter the 
correct values.

• Turns off trigger noise reject.

• Turns on Protocol Decode.

• Sets the trigger type to MIL-1553.

Notes • The MIL-STD-1553 triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the MIL-STD-1553 signal may be 
slow enough that the oscilloscope is Auto triggering. Press the [Mode] key to set 
the trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

MIL-STD-1553 Triggering

To set up the oscilloscope to capture MIL-STD-1553 signals, see "MIL-STD-1553 
Protocol Setup" on page 387.

After you have set up the oscilloscope to capture MIL-STD-1553 signals, you can 
then set up triggers.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
MIL-STD-1553 or Protocol 2: MIL-STD-1553.

The Trigger dialog box controls unique to the PN: MIL-STD-1553 trigger type are:

• Trigger on: — Selects the MIL-STD-1553 trigger condition:
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• Data Word Start — Triggers on the start of a Data word (at the end of a valid 
Data Sync pulse).

• Data Word Stop — Triggers on the end of a Data word.

• Command/Status Word Start — Triggers on the start of Command/Status word 
(at the end of a valid C/S Sync pulse).

• Command/Status Word Stop — Triggers on the end of a Command/Status 
word.

• Remote Terminal Address — Triggers if the RTA of the Command/Status word 
matches the specified value.

When this option is selected, the RTA field becomes available and lets you 
select the hex Remote Terminal Address value to trigger on. If you select 
0xXX (don't cares), the oscilloscope will trigger on any RTA.

• Remote Terminal Address + 11 Bits — Triggers if the RTA and the remaining 11 
bits match the specified criteria.

When this option is selected, these fields become available:

• RTA — This field lets you select the hex Remote Terminal Address value.

• Bit Times = — This field lets you select the bit time position value as a 1, 0, 
or X (don't care).

• Parity Error — Triggers if the (odd) parity bit is incorrect for the data in the 
word.

• Sync Error — Triggers if an invalid Sync pulse is found.

• Manchester Error — Triggers if a Manchester encoding error is detected.

Interpreting MIL-STD-1553 Decode

To display serial decode information, you must press [Run] or [Single] after turning 
on protocol decode.
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The MIL-STD-1553 decode display is color coded as follows:

• Command and Status decoded data is colored green, with the Remote Terminal 
Address (5 bits of data) being displayed first, then the text "C/S:", followed by 
the value of the remaining 11 bits of a Command/Status word.

• Data word decoded data is colored white, preceded by the text "D:".

• Command/Status or Data words with a Parity error have the decode text 
displayed in red instead of green or white.

• SYNC errors are displayed with the word "SYNC" within red angle brackets.

• Manchester encoding errors are displayed with the word "MANCH" within blue 
angle brackets (blue instead of red because a valid Sync pulse started the 
word).
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Interpreting MIL-STD-1553 Lister Data

In addition to the standard Time column, the MIL-STD-1553 Lister contains these 
columns:

• RTA — displays the Remote Terminal Address for Command/Status words, 
nothing for Data words.

• Word Type — "Cmd/Status" for Command/Status words, "Data" for Data words. 
For Command/Status words the background color is green to match the 
decode text color.

• Data — the 11 bits after the RTA for Command/Status words, or the 16 bits of a 
Data word.

• Errors — "Sync", "Parity", or "Manchester" errors as appropriate. The 
background color is red to indicate an error.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for MIL-STD-1553 Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
MIL-STD-1553 data in the Lister (see "Searching Lister Data" on page 132). Then, 
you can use the navigation controls to navigate through the marked rows (see 
"Navigating the Time Base" on page 59).
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The Search dialog box controls unique to the PN: MIL-STD-1553 search type 
selection are:

• Search for — Selects the decode value to find:

• Data Word Start — Finds the start of a Data word (at the end of a valid Data 
Sync pulse).

• Command/Status Word Start — Finds the start of Command/Status word (at 
the end of a valid C/S Sync pulse).

• Remote Terminal Address — Finds the Command/Status word whose RTA 
matches the specified value. The value is specified in hex.

When this option is selected, the RTA field becomes available and lets you 
select the hex Remote Terminal Address value to find.

• Remote Terminal Address + 11 Bits — Finds the RTA and the remaining 11 bits 
that match the specified criteria.

When this option is selected, these fields become available:

• RTA — This field lets you select the hex Remote Terminal Address value.

• Bit Times = — This field lets you select the bit time position value as a 1, 0, 
or X (don't care).

• Parity Error — Finds (odd) parity bits that are incorrect for the data in the 
word.

• Sync Error — Finds invalid Sync pulses.

• Manchester Error — Finds Manchester encoding errors.
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SENT (Single Edge Nibble Transmission) triggering and protocol decode option is 
included with the Automotive Serial Analysis license.

SENT Protocol Setup

To enable SENT protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

2 From the Mode drop-down list, select SENT.

Below the Mode selection are vertical tabs for specifying Signals, Bus Config, and 
Settings.

NOTE Aerospace protocol decodes (ARINC 429 or MIL-STD-155) and Automotive protocol decodes 
(CAN, LIN, or SENT) cannot be used at the same time. Protocol decode mode choices on 
Protocol2 are limited by the last Aerospace or Automotive protocol decode mode selected on 
Protocol1.
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Signals The SENT protocol decode mode Signals subtab has these controls for setting up 
the signals:

• Source — Select the channel for the signal.

Analog channels or digital channels can be used.

• Threshold — Select the signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the trigger 
level when the trigger type is set to the selected serial decode (Protocol 1 or 
Protocol 2).

Bus Config The SENT protocol decode mode Bus Config subtab has these controls for setting 
up the bus configuration:

• Clock Period — Specify the nominal clock period (tick) time.

• Tolerance — Specify the percent tolerance for determining whether the sync 
pulse is valid for decoding the data.

If the measured time of the sync pulse is within the percent tolerance of the 
nominal clock period setting, the decode proceeds; otherwise, the sync pulse is 
in error, and the data is not decoded.

• # of Nibbles — Specify the number of nibbles in a Fast Channel Message.

• Idle State — Specify the idle state of the SENT signal.

• CRC Format — Specify the CRC format that will be used in calculating the 
correctness of the CRCs.
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Enhanced Serial Message CRCs are always calculated using the 2010 format, 
but for the Fast Channel Messages, and for Short Serial Message CRCs, the 
chosen setting is used.

• Pause Mode — Specify whether there is a pause pulse between Fast Channel 
Messages:

• Off — There is no pause pulse between Fast Channel Messages.

Note that a SENT serial bus with no pause pulse is never idle. This means, 
during normal operation, the fast channel decode line will show a 
continuous stream of packets, with a new packet opening as soon as the 
previous one has closed.

• On — Pause pulses are added between Fast Channel Messages so that 
frames come at a regular interval.

If there is a pause pulse (and Pause Pulse is on), idle time is shown between 
messages.

• SPC (Short PWM Code) — In SENT SPC, there are no pause pulses. Instead, 
the message event is triggered by the master when it wants to receive data. 
SENT SPC ends the transmission after the CRC so it almost appears as if 
there is a pause pulse from the end until the next master trigger.

Settings The SENT protocol decode mode Settings subtab has these controls for decode 
settings:

• Message Format — Select the message decode/triggering format:

• Fast Nibbles (All) — Displays the raw transmitted nibble values. Raw 
transmitted nibble values are displayed in the order received.

• Fast Signals — Displays Fast Channel Message Signals.

• Fast + Short Serial — Displays both Fast and Slow Messages (Short format) 
simultaneously.

• Fast + Enhanced Serial — Displays both Fast and Slow Messages (Enhanced 
format) simultaneously.
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• Short Serial — Displays Slow Channel Messages in Short format.

• Enhanced Serial — Displays Slow Channel Messages in Enhanced format.

This selection affects both decoding and triggering. The decode is affected 
both in how the system interprets the data, and what will be displayed. The 
trigger is affected in that the trigger hardware needs to be configured to trigger 
on serial messages correctly.

Slow Channel Serial Messages are always displayed as defined by the SENT 
specification.

• Display — Select between Hexadecimal, Unsigned decimal, or the Transfer Function 
display of Fast Channel nibbles, signals, and CRC values, as well as Slow 
Channel IDs, data, and CRC values. (The S&C value is always displayed in 
binary.)

Your selection is used for both the Lister and the decode line displays.

When Transfer Function is selected, the CRC and Slow Channel information is 
displayed in hex.

When one of the Fast Signal message formats is selected (Fast Signals, Fast + Short 
Serial, or Fast + Enhanced Serial), these additional controls appear:

• Fast Signals — Select the Fast Signal (Signal 1 through Signal 6) to be defined 
with the lower Fast Signals controls:

• On — Enable or disable decode for the selected signal.

• Start Bit # (MSB) — Specify the starting bit for the selected signal.

• # of Bits — Specify the number of bits in the selected signal.

• Nibble Order — Specify the nibble display order as either most significant 
nibble (MSN) or least significant nibble (LSN) first.

• Multiplier, Offset — When the Display selection is Transfer Function, the 
multiplier and offset values are used in calculating a physical value 
displayed for the Fast Signal:

• PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Here are some Fast Signal definition examples:

NOTE For the Slow Channel, the proper format, Short Serial or Enhanced Serial, must be chosen for 
proper decoding and triggering to occur.
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Notes • The SENT triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the SENT signal may be slow 
enough that the oscilloscope is Auto triggering. Press the [Mode] key to set the 
trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

SENT Triggering

To set up the oscilloscope to capture SENT signals, see "SENT Protocol Setup" on 
page 395.

After you have set up the oscilloscope to capture SENT signals, you can then set 
up triggers.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
SENT or Protocol 2: SENT.

The Trigger dialog box controls unique to the PN: SENT trigger type are:

Example 1: Start Bit # = 13, # of bits = 8, Nibble Order = LSN First

15

Result bits:

Message data:

Example 2: Start Bit # = 10, # of bits = 5, Nibble Order = MSN First

14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

13 1211 10 9 87 6

15

Result bits:

Message data: 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

10 9 8 7 6
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• Trigger on: — Selects the SENT trigger condition:

• Start of Fast Channel Message — Triggers on the start of any Fast Channel 
Message (after 56 Synchronization/Calibration ticks).

• Start of Slow Channel Message — Trigger on the start of any Slow Channel 
Message.

• Fast Channel SC & Data — triggers on a Fast Channel Message when the 
Status & Communication nibble and the data nibbles match the values 
entered using additional controls.

• Slow Channel Message ID — Triggers when a Slow Channel Message ID 
matches the value entered using additional controls.

• Slow Channel Message ID & Data — Triggers when a Slow Channel Message ID 
and Data field both match the values entered using additional controls.

• Tolerance Violation — Triggers when the sync pulse width varies from the 
nominal value by greater than the entered percentage.

• Fast Channel CRC Error — Triggers on any Fast Channel Message CRC error.

• Slow Chanel CRC Error — Triggers on any Slow Channel Message CRC error.

• All CRC Errors — Triggers on any CRC error, Fast or Slow.

• Pulse Period Error — Triggers if a nibble is either too wide or too narrow (for 
example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, 
or checksum pulse periods are checked.

• Successive Sync Pulses Error (1/64) — Triggers on a sync pulse whose width 
varies from the previous sync pulse's width by greater than 1/64 (1.5625%, 
as defined in the SENT specification).

• If you choose the Fast Channel SC & Data trigger condition, you get these 
additional controls:

• Base — Select between Hex or Binary data value entry.

Use the Binary method if you need to enter "don't care" bits (X) within a 
nibble. If all bits in a nibble are "don't care", the hex nibble is displayed as 
"don't care" (X). When all bits in a nibble are 1s or 0s, the hex value is shown. 
Hex nibbles that contain a mix of 0/1 bits and "don't care" bits are displayed 
as "$".

• SC & Data — Enter the data value.

The S&C nibble is the left most nibble entered in the string of numbers, 
followed by the data nibbles.
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• If you choose the Slow Channel Message ID or Slow Channel Message ID & Data 
trigger condition, you get these additional controls:

• Configuration — Select the desired packet ID for the selected packet type.

When an Enhanced Serial message format is specified (see "SENT Protocol 
Setup" on page 395), use this control to select which enhanced format 
configuration is being used:

• 16-Bit Data, 4-Bit ID

• 12-Bit Data, 8-Bit ID

• Slow Message ID — Specify the Slow Message ID.

• Slow Data (for the Slow Channel Message ID & Data trigger condition) — Specify 
the Slow Message data.

• If you choose the Tolerance Violation trigger condition, you get these additional 
controls:

• Tolerance — Specify the tolerance variation that is considered a violation.

The percentage entered must be less than the percent tolerance specified in 
the decode bus configuration settings.

Interpreting SENT Decode

The fields of the Fast and Slow Channels are displayed as follows. Note that the 
Slow Channel has three different variants. The colors noted below indicate the 
color of the text:

• Fast Channel:
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• Status & Communication (S&C) Nibble (green) (4 bits):

• 2 Application bits and 2 Serial Message bits will be displayed, in all 
formats.

• Data Nibbles (white) (4 bits, but may be combined into Signals, based on 
format):

• "Fast Nibbles (All)" format — each nibble displayed as hex or decimal 
number.

• "Fast Signals", "Fast + Short Serial", or "Fast + Enhanced Serial" formats — If 
any fast signals are enabled, signals are displayed like:

• S1:<value>;S2:<value>.

• Unused nibbles are not displayed (example, when 6th nibble is an 
inverted copy of the 1st nibble).

• CRC Nibble (blue when valid, red when error detected) (4 bits).

• Slow Channel – Short Serial Message:

• Message ID (yellow) (4 bits).

• Data Byte (white) (8 bits).

• CRC (blue when valid, red when error detected) (4 bits).
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• Slow Channel – Enhanced Serial Message:

• CRC (blue when valid, orange if end of message is off screen, red when error 
detected) (6 bits).

• Message ID (yellow) (4 or 8 bits).

• Data Field (white) (16 or 12 bits).

Enhanced Serial Message CRCs will be displayed in orange if the data to calculate 
the CRC is off-screen to the right. Serial messages will also be shown with a 
leading idle line in orange and an opening brace in orange if the starting location 
cannot be precisely determined due to that data being off screen to the left.

The decode will also indicate errors where a nibble's pulse is too wide or too 
narrow. This will be indicated by a ">" or "<" in red, as well as the rest of the 
packet's outline and closing brace being in red, as well as an orange idle line until 
the next valid sync. At the time of the valid sync, there will be an orange opening 
brace.
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Interpreting SENT Lister Data

Each Fast or Slow Channel message is represented on its own row. The start time 
of Slow Channel messages determines their order relative to the Fast Channel 
messages. Therefore, a Slow Channel message appears before most of the Fast 
Channel messages that it was built from. This is due to the "Time" column holding 
the start time of a packet.

In addition to the standard Time column, the following columns are used to 
support both the Fast Channel and the Slow Channel simultaneously, and these 
columns are displayed for all Message Format modes except Fast Nibbles (All):

• S&C — (Fast Channel Only) (binary).

• ID — (Slow Channel Only) (Hex or Decimal).

• Data — (Hex or Decimal):

• Fast Channel:

• <value> (value in Hex or Decimal) (Raw Decode Format).

• S1:<value>;S2:<value> (values are in Hex or Decimal) (other formats).

• Slow Channel: Hex or Decimal display of a single value.

• CRC — (value in Hex or Decimal).

• Pause Ticks (ticks will be displayed in orange if the uncertainty of the 
measurement is > 25%).

• Errors.
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When the Message Format is set to Fast Nibbles (All), the following columns are 
displayed:

• Sync Width.

• S&C — (Fast Channel Only) (binary).

• Data — (Hex or Decimal).

• CRC — (value in Hex or Decimal).

• Errors.

When the selected Message Format contains both Fast and Slow Channel 
Messages, the S&C Lister field (populated for Fast Messages) has a green 
background, and the ID Lister field (populated for Slow Messages) has a yellow 
background.

Slow Channel CRC values that cannot be confirmed as valid or invalid due to data 
used in the calculation being off screen to the right, will have an orange 
background in the Lister.

Searching for SENT Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
SENT data in the Lister (see "Searching Lister Data" on page 132). Then, you can 
use the navigation controls to navigate through the marked rows (see "Navigating 
the Time Base" on page 59).

The Search dialog box controls unique to the PN: SENT search type selection are:

• Search for — Selects the decode value to find:

• Fast Channel Data — Finds Fast Channel data nibbles that match the values 
entered using additional controls.

• Slow Channel Message ID — Finds Slow Channel Message IDs that match the 
value entered using additional controls.

• Slow Channel Message ID & Data — Finds Slow Channel Message IDs and Data 
that match the values entered using additional controls.

• All CRC Errors — Finds any CRC error, Fast or Slow.

• Pulse Period Error — Finds where a nibble is either too wide or too narrow (for 
example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, 
or checksum pulse periods are checked.
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SPI triggering and protocol decode is included with the Embedded Serial Analysis 
license.

SPI Protocol Setup

To enable SPI protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

2 From the Mode drop-down list, select SPI.

Below the Mode selection are vertical tabs for specifying Signals and Settings.

NOTE Only one SPI serial bus can be decoded at a time.
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Signals Serial Peripheral Interface (SPI) signals setup consists of: connecting the 
oscilloscope to a clock, MOSI data, MISO data, and framing signal, then setting 
the threshold voltage level for each input channel, and finally specifying any other 
signal parameters.

The SPI protocol decode mode Signals subtab has these controls for setting up the 
signals:

• Clock, Threshold, Polarity — For the SPI clock signal:

• Select the channel connected to the SPI serial clock line.

The CLK label for the source channel is automatically set.

• Enter the clock signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode slot.

• Select the  Rising or  Falling edge for the selected Clock source.

This determines which clock edge the oscilloscope will use to latch the serial 
data.

• MOSI, Threshold — For the SPI Master-Out Slave-In signal:

• Select the channel that is connected to a SPI serial data line. (If the channel 
you selected is off, switch it on.)

The MOSI label for the source channel is automatically set.

• Enter the MOSI signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode slot.

• MISO, Threshold, Delay — (Optional) For the the SPI Master-In Slave-Out signal:

• Select the channel that is connected to a second SPI serial data line. (If the 
channel you selected is off, switch it on.)

The MISO label for the source channel is automatically set.
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• Enter the MISO signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode slot.

• Select the number of bits to ignore (delay) before decoding the MISO 
stream.

• Frame by — Select a framing signal that the oscilloscope will use for determining 
which clock edge is the first clock edge in the serial stream.

You can set the oscilloscope to trigger during a high chip select (CS), a low chip 
select (~CS), or after a Timeout period during which the clock signal has been 
idle.

• If the framing signal is set to CS (or ~CS), the first clock edge as defined, 
rising or falling, seen after the CS (or ~CS) signal transitions from low to high 
(or high to low) is the first clock in the serial stream.

CS or ~CS — Select the channel that is connected to the SPI frame line.

The label (~CS or CS) for the source channel is automatically set. The data 
pattern and the clock transition must occur during the time when the 
framing signal is valid. The framing signal must be valid for the entire data 
pattern.

Threshold — Enter the chip select signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode slot.

• If the framing signal is set to Timeout, the oscilloscope generates it's own 
internal framing signal after it sees inactivity on the serial clock line.

Timeout — Set the minimum time that the Clock signal must be idle (not 
transitioning) before the oscilloscope will search for the Data pattern on 
which to trigger.

The Timeout value can be set anywhere from 100 ns to 10 s.

Settings The SPI protocol decode mode has these controls for decode settings:

• Word Size — Enter the number of bits in a word.
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• Bit Order — Select the bit order, most significant bit first (MSB) or least 
significant bit first (LSB), used when displaying data in the serial decode 
waveform and in the Lister.

Notes • The SPI triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the SPI signals may be slow 
enough that the oscilloscope is Auto triggering. Press the [Mode] key to set the 
trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

SPI Triggering

To set up the oscilloscope to capture SPI signals, see "SPI Protocol Setup" on 
page 407.

After the oscilloscope has been set up to capture SPI signals, you can then trigger 
on a data pattern that occurs at the start of a frame. The serial data string can be 
specified to be from 4 to 32 bits long.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
SPI or Protocol 2: SPI.

The Trigger dialog box controls unique to the PN: SPI trigger type are:

• Trigger Type — Selects the trigger condition:

• Master-Out, Slave-In (MOSI) Data — Triggers on the MOSI data signal.

• Master-In, Slave-Out (MISO) Data — Triggers on the MISO data signal.

• Base — Selects between Hex or Binary data value entry.

The entered data value appears in both binary and hex formats in a separate 
dialog.
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Use the Binary method if you need to enter "don't care" bits (X) within a nibble. 
If all bits in a nibble are "don't care", the hex nibble is displayed as "don't care" 
(X). When all bits in a nibble are 1s or 0s, the hex value is shown. Hex nibbles 
that contain a mix of 0/1 bits and "don't care" bits are displayed as "$".

• #Bits — Enter the number of bits in the serial data string.

The number of bits in the string can be set anywhere from 4 bits to 64 bits. The 
data values for the serial string are displayed in the MOSI/MISO Data string in 
the waveform area.

• MOSI Data or MISO Data — Enter bit values of 0 (low), 1 (high), or X (don't care).

The data value is left-justified in the frame when setting up the trigger. If the 
base is Hex, the first digit represents the first 4 bits after the start of frame, 
continuing with the remaining digits in the data value.

Interpreting SPI Decode

• Angled waveforms show an active bus (inside a packet/frame).

• Mid-level blue lines show an idle bus.

• The number of clocks in a frame appears in light-blue above the frame, to the 
right.

• Decoded hexadecimal data values appear in white.

• Decoded text is truncated at the end of the associated frame when there is 
insufficient space within frame boundaries.
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• Pink vertical bars indicate you need to expand the horizontal scale (and run 
again) to see decode.

• Red dots in the decode line indicate that there is data that is not being 
displayed. Scroll or expand the horizontal scale to view the information.

• Aliased bus values (undersampled or indeterminate) are drawn in pink.

• Unknown bus values (undefined or error conditions) are drawn in red.

Interpreting SPI Lister Data

In addition to the standard Time column, the SPI Lister contains these columns:

• Data — data bytes (MOSI and MISO).

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for SPI Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
SPI data in the Lister (see "Searching Lister Data" on page 132). Then, you can use 
the navigation controls to navigate through the marked rows (see "Navigating the 
Time Base" on page 59).

The Search dialog box controls unique to the PN: SPI search type selection are:



SPI Triggering and Protocol Decode 33

Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide 413

 

• Search for — Selects the decode value to find:

• Master-Out, Slave-In (MOSI) Data — Finds MOSI data.

• Master-In, Slave-Out (MISO) Data — Finds MISO data.

• Words — Enter the number of words in the data value.

• Data — Enter the hexadecimal data value.

The search pattern is always left-justified in the packet. If you want to search 
for a value in the second or higher word, increase the Words count and enter 
don't cares ('X's) for the earlier words.
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UART/RS232/422/485 triggering and protocol decode is included with the 
Embedded Serial Analysis license.

UART/RS232/422/485 Protocol Decode Setup

To enable UART/RS232/422/485 protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the P1 or P2 tab (the oscilloscope can decode two protocols at 
the same time), and select On.

2 From the Mode drop-down list, select UART/RS232.

Below the Mode selection are vertical tabs for specifying Signals, Bus Config, and 
Settings.

Signals The UART/RS232/422/485 protocol decode mode Signals subtab has these 
controls for setting up the signals:
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• Rx, Tx — Selects the analog or digital channels that are probing the receive and 
transmit signals.

The RX and TX labels for the source channels are automatically set.

• Threshold — Sets the threshold voltage levels for the receive and transmit 
signals.

The threshold voltage level is used in decoding and will become the trigger 
level when the trigger type is set to the selected serial decode bus.

Bus Config The UART/RS232/422/485 protocol decode mode Bus Config subtab has these 
controls for setting up the bus configuration:

• # of Bits — Sets the number of bits in the UART/RS232 words to match your 
device under test (selectable from 5-9 bits).

• Parity — Selects Odd, Even, or None as the parity being used in your device under 
test.

• Baud — Selects the baud rate of the signals in your device under test. You can 
select baud rates from 1.2 kb/s to 12 Mb/s.

If the desired baud rate is not listed, select User Defined; then, enter the desired 
baud rate in the User Baud field. You can set the user-defined UART baud rate 
from 200 b/s to 8.0000 Mb/s.

• Polarity — Selects Idle low or Idle high to match your device under test's state 
when at idle. For RS232 select Idle low.
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• Bit Order — Selects whether the most significant bit, MSB, or the least significant 
bit, LSB, is presented after the start bit in the signal from your device under test. 
For RS232 select LSB.

Settings The UART/RS232/422/485 protocol decode mode Settings subtab has these 
controls for decode settings:

• Base — Select the base, Hex, Binary, or ASCII, in which decoded words are 
displayed.

• When displaying words in ASCII, the 7-bit ASCII format is used. Valid ASCII 
characters are between 0x00 and 0x7F. To display in ASCII you must select 
at least 7 bits in the Bus Configuration. If ASCII is selected and the data 
exceeds 0x7F, the data is displayed in hex.

• When # of Bits is set to 9 in the Bus Configuration, the 9th (alert) bit is 
displayed directly to the left of the ASCII value (which is derived from the 
lower 8 bits).

• Framing — Enter a value that will be displayed in light blue in the decode 
display. A parity error overrides this setting and displays in red.

Notes • The UART/RS232/422/485 triggering and serial decode option is 
license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the UART/RS232 signals may be 
slow enough that the oscilloscope is Auto triggering. Press the [Mode] key to set 
the trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

NOTE In the serial decode display, the most significant bit is always displayed on the left regardless 
of how Bit Order is set.
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See Also • "UART/RS232/422/485 Triggering" on page 418

• "Interpreting UART/RS232/422/485 Decode" on page 420

• "Interpreting UART/RS232/422/485 Lister Data" on page 421

• "Searching for UART/RS232/422/485 Data in the Lister" on page 421

UART/RS232/422/485 Triggering

To trigger on a UART (Universal Asynchronous Receiver/Transmitter) signal, 
connect the oscilloscope to the Rx and Tx lines and set up a trigger condition. 
RS232 (Recommended Standard 232) is one example of a UART protocol.

To set up the oscilloscope to capture UART/RS232/422/485 signals, see 
"UART/RS232/422/485 Protocol Decode Setup" on page 415.

After you have set up the oscilloscope to capture UART/RS232/422/485 signals, 
you can then set up triggers.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1: 
UART/RS232 or Protocol 2: UART/RS232.

The Trigger dialog box controls unique to the PN: UART/RS232 trigger type are:

• Trigger — Selects the trigger condition:

• Rx Start Bit, Tx Start Bit — The oscilloscope triggers when a start bit occurs on 
Rx, Tx.

• Rx Stop Bit, Tx Stop Bit — Triggers when a stop bit occurs on Rx, Tx. The trigger 
will occur on the first stop bit. This is done automatically whether the device 
under test uses 1, 1.5, or 2 stop bits. You do not need to specify the number 
of stop bits used by the device Under test.

• Rx Data, Tx Data — Triggers on a data byte that you specify. For use when the 
device under test data words are from 5 to 8 bits in length (no 9th (alert) bit).

• Rx 1:Data, Tx 1:Data — For use when the device under test data words are 9 
bits in length including the alert bit (the 9th bit). Triggers only when the 9th 
(alert) bit is 1. The specified data byte applies to the least significant 8 bits 
(excludes the 9th (alert) bit).
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• Rx 0:Data, Tx 0:Data — For use when the device under test data words are 9 
bits in length including the alert bit (the 9th bit). Triggers only when the 9th 
(alert) bit is 0. The specified data byte applies to the least significant 8 bits 
(excludes the 9th (alert) bit).

• Rx X:Data, Tx X:Data — For use when the device under test data words are 9 
bits in length including the alert bit (the 9th bit). Triggers on a data byte that 
you specify regardless of the value of the 9th (alert) bit. The specified data 
byte applies to the least significant 8 bits (excludes the 9th (alert) bit).

• Rx Parity Error, Tx Parity Error — Triggers on a parity error when parity is set in 
the bus configuration.

When you select a trigger condition that includes "Data" (for example: Rx Data):

• Data is — Selects an equality qualifier. You can choose = (Equal), 
≠ (Not equal), < (Less than), or > (Greater than) a specific data value.

• Data — Specifies the data value.

• Base — Selects the format in which you would like to enter data values to trigger 
on, Hex or ASCII.

Note that this setting does not affect the base used in the decode display.

• Burst — Lets you trigger on the Nth frame (1-4096) after an Idle time you enter. 
All trigger conditions must be met for the trigger to occur.

Idle times from 1 µs to 10 s can be entered. The oscilloscope will look for a 
trigger condition only after the Idle time has past.
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Interpreting UART/RS232/422/485 Decode

• Angled waveforms show an active bus (inside a packet/frame).

• Mid-level blue lines show an idle bus.

• When using 5-8 bit formats, the decoded data is displayed in white (in binary, 
hex, or ASCII).

• When using the 9 bit format, all data words are displayed in green, including 
the 9th bit. The 9th bit is displayed on the left.

• When a data word value is selected for framing, it is displayed in light blue. 
When using 9-bit data words, the 9th bit will also be displayed in light blue.

• Decoded text is truncated at the end of the associated frame when there is 
insufficient space within frame boundaries.

• Pink vertical bars indicate you need to expand the horizontal scale (and run 
again) to see decode.

• When the horizontal scale setting does not permit the display of all available 
decoded data, red dots will appear in the decoded bus to mark the location of 
hidden data. Expand the horizontal scale to allow the data to display.

• An unknown (undefined) bus is shown in red.

• A parity error will cause the associated data word to be shown in red, which 
includes the 5-8 data bits and the optional 9th bit.
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Interpreting UART/RS232/422/485 Lister Data

In addition to the standard Time column, the UART/RS232 Lister contains these 
columns:

• Rx — receive data.

• Tx — transmit data.

• Errors — highlighted in red, Parity Error or Unknown Error.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for UART/RS232/422/485 Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
UART/RS232/422/485 data in the Lister (see "Searching Lister Data" on 
page 132). Then, you can use the navigation controls to navigate through the 
marked rows (see "Navigating the Time Base" on page 59).

The Search dialog box controls unique to the PN: UART/RS232 search type selection 
are:

• Search for — Selects the decode value to find:

• Rx Data — Finds a data byte that you specify. For use when the DUT data 
words are from 5 to 8 bits in length (no 9th (alert) bit).
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• Rx 1:Data — For use when the DUT data words are 9 bits in length including 
the alert bit (the 9th bit). Finds only when the 9th (alert) bit is 1. The 
specified data byte applies to the least significant 8 bits (excludes the 9th 
(alert) bit)

• Rx 0:Data — For use when the DUT data words are 9 bits in length including 
the alert bit (the 9th bit). Finds only when the 9th (alert) bit is 0. The 
specified data byte applies to the least significant 8 bits (excludes the 9th 
(alert) bit).

• Rx X:Data — For use when the DUT data words are 9 bits in length including 
the alert bit (the 9th bit). Finds a data byte that you specify regardless of the 
value of the 9th (alert) bit. The specified data byte applies to the least 
significant 8 bits (excludes the 9th (alert) bit).

• Similar choices are available for Tx.

• Rx Parity Error, Tx Parity Error — Finds a parity error based on the parity you 
have set in the Bus Configuration Menu.

• Rx or Tx Any Error — Finds any error.
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USB 2.0 triggering and protocol decode is included with the USB Serial Analysis 
license.

USB 2.0 Protocol Decode Setup

To enable USB 2.0 protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the Protocol1 or Protocol2 tab (the oscilloscope can decode two 
protocols at the same time), and select On.

2 From the Mode drop-down list, select USB.

Below the Mode selection are vertical tabs for specifying Signals and Settings.

Signals The USB 2.0 protocol decode mode Signals subtab has these controls for setting 
up the signals:
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• D+ Source, D- Source — Selects the analog or digital channels that are probing 
the D+ and D- signals.

The labels for the source channels are automatically set.

• Threshold — Sets the threshold voltage levels for the D+ and D- signals.

The threshold voltage level is used in decoding and will become the trigger 
level when the trigger type is set to the selected protocol decode bus.

• Auto Setup — Select to automatically set these options for decoding and 
triggering on USB signals:

• Low-speed:

• D+/- Source thresholds: 1.4 V

• D+/- Source vertical scale: 1.0 V/div

• D+/- Source vertical offset: 0.0 V

• Horizontal scale: 5 µs/div

• Full-speed:

• D+/- Source thresholds: 1.4 V

• D+/- Source vertical scale: 1.0 V/div

• D+/- Source vertical offset: 0.0 V

• Horizontal scale: 500 ns/div

• High-speed:

• D+/- Source thresholds: 0.0 V

• D+/- Source vertical scale: 200 mV/div

• D+/- Source vertical offset: 0.0 V

• Horizontal scale: 20 ns/div

• Protocol Decode: On

• Trigger Mode: currently active protocol decode bus

• USB Trigger Mode: Start of Packet

Settings The USB 2.0 protocol decode mode Settings subtab has these controls for decode 
settings:
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• Speed — Specify the speed of the USB signal:

• Low (1.5 Mb/s) — requires two single-ended probes.

• Full (12 Mb/s) — requires two single-ended probes.

• High (480 Mb/s) — requires a differential probe.

Analog channels can be used for any of these speeds. Digital channels can be 
used for Low and Full speed only.

• Base for Data — Select the base (hex, binary, ASCII, or decimal) in which decoded 
data is displayed.

Notes • The USB 2.0 triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the USB 2.0 signals may be slow 
enough that the oscilloscope is Auto triggering. Press the [Mode] key to set the 
trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

See Also • "USB 2.0 Triggering" on page 425

• "Interpreting USB 2.0 Decode" on page 427

• "Interpreting USB 2.0 Lister Data" on page 429

• "Searching for USB 2.0 Data in the Lister" on page 430

USB 2.0 Triggering

To trigger on a USB 2.0 signal, connect the oscilloscope to the D+ and D- lines 
and set up a trigger condition.

To set up the oscilloscope to capture USB 2.0 signals, see "USB 2.0 Protocol 
Decode Setup" on page 423.
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After you have set up the oscilloscope to capture USB 2.0 signals, you can then set 
up triggers.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1 
or Protocol 2.

The Trigger dialog box controls unique to the USB 2.0 trigger type are:

• Trigger — Selects the USB packet, error, or event to trigger on:

• SOP - Start of Packet — Triggers on the sync bit at the beginning of the packet 
(low and full speed only).

• EOP - End of Packet — Triggers at the end of the SE0 portion of the EOP (low 
and full speed only).

• Suspend — Triggers when the bus is idle for > 3 ms (low and full speed only).

• Resume — Triggers when exiting an idle state > 10 ms (low and full speed 
only).

• Reset — Triggers when SE0 is > 10 ms (low and full speed only).

• Token Packet — Triggers when a token packet with the specified content is 
detected.

• Data Packet — Triggers when a data packet with the specified content is 
detected.

• Handshake Packet — Triggers when a handshake packet with the specified 
content is detected.

• Special Packet — Triggers when a special packet with the specified content is 
detected.

• All Errors — Triggers when any of the following errors are detected.

• PID Error — Triggers when the packet type field does not match the check 
field.

• CRC5 Error — Triggers when a 5 bit CRC error is detected.

• CRC16 Error — Triggers when a 16 bit CRC error is detected.

• Glitch Error — Triggers when two transitions occur in half a bit time.

• Bit Stuff Error — Triggers when > 6 consecutive ones are detected (low and 
full speed only).
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• SE1 Error — Triggers if SE1 > 1 bit time (low and full speed only).

If you selected the Token Packet, Data Packet, Handshake Packet, or Special Packet 
trigger condition:

• PID — Selects the desired packet ID for the selected packet type.

• Base — Selects the Hex or Binary number base when displaying or entering 
USB packet trigger values.

Note that this setting does not affect the selected base of the decode 
display.

• Use any remaining fields to enter trigger value(s).

Interpreting USB 2.0 Decode

The USB decode display is color coded as follows:

• For Token Packets (all but SOF):

• PID (yellow, "OUT", "IN", "SETUP", "PING")

• PID Check (yellow when valid, red when error detected)

• Address (blue)

• Endpoint (green)

• CRC (blue when valid, red when error detected)

• For Token Packets (SOF):

• PID (yellow, "SOF")
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• PID Check (yellow when valid, red when error detected)

• Frame (green) – the frame number

• CRC (blue when valid, red when error detected)

• For Data Packets:

• PID (yellow, "DATA0", "DATA1", "DATA2", "MDATA")

• PID Check (yellow when valid, red when error detected)

• Data (white)

• CRC (blue when valid, red when error detected)

• For Handshake Packets:

• PID (yellow, "ACK", "NAK", "STALL", "NYET", "PRE", "ERR")

• PID Check (yellow when valid, red when error detected)

• For Split Transaction Token Packets:

• PID (yellow, "SPLIT")

• PID Check (yellow when valid, red when error detected)

• Hub Addr (green)

• SC (blue)

• Port (green)

• S & E|U (blue)

• ET (green)

• CRC (blue when valid, red when error detected)

If the packet type is unknown because the PID is off screen, all bytes will be 
displayed in orange.
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Interpreting USB 2.0 Lister Data

In addition to the standard Time column, the USB 2.0 Lister contains these 
columns:

• PID — PID is displayed as red text if the PID check value does not match.

• Addr — Address.

• Endp — Endpoint.

• Data — either the Data of a Data Packet, or the various fields of a SPLIT packet.

• Fr — Frame – frame number of a SOF packet.

• CRC.

• Errors — "PID", "CRC5", "CRC16", "Glitch", "Stuff" , or "SE1" errors as 
appropriate. The background color is red to indicate an error.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

If the packet type is unknown because the PID is off screen, the Lister text will have 
an orange background.



430 Keysight InfiniiVision HD3-Series Oscilloscopes User's Guide

35 USB 2.0 Triggering and Serial Decode
 

Searching for USB 2.0 Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
USB 2.0 data in the Lister (see "Searching Lister Data" on page 132). Then, you 
can use the navigation controls to navigate through the marked rows (see 
"Navigating the Time Base" on page 59).

The Search dialog box controls unique to the USB 2.0 search type selection are:

• Search for — Selects the decode value to find:

• Token Packet — Finds token packets with the specified content.

• Data Packet — Finds data packets with the specified content.

• Handshake Packet — Finds handshake packets with the specified content.

• Special Packet — Finds special packets with the specified content.

• All Errors — Finds any of the following errors.

• PID Error — Finds packet type fields that do not match the check field.

• CRC5 Error — Finds 5 bit CRC errors.

• CRC16 Error — Finds 16 bit CRC errors.

• Glitch Error — Finds two transitions that occur in half a bit time.

• Bit Stuff Error — Finds > 6 consecutive ones (low and full speed only).

• SE1 Error — Finds when SE1 > 1 bit time (low and full speed only).
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USB PD (Power Delivery) triggering and protocol decode is included with the USB 
Serial Analysis license.

USB PD Protocol Decode Setup

To enable USB PD protocol decode:

1 Press [Protocol Decode].

Or:

a From the main menu (see page 40), choose Analyze > Protocol Decode....

b In the Protocol Decode dialog box, select Enable.

c Select either the Protocol1 or Protocol2 tab (the oscilloscope can decode two 
protocols at the same time), and select On.

2 From the Mode drop-down list, select USB PD.

Below the Mode selection is a vertical tab for specifying Signals.

Signals The USB PD protocol decode mode has these controls for setting up the signals:
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• Source — Selects the channel for the signal.

• Threshold — Select the signal threshold voltage level.

The threshold voltage level is used in decoding and will become the trigger 
level when the trigger type is set to the selected protocol decode bus.

Notes • The USB PD triggering and serial decode option is license-enabled.

• If the decode line does not appear on the display, press the [Protocol Decode] key 
to turn it on.

• If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

• If the setup does not produce a stable trigger, the USB PD signals may be slow 
enough that the oscilloscope is Auto triggering. Press the [Mode] key to set the 
trigger mode from Auto to Trig'd.

• You can use the horizontal [Zoom] window for easier navigation of the decoded 
data.

See Also • "USB 2.0 Triggering" on page 425

• "Interpreting USB 2.0 Decode" on page 427

• "Interpreting USB 2.0 Lister Data" on page 429

• "Searching for USB 2.0 Data in the Lister" on page 430

USB PD Triggering

To trigger on a USB PD signal, connect the oscilloscope to the signal line and set 
up a trigger condition.

To set up the oscilloscope to capture USB PD signals, see "USB 2.0 Protocol 
Decode Setup" on page 423.

After you have set up the oscilloscope to capture USB PD signals, you can then set 
up triggers.

1 Select the trigger badge, or from the main menu (see page 40), choose Trigger > 
Setup....

2 In the Trigger dialog box, from the Trigger Type drop-down list, select Protocol 1 
or Protocol 2.
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The Trigger dialog box controls unique to the USB PD trigger type are:

• Trigger — Selects the USB PD trigger mode:

• Preamble Start — Triggers at the start of a preamble, which starts with 0.

• EOP — Triggers at the end of packet.

• SOP — Triggers on ordered set Sync-1, Sync-1, Sync-1, Sync-2.

• SOP' — Triggers on ordered set Sync-1, Sync-1, Sync-3, Sync-3.

• SOP'' — Triggers on ordered set Sync-1, Sync-3, Sync-1, Sync-3.

• SOP' Debug — Triggers on ordered set Sync-1, RST-2, RST-2, Sync-3.

• SOP'' Debug — Triggers on ordered set Sync-1, RST-2, Sync-3, Sync-2.

• Hard Reset — Triggers on ordered set RST-1, RST-1, RST-1, RST-2.

• Cable Reset — Triggers on ordered set RST-1, Sync-1, RST-1, Sync-3.

• CRC Error — Triggers when an error is detected on a 32-bit CRC.

• Preamble Error — Triggers when an error is detected on a 64-bit sequence of 
alternating 0 and 1.

• Header Content — Triggers on a user-defined 16-bit value.

In this mode, additional controls let you further set up the trigger mode.

When the Header Content trigger mode is selected, use the Header Type control to 
select the header type:

• Control Message — Triggers on control message types (0 data object). Use the 
Message Type control to select the control message.

• Data Message — Triggers on data message types (1 or more data objects). 
Use the Message Type control to select the data message.

• Extended Message — Triggers on extended message types (bit 15 is set). Use 
the Message Type control to select the extended data message.

• Value — Triggers on a user-defined header value. Use the Base control to 
specify the number base, and use the Header field to enter the value.

Also when the Header Content trigger mode is selected, there is a Qualifier control 
that can further qualify the trigger:

• None — There is no additional qualifier for the trigger.
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• SOP — The trigger occurs on Sync-1, Sync-1, Sync-1, Sync-2 ordered sets 
only.

• SOP' — The trigger occurs on Sync-1, Sync-1, Sync-3, Sync-3 ordered sets 
only.

• SOP'' — The trigger occurs on Sync-1, Sync-3, Sync-1, Sync-3 ordered sets 
only.

Interpreting USB PD Decode

The USB PD decode is displayed as a single bus, with one decode line positioned 
at the bottom of the waveform area, time-aligned with the associated physical 
signal. Above the decode line is abbreviated symbolic decode information, shown 
in white, that describes the header's port power role (bit 8), port data role (bit 5), 
and message type (bits 4-0).

The decode line shows a blue idle line until the preamble is reached, at which point 
the start of frame angle bracket (<) is drawn in blue. The end of frame angle 
bracket (>) is drawn in blue at the end of the EOP, followed by a blue idle line. The 
fields and hex data within a packet are distinguished by color:

• SOP* (blue)

• Message Header (yellow)

• Extended Message Header (yellow)

• Data (white)

• CRC (green)
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• EOP (blue)

When errors occur, a red error frame is drawn until a valid idle signal is detected. 
For CRC errors, the decoded text is shown in red. For preamble errors, "PError" is 
shown in red.

Interpreting USB PD Lister Data

In addition to the standard Time column, the USB PD Lister contains these 
columns:

• ORD Set — the ordered set type.

• Header — the header type and value.

• Data — the data or extended message.

• CRC — value in Hex.

• Errors — string value that displays the type of error detected.

Searching for USB PD Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
USB PD data in the Lister (see "Searching Lister Data" on page 132). Then, you 
can use the navigation controls to navigate through the marked rows (see 
"Navigating the Time Base" on page 59).

The Search dialog box controls unique to the USB PD search type selection are:
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• Search for — Selects the decode value to find:

• SOP — Finds ordered set Sync-1, Sync-1, Sync-1, Sync-2.

• SOP' — Finds ordered set Sync-1, Sync-1, Sync-3, Sync-3.

• SOP'' — Finds ordered set Sync-1, Sync-3, Sync-1, Sync-3.

• SOP' Debug — Finds ordered set Sync-1, RST-2, RST-2, Sync-3.

• SOP'' Debug — Finds ordered set Sync-1, RST-2, Sync-3, Sync-2.

• Hard Reset — Finds ordered set RST-1, RST-1, RST-1, RST-2.

• Cable Reset — Finds ordered set RST-1, Sync-1, RST-1, Sync-3.

• CRC Error — Finds when an error is detected on a 32-bit CRC.

• Preamble Error — Finds when an error is detected on a 64-bit sequence of 
alternating 0 and 1.

• Header Content — Finds a user-defined 16-bit value.

In this mode, additional controls let you further set up the search.
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Symbols

(-) Width measurement, 214
(+) Width measurement, 213
+Width to +Width jitter measurement, 246

Numerics

1 M ohm input impedance, 66
50 ohm input impedance, 66

A

About Oscilloscope, 321
absolute value math function, 90
AC channel coupling, 66
AC RMS - Full Screen measurement, 210
AC RMS - N Cycles measurement, 210
accessories, 23, 339
acquire, 177
acquisition memory, 150
acquisition mode, 183
acquisition mode, averaging, 186
acquisition mode, normal, 183
acquisition mode, peak detect, 184
acquisition modes, 177
active serial bus, 376, 384, 411, 420
activity indicator, 118
addition math function, 87
address with no ack condition, I2C 

trigger, 374
address, I2C trigger, 374
adjacent channel power ratio (ACPR) FFT 

analysis measurement, 221
aliasing, 178
all edges, measure, 242
alternating edge trigger, 152
AM (amplitude modulation), waveform 

generator output, 288
Amplitude measurement, 206
amplitude modulation (AM), waveform 

generator output, 288
analog channel inputs, 25
analog channel, probe attenuation, 69
analog channel, setup, 63
analog filters, adjusting, 73, 98
analysis record length, jitter analysis 

and, 242
Analyze Segments, 188, 189
annotation, adding, 143

antialiasing, disabling/enabling, 137
arbitrary generated waveforms, 

editing, 284
arbitrary waveform generator output, 280
arbitrary waveforms, copying from other 

sources, 286
arbitrary waveforms, creating new, 284
arbitrary waveforms, editing existing, 286
Area - Full Screen measurement, 219
Area - N Cycles measurement, 220
ARINC 429 decode, interpreting, 355
ARINC 429 Lister data, 356
ARINC 429 trigger, 354
ARINC 429 decode, signal speed, 352
ARINC 429 decode, signal type, 352
ARINC 429 decode, word format, 353
ASCII file format, 292
ASCII XY data, 295
attenuation, probe, 69
attenuation, probe, external trigger, 176
attenuators, 71
Auto Scale key, 36
Auto Setup. Fault Hunter, 272
Auto trigger mode, 170
Auto? trigger indicator, 171
AutoIP, 305, 306
automatic measurements, 199, 203
automatic setup, 116
AutoProbe interface, 25, 66
Autoscale preferences, 310
Autoscale, digital channels, 116
AUX OUT connector, 28, 312
AUX OUT signal and zone qualified 

trigger, 167
AUX TRIG IN as Z-axis input, 55
AUX TRIG IN connector, 28
Average - Full Screen measurement, 209
Average - N Cycles measurement, 209
average measurement trend, 104
averaged value math function, 99
averaging acquire mode, 183, 186
Ax + B math function, 90

B

back panel inputs and outputs, 26
badges, 40
Band Pass Filter math function, 100
bandwidth, 3, 321
bandwidth limit, 67
bandwidth required, oscilloscope, 181
bandwidth, oscilloscope, 179

Bartlett FFT window, 77
base 10 exponential math function, 91
Base measurement, 207
BIN file format, 292
binary data (.bin), 341
binary data file examples, 345
binary data in MATLAB, 342
binary data, example program for 

reading, 345
Binary marker mode, 193
bit rate measurement, 214
bits, SPI trigger, 411
Blackman Harris FFT window, 77
blanking, 55
BMP file format, 292
Bode plot, frequency response 

analysis, 277
brick-wall frequency response, 179
Browser Web Control, 327
built-in help, 47
burst width measurements, 214
burst, capture signal bursts, 188
burst, Quick WaveGen Burst, 323
bus display mode, 120
BW Limit? in DVM display, 264

C

calibrate probe, 71
calibration, 319
calibration status, 333
CAN decode, source channels, 360
CAN FD standard, 362
CAN symbolic data, 363
CAN trigger, 364
CAN XL standard, 362
capture signal bursts, 188
cardiac waveform generator output, 282
Center, FFT, 76, 98
change network password, 335
channel power FFT analysis 

measurement, 220
channel, analog, 63
channel, bandwidth limit, 67
channel, coupling, 65
channel, fine adjustment, 68
channel, invert, 68
channel, on/off keys, 37
channel, position, 65
channel, probe external scaling, 72
channel, probe units, 69
channel, skew, 70
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channel, vertical sensitivity, 65
characteristics, 337
choosing values, 36
cleaning, 321
clear display, 139, 185
clear display, Quick Clear Display, 323
clear persistence, 139
clock recovery, 104
Clock TIE jitter measurement, 245
clock, oscilloscope date/time, 311
CMOS threshold, 120
color grade themes, 239
color grade waveform, 237
color grade waveform, enabling, 238
Common Logarithm math function, 92
compensate passive probes, 26, 33
connect probes, digital, 113
connection, to a PC, 306
connections for frequency response analysis 

(FRA), 275
constant frequency clock recovery, 105
Control Instrument, web browser 

interface, 327
control, remote, 303
copyright, 2
Counter measurement, 213
counters, 265
coupling, channel, 65
coupling, trigger, 172
crosstalk problems, 73, 98
CSV data, 295
CSV file format, 292
CSV files, minimum and maximum 

values, 348
custom location, time reference, 58
cybersecurity incident monitoring and 

response, 350
cybersecurity, product, 350

D

D*, 37
d/dt math function, 92
damage, shipping, 23
damping factor (second-order PLL), clock 

recovery, 105
data sheet, 337
Data TIE jitter measurement, 244
DC channel coupling, 66
DC offset correction for integrate 

waveform, 94
DC RMS - Full Screen measurement, 209
DC RMS - N Cycles measurement, 209
DC signals, checking, 171
DC waveform generator output, 281
DDR burst, random trigger holdoff, 175
dead time (re-arm), 189
decaying average approximation, 100
decibels, FFT vertical units, 77
decimation, for analysis record, 348
decimation, for screen, 348

default configuration, 31
default setup, 31
Default Setup key, 36
defaults, waveform generator, 283
delay knob, 51
Delay measurement, 203, 215
delay time indicator, 58
delayed sweep, 56
delete file, 307
depth, AM modulation, 288
detection type, FFT (Magnitude), 77
deviation, FM modulation, 289
DHCP, 305, 306
differentiate math function, 92
digital bus mode, 120
digital channel inputs, 28
digital channels, Autoscale, 116
digital channels, logic threshold, 120
digital channels, probing, 123
digital channels, size, 118
digital display, interpreting, 117
Digital key, 37
digital probes, 113, 123
digital probes, impedance, 123
digital voltmeter (DVM), 263
Digitizer mode, 182
digits, counter resolution, 266
disable network password, 335
display multiple acquisitions, 178
display, clear, 139
display, persistence, 138
display, signal detail, 145
distortion problems, 73, 98
Divide math function, 88
DNS IP, 306
dots or vectors, waveform display, 136
Drag Waveforms mode, 44
Draw Box mode, 44
Duty cycle measurement, 214
duty cycle measurement trend, 104
DVM (digital voltmeter), 263

E

ECL threshold, 120
edge speeds, 181
edge then edge triggering, 153
edge triggering, 151
edges, measure all, 242
editing measurements, 202
EEPROM data read, I2C trigger, 374
either edge trigger, 152
eject USB storage device, 308
e-mail setups, images, or data, 297
e-mail, Quick Email, 323
energy of a pulse, 94
English user interface and Quick Help, 30
enhanced security options, 314
Entry knob, 36
Entry knob, push to select, 36
envelope math function, 100

environmental conditions, 339
erase, secure, 302
event table, 130
exFAT file system format not 

supported, 308
expand about, 65, 309
expand about center, 309
expand about ground, 309
explicit clock recovery, 105
exponential fall waveform generator 

output, 281
Exponential math function, 93
exponential rise waveform generator 

output, 281
exporting waveform, 291
EXT2 file system format, 308
EXT3 file system format, 308
EXT4 file system format, 308
external memory device, 26
external scaling, probe, 72
external trigger, 175
external trigger, input impedance, 176
external trigger, probe attenuation, 176
external trigger, probe units, 176

F

factory default, 301
factory reset, 302
Fall time measurement, 215
fall time measurement trend, 104
falling edges count measurements, 219
FAT file system format, 308
FAT16 file system format, 308
FAT32 file system format, 308
Fault Hunter, 269
favorites menu, 44
FFT (Magnitude) detection type, 77
FFT aliasing, 80
FFT aliasing example, 81
FFT analysis measurements, 220
FFT Auto Setup, 74, 98, 99
FFT DC value, 80
FFT magnitude math function, 97
FFT math function, 73
FFT math functions, 97
FFT Max function, 82
FFT measurement hints, 79
FFT peaks, searching, 78
FFT phase math function, 97
FFT resolution, 79
FFT spectral leakage, 81
FFT units, 80
FFT vertical units, 77
FFT window, 77
file explorer, 307
file format, ASCII, 292
file format, BIN, 292
file format, BMP, 292
file format, CSV, 292
file format, PNG, 292
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file, save, recall, load, 307
filter math function, averaged value, 99
filter math function, envelope, 100
filter math function, high pass and low 

pass, 101
filter math function, smoothing, 101
filters, math, 99
fine adjustment, channel, 68
fine adjustment, horizontal scale, 57
firmware updates, 341
firmware upgrade files, 333
firmware version, 321
firmware versions, 333
first-order PLL clock recovery, 105
flash drive, 26
Flat top FFT window, 77
FM (frequency modulation), waveform 

generator output, 289
folding frequency, 178
Force key, 36
forcing a trigger, 151
FRA (frequency response analysis), 275
frame trigger, I2C, 374
frame, LIN symbolic, 384
French front panel overlays, 38
French user interface and Quick Help, 30
frequency counter, 266
frequency data in CSV files, 348
frequency deviation, FM modulation, 289
Frequency measurement, 212
frequency measurement trend, 104
frequency modulation (FM), waveform 

generator output, 289
frequency peaks, searching, 78
frequency requirements, power source, 29
frequency response analysis (FRA), 275
frequency response analysis data, 

email, 278
frequency response analysis data, 

save, 278
frequency, Nyquist, 178
front panel inputs and outputs, 25
front panel keys and knobs, 34
front panel self test, 320
front panel, language overlay, 38

G

gated by markers measurement 
window, 224

gateway IP, 306
Gaussian frequency response, 180
Gaussian pulse waveform generator 

output, 282
GEN OUT connector, 27
German front panel overlays, 38
German noise requirements, 349
German user interface and Quick Help, 30
glitch capture, 184
glitch trigger, 155
golden waveform test, 249

grabber, 115, 116
graph, histogram, 234
graphical user interface language, 30
graticule intensity, 140
graticule options, 139
grid intensity, 140
grid options, 139
ground level, 64
Ground terminal, 26
GUI scale factor, 311

H

Hanning FFT window, 77
hardware self test, 320
HD300AERA license, 340
HD300AUTA license, 340
HD300BDLA license, 340
HD300BDLB license, 340
HD300EMBA license, 340
HD300PWRA license, 340
HD300QJTA license, 340
HD300USBA license, 340
help, built-in, 47
hex bus trigger, 159
Hex marker mode, 193
HF Reject, 173
high pass filter math function, 101
high-frequency noise rejection, 173
high-resolution mode, 183
histogram, 229
histogram graph, 234
histogram statistics, 235
histogram statistics, quick reset, 322
histogram, measurement, 230, 233
holdoff, 174
Horiz key, 56
Horizontal controls, 52
horizontal position control, 36
horizontal position knob, 51
horizontal scale fine adjustment, 57
horizontal sweep speed control, 36
horizontal time/div control, 36
horizontal Zoom key, 36
host ID, 321
host name, 306, 325
hysteresis, measurement, 224
hysteresis, trigger, 174

I

I/O interface settings, 303
I2C trigger, 373
identification function, web interface, 332
idle serial bus, 376, 384, 411, 420
impedance, analog channel input, 66
impedance, digital probes, 123
indeterminate state, 193
infinite persistence, 138, 178, 184
input impedance, analog channel, 66

installed licenses, 321
installed options, 333
instantaneous slope of a waveform, 92
Instrument Utilities web page, 333
Integrate math function, 93
intensity control, 145
invert waveform, 68
invert waveform generator output, 283
IP address, 306, 325
Italian front panel overlays, 38
Italian user interface and Quick Help, 30

J

Japanese front panel overlays, 38
Japanese user interface and Quick Help, 30
jitter analysis, 241
Jitter analysis measurements, 204
jitter analysis, setting up, 242
jitter measurements, 244
Jitter-Free Trigger, 311

K

Keysight IO Libraries Suite, 328
Korean front panel overlays, 39
Korean user interface and Quick Help, 30

L

label list, 143
label list, loading from text file, 142
labels, 141
labels, auto-increment, 142
labels, reset library, 143
LAN connection, 305
LAN interface, remote control, 303
LAN port, 27
language, user interface, 30
layout, waveform, 135
length control, 295
Length option, 294
level, trigger, 150
LF Reject, 172
library, labels, 142
license files, 307, 333
licenses, 340
limit testing, measurement, 227
LIN decode, source channels, 380
LIN symbolic data, 382
LIN trigger, 382
line voltage, 29
load file, 307
localized front panel overlay, 38
logging remote commands, 313
logic presets, waveform generator, 282
logic threshold, 120
loop bandwidth (PLL), clock recovery, 105
low pass filter math function, 101
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Low signal in measurement results, 224
low-frequency noise rejection, 172

M

magnify math function, 102
Manual marker mode, 192
marker measurements, 191
marker units, 194
Markers key, 37
markers, dragging, 44
markers, gated measurement window, 224
markings, product, 349
mask file, building, 257
mask files, recall, 300
mask region limit per pixel column, 260
mask statistics, quick reset, 322
mask test, trigger output, 252, 284, 313
mask testing, 249
mask testing, how it works, 260
mask, AUX OUT signal, 284, 313
math filters, 99
math function Auto Setup, 85
math functions, cascaded, 84
math gating, 75, 85
math operators, 87
math transforms, 89
math visualizations, 102
math, 1*2, 88
math, 1/2, 88
math, addition, 87
math, differentiate, 92
math, divide, 88
math, FFT, 73
math, FFT magnitude/phase, 97
math, functions, 83
math, integrate, 93
math, multiply, 88
math, offset, 84
math, scale, 84
math, subtract, 87
math, units, 87
math, using waveform math, 83
MATLAB binary data, 342
Max Envelope math function, 103
Max Hold math function, 103
maximum input voltages, 338
Maximum math function, 103
Maximum measurement, 205
measure all edges, 242
Measure marker mode, 192
Measure menu, 199
measure statistics, quick reset, 322
measure, Quick Measure, 322
measurement category, definitions, 338
measurement definitions, 203
measurement histogram, 230, 233
measurement limit testing, 227
measurement statistics, 225
measurement thresholds, 222
measurement trend math function, 103

measurement window, 224
measurements, 203
measurements, automatic, 199
measurements, delay, 203
measurements, edit, 202
measurements, jitter, 244
measurements, overshoot, 203
measurements, phase, 204
measurements, preshoot, 204
measurements, time, 211
measurements, voltage, 204
MegaZoom IV, 4
memory depth, 3
memory depth and sample rate, 181
memory, segmented, 188
menu, main, 40
Message Log, 44
Message Log button, 44
message, CAN symbolic, 366
MIL-STD-1553 decode, interpreting, 390
MIL-STD-1553 Lister data, 392
MIL-STD-1553 trigger, 389
Min Envelope math function, 103
Min Hold math function, 103
Minimum math function, 103
Minimum measurement, 205
missing acknowledge condition, I2C 

trigger, 374
Mode key, 36
model number, 321, 325
modulation, waveform generator 

output, 287
module installed, 321
MSO, 3
Multicast DNS, 305
Multiply math function, 88

N

N8900A Infiniium Offline oscilloscope 
analysis software, 292

natural logarithm math function, 95
navigate files, 307
navigating the time base, 59
negative pulse width measurement 

trend, 104
network configuration parameters, 325
network, connecting to, 305
new label, 142
noise rejection, 173
noise waveform generator output, 281
noise, adding to waveform generator 

output, 282
noise, high-frequency, 173
noise, low-frequency, 172
noisy signals, 170
nominal data rate, clock recovery, 105
non-volatile memory, secure erase, 302
normal acquire mode, 183
normal mode, 183
notices, 2

N-Period jitter measurement, 245
NTFS file system format, 308
number of negative pulses 

measurements, 218
number of positive pulses 

measurements, 218
Nyquist frequency, 80
Nyquist sampling theory, 178

O

occupied bandwidth FFT analysis 
measurement, 220

offset (DC) correction for integrate 
waveform, 94

online help, 47
operators, math, 87
OR trigger, 160
oscilloscope bandwidth, 179
oscilloscope bandwidth required, 181
oscilloscope rise time, 180
oscilloscope sample rate, 180
output load expected, waveform 

generator, 283
output settings, waveform generator, 283
output, trigger, 312
overlay, localized, 38
Overshoot measurement, 203, 207
overvoltage category, 339

P

pan and zoom, 50
passive probes, compensating, 33
password (network), change or 

disable, 335
password (network), setting, 334
pattern trigger, 157
pattern, SPI trigger, 411
PC connection, 306
peak detect mode, 183, 184
Peak-Peak math function, 104
Peak-peak measurement, 205
period counter, 266
Period measurement, 212
period measurement trend, 104
Period-Period jitter measurement, 246
persistence, 138
persistence, clearing, 139
persistence, infinite, 178
Phase measurement, 204, 216
phase X marker units, 194
PNG file format, 292
points per span, FFT (Magnitude), 78
point-to-point connection, 306
pollution degree, 339
pollution degree, definitions, 339
Portuguese front panel overlays, 39
Portuguese user interface and Quick 

Help, 30
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position digital channels, 119
position, analog, 65
positive pulse width measurement 

trend, 104
post-processing, 200
post-trigger information, 51
Power App measurements, 204
power consumption, 29
power cord connector, 27
power cycle the oscilloscope, 29
power requirements, 29
power supply, 27
power switch, 25, 29
power-on, 29
predefined labels, 142
Preshoot measurement, 204, 208
pre-trigger information, 51
probe attenuation, 69
probe attenuation, external trigger, 176
Probe Comp terminal, 26
probe compensation, 26
probe external scaling, 72
probe head, 71
probe units, 69
probe, AutoProbe interface, 25
probe, calibrate, 71
probes, 339
probes, connecting to oscilloscope, 30
probes, digital, 113
probes, passive, compensating, 33
product cybersecurity, 350
programmer's guide, 328
Protocol Decode key, 37
Protocol Listing, 130
pulse polarity, 156
pulse waveform generator output, 281
pulse width trigger, 155

Q

qualifier, pulse width, 156
Quick Action menu item, 322
Quick Clear Display, 323
Quick Email, 323
Quick Histogram Statistics Reset, 322
Quick Mask Statistics Reset, 322
Quick Measure, 322
Quick Measure Statistics Reset, 322
Quick Recall, 323
Quick Save, 323
Quick Selection button, 41, 64
Quick Trigger Mode, 323
Quick WaveGen Burst, 323

R

ramp waveform generator output, 281
random noise, 170
random trigger holdoff, 175
ratio measurement, 211

ratio measurement trend, 104
ratio X marker units, 194
ratio Y marker units, 194
raw acquisition record, 295
re-arm time, 189
recall, 323
recall files via web interface, 331
recall mask files, 300
recall setups, 300
recall, Quick Recall, 323
recovery, clock, 104
Rectangular FFT window, 77
reference point, waveform, 309
reference waveforms, 109
regulatory information, 349
remote commands, logging, 313
remote control, 303
Remote Front Panel, 327
remote GUI access, VNC, 329
remote programming, Keysight IO 

Libraries, 328
remote programming, web interface, 327
required oscilloscope bandwidth, 181
reset label library, 143
restart condition, I2C trigger, 374
Results area, 46
results, frequency response analysis 

(FRA), 277
return instrument for service, 322
Rise time measurement, 214
rise time measurement trend, 104
rise time, oscilloscope, 180
rise time, signal, 181
rise/fall time triggering, 160
rising edge count measurements, 219
RMS - AC measurement trend, 104
roll mode, 53
RS232 trigger, 418
Run/Stop key, 35
running acquisition record, 295
runt pulses, 212
runt triggering, 162

S

sample rate, 3
sample rate and memory depth, 181
sample rate, current rate displayed, 50
sample rate, oscilloscope, 179, 180
sampling theory, 178
sampling, overview, 178
saturated color grade, 238
save, 323
save file, 307
save files via web interface, 330
Save Screen key, 37
save segment, 294
save setup files, 293
save times, data, 296
save, Quick Save, 323
save/recall from web interface, 330

saver, screen, 310
saving data, 291
SCL (serial clock), I2C trigger, 372
SCPI Commands window, 327
screen image via web interface, 330
screen saver, 310
SDA, 371
SDA (serial data), I2C trigger, 372
second-order PLL clock recovery, 105
secure erase, 302
security options, enhanced, 314
segmented memory, 188
segmented memory, re-arm time, 189
segmented memory, saving segments, 294
segmented memory, statistical data, 189
selecting, values, 36
self test, front panel, 320
self test, hardware, 320
SENT decode, interpreting, 401
SENT fast signals definition, 398
SENT Lister data, 404
SENT trigger, 399
serial data, 371
serial number, 321, 325
service functions, 318
setup and hold triggering, 163
setup files, saving, 293
setup, automatic, 116
setup, default, 31
setup, frequency response analysis 

(FRA), 276
setups, recall, 300
shipping damage, 23
shipping precautions, 322
shut down the oscilloscope, 30
Sigma, minimum, 252
signal, CAN symbolic, 366
signal, LIN symbolic, 384
Simplified Chinese front panel overlays, 39
Simplified Chinese user interface and Quick 

Help, 30
sinc waveform generator output, 281
sine waveform generator output, 280
single acquisition, 35
Single key, 35, 177
single-shot acquisitions, 171
single-shot events, 177
single-shot infinite persistence, 138
size, 118
skew, analog channel, 70
Slew Rate measurement, 220
Slope key, 36
slope trigger, 151
smoothing math function, 101
software updates, 341
Span, FFT, 76, 98
Spanish front panel overlays, 39
Spanish user interface and Quick Help, 30
specifications, 337
spectral leakage, FFT, 81
SPI trigger, 410
square root, 96
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square waveform generator output, 280
square waves, 180
Squared math function, 97
stand-alone connection, 306
start acquisition, 35
start condition, I2C, 373
Start Freq, FFT, 76, 98
statistics, histogram, 235
statistics, mask test, 253
statistics, measurement, 225
statistics, using segmented memory, 189
status, User Cal, 318
Std Deviation measurement, 210
stop acquisition, 35
stop condition, I2C, 373
Stop Freq, FFT, 76, 98
subnet mask, 306
subtract math function, 87
sweep frequencies, frequency response 

analysis, 277
swu files, 307
symbolic data, CAN, 363
symbolic data, LIN, 382
sync pulse, waveform generator, 284

T

template, front panel, 38
test, mask, 249
Thai front panel overlays, 39
Thai user interface and Quick Help, 30
themes, color grade, 239
theory, sampling, 178
threshold, analog channel 

measurements, 222
threshold, digital channels, 120
thumb drive, 26
tilt for viewing, 28
Time at Edge measurement, 215
time measurements, 211
time reference indicator, 58
time, re-arm, 189
timebase, 52
times for saving data, 296
Top measurement, 206
total harmonic distortion (THD) FFT analysis 

measurement, 221
totalize counter, 266
Touch key, 37, 39
touchscreen user interface, 39
Track Waveform marker mode, 192
Traditional Chinese front panel overlays, 39
Traditional Chinese user interface and Quick 

Help, 30
transforms, math, 89
Transparent backgrounds, 309
Trig'd trigger indicator, 171
Trig'd trigger mode, 170
Trig'd? trigger indicator, 171
trigger coupling, 172
trigger Force key, 36

trigger hysteresis, 174
trigger indicator, Auto?, 171
trigger indicator, Trig'd, 171
trigger indicator, Trig'd?, 171
trigger level, 150
trigger Level knob, 36
trigger Mode key, 36
trigger mode, Auto or Trig'd, 170
trigger mode, Quick Trigger Mode, 323
trigger output, 312
trigger output, mask test, 252, 284, 313
trigger qualified event signal, 

counting, 266
trigger Slope key, 36
trigger type, ARINC 429, 354
trigger type, CAN, 364
trigger type, edge, 151
trigger type, edge then edge, 153
trigger type, glitch, 155
trigger type, hex bus, 159
trigger type, I2C, 373
trigger type, LIN, 382
trigger type, MIL-STD-1553, 389
trigger type, OR, 160
trigger type, pattern, 157
trigger type, pulse width, 155
trigger type, rise/fall time, 160
trigger type, RS232, 418
trigger type, runt, 162
trigger type, SENT, 399
trigger type, setup and hold, 163
trigger type, slope, 151
trigger type, SPI, 410
trigger type, UART, 418
trigger type, USB 2.0, 425
trigger type, USB PD, 432
trigger types, 149
trigger, definition, 150
trigger, external, 175
trigger, forcing a, 151
trigger, general information, 150
trigger, holdoff, 174
trigger, mode and conditioning, 169
trigger, source, 152
trigger, zone qualified, 165
triggers, AUX OUT signal, 284, 313
TTL threshold, 120
turn channel on, 37

U

UART trigger, 418
under-sampled signals, 178
Undo button, 32, 117
units, external trigger probe, 176
units, marker, 194
units, math, 87
units, probe, 69
updating software and firmware, 341
upgrade files, 333
upgrade options, 340

USB 2.0 trigger, 425
USB decode, signal speed, 425
USB device port, 27
USB device port, remote control, 303
USB host port, 27
USB host ports, 26
USB PD decode, interpreting, 434
USB PD Lister data, 435
USB PD trigger, 432
USB storage device, 26
USB storage devices, 308
USB, CD device, 308
USB, eject device, 26
user calibration, 319
user interface language, 30
User-defined threshold, 120
utilities, 303

V

V RMS, FFT vertical units, 77
values, choosing, 36
variable persistence, 138
vectors or dots, waveform display, 136
ventilation requirements, 29
vertical expansion, 65
vertical offset, 65
vertical position, 65
vertical position knob, 37
vertical resolution, 67
vertical scale knob, 37
vertical sensitivity, 37, 65
viewing, tilt the instrument, 28
VISA connect string, 325
visualizations, math, 102
VNC, remote GUI access, 329
voltage measurements, 204

W

warranted specifications, 337
warranty, 2, 321
Wave Gen key, 27, 37
waveform generator, 279
waveform generator amplitude, frequency 

response analysis, 277
waveform generator defaults, 

restoring, 283
waveform generator expected output 

load, 283
waveform generator logic presets, 282
waveform generator output settings, 283
waveform generator sync pulse, AUX OUT 

signal, 284, 313
waveform generator, arbitrary 

waveforms, 284
waveform generator, invert output, 283
waveform generator, waveform type, 279
waveform labels, 141
waveform layout, 135
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waveform type, waveform generator, 279
waveform, intensity, 145
waveform, reference point, 309
waveform, saving/exporting, 291
web interface, 325
web interface, accessing, 326
white noise, adding to waveform generator 

output, 282
Width - measurement, 214
Width + measurement, 213
-Width to -Width jitter measurement, 247
write data with no ack condition, I2C 

trigger, 374

X

X at Max Y measurement, 217
X at Max Y on FFT, 204
X at Min Y measurement, 218
X at Min Y on FFT, 204
X marker level knob, 37
XY mode, 52, 54

Y

Y at X measurement, 206
Y marker level knob, 37

Z

Z-axis blanking, 55
zero phase reference, FFT (Phase), 98
zone qualified trigger, 165
zoom and pan, 50
zoom display measurement window, 224
Zoom key, 36
Z-order for waveforms in grid, 140
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