如何验证路由和交换

IxNetwork
+ IxNetwork

路由、收敛和转发测试

工程师可以通过在被测设备周围构建可重复的协议拓扑,并在定义的条件下对控制平面和数据平面进行测试,从而验证路由和交换行为。 首先,通过中间系统到中间系统(IS-IS)、开放最短路径优先(OSPF)、增强型内部网关路由协议(EIGRP)、路由信息协议(RIP)和边界网关协议(BGP)等协议,模拟路由邻居、建立协议会话并发布受控路由集。 然后,通过已学习的路由路径生成转发流量,并调整路由规模、流量组合和协议活动,以重现目标网络环境。工程师还可以引入双向转发检测(BFD)、路由波动、会话变更和重启事件,以创建可重复的收敛场景。

在每次测试运行期间,工程师可以在仿真网络保持活动状态的同时,跟踪协议状态、路由计数、收敛行为、吞吐量、延迟、抖动以及数据包测试结果。他们可以混合使用 IPv4 和 IPv6 流量,同时运行多种协议,并扩大路由或流量规模,以评估设备在网络复杂性增加时的响应情况。 当工作流程需要可重复的转发或组播性能测量时,工程师还可以应用标准化的基准测试方法,包括 RFC 2544、RFC 2889 和 RFC 3918 测试。通过在不同运行之间保持拓扑结构、路由规模、流量负载、故障事件和通过标准的一致性,团队可以在相同的路由和交换条件下,比较软件版本、配置以及硬件变更带来的影响。

路由与交换验证解决方案

围绕被测设备配置协议仿真,建立路由会话,发布受控路由,并在收集控制平面和数据平面测量数据的同时生成转发流量。 是德科技的IxNetwork 能够大规模仿真路由和交换协议,包括IS-IS、OSPF、EIGRP、RIP、内部边界网关协议(IBGP)和外部边界网关协议(EBGP),并支持大型路由广播以及所选锚点资产中描述的真实互联网路由表导入。 工程师可以添加双向转发检测(BFD)、路由或会话抖动以及重启序列,以测试故障检测和收敛行为,同时 IPv4 和 IPv6 协议变体与线速流量协同运行。IxNetwork 还支持标准化的基准测试工作流,例如 RFC 2544、RFC 2889 和 RFC 3918 QuickTests。 工程师可利用所得的协议状态、路由规模、收敛时间、吞吐量、延迟、抖动和数据包测量结果,在可重复的测试条件下比较路由和交换性能。

观看我们路由与交换验证解决方案的演示视频

了解我们路由和交换验证解决方案中的产品

联系我们 标识

联系我们的专家之一

需要帮助找到适合您的解决方案吗?